Getting Started

AgMD1 IVI Driver Reference |
Getting Started | Agilent Technologies

Welcome to the AgMD1 version 1.4.6.0 IVI driver. Agilent's IVI drivers simplify the creation and maintenance of instrument control applications in a variety of development environments. IVI drivers allow you to programmatically control your instrumentation while providing a greater degree of instrument interchangeability and code reuse. This driver supports compiling application programs for 32 or 64 bit platforms.

Programming with the AgMD1 Driver

Basics of programming this driver including example code. How to: Reference the Driver, Create an Instance of the Driver, Initialize the Driver, and Access Items of Various Data Types

    Programming with the IVI-COM Driver - Using the IVI-COM driver in the following application development environments: Visual C#, Visual C++, Visual Basic.NET, Visual Basic 6, Agilent VEE Pro®, LabVIEW®, MATLAB®

    Programming with the IVI-C Driver - Using the IVI-C driver in the following application development environments: Visual C++, LabWindow/CVI®, LabVIEW®

    - You may build and run these example programs installed with the driver. They demonstrate basic driver usage in a variety of application development environments.

AgMD1 Driver Reference

    IVI-COM Driver Reference - Documentation for each IVI-COM method, property, and error code.

    IVI-C Driver Reference - Documentation for each IVI-C function, attribute, and error code.

IVI Overview

General, information on IVI features common to all IVI drivers as well as compliance and installation information.

    IVI Compliance Information - IVI-required compliance information for the AgMD1 driver.

    IVI Backgrounder - An overview of IVI topics and concepts for driver developers including introductory information on the IVI Foundation standards and specifications.

Web Sites

  • Agilent Technologies Home Page
    • IVI Drivers & Components Downloads
    • Agilent I/O Libraries Suite
    • GPIB, USB, & Instrument Control Products
    • Agilent VEE Pro
    • Technical Support, Manuals, & Downloads
    • Contact Agilent Test & Measurement
  • IVI Foundation - Usage Guides, Specifications, Shared Components Downloads
  • MSDN Online
Copyright 2010-2012 Agilent Technologies. All rights reserved.


IVI Compliance Information

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IVI Compliance Information

This page provides IVI-required compliance information for the AgMD1 driver.

Compliance Category

IVI drivers come in a variety of types and configurations. This section provides IVI-required compliance information on the various categories of IVI compliance for the AgMD1 driver.

Compliance Category | Compliance Information
Category Name | IVI-COM/C IviDigitizer Specific Instrument Driver
Class Specification Version | 1.0

Class Capability Groups

In addition to the IVI Inherent Capabilities required of all IVI instrument drivers, the AgMD1 driver supports the IviDigitizer instrument class.

The following table lists each of the capability groups for the IviDigitizer instrument class and indicates whether the group is supported by the AgMD1 driver.

Capability Name | Supported | Description
IviDigitizerBase | Yes | This group includes the capability to acquire waveforms using edge triggering.
IviDigitizerMultiRecordAcquisition | Yes | IviDigitizer with the ability to do multi-record acquisitions.
IviDigitizerBoardTemperature | Yes | IviDigitizer with the ability to report the temperature of the digitizer.
IviDigitizerChannelFilter | Yes | IviDigitizer with the ability to control the channel input filter frequency.
IviDigitizerChannelTemperature | Yes | IviDigitizer with the ability to report the temperature of individual digitizer channels.
IviDigitizerTimeInterleavedChannels | Yes | IviDigitizer with the ability to combine two or more input channels to achieve higher acquisitions rates and/or record lengths.
IviDigitizerDataInterleavedChannels | No | IviDigitizer with the ability to interleave the data from two or more input channels, usually to create complex (I/Q) data.
IviDigitizerReferenceOscillator | Yes | IviDigitizer with the ability to use an external reference oscillator.
IviDigitizerSampleClock | Yes | IviDigitizer with the ability to use an external sample clock.
IviDigitizerSampleMode | Yes | IviDigitizer with the ability to control whether the digitizer is using real-time or equivalent-time sampling.
IviDigitizerSelfCalibration | Yes | IviDigitizer with the ability to perform self calibration.
IviDigitizerDownconversion | Yes | IviDigitizer with the ability to do frequency translation or downconversion in hardware.
IviDigitizerArm | No | IviDigitizer with the ability to arm on positive or negative edges.
IviDigitizerMultiArm | No | IviDigitizer with the ability to arm on one or more sources.
IviDigitizerGlitchArm | No | IviDigitizer with the ability to arm on glitches.
IviDigitizerGlitchTrigger | No | IviDigitizer with the ability to trigger on glitches.
IviDigitizerPretriggerSamples | Yes | IviDigitizer with the ability to specify a number of samples to fill up the data buffer with pre-trigger data.
IviDigitizerRuntArm | No | IviDigitizer with the ability to arm on runts
IviDigitizerSoftwareArm | No | IviDigitizer with the ability to arm acquisitions.
IviDigitizerTVArm | No | IviDigitizer with the ability to arm on standard TV signals.
IviDigitizerWidthArm | No | IviDigitizer with the ability to arm on a variety of conditions regarding pulse widths.
IviDigitizerWindowArm | No | IviDigitizer with the ability to arm on signals entering or leaving a defined voltage range.
IviDigitizerTriggerSamples | Yes | IviDigitizer with the ability to ignore triggers for a fixed period of time relative to the last trigger event.
IviDigitizerMultiTrigger | Yes | IviDigitizer with the ability to trigger on one or more sources.
IviDigitizerRuntTrigger | No | IviDigitizer with the ability to trigger on runts.
IviDigitizerSoftwareTrigger | Yes | IviDigitizer with the ability to trigger acquisitions.
IviDigitizerTVTrigger | Yes | IviDigitizer with the ability to trigger on standard television signals.
IviDigitizerWidthTrigger | No | IviDigitizer with the ability to trigger on a variety of conditions regarding pulse widths.
IviDigitizerWindowTrigger | No | IviDigitizer with the ability to trigger on signals entering or leaving a defined voltage range.
IviDigitizerTriggerModifier | Yes | IviDigitizer with the ability to perform an alternative triggering function in the event that the specified trigger event doesn?t occur.
IviDigitizerTriggerHoldoff | Yes |

Optional Features

This section provides IVI-required information regarding optional IVI driver features supported by the AgMD1 driver.

Feature | Supported
Interchangeability checking | No
State caching | No
Coercion recording | No

Driver Identification

This section provides IVI-required identity information for the AgMD1 driver.

Identification Category | Description
Driver Revision | 1.4
Driver Vendor | Agilent Technologies
Driver Description | IVI Driver for the Agilent AgMD1 Family of Digitizer Modules
Prefix/Component Identifier | AgMD1
Supported Models | DC270, DC240, DC265, DC271, DC271A, DC211, DC241, DC271AR, DC241A, DC211A, DC282, DC222, DC282HZ, DC222HF, DC222HZ, DC252, DC252HF, DC252HZ, DC440, DC436, DC438, DC152, DC152HZ, DC122, DC122HF, DC122HZ, M9210A, M9211A, DP105, DP106, DP110, DP111, DC110, DP210, DP211, DP212, DP214, DP235, DP240, DC135, DC140, DC140HZ, DC135HZ, DP306, DP308, DP310, U1071A002, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1071A004, DP1400, U1091AD28, M9202A, M9203A, U1084A001, U1084A002, U1084A003, M9703A


AgMD1 IVI-COM Driver

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1 IVI-COM Driver

The AgMD1 driver includes a fully compliant IVI-COM driver. The topics in this section detail how to perform specific programming tasks using the IVI-COM interfaces available with the AgMD1 driver.

In This Section

Initializing the IVI-COM Driver

Presents the steps required to properly initialize the IVI-COM driver.

Accessing Instrument-Specific Functionality

Explains how to access the specialized functionality of the AgMD1 driver.

Using Simulation

Provides information on using the simulation capabilities of the driver.

Programming with the IVI-COM Driver in Various Development Environment

Demonstrates how the AgMD1 driver can be used in a various application development environments (ADEs).

Reference

Presents reference documentation for each IVI-COM method and property.


Initializing the IVI-COM Driver

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Initializing the IVI-COM Driver

Initializing the IVI-COM driver proceeds in two steps. First, the IVI-COM driver must be instantiated and then the Initialize function is called. This topic explains these two steps along with the options available for each step.

Instantiating the IVI-COM Driver

There are two ways to instantiate the IVI-COM driver -- direct instantiation using the specific driver name, and using the COM Session Factory. If the client application is to be interchangeable, then the COM Session Factory must be used and the driver must support an IVI instrument class. This driver supports IviDigitizer. This component exposes a CreateDriver function that accepts a logical name for the driver. Instantiating the driver by name keeps the client program from having any dependencies on a specific driver and enables the application to be interchangeable.

If interchangeability is not necessary for a particular client application or the driver does not support an IVI instrument class, then you may instantiate the IVI-COM driver directly. The exact syntax for creating an instance of a COM component varies from language to language. For instance, the CreateInstance function can be used in C++ while the new operator is used in C# and Visual Basic.NET. In any event, the client application will have a direct reference to the specific driver, so the program would not be interchangeable. For many applications, this is perfectly acceptable.

The examples below in the section describing the Initialize function will present both techniques for instantiating an IVI-COM driver.

Calling the Initialize Function

The IVI-defined Initialize function offers a variety of options and parameters that control fundamental aspects of the driver's behavior. It is critical to understand what options are available and how they impact driver operation.

ResourceName

The ResourceName parameter can be a logical name present in the IVI Configuration Store or a physical resource descriptor. If the ResourceName is a logical name, then additional options stored in the IVI Configuration Store will be loaded and processed. This allows client code to reuse driver option settings and to keep the driver code as concise as possible, by removing settings that can be stored in the IVI Configuration Store. It is important to note that any parameters or options passed directly to the Initialize function via the OptionString parameter (discussed below) override any settings found in the IVI Configuration Store.

Interface Physical Resource Descriptor Syntax
GPIB GPIB[board]::primary address[::secondary address][::INSTR]
Example: GPIB0::18::INSTR
ASRL ASRL[board][::INSTR]
Example: ASRL1::INSTR
TCPIP TCPIP[board]::host address[::LAN device name]::INSTR
Example: TCPIP0::127.0.0.1::INSTR
TCPIP TCPIP[board]::host address::port::SOCKET
Example: TCPIP0::127.0.0.1::5025::SOCKET
USB USB[board]::manufacturer ID::model code::serial number[::USB interface number][::INSTR]
Example: USB0::2391::291::SN_001001::INSTR
PXI PXI[bus]::device[::function][::INSTR]
Example: PXI1::5::INSTR
PXI PXI0::CHASSISchassis::SLOTslot[::FUNCfunction][::INSTR]
PXI0::bus-device[.function][::INSTR]

IdQuery

If this is enabled, the driver will query the instrument model and compare it with a list of instrument models that is supported by the driver. If the model is not supported, Initialize will fail with the E_IVI_ID_QUERY_FAILED error code.

Reset

If this is enabled, the driver will perform a reset of the instrument. If the reset fails, Initialize will fail with the E_IVI_RESET_FAILED error code.

OptionString

The OptionString allows the user to pass optional settings to the driver. These settings override any settings that are specified in the IVI Configuration Store. If the IVI Configuration Store is not used (a resource descriptor is passed as the ResourceName instead of a logical name) then any setting that is not specified has a default value as specified by IVI.

Option Name | Description | Default
QueryInstrStatus | Specifies whether the IVI specific driver queries the instrument status at the end of each user operation. Querying the instrument status is very useful for debugging. After validating the program, the user can set this attribute to False to disable status checking and maximize performance. The user specifies this value for the entire IVI driver session. | false
Simulate | Specifies whether or not the IVI specific driver simulates instrument driver I/O operations. If simulation is enabled, the specific driver functions do not perform instrument I/O. For output parameters that represent instrument data, the specific driver functions return simulated values. | false
Cache | Specifies whether or not to cache the value of attributes. When caching is enabled, the IVI specific driver keeps track of the current instrument settings so that it can avoid sending redundant commands to the instrument. | true
InterchangeCheck | Specifies whether the IVI specific driver performs interchangeability checking. If the Interchange Check attribute is enabled, the specific driver maintains a record of each interchangeability warning that it encounters. The user calls the Get Next Interchange Warning function to extract and delete the oldest interchangeability warning from the list. | false
RangeCheck | Specifies whether the IVI specific driver validates attribute values and function parameters. If enabled, the specific driver validates the parameter values that users pass to driver functions. Validating attribute values and function parameters is useful for debugging. After validating the program, the user can set this attribute to False to disable range checking and maximize performance. | true
RecordCoercions | Specifies whether the IVI specific driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the Record Value Coercions attribute is enabled, the specific driver maintains a record of each coercion. The user calls the Get Next Coercion Record function to extract and delete the oldest coercion record from the list. | false
DriverSetup | Specifies additional settings supported by the driver, but not defined by IVI. | ""

DriverSetup

This is used to specify settings that are supported by the driver but not defined by IVI. If the Options String parameter contains an assignment for the Driver Setup attribute, the Initialize function assumes that everything following 'DriverSetup=' is part of the assignment. The following settings are supported by the AgMD1 driver.

Option Name | Description | Default
Model | Instrument model to use during simulation. Must be one of the supported model strings as returned by the IviDriver.Identity.SupportedInstrumentModels property. | (default_model)
Trace | If true, output trace log of all driver calls to an XML file in the same directory as the application executable accessing the driver or as specified by the TraceName option. The log file may be viewed in your web browser. Beginning with Agilent IO Libraries Suite 16.0, driver trace messages may also be viewed with the IO Monitor utility. See IO Monitor help for details. | false
TraceName | If specified, sets the path and file name for the XML log file output when option Trace=true. It is not necessary to include the .xml extension with the name. Example: 'DriverSetup = Trace=true, TraceName=C:\Temp\TraceOut' If not specified, tracing generates a unique XML trace file name based on the date and time. A new file is created each time the driver is initialized with tracing enabled. | ""
TraceArray | If true, array parameter data is output to the trace log. | false
TraceArraySizeMax | Specifies the maximum number of elements to trace for array parameters. Requires option 'TraceArray=true'. | 10
TraceSizeMax | Specifies the maximum size of the trace log file in bytes. Once the file reaches this size, tracing will be turned off automatically by the driver. | 1000000
TraceSaveInterval | Specifies how often the driver should save trace data to the trace log file. The value is specified in minutes. | 1

Example 1 (no range checking, no state caching) -- Instantiate with the COM Session Factory

Note: This example only applies to drivers that support an IVI instrument class. This driver supports: IviDigitizer

The following code initializes the driver with default options, except for range checking and state caching which are turned off.

C++ Copy image Copy Code
#import "IviDriverTypeLib.dll" no_namespace
#import "IviSessionFactory.dll" no_namespace

void main()
{
  try
  {
    // Create an instance of the driver using the session factory.
    // This code is interchangeable since no reference to the specific driver exists.
    IIviSessionFactory spFactory(__uuidof(IviSessionFactory));
    IIviDriverPtr spDriver = spFactory->CreateDriver(_T("MyLogicalName"));

    // Initialize the driver with no range checking and no state caching
    // This will also check the instrument ID to make sure it is supported
    // and reset the instrument
    spDriver->Initialize(_T("MyLogicalName"), VARIANT_TRUE, VARIANT_TRUE, _T("RangeCheck=false, Cache=false"));

    // Use the driver...

    // Close the session
    spDriver->Close();
  }
  catch (_com_error&)
  {
  }
}
C# Copy image Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Ivi.SessionFactory.Interop;

public class App
{
  public static void Main(string[] args)
  {
    try
    {
      // Create an instance of the driver using the session factory
      // This code is interchangeable since no reference to the specific driver exists.
      IIviSessionFactory factory = new IviSessionFactoryClass();
      IIviDriver driver = (IIviDriver)factory.CreateDriver("MyLogicalName");

      // Initialize the driver with no range checking and no state caching
      // This will also check the instrument ID to make sure it is supported
      // and reset the instrument
      driver.Initialize("MyLogicalName", true, true, "RangeCheck=false, Cache=false");

      // Use the driver...

      // Close the session
      driver.Close();
    }
    catch (Exception e)
    {
      Console.WriteLine(e.Message);
    }
  }
}

Example 2 (simulation) -- Direct Driver Instantiation

The following code initializes the driver in simulation mode and specifies the model to simulate.

C++ Copy image Copy Code
#import "IviDriverTypeLib.dll" no_namespace
#import "IviSessionFactory.dll" no_namespace
#import "AgMD1.dll" no_namespace

void main()
{
  try
  {
    // Instantiate the driver class directly
    IIviDriverPtr spDriver(__uuidof(AgMD1)); // not interchangeable, using driver class name

    // Initialize the driver with no range checking and no state caching
    // This will also check the instrument ID to make sure it is supported
    // and reset the instrument
    spDriver->Initialize(_T("GPIB0::13::INSTR"), VARIANT_TRUE, VARIANT_TRUE, _T("Simulate=true, DriverSetup= Model=M9210A"));

    // Use the driver ...

    // Close the session
    spDriver->Close();
  }
  catch (_com_error&)
  {
  }
}
C# Copy image Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Ivi.SessionFactory.Interop;
using Agilent.AgMD1.Interop;

public class App
{
  [STAThread]
  public static void Main(string[] args)
  {
    try
    {
      // Instantiate the driver class directly
      IIviDriver driver = new AgMD1Class(); // not interchangeable, using driver class name

      // Initialize the driver with no range checking and no state caching
      // This will also check the instrument ID to make sure it is supported
      // and reset the instrument
      driver.Initialize("GPIB0::13::INSTR", true, true, "Simulate=true, DriverSetup= Model=M9210A");

      // Use the class-compliant capabilities...

      // Close the session
      driver.Close();
    }
    catch (Exception e)
    {
      Console.WriteLine(e.Message);
    }
  }
}


Writing Interchangeable Code Using the IviDigitizer Class-Compliant Interfaces

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Writing Interchangeable Code Using the IviDigitizer Class-Compliant Interfaces

IVI class-compliant capabilities refers to functionality defined for a particular instrument class, such as IviDigitizer for digitizers. IVI drivers may or may not include class-compliant capabilities. Users that wish to write interchangeable application programs must restrict themselves to accessing only the IVI-defined (Inherent and class-compliant) interfaces on the IVI-COM driver.

Often, an instrument driver will expose functionality through the instrument-specific interfaces that is not available in the class-compliant interfaces. If some of the instrument-specific capabilities are required in an application program, then it is a good design practice to isolate those sections that access instrument-specific capabilities from those sections that only use the class-compliant capabilities. This makes it possible to have sections of easily identifiable interchangeable and non-interchangeable application code.

Example 1 -- Using IviDigitizer Interfaces

The following C# code accesses the class-compliant interfaces, and uses the IVI Session Factory for interchangeability. Since this code uses only IVI-defined interfaces, there are no references to any instrument-specific driver details. This means the code is interchange

C++ Copy image Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Ivi.Digitizer.Interop;
using Ivi.SessionFactory.Interop;

namespace ClientApp
{
  public class App
  {
    [STAThread]
    public static void Main(string[] args)
    {
      try
      {
        // Create an instance of the session factory
        IIviSessionFactory factory = new IviSessionFactoryClass();

        // Ask the session factory to create an instance of
        // the appropriate driver based on a logical name
        IIviDigitizer digitizer = (IIviDigitizer)factory.CreateDriver("MyLogicalName");

        // Initialize the driver using the same logical name
        digitizer.Initialize("MyLogicalName", true, true, "");

        // Use the class-compliant capabilities...
        digitizer.Acquisition.SampleRate = 1000;
        digitizer.Acquisition.NumRecordsToAcquire = 500;

        // Close the session
        digitizer.Close();
      }
      catch (Exception e)
      {
        Console.WriteLine(e.Message);

        // Handle errors appropriately
      }
    }
  }
}

Example 2 -- Using IviDigitizer and Instrument-Specific Interfaces

The following code accesses the class-compliant interfaces as well as some instrument-specific interfaces for functionality that is not exposed in the class-compliant interfaces. Since this example has instrument-specific references in it, the code is not interchangeable.

C++ Copy image Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Ivi.Digitizer.Interop;
using Ivi.SessionFactory.Interop;
using Agilent.AgMD1.Interop; // WARNING: non-interchangeable code

namespace ClientApp
{
  public class App
  {
    [STAThread]
    public static void Main(string[] args)
    {
      try
      {
        // Create an instance of the session factory
        IIviSessionFactory factory = new IviSessionFactoryClass();

        // Ask the session factory to create an instance of
        // the appropriate driver based on a logical name
        IIviDigitizer digitizer = (IIviDigitizer)factory.CreateDriver("MyLogicalName");

        // Initialize the driver using the same logical name
        digitizer.Initialize("MyLogicalName", true, true, "");

        // Use the class-compliant capabilities...
        digitizer.Acquisition.SampleRate = 10000;
        digitizer.Acquisition.NumRecordsToAcquire = 1000;

        // WARNING: non-interchangeable code
        // Accessing instrument-specific capabilities
        IAgMD1 driver = (IAgMD1)digitizer;
        driver.ConfigureTrigger(AgMD1TriggerSourceEnum.AgMD1TriggerSourceBackplane, 50, true);

        // Close the session
        digitizer.Close();
      }
      catch (Exception e)
      {
        Console.WriteLine(e.Message);

        // Handle error appropriately
      }
    }
  }
}


Accessing Repeated Capabilities

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Accessing Repeated Capabilities

This page provides information on the supported repeated capabilities and repeated capability names for the AgMD1 driver.

Repeated Capabilities

The AgMD1 driver supports the following repeated capabilities:

  • Channel
  • TriggerSource
  • ArmSource
  • DelayControl
  • LogicDevice

The following table provides detailed information on each repeated capability supported by the AgMD1 driver.

For a detailed explanation of repeated capabilities, including repeated capability styles, physical names, and dynamic repeated capabilities, see the topic Repeated Capabilities.

Repeated Capability | IVI-COM Style | Dynamic | Physical Names
Channel | Collection | Yes | Channel1
TriggerSource | Collection | Yes |
ArmSource | Collection | No |
DelayControl | Collection | Yes |
LogicDevice | Collection | Yes |


Accessing Instrument-Specific Functionality

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Accessing Instrument-Specific Functionality

As the name implies, the instrument-specific capabilities are those methods and properties that are unique to the instrument. In practice, the instrument-specific portion of the driver exposes the full functionality of the instrument -- including functionality that may also be available in the class-compliant capabilities. Users that do not care about interchangeability or that need to access functionality that is not defined by IVI will use the instrument-specific interfaces in application programs.

When to use the instrument specific interfaces

  • When the required functionality is not exposed in the class-compliant interfaces.
  • When interchangeability is not a requirement.
  • When performance is critical. Sometimes a driver may perform better using the instrument specific interfaces because they match the instrument functionality more closely than the class-compliant interfaces.

Example

The following client code uses the instrument specific interfaces.

C++ Copy image Copy Code
#import "IviDriverTypeLib.dll" no_namespace
#import "AgMD1.dll" no_namespace

void main()
{
  try
  {
    // Instantiate the driver class directly
    IAgMD1Ptr spDriver(__uuidof(AgMD1));

    // Initialize the driver
    spDriver->Initialize(_T("GPIB0::13::INSTR"), VARIANT_TRUE, VARIANT_TRUE, _T(""));

    // Use instrument specific interfaces...
    spDriver->Output->Enabled = VARIANT_TRUE;

    // Close the session
    spDriver->Close();
  }
  catch (_com_error&)
  {
  }
}
C# Copy image Copy Code
using System;
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Agilent.AgMD1.Interop;

namespace ClientApp
{
  public class App
  {
    [STAThread]
    public static void Main(string[] args)
    {
      try
      {
        // Instantiate the driver class directly
        IAgMD1 driver = new AgMD1Class();

        // Initialize the driver
        driver.Initialize("GPIB0::13::INSTR", true, true, "");

        // Use instrument specific interfaces...
        driver.Output.Enabled = true;

        // Close the session
        driver.Close();
      }
      catch (Exception e)
      {
        Console.WriteLine(e.Message);
      }
    }
  }
}


Using Simulation

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Simulation

An IVI driver can operate without the presence of an actual instrument by using simulation mode. When simulation is turned on, the driver performs no instrument communication, but attempts to generate results which allow client applications to reasonably execute. You can turn on simulation using either of the following two techniques:

  • Passing the "simulate=true" option string parameter to the Initialize method.
  • Setting the Simulate property to True.

The IVI-COM driver contains a Simulate property in the IIviDriverOperation interface. The IVI-C driver contains a corresponding Simulate attribute. Note that if you initialize an IVI-COM driver with simulation turned off you can later turn the simulation on. However, if you initialize an IVI-COM driver with simulation turned on, you will get an error (The simulation state cannot be changed) if you attempt to later turn it off. This is because you cannot initiate a live I/O session with an instrument after you have called the Initialize function.

Using The Option String

The fourth and last parameter to the Initialize method is the option string. See the help on Initialize for more details. To turn simulation on with the option string, include the following in the option string:

simulate=true

For example, the Initialize call in C# might look like this:

instr.Initialize("GPIB0::13::INSTR", true, true, "Simulate=True");

When the simulate option is set True, the value of the resource descriptor parameter (the first parameter above) is ignored. This is because no I/O connection will be made with the instrument, as is required by IVI-3.1: Driver Architecture Specification.

The Driver Session Simulate Property

A DriverSession in the IVI Configuration Store contains properties for the same items which can be set with the option string parameter. The name of a DriverSession, or the name of a LogicalName which points to a DriverSession, can be used as the first parameter to Initialize. If the Simulate property in the DriverSession is true, the driver is initialized in simulation mode.

Changing the Instrument Model

Many drivers support more than one instrument model. These models are listed in the SupportedInstrumentModels property in the IIviDriverIdentity interface. Drivers will typically select one of these as the default model by creating a special type of entry in the IVI Configuration Store known as a Configurable Initial Settings. You can modify the Model value in the Configurable Initial Settings for the DriverSession of interest, or you can simply specify the model to simulate at runtime during the call to Initialize.

To have the driver simulate a specific model of your choosing, simply add the desired model to the DriverSetup string using the following special syntax:

Simulate=true, DriverSetup=Model=M9210A

The complete Initialize call becomes:

instr.Initialize("GPIB0::13::INSTR", True, True, "Simulate=True, DriverSetup= Model=M9210A")

If you set the model to a value not supported by the driver, the driver reports an error.

Limitations of Simulation

Simulation is designed to allow the driver to be used without an instrument or any I/O software or hardware. However, simulation is not intended to fully emulate the instrument. There are some important differences you should be aware of:

  • Many instruments have status systems, and these are not live. For instance, you can set Enable and Transition registers but queries of Condition and Event registers will always return a fixed value, which is usually zero.
  • There often is no parameter range checking or coercion unless done in the driver. Most drivers depend on the instrument to perform range checking and coercion of parameter values. In simulation mode, this will not occur. For example setting a frequency parameter to 1E99 will be accepted without error in simulation where an instrument would return a "parameter out of range" error.
  • IIviDriverUtility::ErrorQuery() typically returns no error.
  • Measurement data is not live. Most data queries will return a fixed value or a small array of values.


Programming with the IVI-COM Driver in Various Development Environments

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Programming with the IVI-COM Driver in Various Development Environments

IVI-COM drivers are implemented using standard COM technology. Specifically, IVI-COM drivers support what are known as custom COM interfaces. To ensure compatibility with the broadest possible set of development environments, the IVI specifications restrict data types that can be used in an IVI-COM driver to a special set called oleautomation data types (also known simply as automation data types. Automation types were originally designed for Visual Basic but have since gained broad acceptance. Consequently, IVI-COM drivers can be used in a wide variety of development environments, namely, those that support custom oleautomation COM interfaces.

IVI-COM Drivers and .NET

Interop assemblies are used in .NET environments, such as C# and VB.NET, to access COM components. When installing an IVI-COM driver on a computer with the .NET Framework, the IVI specifications require an interop assembly be deployed and properly registered. The full path to the interop assembly for the AgMD1 driver is:

<IviInstallDir>\Bin\Primary Interop Assemblies\Agilent.AgMD1.Interop.dll

The topics in this section provide detailed instructions on how to access and use IVI-COM drivers in a variety of popular development environments. Each topic includes a complete example of IVI-COM driver usage.

In This Section

Using C#

Provides instructions on using interop assemblies to access IVI-COM drivers.

Using Visual Basic.NET

Describes the process for importing interop assemblies into Visual Basic.NET and invoking methods and properties.

Using Visual C++

Explains how to import IVI-COM driver type libraries into C++ and use smart pointers to access methods and properties.

Using Visual Basic 6

Explains how to use IVI-COM drivers with pre-.NET Visual Basic.

Using Agilent VEE Pro®

Presents information on using the driver with Agilent VEE Pro.

Using LabVIEW®

Provides an introduction to LabVIEW's special support of IVI-COM.

Using MATLAB®

Presents information on using the driver with MATLAB.

Using Simulation

Presents information on using the simulation capabilities of the driver.


Using Visual C#

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Visual C#

This section describes how to use an IVI-COM driver from Visual C#.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver DLL and at least one of the IVI DLLs (specifically, IviDriverTypeLib.dll) must be created.

  1. In solution explorer, right-click on References and select Add Reference.
  2. Click the COM tab.
  3. Select the following type libraries:
    • IviDriver 1.0 Type Library
    • IviDigitizer 3.0 Type Library
    • IviSessionFactory 1.0 Type Library
    • IVI AgMD1 1.4 Type Library
  4. Click the Select button and then OK.
  5. Each of the above type libraries should now appear under the References node in solution explorer.

All data types (interfaces and enums) are contained within namespaces. Usually the namespace-qualified name must be used, but the C# using statement allows the type name to be used directly.

C# Copy image Copy Code
using Ivi.Driver.Interop;
using Ivi.Digitizer.Interop;
using Agilent.AgMD1.Interop;
using Ivi.SessionFactory.Interop;

Creating an Instance of the Driver

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the instance of the driver using the COM Session Factory.

C# Copy image Copy Code
IIviSessionFactory factory = new IviSessionFactoryClass();
IIviDigitizer digitizer = factory.CreateDriver("MyLogicalName");

Creating a Driver Instance Directly

It is not necessary to use the COM Session Factory to instantiate the driver when using the instrument specific capabilities because interchangeability is already compromised since a reference to the driver DLL is required.

C# Copy image Copy Code
IAgMD1 driver = new AgMD1Class();

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if Close is not called.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party configuration utility.

C# Copy image Copy Code
digitizer.Initialize("MyLogicalName", false, false, "");
digitizer.Close();

Initializing Using a Resource Descriptor

When interchangeability is not required, the driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C# Copy image Copy Code
digitizer.Initialize("GPIB0::13::INSTR", false, false, "");
digitizer.Close();

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on Initialize, see Initializing the Driver topic.

C# Copy image Copy Code
// If true, this will query the instrument model and fail initialization
// if the model is not supported by the driver
bool idQuery = false;

// If true, the instrument is reset at initialization
bool reset = false;

// Setup IVI-defined initialization options
string standardInitOptions =
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false";

// Setup driver-specific initialization options
string driverSetupOptions =
  "DriverSetup= Model=M9210A, Trace=false";

digitizer.Initialize("MyLogicalName", idQuery, reset, standardInitOptions + "," + driverSetupOptions);
digitizer.Close();

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Simple Data Types

C# Copy image Copy Code
// Set the value of a property
digitizer.Acquisition.SampleRate = 2000;

// Get the value of a property
double rate = digitizer.Acquisition.SampleRate;

// Set the value of a property (enum)
digitizer.Trigger.Sources.get_Item("Channel1").Type = IviDigitizerTriggerTypeEnum.IviDigitizerTriggerTypeEdge;

// Read a value from a method (as a return value)
double measuredValue = digitizer.Measure(5000);

Strings

C# Copy image Copy Code
// Get a string property
string description = digitizer.Identity.Description;

// Read a value from a method (as a return value)
string coercionRecord = digitizer.DriverOperation.GetNextCoercionRecord();

// Read a value from a method (as an out parameter)
string errMsg = null;
int errCode = 0;
digitizer.Utility.ErrorQuery(ref errCode, ref errMsg);

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval].

C# Copy image Copy Code
// Read an array of values, this returns a typed array
double incX;
double incY;
double[] measuredValues = digitizer.Measurements.get_Item("Channel1").ReadWaveform(5000, ref incX, ref incY);

// Iterate through the array
for (int i = 0; i < measuredValues.Length; i++)
{
  double measuredValue = measuredValues[i];
}

This example demonstrates passing an input array to a driver method. Note the use of the C# ref keyword.

C# Copy image Copy Code
// Here we know in advance the exact size of the array
double[] frequencies = new double[3];
frequencies[0] = 10.0E6;
frequencies[1] = 12.0E6;
frequencies[2] = 14.0E6;

// An array input parameter takes a reference to an array
driver.ConfigureFrequencies(ref frequencies);

// Here we do not know in advance the size of the array
// so we use a resizable array
ArrayList valueList = new ArrayList();
valueList.Add(10.0E6);
valueList.Add(12.0E6);
valueList.Add(14.0E6);

// Create a fixed size array from the resizable array
double[] valueArray = (double[])valueList.ToArray(typeof(double));

// An array input parameter takes a reference to an array
driver.ConfigureFrequencies(ref valueArray);

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities. This driver may not use any or all types of repeated capabilites. The example code in this section may be from other drivers and can not be used directly with this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Channel1") of a collection-style repeated capability. capability. Note that C# requires a special syntax when using parameterized properties, such as the Item property. Specifically parameterized properties appear in C# as methods with "get_" prepended to the property name.

C# Copy image Copy Code
IIviDigitizerChannel ch = digitizer.Channels.get_Item("Channel1");

ch.Offset = 0.1;

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a selector-style repeated capability:

C# Copy image Copy Code
IIviSpecAnMarker marker = specAn.Marker;

marker.ActiveMarker = "Marker1";
marker.Position = 1.2E9;
marker.Enabled = true;

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a parameter-style repeated capability:

C# Copy image Copy Code
IIviFgenFM fm = fgen.FM;

fm.set_Enabled("Channel1", true);
bool enabled = fm.get_Enabled("Channel1");

Complete Example

The following code demonstrates a console application that uses the COM Session Factory to create the driver. The example also demonstrates use of class-compliant interfaces and shows how to handle errors from the instrument and from the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Agilent IVI Drivers, AgMD1, Examples

C# Copy image Copy Code
using System.Runtime.InteropServices;
using Ivi.Driver.Interop;
using Ivi.Digitizer.Interop;
using Ivi.SessionFactory.Interop;

namespace ClientApp
{
  public class App
  {
    [STAThread]
    public static void Main(string[] args)
    {
      try
      {
        string logicalName = "MyLogicalName";

        IIviSessionFactory factory = new IviSessionFactoryClass();
        IIviDriver driver = (IIviDriver)factory.CreateDriver(logicalName);

        // IIviDriverIdentity properties - Initialize not required
        string identifier = driver.Identity.Identifier;
        Console.WriteLine("Identifier: {0}", identifier);

        string revision = driver.Identity.Revision;
        Console.WriteLine("Revision: {0}", revision);

        string vendor = driver.Identity.Vendor;
        Console.WriteLine("Vendor: {0}", vendor);

        // Setup IVI-defined initialization options
        string standardInitOptions =
          "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false";

        // Setup driver-specific initialization options
        string driverSetupOptions =
          "DriverSetup= Model=M9210A, Trace=false";

        driver.Initialize(logicalName, false, false, standardInitOptions + "," + driverSetupOptions);

        try
        {
          // IIviDriverIdentity properties - Initialize required
          string instModel = driver.Identity.InstrumentModel;
          Console.WriteLine("InstrumentModel: {0}", instModel);

          string instFirmwareRevision = driver.Identity.InstrumentFirmwareRevision;
          Console.WriteLine("InstrumentFirmwareRevision: {0}", instFirmwareRevision);

          string instManufacturer = driver.Identity.InstrumentManufacturer;
          Console.WriteLine("InstrumentManufacturer: {0}", instManufacturer);

          IIviDigitizer digitizer = (IIviDigitizer)driver;

          digitizer.Acquisition.SampleRate = 2000;
          digitizer.Acquisition.NumRecordsToAcquire = 500;

          // Check instrument for errors
          int errorNum = -1;
          string errorMsg = null;
          Console.WriteLine("");
          while (errorNum != 0)
          {
            driver.Utility.ErrorQuery(ref errorNum, ref errorMsg);
            Console.WriteLine("ErrorQuery: {0}, {1}", errorNum, errorMsg);
          }
        }
        catch (COMException ex)
        {
          if (ex.ErrorCode == (int)IviDriver_ErrorCodes.E_IVI_INSTRUMENT_STATUS)
          {
            // ErrorQuery should give us more information
            int errCode = 0;
            string errMsg = "";
            driver.Utility.ErrorQuery(ref errCode, ref errMsg);

            // Print the error
            Console.WriteLine("Instrument Error: {0}, {1}", errCode, errMsg);
          }
          else
          {
            // Print the exception
            Console.WriteLine("Exception: {0}", ex.Message);
          }
        }

        // Close driver
        driver.Close();
      }
      catch (Exception e)
      {
        Console.WriteLine(e.Message);
      }

      Console.WriteLine("Done - Press Enter to Exit");
      Console.ReadLine();
    }
  }
}


Using Visual Basic.NET

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Visual Basic.NET

This section describes how to use an IVI-COM driver from Visual Basic 6.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver DLL and at least one of the IVI DLLs (specifically, IviDriverTypeLib.dll) must be created.

  1. In solution explorer, right-click on References and select Add Reference.
  2. Click the COM tab.
  3. Select the following type libraries:
    • IviDriver 1.0 Type Library
    • IviDigitizer 3.0 Type Library
    • IviSessionFactory 1.0 Type Library
    • IVI AgMD1 1.4 Type Library
  4. Click the Select button and then OK.
  5. Each of the above type libraries should now appear under the References node in solution explorer.

All data types (interfaces and enums) are contained within namespaces. Usually the namespace-qualified name must be used, but the VB Imports statement allows the type name to be used directly.

Visual Basic Copy image Copy Code
Imports Ivi.Driver.Interop
Imports Ivi.Digitizer.Interop
Imports Agilent.AgMD1.Interop
Imports Ivi.SessionFactory.Interop

Creating an Instance of the Driver

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the instance of the driver using the COM Session Factory.

Visual Basic Copy image Copy Code
Dim factory As New IviSessionFactoryClass()
Dim digitizer As IIviDigitizer = factory.CreateDriver("MyLogicalName")

Creating a Driver Instance Directly

It is not necessary to use the COM Session Factory to instantiate the driver when using the instrument specific capabilities because interchangeability is already compromised since a reference to the driver DLL is required.

Visual Basic Copy image Copy Code
Dim driver As new AgMD1

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if Close is not called.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party configuration utility.

Visual Basic Copy image Copy Code
digitizer.Initialize("MyLogicalName", False, False, "")
digitizer.Close()

Initializing Using a Resource Descriptor

When interchangeability is not required, the driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

Visual Basic Copy image Copy Code
digitizer.Initialize("GPIB0::13::INSTR", False, False, "")
digitizer.Close()

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on Initialize, see Initializing the Driver topic.

Visual Basic Copy image Copy Code
' If True, this will query the instrument model and fail initialization
' if the model is not supported by the driver
Dim idQuery As Boolean = False

' If True, the instrument is reset at initialization
Dim reset As Boolean = False

' Setup IVI-defined initialization options
Dim standardInitOptions As String = _
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false"

' Setup driver-specific initialization options
Dim driverSetupOptions As String = _
  "DriverSetup= Model=M9210A, Trace=false"

digitizer.Initialize("MyLogicalName", idQuery, reset, standardInitOptions + "," + driverSetupOptions)
digitizer.Close()

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Simple Data Types

Visual Basic Copy image Copy Code
' Set the value of a property
digitizer.Acquisition.SampleRate = 2000

' Get the value of a property
Dim rate as Double = digitizer.Acquisition.SampleRate

' Set the value of a property (enum)
digitizer.Trigger.Sources.Item("Channel1").Type = IviDigitizerTriggerTypeEnum.IviDigitizerTriggerTypeEdge

' Read a value from a method (as a return value)
Dim measuredValue as Double = digitizer.Measurements.Item("Channel1").ReadWaveformMeasurement(IviDigitizerMeasurementEnum.IviDigitizerMeasurementPeriod, 5000)

Strings

Visual Basic Copy image Copy Code
' Get a string property
Dim description As String = digitizer.Identity.Description

' Read a value from a method (as a return value)
Dim coercionRecord As String = digitizer.DriverOperation.GetNextCoercionRecord()

' Read a value from a method (as an out parameter)
Dim errMsg As String = ""
Dim errCode As Integer = 0
digitizer.Utility.ErrorQuery(errCode, errMsg)

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval].

Visual Basic Copy image Copy Code
' Read an array of values. This returns a typed array
Dim measuredValues() As Double = digitizer.Measurement.ReadMultiPoint(5000)

' Iterate through the array
Dim index As Integer
For index = 0 To (measuredValues.Length - 1)
  Dim measuredValue As Double = measuredValues(i)
Next

This example demonstrates passing an input array to a driver method.

Visual Basic Copy image Copy Code
' Here we know in advance the exact size of the array
Dim frequencies(3) As Double
frequencies(0) = 10.0E6
frequencies(1) = 12.0E6
frequencies(2) = 14.0E6

' An array input parameter takes a reference to an array
driver.ConfigureFrequencies(frequencies)

' Here we do not know in advance the size of the array
' so we use a resizable array
Dim valueList As New ArrayList
valueList.Add(10.0E6)
valueList.Add(12.0E6)
valueList.Add(14.0E6)

' Create a fixed size array from the resizable array
Dim valueArray() As Double
valueArray = valueList.ToArray(GetType(Double))

' An array input parameter takes a reference to an array
driver.ConfigureFrequencies(valueArray)

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities. This driver may not use any or all types of repeated capabilites. The example code in this section may be from other drivers and can not be used directly with this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Channel1") of a collection-style repeated capability. capability.

Visual Basic Copy image Copy Code
IIviDigitizerChannel ch = digitizer.Channels.Item("Channel1")

ch.Offset = 0.1

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a selector-style repeated capability:

Visual Basic Copy image Copy Code
Dim marker As IIviSpecAnMarker = specAn.Marker

marker.ActiveMarker = "Marker1"
marker.Position = 1.2E9
marker.Enabled = true

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a parameter-style repeated capability:

Visual Basic Copy image Copy Code
Dim fm As IIviFgenFM = fgen.FM

fm.Enabled("Channel1") = true
Dim enabled As Boolean = fm.Enabled("Channel1")

Complete Example

The following code demonstrates a console application that uses the COM Session Factory to create the driver. The example also demonstrates use of class-compliant interfaces and shows how to handle errors from the instrument and from the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Agilent IVI Drivers, AgMD1, Examples

Visual Basic Copy image Copy Code
Imports System
Imports System.Runtime.InteropServices
Imports Ivi.Driver.Interop
Imports Ivi.Digitizer.Interop
Imports Ivi.SessionFactory.Interop

Module ClientApp

  Sub Main()

    Try

      Dim logicalName As String = "MyLogicalName"

      Dim factory As New IviSessionFactoryClass()
      Dim driver As IIviDriver = factory.CreateDriver(logicalName)

      ' IIviDriverIdentity properties - Initialize not required
      Dim identifier As String = driver.Identity.Identifier
      Console.WriteLine("Identifier: {0}", identifier)

      Dim revision As String = driver.Identity.Revision
      Console.WriteLine("Revision: {0}", revision)

      Dim vendor As String = driver.Identity.Vendor
      Console.WriteLine("Vendor: {0}", vendor)

      ' Setup IVI-defined initialization options
      Dim standardInitOptions As String = _
        "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false"

      ' Setup driver-specific initialization options
      Dim driverSetupOptions As String = _
        "DriverSetup= Model=M9210A, Trace=false"

      driver.Initialize(logicalName, False, False, standardInitOptions + "," + driverSetupOptions)

      Try

        ' IIviDriverIdentity properties - Initialize required
        Dim instModel As String = driver.Identity.InstrumentModel
        Console.WriteLine("InstrumentModel: {0}", instModel)

        Dim instFirmwareRevision As String = driver.Identity.InstrumentFirmwareRevision
        Console.WriteLine("InstrumentFirmwareRevision: {0}", instFirmwareRevision)

        Dim instManufacturer As String = driver.Identity.InstrumentManufacturer
        Console.WriteLine("InstrumentManufacturer: {0}", instManufacturer)

        Dim digitizer As IIviDigitizer = driver

        digitizer.Acquisition.SampleRate = 2000
        digitizer.Acquisition.NumRecordsToAcquire = 500

        ' Check instrument for errors
        Dim errorNum As Integer = -1
        Dim errorMsg As String = ""
        Console.WriteLine("")
        While (errorNum <> 0)

          driver.Utility.ErrorQuery(errorNum, errorMsg)
          Console.WriteLine("ErrorQuery: {0}, {1}", errorNum, errorMsg)

        End While

        Catch ex As COMException

          If ex.ErrorCode = IviDriver_ErrorCodes.E_IVI_INSTRUMENT_STATUS Then

            ' ErrorQuery should give us more information
            int errCode = 0;
            string errMsg = "";
            driver.Utility.ErrorQuery(errCode, errMsg)

            ' Print the error
            Console.WriteLine("Instrument Error: {0}, {1}", errCode, errMsg)

          Else

            ' Print the exception
            Console.WriteLine("Exception: {0}", ex.Message)

          End If

        End Try

        ' Close driver
        driver.Close()

      Catch e As Exception e

        Console.WriteLine(e.Message)

      End Try

      Console.WriteLine("Done - Press Enter to Exit")
      Console.ReadLine()

  End Sub

End Module


Using Visual C++

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Visual C++

This section describes how to use an IVI-COM driver from Visual C++. The techniques presented in this section work for Visual Studio 6 and later.

Smart Pointer Wrapper Classes

There are many ways to use COM objects, such as IVI-COM drivers, from Visual C++. The easiest way is to use the #import statement. This special compiler directive automatically generates smart pointer wrapper classes for every interface in your IVI-COM driver. These wrapper classes greatly simplify the use of IVI-COM drivers in C++.

Smart pointer wrapper classes have the following benefits:

  • They provide a simple syntax for instantiating the driver (e.g. calling CoCreateInstance).
  • They automatically call AddRef and Release when needed.
  • They automatically call QueryInterface when navigating to different interfaces on the driver.
  • Method parameters marked as [out, retval] appear as the method return value type instead of an HRESULT.
  • Properties can be accessed as a property instead of using get_ and put_ accessor functions.
  • Methods and properties throw exceptions rather than requiring explicit checks against an HRESULT return code.
  • String parameters (BSTRs) are transformed into the _bstr_t smart string class, which can be initialized with ANSI or Unicode strings.

The code in this section uses smart pointer wrappers. The #import statement supports a variety of optional parameters to exercise more precise control over the wrapper generation and format. See the MSDN documentation on #import for more details.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver DLL and at least one of the IVI DLLs (specifically, IviDriverTypeLib.dll) must be created. Note that the order of the #import statements shown below is important. Compilation will fail if the order is incorrect, as there are dependencies between the types defined in the various DLLs.

GlobMgr.dll is required by drivers using VISA-COM I/O. Generally, SCPI based instrument drivers use VISA-COM and non-SCPI based modular instrument drivers do not. If required, you may have to add the path to GlobMgr.dll (<Program Files>\IVIFoundation\Visa\VisaCom) to your Visual Studio, Tools, Options, Projects and Solutions, VC++ Directories path for executable files.

C++ Copy image Copy Code
#import "GlobMgr.dll" no_namespace  // VISA-COM I/O funtionality - omit for non-SCPI modular instruments
#import "IviDriverTypeLib.dll" no_namespace
#import "IviDigitizerTypeLib.dll" no_namespace      // can be omitted if not using class-compliant interfaces
#import "AgMD1.dll" no_namespace      // can be omitted if not using instrument-specific interfaces
#import "IviSessionFactory.dll" no_namespace    // can be omitted if not using session factory

Creating an Instance of the Driver

Unlike most environments that support COM, C++ does not automatically initialize COM, so this must be done explicitly. If you fail to perform this step, then any attempt to make any COM-based call (such as instantiating the driver) will fail.

C++ Copy image Copy Code
// Initialize COM, do this at the start of the program
HRESULT hr = ::CoInitialize(NULL);

// Uninitialize COM, do this at the end of the program
::CoUninitialize();

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the driver instance using the COM Session Factory. To instantiate the COM Session Factory, you simply pass in the CLSID of the COM Session Factory to the constructor of the wrapper class. The easiest way to obtain the CLSID of any COM class is via the __uuidof C++ keyword, as shown below.

C++ Copy image Copy Code
IIviSessionFactory spFactory(__uuidof(IviSessionFactory));
IIviDigitizerPtr spDigitizer = spFactory->CreateDriver(_T("MyLogicalName"));

spDigitizer->Range = 300;

Creating a Driver Instance Directly

It is not necessary to use the COM Session Factory to instantiate the driver when using the instrument specific capabilities because interchangeability is already compromised since a reference to the driver DLL is required.

To instantiate the driver directly, pass in the CLSID of the specific driver using the __uuidof C++ keyword, as shown below:

C++ Copy image Copy Code
IAgMD1Ptr spDriver(__uuidof(AgMD1));

double dMeasurement = spDriver->Measure();

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close is required by the IVI specifications, else unpredictable driver behavior could result. Simply releasing the driver object (which the wrapper classes automatically do for you) is not sufficient. The reference count of the driver will never reach zero if Close is not called.

For more details on the Initialize function, see Initializing the Driver topic.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party configuration utility.

C++ Copy image Copy Code
spDigitizer->Initialize(_T("MyLogicalName"), VARIANT_FALSE, VARIANT_FALSE, _T(""));
spDigitizer->Close();

Initializing Using a Resource Descriptor

When interchangeability is not required, the driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C++ Copy image Copy Code
spDigitizer->Initialize(_T("GPIB0::13::INSTR"), VARIANT_FALSE, VARIANT_FALSE, _T(""));
spDigitizer->Close();

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on Initialize, see Initializing the Driver topic.

C++ Copy image Copy Code
// If VARIANT_TRUE, this will query the instrument model and fail initialization
// if the model is not supported by the driver
VARIANT_BOOL idQuery = VARIANT_FALSE;

// If VARIANT_TRUE, the instrument is reset at initialization
VARIANT_BOOL reset = VARIANT_FALSE;

// Setup IVI-defined initialization options
_bstr_t standardInitOptions =
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false";

// Setup driver-specific initialization options
_bstr_t driverSetupOptions =
  "DriverSetup= Model=M9210A, Trace=false";

spDigitizer->Initialize(_T("MyLogicalName"), idQuery, reset, standardInitOptions + _bstr_t(_T(",")) + driverSetupOptions);
spDigitizer->Close();

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Simple Data Types

C++ Copy image Copy Code
// Set the value of a property
spDigitizer->Acquisition->SampleRate = 2000;

// Get the value of a property
double rate = spDigitizer->Acquisition->SampleRate;

// Set the value of a property (enum)
spDigitizer->Trigger->Sources->Item["Channel1"]->Type = IviDigitizerTriggerTypeEdge;

// Read a value from a method (as a return value)
double measuredValue = spDigitizer->Measure(5000);

Strings

It is important to correctly free the memory when reading or writing strings. Here the _bstr_t destructor takes care of freeing the memory when the object goes out of scope.

C++ Copy image Copy Code
// Get a string property
_bstr_t description = spDigitizer->Identity->Description;

// Read a value from a method (as a return value)
_bstr_t coercionRecord = spDigitizer->DriverOperation->GetNextCoercionRecord();

// Read a value from a method (as an out parameter)
_bstr_t errMsg;
long errCode;
spDigitizer->Utility->ErrorQuery(&errCode, errMsg.GetAddress());

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval]. This uses the CComSafeArray class to manage the memory automatically.

C++ Copy image Copy Code
#include <atlsafe.h> // for CComSafeArray

// Read an array of values, this returns a raw SAFEARRAY pointer
SAFEARRAY* psaMeasuredValues = spDigitizer->Measurement->ReadMultiPoint(5000);

// Use the CComSafeArray smart data type, transferring memory ownership to it
// Memory will be freed when the smart data type goes out of scope
CComSafeArray<double> csaMeasuredValues;
csaMeasuredValues.Attach(psaMeasuredValues);

// Iterate through the array
for (long i = 0; i < (long)csaMeasuredValues.GetCount(); i++)
{
  double measuredValue = csaMeasuredValues.GetAt(i);
}

It is important to know that the CComSafeArray constructor and assignment operator make a copy of the SAFEARRAY. For arrays containing many elements, this must be carefully taken into consideration. The Attach and Detach functions do not perform copies and can often be used when one might have unnecessarily used the constructor or assignment operator.

The code below demonstrates some common mistakes made when using SAFEARRAYs and the CComSafeArray class.

C++ Copy image Copy Code
#include <atlsafe.h> // for CComSafeArray

// DO NOT DO THIS, this will LEAK!
CComSafeArray<double> csaMeasuredValues = spDigitizer->Measurement->ReadMultiPoint(5000);

// DO NOT DO THIS, this will LEAK!
CComSafeArray<double> csaMeasuredValues(spDigitizer->Measurement->ReadMultiPoint(5000));

The following code demonstrates how to pass an array to a driver method.

C++ Copy image Copy Code
#include <atlsafe.h> // for CComSafeArray

CComSafeArray<double> csaFrequencies;
csaFrequencies.Add(10.0E6);
csaFrequencies.Add(12.0E6);
csaFrequencies.Add(14.0E6);

// An array input parameter takes a SAFEARRAY**
spDriver->ConfigureFrequencies(csaFrequencies.GetSafeArrayPtr());

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities. This driver may not use any or all types of repeated capabilites. The example code in this section may be from other drivers and can not be used directly with this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Channel1") of a collection-style repeated capability. capability. Note that C++ requires a special syntax when using parameterized properties, such as the Item property. Specifically, square brackets must be used around the repeated capability physical name.

C++ Copy image Copy Code
IIviDigitizerChannelPtr spChannel = spDigitizer->Channels->Item[_T("Channel1"));

spChannel->Offset = 0.1;

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a selector-style repeated capability:

C++ Copy image Copy Code
IIviSpecAnMarkerPtr spMarker = spSpecAn->Marker;

spMarker->ActiveMarker = _T("Marker1");
spMarker->Position = 1.2E9;
spMarker->Enabled = VARIANT_TRUE;

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a parameter-style repeated capability:

C++ Copy image Copy Code
IIviFgenFMPtr spFM = spFgen->FM;

spFM->Enabled[_T("Channel1")] = VARIANT_TRUE;
VARIANT_BOOL enabled = spFM->Enabled[_T("Channel1")];

Complete Example

The following code demonstrates a console application that uses the COM Session Factory to create the driver. The example also demonstrates use of class-compliant interfaces and shows how to handle errors from the instrument and from the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Agilent IVI Drivers, AgMD1, Examples

C++ Copy image Copy Code
#import "GlobMgr.dll" no_namespace  // VISA-COM I/O funtionality - omit for non-SCPI modular instruments
#import "IviDriverTypeLib.dll" no_namespace
#import "IviDigitizerTypeLib.dll" no_namespace
#import "IviSessionFactory.dll" no_namespace

void main()
{
  HRESULT hr = ::CoInitialize(NULL);

  try
  {
    IIviSessionFactory spFactory(__uuidof(IviSessionFactory));
    IIviDigitizerPtr spDigitizer = spFactory->CreateDriver(_T("MyLogicalName"));

    spDigitizer->Initialize(_T("MyLogicalName"), VARIANT_TRUE, VARIANT_TRUE, _T("QueryInstrStatus=true"));
    try
    {
      spDigitizer->Acquisition->SampleRate = 2000;
      spDigitizer->Acquisition->NumRecordsToAcquire = 500;
    }
    catch (_com_error& ex)
    {
      if (ex.Error() == E_IVI_INSTRUMENT_STATUS)
      {
        // ErrorQuery should give us more information
        long errCode;
        _bstr_t errMsg;
        spDigitizer->Utility->ErrorQuery(&errCode, errMsg.GetAddress());

        // Print the error
        wprintf(L"Instrument Error: %s\n", errMsg.GetBSTR());
      }
      else
      {
        // Print the exception
        wprintf(L"Exception: %s\n", ex.Description.GetBSTR());
      }
    }
    spDigitizer->Close();
  }
  catch (_com_error& e)
  {
    // There was some problem creating the driver or initializing it
    // There is no need to call Close() and we cannot call ErrorQuery()
    // because the driver is not initialized.
    wprintf(L"Exception: %s\n", e.Description.GetBSTR());
  }

  // Note that by this point all COM objects have been released
  // because all the smart pointers go out of scope at the end of
  // the outermost try block.
  // This is important, no COM calls can be made after CoUninitialize.
  ::CoUninitialize();
}


Using Visual Basic 6

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Visual Basic 6

This section describes how to use an IVI-COM driver from Visual Basic 6.

Referencing the Driver

In order to access any of the driver interfaces, the proper references to the driver DLL and at least one of the IVI DLLs (specifically, IviDriverTypeLib.dll) must be created.

  1. In the project menu, select References.
  2. Click the COM tab.
  3. Check the following type libraries:
    • IviDriver 1.0 Type Library
    • IviDigitizer 3.0 Type Library
    • IviSessionFactory 1.0 Type Library
    • IVI AgMD1 1.4 Type Library
  4. Click OK.

Creating an Instance of the Driver

Creating a Driver Instance Using the COM Session Factory

When interchangeability is desired, use the class-compliant interfaces and create the instance of the driver using the COM Session Factory.

Visual Basic Copy image Copy Code
Dim factory As New IviSessionFactory
Dim digitizer As IIviDigitizer
Set digitizer = factory.CreateDriver("MyLogicalName")

Creating a Driver Instance Directly

It is not necessary to use the COM Session Factory to instantiate the driver when using the instrument specific capabilities because interchangeability is already compromised since a reference to the driver DLL is required.

Visual Basic Copy image Copy Code
Dim driver As new AgMD1

Initializing the Driver

Calling Initialize will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling Close is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if Close is not called.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party configuration utility.

Visual Basic Copy image Copy Code
digitizer.Initialize "MyLogicalName", False, False, ""
digitizer.Close()

Initializing Using a Resource Descriptor

When interchangeability is not required, the driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

Visual Basic Copy image Copy Code
digitizer.Initialize "GPIB0::13::INSTR", False, False, ""
digitizer.Close()

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on Initialize, see Initializing the Driver topic.

Visual Basic Copy image Copy Code
' If True, this will query the instrument model and fail initialization
' if the model is not supported by the driver
Dim idQuery As Boolean
idQuery = False

' If True, the instrument is reset at initialization
Dim reset As Boolean
reset = False

' Setup IVI-defined initialization options
Dim standardInitOptions As String
standardInitOptions = "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false"

' Setup driver-specific initialization options
Dim driverSetupOptions As String
driverSetupOptions = "DriverSetup= Model=M9210A, Trace=false"

digitizer.Initialize "MyLogicalName", idQuery, reset, standardInitOptions & "," & driverSetupOptions
digitizer.Close

Accessing Methods and Properties

Each set of capabilities (inherent, class-compliant or instrument specific) is defined as a hierarchy of interfaces containing methods and properties. A property can return a pointer to another interface -- this is how the hierarchy is built.

Simple Data Types

Visual Basic Copy image Copy Code
' Set the value of a property
digitizer.Acquisition.SampleRate = 2000

' Get the value of a property
Dim rate Double
rate = digitizer.Acquisition.SampleRate

' Set the value of a property (enum)
digitizer.Trigger.Sources.Item("Channel1").Type = IviDigitizerTriggerTypeEdge

' Read a value from a method (as a return value)
Dim measuredValue as Double
measuredValue = digitizer.Measure(5000)

Strings

Visual Basic Copy image Copy Code
' Get a string property
Dim description As String
description = digitizer.Identity.Description

' Read a value from a method (as a return value)
Dim coercionRecord As String
coercionRecord = digitizer.DriverOperation.GetNextCoercionRecord()

' Read a value from a method (as an out parameter)
Dim errCode As Long
Dim errMsg As String
digitizer.Utility.ErrorQuery errCode, errMsg

Arrays

The example below demonstrates calling a method with an array parameter marked as [out,retval].

Visual Basic Copy image Copy Code
' Read an array of values. This returns a typed array
Dim measuredValues() As Double
measuredValues = digitizer.Measurement.ReadMultiPoint(5000)

' Iterate through the array
Dim index As Long
For index = LBound(measuredValues) To UBound(measuredValues)
  Dim measuredValue As Double
  measuredValue = measuredValues(i)
Next

This example demonstrates passing an input array to a driver method.

Visual Basic Copy image Copy Code
' Here we know in advance the exact size of the array
Dim frequencies(3) As Double
frequencies(0) = 10.0E6
frequencies(1) = 12.0E6
frequencies(2) = 14.0E6

' An array input parameter takes a reference to an array
driver.ConfigureFrequencies frequencies

Accessing Repeated Capabilities

IVI-COM drivers can support three different styles of repeated capabilities. This is discussed in the topic Repeated Capabilities. This section demonstrates repeated capability access for all three types of repeated capabilities. This driver may not use any or all types of repeated capabilites. The example code in this section may be from other drivers and can not be used directly with this driver.

Accessing Collection-Style Repeated Capabilities

The following example demonstrates uses of the Item property to access a particular instance ("Channel1") of a collection-style repeated capability. capability.

Visual Basic Copy image Copy Code
Dim ch as IIviDigitizerChannel
Set ch = digitizer.Channels.Item("Channel1")

ch.Offset = 0.1

Accessing Selector-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Marker1" from a selector-style repeated capability:

Visual Basic Copy image Copy Code
Dim marker As IIviSpecAnMarker
Set marker = specAn.Marker

marker.ActiveMarker = "Marker1"
marker.Position = 1.2E9
marker.Enabled = true

Accessing Parameter-Style Repeated Capabilities

The following example demonstrates how to access an instance named "Channel1" from a parameter-style repeated capability:

Visual Basic Copy image Copy Code
Dim fm As IIviFgenFM
Set fm = fgen.FM

fm.Enabled("Channel1") = true
Dim enabled As Boolean
enabled = fm.Enabled("Channel1")

Complete Example

The following code demonstrates a console application that uses the COM Session Factory to create the driver. The example also demonstrates use of class-compliant interfaces and shows how to handle errors from the instrument and from the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Agilent IVI Drivers, AgMD1, Examples

Visual Basic Copy image Copy Code
Sub Example()

  Dim logicalName As String
  logicalName = "MyLogicalName"

  Dim factory As New IviSessionFactory
  Dim driver As IIviDriver
  Set driver = factory.CreateDriver(logicalName)

  ' IIviDriverIdentity properties - Initialize not required
  Dim identifier As String
  identifier = driver.Identity.identifier
  Output.Text = Output.Text & "Identifer: " & identifier & vbCr & vbLf

  Dim revision As String
  revision = driver.Identity.revision
  Output.Text = Output.Text & "Revision: " & revision & vbCr & vbLf

  Dim vendor As String
  vendor = driver.Identity.vendor
  Output.Text = Output.Text & "Vendor: " & vendor & vbCr & vbLf

  ' Setup IVI-defined initialization options
  Dim standardInitOptions As String
  standardInitOptions = "Cache=true, InterchangeCheck=false, QueryInstrStatus=false, RangeCheck=true, RecordCoercions=false, Simulate=false"

  ' Setup driver-specific initialization options
  Dim driverSetupOptions As String
  driverSetupOptions = "DriverSetup= Model=M9210A, Trace=false"

  driver.Initialize logicalName, False, False, standardInitOptions + "," + driverSetupOptions

  ' IIviDriverIdentity properties - Initialize required
  Dim instModel As String
  instModel = driver.Identity.InstrumentModel
  Output.Text = Output.Text & "InstrumentModel: " & instModel & vbCr & vbLf

  Dim instFirmwareRevision As String
  instFirmwareRevision = driver.Identity.InstrumentFirmwareRevision
  Output.Text = Output.Text & "InstrumentFirmwareRevision: " & instFirmwareRevision & vbCr & vbLf

  Dim instManufacturer As String
  instManufacturer = driver.Identity.InstrumentManufacturer
  Output.Text = Output.Text & "InstrumentManufacturer: " & instManufacturer & vbCr & vbLf

  Dim digitizer As IIviDigitizer
  Set digitizer = driver

  digitizer.Acquisition.SampleRate = 2000
  digitizer.Acquisition.NumRecordsToAcquire = 500

  ' Check instrument for errors
  Dim errorNum As Long
  Dim errorMsg As String
  errorNum = -1
  While (errorNum <> 0)

    driver.Utility.ErrorQuery errorNum, errorMsg
    Output.Text = Output.Text & "ErrorQuery: " & errorNum & ", " & errorMsg & vbCr & vbLf

  Wend

  ' Close driver
  driver.Close

  End Sub


Using Agilent VEE Pro

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Agilent VEE Pro®

Agilent VEE Pro 7.0 or greater is required. VEE Pro 7.5 or greater is recommended as it adds significant new features for using IVI-COM drivers. VEE Pro provides access to the AgMD1 driver COM object using .NET interop references. You may use Agilent VEE Pro's help for general information on using IVI-COM objects in Agilent VEE Pro. Look in the index for the following topics:
IVI, IVI-COM, Instrument Manager, Component Drivers

Referencing the AgMD1 IVI-COM Driver in VEE Pro

With VEE Pro 7.5 and above, it is recommended that you take advantage of the fully integrated and simplified "To/From IVI-COM" feature.

Open VEE Pro's Instrument Manager, if you have an instrument connected already, you can click the "Configure Drivers" button and VEE Pro will automatically search for the IVI-COM drivers installed on your machine. If an IVI-COM driver for your instrument is found, the "IVI-COM Driver" button will be enabled.

If you do not have an instrument connected, you can click on the "Properties" button and then the "Advanced" button, under the "IVI-COM" tab, select an IVI-COM driver or IVI-COM driver session in the drop-down list box. Click OK, and the "IVI-COM Driver" button will be enabled.

If you cannot find the driver in this list, it was not installed and registered properly. See Installation.

Creating an AgMD1 IVI-COM Driver Instance in VEE Pro

Open Instrument Manager again and select your instrument, click the "IVI-COM Driver" button. This will place an "To/From IVI-COM" object onto your workspace. Double click on the highlighted line, this will open a dialog to let you select the operations that you want to perform on the driver.

CreateInstance

Before you do anything else, double-click the first bolded operation, and click the OK button. This will add an operation to create an instance of the IVI-COM driver.

It is recommended that you use a global Declare Variable object for your driver instance object. This is more robust and provides easy access to your driver object throughout your program.

Initializing the Driver

Before you can do anything very interesting with an IVI-COM driver you must call its Initialize method. Double-click the second bolded operation. This will let you modify any initialization parameters.

ResourceName
This string identifies a particular instrument in the system. Its contents may be a VISA style string such as GPIB0::13::INSTR.
IdQuery
This Boolean determines whether the driver interrogates the instrument about its identity and then verifies that the instrument is one suitable for the driver. The instrument model must be in the supported model list. If this parameter is False, the driver skips this verification.
Reset
This second Boolean determines whether the driver resets the instrument.
OptionString
The final parameter, a string, may set a number of driver properties. If the string is empty, the properties are set to default values or the values contained in the Configuration Store for this session.
Closing the Driver

You should always match your Initialize operation with the Close operation to release any resources. It is the third bolded operation in the "Select an Operation from" dialog.

Accessing Properties and Methods in VEE Pro

Now you can use the driver to program the instrument by accessing the driver's properties and methods. An IVI-COM driver is used the same way as other ActiveX objects are used in Agilent VEE Pro.

You can use a To/From IVI-COM object or you can use a formula box. For example, here is a To/From IVI-COM object. The first line creates an instance of the driver, the second line initializes the driver, the third line calls a method to clear the status, the fourth line sets a property to enable the display. The last line closes the driver.

The help file for the driver lists and explains all of the driver's methods and properties.

Descending the Interface Hierarchy in VEE Pro

An IVI-COM driver contains a hierarchy of interfaces. Many of the properties at the root are interface pointers.

So how does a VEE Pro program get to these members? From the To/From IVI-COM object, you see that this driver has a property called DriverOperation whose type is IIviDriverOperation. Now you can open up that tree node to discover all its methods and properties. Once you find the method or property that you want, double-click on it to do any editing and then the operation will be added to the To/From IVI-COM object.

These techniques for descending the interface hierarchy apply equally to the IVI inherent capabilities, class-compliant interfaces, and instrument-specific interfaces.

Keeping an Interface Pointer

If the program accesses many methods and properties in the same sub-interface or even uses the same method or property in a sub-interface many times, a more efficient programming technique is to create a reference to the interface. This efficiency becomes especially important if you are using DCOM to access the driver. If the program contains a formula box with:

A.DriverOperation.IoResourceDescriptor

Every time the code executes, Agilent VEE Pro queries the object for the DriverOperation property. While the time for this operation is very small when on the local machine, the time becomes measurable when done over a network.

To save this time, the program can hold a reference to the interface. A formula box would contain the line:

A.DriverOperation

The Result from this box is connected to formula boxes or .NET Operation Builders which use the DriverOperation interface. If this interface pointer is used many times, Agilent VEE Pro is saved from asking the driver for the same, static information that many times. That time saving becomes significant in a remote, DCOM environment.

Tip: to create a .NET Operation Builder for any .NET type, go to Device->.NET Operation Builder, click the Find toolbar button, and type in the type name or a part of the type name.

Handling COM Data Types in VEE Pro

Agilent VEE Pro can handle all COM automation data types. IVI-COM drivers are no exception and even purposely restrict the data types used by the driver to avoid any difficult programming tasks.

Boolean
The COM VARIANT_BOOL data type is used. Its value can be VARIANT_TRUE or VARIANT_FALSE.
Int32

The COM LONG data type is used for Int32 values.

Real64

The COM DOUBLE data type is used for Real64 values.

Text

The COM BSTR data type is used for text strings.

Array

The COM SAFEARRAY data type is for arrays.

Interface Pointer

An interface pointer's type is maintained by Agilent VEE Pro.

in, out parameters
Some parameters are declared to be both in and out. For these parameters, you must have an input and output for the parameter. The method call in the formula requires the keyword ByRef before these parameters. Two examples are ErrorQuery and SelfTest in IIviDriverUtility.

The formula box for doing an ErrorQuery would look like:

Further Information

To learn more about Using Agilent VEE Pro, visit:
http://www.agilent.com/find/vee.


Using LabVIEW

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using LabVIEW

National Instruments® LabVIEW® provides extensive support for COM components. Any COM component that restricts itself to automation data types (i.e. Visual Basic-compatible types) may be used directly from LabVIEW. Since all IVI-COM drivers use only automation data types, they can be used from LabVIEW in precisely the same manner as any other COM component.

There are two ways to access the AgMD1 IVI-COM driver in LabVIEW: using the Class Browser and using the IVI Class Driver VIs. This section discusses both techniques.

Using the LabVIEW Class Driver VIs

LabVIEW provides IVI Class Driver VIs that can be used to write interchangeable IVI applications. If interchangeability is the overriding requirement or if only the IVI-defined functions are needed in an application, then using the LabVIEW IVI Class Driver VIs is the preferred way to access the AgMD1 driver in LabVIEW. These VIs are located on the Functions palette under Instrument I/O -> IVI Class Drivers.

The COM Adapter

The IVI Class Driver VIs have the ability to load both IVI-COM and IVI-C drivers directly. If the driver includes an IVI-C wrapper, then the IVI Class Driver VIs will load the AgMD1 driver as if it were a native IVI-C driver. No extra steps are required on the part of the developer.

If an IVI driver does not include an IVI-C wrapper, then the IVI Class Driver VIs can still be used to load the IVI-COM native driver directly. There are two requirements for the IVI Class Driver VIs to be used with a native IVI-COM driver:

  1. The NI IVI Compliance Package 3.2 (or later) must be installed.
  2. The IVI-COM adapter feature must be enabled when installing the NI IVI Compliance Package. Note: This feature is disabled by default, so you must explicitly enable it when installing.

The LabVIEW Class Browser

The most convenient way to access the instrument-specific features of an IVI-COM driver is to use the Class Browser. This feature is available in LabVIEW version 8.0 and later. The Class Browser presents an intuitive hierarchical view of all methods and properties in the driver -- class-compliant and instrument-specific. From this hierarchical view, the LabVIEW developer can simply drag-n-drop methods and properties onto the block diagram and LabVIEW automatically creates the appropriately configured Invoke Node (for methods) or Property Node (for properties).

Building a Simple IVI Application in LabVIEW

This section provides step-by-step instructions for building a simple LabVIEW application with the AgMD1 IVI-COM driver.

Accessing the AgMD1 Driver from the Class Browser

The first step in building a LabVIEW application using an IVI-COM driver is to access the Class Browser and direct it to load the AgMD1 IVI-COM driver. From LabVIEW's perspective, the AgMD1 driver is simply a COM (aka "ActiveX") component. As such, it can be loaded via the ActiveX feature of the Class Browser.

To load the AgMD1 into the Class Browser

  1. From the View menu, choose Class Browser. The Class Browser window appears.
  2. From the Object Library combo box at the top, choose ActiveX and then Select Type Libraries... The system will likely pause for several seconds as LabVIEW scans your system for all installed COM components.
  3. From the Select Type Libraries dialog box that appears, check the checkbox labeled "IVI AgMD1 1.4 Type Library Version 1.4" and click OK.
  4. From the Class combo box, select AgMD1Lib.IAgMD1.
  5. The Properties and Methods window now displays the hierarchy of methods and properties available in the AgMD1 driver. The items with small blue dots are interface reference properties and allow you to navigate to sub-interfaces on the driver. Double-click on one of these, such as the System interface and the Properties and Methods window is updated to display the methods and properties of the sub-interface. To navigate back to the root of the hierarchy, click on the System hyperlink in the Selected property or method textbox near the bottom.

Initializing the Driver

The two main LabVIEW primitives required to access IVI-COM driver methods and properties are the Invoke Node (for methods) and the Property Node (for properties). Conveniently, the Class Browser automatically creates and configures these nodes for you.

Before any Invoke Node or Property Node can execute on the IVI-COM driver, it must be instantiated. This is accomplished using the Automation Open VI from the ActiveX palette. The following procedure explains how to instantiate and initialize the driver.

To instantiate and initialize the AgMD1 driver

  1. From the Class Browser, choose the Initialize node from the hierarchy displayed in the Properties and Methods window. Drag-n-drop the node onto the block diagram.
  2. The Automation Open VI is used to instantiate the IVI-COM driver before executing the Initialize function. Right-click on the Initialize Invoke Node just at the top left corner at the reference input, and select ActiveX Palette and then Automation Open. This creates the Automation Open VI. Make sure the Automation Refnum output of the Automation Open VI is wired to the reference input of the Initialize Invoke Node. Also, make sure the error clusters of the two VIs are wired together.
  3. The Automation Open VI requires an input control. Right-click on the Automation Refnum input of the Automation Open VI and choose Select ActiveX Class and then choose Browse.
  4. From the Type Library combo box at the top, choose "AgMD1 Version 1.4". Expand the AgMD1 node and choose IAgMD1 (the first interface under the expanded node). Click OK.
  5. LabVIEW creates an Automation Refnum input control and wires it to the Automation Open VI. Make sure the error clusters of the two VIs are wired together.
  6. At this point, the VI will not compile since some of the required inputs of the Initialize Invoke Node have not be supplied. Right-click on the ResourceName input of the Initialize Invoke Node and choose Create and then Constant. LabVIEW places a constant string on the diagram and wires it to the ResourceName input. In the string constant created, enter the appropriate VISA resource descriptor for connecting to the instrument.
  7. Right-click on the IdQuery input of the Initialize Invoke Node, choose Create and then Constant. LabVIEW creates a constant boolean wired to the IdQuery input. Repeat this process with the Reset input.
  8. At this point, the application is executable. LabVIEW will instantiate the AgMD1 IVI-COM driver and call the Initialize function. However, we must properly close the IVI-COM driver. We must also have the ability to read and write driver properties. These final tasks are covered in the next sections.

Reading and Writing Properties

Once the driver has been instantiated with the Automation Open VI and the Initialize function executes, any method or property on the AgMD1 driver can be invoked. The previous sections explained how to call the Initialize method. Other driver methods are accessed in precisely the same fashion.

This section explains how to read and write driver properties.

To access properties on the AgMD1 driver

  1. From the Class Browser, choose any property from the hierarchy displayed in the Properties and Methods window. Drag-n-drop the node onto the block diagram.
  2. LabVIEW creates a Property Node for that property on the diagram. Wire the reference out terminal of the Initialize Invoke Node to the reference input terminal of the Property Node. Also, wire the error clusters together.
  3. By default, the Property Node is configured to read a driver property, as indicated by the small arrow on the right side of the node's terminal. Right-click on the Property Node terminal and select Create and then choose Indicator. This places an output indicator on the diagram and wires it to the Property Node. This reads the value of the selected property from the driver and present it in the indicator.
  4. To use a Property Node to write a property value to the driver, simply right-click on the Property Node and choose Change to Write. This reconfigures the Property Node to be a "setter" node, as indicated by the re-positioning of the small arrow to the left side of the node terminal.
  5. A single Property Node can be used to read and write multiple properties. This is accomplished by resizing the Property Node vertically. Move the cursor over the node and resizing handles appear at the top and bottom of the node. Use the resizing handles to drag the border of the node down to display additional terminals.
  6. To configure a specific terminal to access a particular property, right-click on a terminal and choose Select Property.... This brings up an additional Class Browser window, from which you can select the desired property. You can configure individual terminals to read or write by right-clicking the specific terminal and choosing Change To Read or Change To Write as appropriate. Note that multi-terminal Property Nodes execute in order from top to bottom.

Closing the Driver

To complete a LabVIEW application using the AgMD1 driver, it is important to properly close the driver. If the driver is not properly closed, unexpected behavior and resource leaks could result. Moreover, it is important to understand when to close the driver. If multiple VIs within an LabVIEW application need to access the driver, the instantiation and initialization of the driver is typically done in a dedicated VI as is the close operation described in this section. You generally do not open, access, and close an IVI-COM driver within a single LabVIEW VI. Nevertheless, the procedure described here applies to a single VI application and to applications that share a driver instance.

To close the AgMD1 driver

  1. From the Class Browser, choose the Close node from the hierarchy displayed in the Properties and Methods window. Drag-n-drop the node onto the block diagram.
  2. Wire the reference out terminal of the last Invoke Node or Property Node in your VI to the reference input of the Close Invoke Node. Also, wire the error clusters together.
  3. Executing the Close method on the driver instructs the driver to release any resources it is holding. It does not, however, tell LabVIEW to dispose of the driver instance. This is accomplished with the Close Reference VI.
  4. Right-click on the reference out terminal of the Close Invoke Node and choose ActiveX Palette and then select Reference Close.
  5. Wire the reference out terminal of the Close Invoke Node to the reference input of the Close Reference VI.
  6. Your simple LabVIEW application using the AgMD1 driver is now complete.


Using MATLAB

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using MATLAB®

MATLAB® provides rich support for building applications with IVI-COM drivers. Special preconfigured MATLAB classes allow you to access IVI-defined functionality. In addition, for accessing instrument-specific functionality, the AgMD1 driver includes a MATLAB wrapper file that is automatically installed by the AgMD1 driver installer at the following location:

    • For 32 bit platform : \Program Files\IVI Foundation\IVI\Components\MATLAB
    • For 64 bit platform : \Program Files (x86)\IVI Foundation\IVI\Components\MATLAB

Requirements for Using the AgMD1 in MATLAB

The following components are required to be installed (at the time the AgMD1 driver installer runs), in order to use the AgMD1 driver in MATLAB:

  • MATLAB R2011b (32-bit Version only) for both 32 bit and 64 bit platforms
  • MATLAB Instrument Control Toolbox

Accessing Class-Compliant Functionality

Access to class-compliant functionality in an IVI driver is provided by the MATLAB Class objects. You use the appropriate MATLAB Class to create an instrument object. These classes are located in the instrument.ivicom package.

Note: If the class is listed as 'NoClass' below, this driver does not support an IVI instrument class and this section may be disregarded.

The following code demonstrates how to access the 'IviDigitizer' class supported by the AgMD1 driver.

driver = instrument.ivicom.IviDigitizer(‘MyLogicalName’);

Note that in addition to using the logical name to identify the driver to use (as shown in the example above), you can also use the session name or the software module name. Please see the topic Configuring the Driver for information on these additional identifiers.

Accessing Instrument-Specific Functionality

In order to access the instrument-specific functionality of the AgMD1 driver, the driver must be directly referenced. Note that directly referencing the AgMD1 driver provides access to the class-compliant functionality as well. The class for the AgMD1 driver is located in the instrument.driver package.

The following code demonstrates how to directly access the AgMD1 driver.

driver = instrument.driver.AgMD1();

The DeviceSpecific property is used to gain access to the instrument-specific methods and properties, as shown below.

driver.DeviceSpecific.System.WaitForOperationComplete(2000);

Complete Example

The following code demonstrates a simple console application that creates and initializes the driver, reads some properties, checks the instrument for errors, and closes the driver.

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Agilent IVI Drivers, AgMD1, Examples

MATLAB Copy image Copy Code
    % Creates a driver object, reads a few Identity interface
    % properties, and checks the instrument error queue.
    %
    % Runs in simulation mode without an instrument.

disp(blanks(1)');
disp('  ML_Example1');
try

    % Create driver instance
    driver = instrument.driver.AgMD1();

    % Edit resource and options as needed.  Resource is ignored if option Simulate=true
    resourceDesc = 'GPIB0::13::INSTR';

    initOptions = 'QueryInstrStatus=true, Simulate=true, DriverSetup= Model=, Trace=false';
    idquery = true;
    reset   = true;

    driver.Initialize(resourceDesc, idquery, reset, initOptions);
    disp('Driver Initialized');

    % Print a few IIviDriver.Identity properties
    disp(['Identifier:      ', driver.Identity.Identifier]);
    disp(['Revision:        ', driver.Identity.Revision]);
    disp(['Vendor:          ', driver.Identity.Vendor]);
    disp(['Description:     ', driver.Identity.Description]);
    disp(['InstrumentModel: ', driver.Identity.InstrumentModel]);
    disp(['FirmwareRev:     ', driver.Identity.InstrumentFirmwareRevision]);
    disp(blanks(1));

    % TODO: Exercise 'DeviceSpecific' driver methods and properties
    % Example syntax: serNum = driver.DeviceSpecific.System.SerialNumber;

    % Check instrument for errors
    errorNum = -1;
    errorMsg = ('');
    disp(blanks(1)');
    while (errorNum ~= 0)
        [errorNum, errorMsg] = driver.Utility.ErrorQuery();
        disp(['ErrorQuery: ', num2str(errorNum), ', ', errorMsg]);
    end

catch exception
    disp(getReport(exception));
end

if driver.Initialized
    driver.Close();
    disp('Driver Closed');
end

disp('Done');
disp(blanks(1)');

Further Information

To learn more about using MATLAB with IVI instrument drivers, visit:
http://www.mathworks.com/ivi.


Reference

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Reference

The topics in this section document each method and property exposed from the IVI-COM driver. Both a hierarchical and flat view of the AgMD1 driver functionality are available, as is a listing of instrument command strings and their associated driver methods and properties.

In This Section

Driver Hierarchy

Presents a hierarchical view of all driver methods and properties.

Driver Interfaces

Presents the driver functionality in a flat list of interfaces.

Instrument Command Reference

Provides a table associating instrument command strings with driver methods and properties.

Errors and Warnings

Presents all driver errors and warnings.


IVI-COM Hierarchy

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IVI-COM Hierarchy

This section presents the functionality of the AgMD1 driver in hierarchical form. Each link below represents the root of a specific hierarchy exposed by the driver, such as the instrument-specific hierarchy, the inherent capabilities (IIviDriver) hierarchy, etc.

Hierarchies

Root Interface Name
IAgMD1Ex2
IIviDriver
IIviDigitizer
IIviScope
Top


IAgMD1Ex2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex2 Interface
See Also

IAgMD1Ex2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Ex2
   Inherits IAgMD1Ex
C#
public interface IAgMD1Ex2 : IAgMD1Ex
Visual C++
__interface IAgMD1Ex2 : IAgMD1Ex

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgMD1Acquistion interface. (Inherited from IAgMD1.)
Public property | Acquisition2 | Pointer to the IAgMD1Acquistion interface.
Public property | Arm | Pointer to the IAgMD1Arm interface. (Inherited from IAgMD1.)
Public property | Calibration | Pointer to the IAgMD1Calibration interface. (Inherited from IAgMD1.)
Public property | Calibration2 | Pointer to the IAgMD1Calibration interface.
Public property | Channels | Pointer to the IAgMD1Channels interface. (Inherited from IAgMD1.)
Public property | Channels2 | Pointer to the IAgMD1Channels interface. (Inherited from IAgMD1Ex.)
Public property | Channels3 | Pointer to the IAgMD1Channels interface.
Public property | ControlIO | Pointer to the IAgMD1ControlIO interface. (Inherited from IAgMD1.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | InstrumentInfo | Pointer to the IAgMD1SystemInstrumentInfo interface. (Inherited from IAgMD1.)
Public property | InstrumentInfo2 | Pointer to the IAgMD1SystemInstrumentInfo2 interface. (Inherited from IAgMD1Ex.)
Public property | LogicDevices | Pointer to the IAgMD1LogicDevices interface.
Public property | ReferenceLevel | Pointer to the IAgMD1ReferenceLevel interface (Inherited from IAgMD1.)
Public property | ReferenceOscillator | Pointer to the IAgMD1Reference Oscillator interface. (Inherited from IAgMD1.)
Public property | SampleClock | Pointer to the IAgMD1SampleClock interface. (Inherited from IAgMD1.)
Public property | System | Pointer to the IAgMD1System interface. (Inherited from IAgMD1.)
Public property | Temperature | Pointer to the IAgMD1Temperature interface. (Inherited from IAgMD1.)
Public property | Trigger | Pointer to the IAgMD1Trigger interface. (Inherited from IAgMD1.)
Public property | Trigger2 | Pointer to the IAgMD1Trigger interface. (Inherited from IAgMD1Ex.)
Public property | Trigger3 | Pointer to the IAgMD1Trigger interface.
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


Acquisition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.Acquisition Property
IAgMD1 See Also

Pointer to the IAgMD1Acquistion interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition As IAgMD1Acquisition
C#
public IAgMD1Acquisition  Acquisition { get; }
Visual C++
HRESULT get_Acquisition(
    IAgMD1Acquisition**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


Abort Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.Abort Method
IAgMD1Acquisition See Also

Aborts an acquisition and returns the digitizer to the Idle state.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Abort ( _
)
C#
public void  Abort(
)
Visual C++
HRESULT Abort(
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


ConfigureAcquisition Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.ConfigureAcquisition Method
IAgMD1Acquisition See Also

This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureAcquisition ( _
    ByVal  NumRecordsToAcquire As Long  _
    ByVal  RecordSize As Long  _
    ByVal  SampleRate As Double  _
)
C#
public void  ConfigureAcquisition(
    long  NumRecordsToAcquire,
    long  RecordSize,
    double  SampleRate
)
Visual C++
HRESULT ConfigureAcquisition(
    __int64  NumRecordsToAcquire,
    __int64  RecordSize,
    double  SampleRate
);

Parameters

NumRecordsToAcquire

Specifies the number of records in the acquisition. This value sets the Num Records to Acquire attribute.

RecordSize

Specifies the number of samples in each record. This value sets the Record Size attribute.

SampleRate

Specifies the sample rate in samples per second. This value sets the Sample Rate attribute.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


ConfigureRecord Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.ConfigureRecord Method
IAgMD1Acquisition See Also

Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureRecord ( _
    ByVal  TimePerRecord As Double  _
    ByVal  MinNumPts As Integer  _
    ByVal  AcquisitionStartTime As Double  _
)
C#
public void  ConfigureRecord(
    double  TimePerRecord,
    int  MinNumPts,
    double  AcquisitionStartTime
)
Visual C++
HRESULT ConfigureRecord(
    double  TimePerRecord,
    long  MinNumPts,
    double  AcquisitionStartTime
);

Parameters

TimePerRecord

Specifies the time per record. This value sets the Horizontal Time Per Record property.

MinNumPts

Specifies the minimum number of points the end-user allows in the waveform recorded. This value sets the Horizontal Minimum Number of Points property.

AcquisitionStartTime

Specifies the position of the first point in the waveform record relative to the trigger event. This value sets the Acquisition Start Time property.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


DitherEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.DitherEnabled Property
IAgMD1Acquisition See Also

If true, enables dithering. Requires model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property DitherEnabled As Boolean
C#
public bool  DitherEnabled { get; set; }
Visual C++
HRESULT get_DitherEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_DitherEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

M9202A, U1084A001, U1084A002, U1084A003

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


DitherRange Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.DitherRange Property
IAgMD1Acquisition See Also

Sets amplitude of dithering signal. Range: 0 to 31. 0 = dithering amplitude is 0 (i. e. no dithering). 31 = dithering amplitude is Full Scale/2 = 500 mV. Requires model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property DitherRange As Integer
C#
public int  DitherRange { get; set; }
Visual C++
HRESULT get_DitherRange(
    long*  val
);
HRESULT put_DitherRange(
    long  val
);

Requirements

Supported Models

M9202A, U1084A001, U1084A002, U1084A003

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


Initiate Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.Initiate Method
IAgMD1Acquisition See Also

Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Initiate ( _
)
C#
public void  Initiate(
)
Visual C++
HRESULT Initiate(
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


MaxFirstValidPointValue Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.MaxFirstValidPointValue Property
IAgMD1Acquisition See Also

Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property MaxFirstValidPointValue As Long
C#
public long  MaxFirstValidPointValue { get; set; }
Visual C++
HRESULT get_MaxFirstValidPointValue(
    __int64*  val
);
HRESULT put_MaxFirstValidPointValue(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


MaxSamplesPerChannel Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.MaxSamplesPerChannel Property
IAgMD1Acquisition See Also

Returns the maximum number of samples per channel that can be captured.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MaxSamplesPerChannel As Long
C#
public long  MaxSamplesPerChannel { get; }
Visual C++
HRESULT get_MaxSamplesPerChannel(
    __int64*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


MinRecordSize Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.MinRecordSize Property
IAgMD1Acquisition See Also

Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property MinRecordSize As Long
C#
public long  MinRecordSize { get; set; }
Visual C++
HRESULT get_MinRecordSize(
    __int64*  val
);
HRESULT put_MinRecordSize(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


Mode Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.Mode Property
IAgMD1Acquisition See Also

The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgMD1AcquisitionModeEnum
C#
public AgMD1AcquisitionModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgMD1AcquisitionModeEnum*  val
);
HRESULT put_Mode(
    AgMD1AcquisitionModeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


NumAcquiredRecords Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.NumAcquiredRecords Property
IAgMD1Acquisition See Also

Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NumAcquiredRecords As Long
C#
public long  NumAcquiredRecords { get; }
Visual C++
HRESULT get_NumAcquiredRecords(
    __int64*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


NumberOfAverages Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.NumberOfAverages Property
IAgMD1Acquisition See Also

The number of waveforms the digitizer acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfAverages As Integer
C#
public int  NumberOfAverages { get; set; }
Visual C++
HRESULT get_NumberOfAverages(
    long*  val
);
HRESULT put_NumberOfAverages(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


NumRecordsToAcquire Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.NumRecordsToAcquire Property
IAgMD1Acquisition See Also

Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property NumRecordsToAcquire As Long
C#
public long  NumRecordsToAcquire { get; set; }
Visual C++
HRESULT get_NumRecordsToAcquire(
    __int64*  val
);
HRESULT put_NumRecordsToAcquire(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


QueryMinWaveformMemory Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.QueryMinWaveformMemory Method
IAgMD1Acquisition See Also

This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Function QueryMinWaveformMemory ( _
    ByVal  DataWidth As Integer  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
) As Long
C#
public long  QueryMinWaveformMemory(
    int  DataWidth,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord
)
Visual C++
HRESULT QueryMinWaveformMemory(
    long  DataWidth,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord
    __int64*  retval
);

Parameters

DataWidth

Specifies the size of the sampled data that will be retrieved. The value of this parameter must be 8, 16, 32 or 64, corresponding to the intended Read/Fetch function.

NumRecords

Specifies the number of records that will be read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved.

NumPointsPerRecord

Specifies the number of data points to return or if greater, the Acquisition RecordSize.

Return Value

The minimum buffer size in samples (elements) needed for a subsequent Read or Fetch call with the same readout parameters.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


RecordSize Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.RecordSize Property
IAgMD1Acquisition See Also

Specifies the number of samples to acquire in each waveform record.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property RecordSize As Long
C#
public long  RecordSize { get; set; }
Visual C++
HRESULT get_RecordSize(
    __int64*  val
);
HRESULT put_RecordSize(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


SampleMode Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.SampleMode Property
IAgMD1Acquisition See Also

-- Always RealTime mode -- Specifies the sample mode used by the digitizer.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SampleMode As AgMD1SampleModeEnum
C#
public AgMD1SampleModeEnum  SampleMode { get; set; }
Visual C++
HRESULT get_SampleMode(
    AgMD1SampleModeEnum*  val
);
HRESULT put_SampleMode(
    AgMD1SampleModeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


SampleRate Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.SampleRate Property
IAgMD1Acquisition See Also

Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SampleRate As Double
C#
public double  SampleRate { get; set; }
Visual C++
HRESULT get_SampleRate(
    double*  val
);
HRESULT put_SampleRate(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


StartTime Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.StartTime Property
IAgMD1Acquisition See Also

The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property StartTime As Double
C#
public double  StartTime { get; set; }
Visual C++
HRESULT get_StartTime(
    double*  val
);
HRESULT put_StartTime(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


Status Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.Status Property
IAgMD1Acquisition See Also

Pointer to the IAgMD1AcquisitionStatus interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Status As IAgMD1AcquisitionStatus
C#
public IAgMD1AcquisitionStatus  Status { get; }
Visual C++
HRESULT get_Status(
    IAgMD1AcquisitionStatus**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


IsIdle Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1AcquisitionStatus..::.IsIdle Property
IAgMD1AcquisitionStatus See Also

Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsIdle As AgMD1AcquisitionStatusResultEnum
C#
public AgMD1AcquisitionStatusResultEnum  IsIdle { get; }
Visual C++
HRESULT get_IsIdle(
    AgMD1AcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1AcquisitionStatus Interface
Agilent.AgMD1.Interop Namespace


IsMeasuring Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1AcquisitionStatus..::.IsMeasuring Property
IAgMD1AcquisitionStatus See Also

Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsMeasuring As AgMD1AcquisitionStatusResultEnum
C#
public AgMD1AcquisitionStatusResultEnum  IsMeasuring { get; }
Visual C++
HRESULT get_IsMeasuring(
    AgMD1AcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1AcquisitionStatus Interface
Agilent.AgMD1.Interop Namespace


IsWaitingForArm Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1AcquisitionStatus..::.IsWaitingForArm Property
IAgMD1AcquisitionStatus See Also

Returns whether the device is currently in the Waiting For Arm state. If true, acquisition has been initiated and is waiting for an arm signal from Arm.SendSoftwareArm method to enable triggering. Requires model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsWaitingForArm As AgMD1AcquisitionStatusResultEnum
C#
public AgMD1AcquisitionStatusResultEnum  IsWaitingForArm { get; }
Visual C++
HRESULT get_IsWaitingForArm(
    AgMD1AcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1AcquisitionStatus Interface
Agilent.AgMD1.Interop Namespace


IsWaitingForTrigger Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1AcquisitionStatus..::.IsWaitingForTrigger Property
IAgMD1AcquisitionStatus See Also

Returns whether the device is currently in the Waiting For Trigger state. If true, acquisition has been initiated, armed, and is waiting for a trigger. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsWaitingForTrigger As AgMD1AcquisitionStatusResultEnum
C#
public AgMD1AcquisitionStatusResultEnum  IsWaitingForTrigger { get; }
Visual C++
HRESULT get_IsWaitingForTrigger(
    AgMD1AcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1AcquisitionStatus Interface
Agilent.AgMD1.Interop Namespace


TimeInterleavedChannelListAuto Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.TimeInterleavedChannelListAuto Property
IAgMD1Acquisition See Also

-- Always false -- Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property TimeInterleavedChannelListAuto As Boolean
C#
public bool  TimeInterleavedChannelListAuto { get; set; }
Visual C++
HRESULT get_TimeInterleavedChannelListAuto(
    VARIANT_BOOL*  val
);
HRESULT put_TimeInterleavedChannelListAuto(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


TimePerRecord Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.TimePerRecord Property
IAgMD1Acquisition See Also

The time in seconds that corresponds to the record length.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property TimePerRecord As Double
C#
public double  TimePerRecord { get; set; }
Visual C++
HRESULT get_TimePerRecord(
    double*  val
);
HRESULT put_TimePerRecord(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


Type Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.Type Property
IAgMD1Acquisition See Also

How the oscilloscope acquires data and fills the waveform record. When set to TypeAverage, averaged waveforms must be read uisng the Measurement ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgMD1AcquisitionTypeEnum
C#
public AgMD1AcquisitionTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgMD1AcquisitionTypeEnum*  val
);
HRESULT put_Type(
    AgMD1AcquisitionTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


WaitForAcquisitionComplete Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition..::.WaitForAcquisitionComplete Method
IAgMD1Acquisition See Also

Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub WaitForAcquisitionComplete ( _
    ByVal  MaxTimeMilliseconds As Integer  _
)
C#
public void  WaitForAcquisitionComplete(
    int  MaxTimeMilliseconds
)
Visual C++
HRESULT WaitForAcquisitionComplete(
    long  MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this function to complete. The units are milliseconds. Defined values: IviDigitizerTimeOutInfinite (-1) - The function waits indefinitely for the acquisition to complete.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Acquisition Interface
Agilent.AgMD1.Interop Namespace


Acquisition2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex2..::.Acquisition2 Property
IAgMD1Ex2 See Also

Pointer to the IAgMD1Acquistion interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition2 As IAgMD1Acquisition2
C#
public IAgMD1Acquisition2  Acquisition2 { get; }
Visual C++
HRESULT get_Acquisition2(
    IAgMD1Acquisition2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex2 Interface
Agilent.AgMD1.Interop Namespace


DownconversionDataScalingEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition2..::.DownconversionDataScalingEnabled Property
IAgMD1Acquisition2 See Also

Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property DownconversionDataScalingEnabled As Boolean
C#
public bool  DownconversionDataScalingEnabled { get; set; }
Visual C++
HRESULT get_DownconversionDataScalingEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_DownconversionDataScalingEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1Acquisition2 Interface
Agilent.AgMD1.Interop Namespace


Arm Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.Arm Property
IAgMD1 See Also

Pointer to the IAgMD1Arm interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Arm As IAgMD1Arm
C#
public IAgMD1Arm  Arm { get; }
Visual C++
HRESULT get_Arm(
    IAgMD1Arm**  val
);

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Arm..::.Enabled Property
IAgMD1Arm See Also

If true, auto arming is enabled. If false, after an acquisition has been initiated, SendSoftwareArm method must be called before any triggers will be accepted. Requires model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1Arm Interface
Agilent.AgMD1.Interop Namespace


SendSoftwareArm Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Arm..::.SendSoftwareArm Method
IAgMD1Arm See Also

When Arm.Enabled is true and an acquisition has been initiated, arms the system to accept triggers. Requires model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub SendSoftwareArm ( _
)
C#
public void  SendSoftwareArm(
)
Visual C++
HRESULT SendSoftwareArm(
);

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1Arm Interface
Agilent.AgMD1.Interop Namespace


Calibration Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.Calibration Property
IAgMD1 See Also

Pointer to the IAgMD1Calibration interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Calibration As IAgMD1Calibration
C#
public IAgMD1Calibration  Calibration { get; }
Visual C++
HRESULT get_Calibration(
    IAgMD1Calibration**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


CalRequired Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration..::.CalRequired Method
IAgMD1Calibration See Also

Check if a self calibration is needed on the specified channel.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Function CalRequired ( _
    ByVal  Channel As Integer  _
) As Boolean
C#
public bool  CalRequired(
    int  Channel
)
Visual C++
HRESULT CalRequired(
    long  Channel
    VARIANT_BOOL*  retval
);

Parameters

Channel

Channel number [0,1...Nchan]. The value Channel = 0 can be used to do the query on all channels simultaneously.

Return Value

True if the specified channel need to be calibrated.

Remarks

Query about the necessity of self calibration. A calibration is needed for channel 'Channel'>0, if one or more of the 3 following condition is true: 1. The channel 'Channel' of the instrument has never been calibrated for the desired acquisition conditions. 2. It has been calibrated more than 2 hours ago. 3. The instrument temperature since the last self calibration has changed by more than 5 degrees C.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Calibration Interface
Agilent.AgMD1.Interop Namespace


Cancel Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration..::.Cancel Method
IAgMD1Calibration See Also

Abort any running self-calibration and return.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Cancel ( _
)
C#
public void  Cancel(
)
Visual C++
HRESULT Cancel(
);

Remarks

If a self-calibration is run from another thread, this other thread will be interrupted immediately and the call will return with an operation cancelled error.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Calibration Interface
Agilent.AgMD1.Interop Namespace


LoadCal Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration..::.LoadCal Method
IAgMD1Calibration See Also

Load calibration values and info from file.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub LoadCal ( _
    ByVal  FilePathName As String  _
)
C#
public void  LoadCal(
    string  FilePathName
)
Visual C++
HRESULT LoadCal(
    BSTR  FilePathName
);

Parameters

FilePathName

If NULL or empty string uses working directory and default file name of 'snXXXXX_calVal.bin'. If set to a path uses the specified directory with default file name. If a file name, with or without path, the specified name and path is used. File names must end in '.bin'

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Calibration Interface
Agilent.AgMD1.Interop Namespace


SaveCal Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration..::.SaveCal Method
IAgMD1Calibration See Also

Save calibration values and info in a binary file.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub SaveCal ( _
    ByVal  FilePathName As String  _
)
C#
public void  SaveCal(
    string  FilePathName
)
Visual C++
HRESULT SaveCal(
    BSTR  FilePathName
);

Parameters

FilePathName

If NULL or empty string uses working directory and default file name of 'snXXXXX_calVal.bin'. If set to a path uses the specified directory with default file name. If a file name, with or without path, the specified name and path is used. File names must end in '.bin'

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Calibration Interface
Agilent.AgMD1.Interop Namespace


SelfCalibrate Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration..::.SelfCalibrate Method
IAgMD1Calibration See Also

Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub SelfCalibrate ( _
    ByVal  Type As AgMD1CalibrateTypeEnum  _
    ByVal  Channel As Integer  _
)
C#
public void  SelfCalibrate(
    AgMD1CalibrateTypeEnum  Type,
    int  Channel
)
Visual C++
HRESULT SelfCalibrate(
    AgMD1CalibrateTypeEnum  Type,
    long  Channel
);

Parameters

Type

Type of self-calibration: see Programmers Reference manual.

Channel

If supported for the chosen calibrate type, specifies the channel: 0 = calibrate all channels, >0 = calibrate only the specified channel.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Calibration Interface
Agilent.AgMD1.Interop Namespace


Calibration2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex2..::.Calibration2 Property
IAgMD1Ex2 See Also

Pointer to the IAgMD1Calibration interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Calibration2 As IAgMD1Calibration2
C#
public IAgMD1Calibration2  Calibration2 { get; }
Visual C++
HRESULT get_Calibration2(
    IAgMD1Calibration2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex2 Interface
Agilent.AgMD1.Interop Namespace


DelayControls Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration2..::.DelayControls Property
IAgMD1Calibration2 See Also

Pointer to the IAgMD1DelayControls interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property DelayControls As IAgMD1DelayControls
C#
public IAgMD1DelayControls  DelayControls { get; }
Visual C++
HRESULT get_DelayControls(
    IAgMD1DelayControls**  val
);

Remarks

WARNING: These controls are provided for very specific use cases. Their usage may have significant influences on the analog performance of the digitizer.

The delay controls are in DAC codes or delay steps, but not in time unit because the DACs are not calibrated. The conversion factors to time are provided for guidance but should not be taken as exact or calibrated values. If exact times are required, an external calibration is necessary.

Delay control repeated capability supported values
Repcap name | Description | Min | Max | Time Step or Delay [ps] | Time Range [ps]
DelayAXIe100 | Controls the delay on the AXIe 100MHz reference. | 0 | 4095 | ~0.130 | 0 to ~550 (Not linear)
DelayPLLReference | Controls the delay on the PLL reference. Positive values will control the delay of the AXIe and External references. Negative values will control the delay of the Internal reference, and in the opposite direction (i.e. negative delay values). | -7 | 7 | Not linear: 0: 0 1: 160 2: 320 3: 480 4: 830 5: 1130 6: 1450 7: 1750 | -1750 to 1750
DelaySampleClock<X> | Control the delay on the Sample Clock for channels on DPU <X>. <X> can be A, B, C or D (e.g. DelaySampleClockA). There is an Extended range which can be selected with the Range property. | 0 | 4095 | ~0.007 (Default range) ~0.013 (Extended range) | 0 to ~30 (Default range) 0 to ~60 (Extended range)
Note
Time Step and Time Range are specific to the hardware and can be different for each instrument modules. The values here are approximate.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Calibration2 Interface
Agilent.AgMD1.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControls..::.Count Property
IAgMD1DelayControls See Also

Returns the number of delay controls.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1DelayControls Interface
Agilent.AgMD1.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControls..::.Enabled Property
IAgMD1DelayControls See Also

Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1DelayControls Interface
Agilent.AgMD1.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControls..::.Item Property
IAgMD1DelayControls See Also

Pointer to the IAgMD1DelayControl interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgMD1DelayControl
C#
public IAgMD1DelayControl  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgMD1DelayControl**  val
);

Parameters

Name

The name of a delay control. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the DelayControl repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1DelayControls Interface
Agilent.AgMD1.Interop Namespace


Max Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControl..::.Max Property
IAgMD1DelayControl See Also

Maximum value (DAC code) that can be set for the delay control.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Max As Integer
C#
public int  Max { get; }
Visual C++
HRESULT get_Max(
    long*  val
);

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1DelayControl Interface
Agilent.AgMD1.Interop Namespace


Min Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControl..::.Min Property
IAgMD1DelayControl See Also

Minimum value (DAC code) that can be set for the delay control.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Min As Integer
C#
public int  Min { get; }
Visual C++
HRESULT get_Min(
    long*  val
);

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1DelayControl Interface
Agilent.AgMD1.Interop Namespace


Range Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControl..::.Range Property
IAgMD1DelayControl See Also

Selects the range for the delay control. Useful only for delay controls with multiple ranges.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Range As AgMD1DelayControlRangeEnum
C#
public AgMD1DelayControlRangeEnum  Range { get; set; }
Visual C++
HRESULT get_Range(
    AgMD1DelayControlRangeEnum*  val
);
HRESULT put_Range(
    AgMD1DelayControlRangeEnum  val
);

Remarks

Please refer to DelayControls property for a list of supported delay controls and ranges.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1DelayControl Interface
Agilent.AgMD1.Interop Namespace


Value Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControl..::.Value Property
IAgMD1DelayControl See Also

The value (DAC code) set for the delay control.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Value As Integer
C#
public int  Value { get; set; }
Visual C++
HRESULT get_Value(
    long*  val
);
HRESULT put_Value(
    long  val
);

Remarks

WARNING: These controls are provided for very specific use cases. Their usage may have significant influences on the analog performance of the digitizer.

The delay controls are in DAC codes or delay steps, but not in time unit because the DACs are not calibrated. The conversion factors to time are provided for guidance but should not be taken as exact or calibrated values. If exact times are required, an external calibration is necessary.

Delay control repeated capability supported values
Repcap name | Description | Min | Max | Time Step or Delay [ps] | Time Range [ps]
DelayAXIe100 | Controls the delay on the AXIe 100MHz reference. | 0 | 4095 | ~0.130 | 0 to ~550 (Not linear)
DelayPLLReference | Controls the delay on the PLL reference. Positive values will control the delay of the AXIe and External references. Negative values will control the delay of the Internal reference, and in the opposite direction (i.e. negative delay values). | -7 | 7 | Not linear: 0: 0 1: 160 2: 320 3: 480 4: 830 5: 1130 6: 1450 7: 1750 | -1750 to 1750
DelaySampleClock<X> | Control the delay on the Sample Clock for channels on DPU <X>. <X> can be A, B, C or D (e.g. DelaySampleClockA). There is an Extended range which can be selected with the Range property. | 0 | 4095 | ~0.007 (Default range) ~0.013 (Extended range) | 0 to ~30 (Default range) 0 to ~60 (Extended range)
Note
Time Step and Time Range are specific to the hardware and can be different for each instrument modules. The values here are approximate.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1DelayControl Interface
Agilent.AgMD1.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControls..::.Name Property
IAgMD1DelayControls See Also

Returns the delay control name for a given index.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of delaycontrols.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1DelayControls Interface
Agilent.AgMD1.Interop Namespace


Channels Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.Channels Property
IAgMD1 See Also

Pointer to the IAgMD1Channels interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Channels As IAgMD1Channels
C#
public IAgMD1Channels  Channels { get; }
Visual C++
HRESULT get_Channels(
    IAgMD1Channels**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


ActiveInputs Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels..::.ActiveInputs Property
IAgMD1Channels See Also

String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ActiveInputs As String
C#
public string  ActiveInputs { get; set; }
Visual C++
HRESULT get_ActiveInputs(
    BSTR*  val
);
HRESULT put_ActiveInputs(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels Interface
Agilent.AgMD1.Interop Namespace


ConvertersPerChannel Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels..::.ConvertersPerChannel Property
IAgMD1Channels See Also

The number of converters currently assigned to each channel.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ConvertersPerChannel As Integer
C#
public int  ConvertersPerChannel { get; }
Visual C++
HRESULT get_ConvertersPerChannel(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels Interface
Agilent.AgMD1.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels..::.Count Property
IAgMD1Channels See Also

Returns the number of Channels.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels Interface
Agilent.AgMD1.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels..::.Item Property
IAgMD1Channels See Also

Pointer to the IAgMD1Channel interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgMD1Channel
C#
public IAgMD1Channel  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgMD1Channel**  val
);

Parameters

Name

The name of a Channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Configure Method
IAgMD1Channel See Also

This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Range As Double  _
    ByVal  Offset As Double  _
    ByVal  Coupling As AgMD1VerticalCouplingEnum  _
    ByVal  Enabled As Boolean  _
)
C#
public void  Configure(
    double  Range,
    double  Offset,
    AgMD1VerticalCouplingEnum  Coupling,
    bool  Enabled
)
Visual C++
HRESULT Configure(
    double  Range,
    double  Offset,
    AgMD1VerticalCouplingEnum  Coupling,
    VARIANT_BOOL  Enabled
);

Parameters

Range

Specifies the vertical range. This value sets the Vertical Range attribute.

Offset

Specifies the vertical offset. This value sets the Vertical Offset attribute.

Coupling

Specifies how to couple the input signal. This value sets the Vertical

Enabled

Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled attribute.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


ConnectorName Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.ConnectorName Property
IAgMD1Channel See Also

The connector name as it appears on the instrument's front panel.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ConnectorName As String
C#
public string  ConnectorName { get; }
Visual C++
HRESULT get_ConnectorName(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Coupling Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Coupling Property
IAgMD1Channel See Also

Specifies how the digitizer couples the input signal for the channel.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As AgMD1VerticalCouplingEnum
C#
public AgMD1VerticalCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    AgMD1VerticalCouplingEnum*  val
);
HRESULT put_Coupling(
    AgMD1VerticalCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


DigitalDownconversion Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.DigitalDownconversion Property
IAgMD1Channel See Also

Pointer to the IAgMD1ChannelDigitalDownconversion interface. Requires Model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property DigitalDownconversion As IAgMD1ChannelDigitalDownconversion
C#
public IAgMD1ChannelDigitalDownconversion  DigitalDownconversion { get; }
Visual C++
HRESULT get_DigitalDownconversion(
    IAgMD1ChannelDigitalDownconversion**  val
);

Remarks

Please refer to the Remarks in the DigitalDownconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelDigitalDownconversion..::.Configure Method
IAgMD1ChannelDigitalDownconversion See Also

Configures the DigitalDownconverson DataBandwidth and TriggerBandwidth. Requires Model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  DataBandwidth As Double  _
    ByVal  TriggerBandwidth As Double  _
)
C#
public void  Configure(
    double  DataBandwidth,
    double  TriggerBandwidth
)
Visual C++
HRESULT Configure(
    double  DataBandwidth,
    double  TriggerBandwidth
);

Parameters

DataBandwidth

The output bandwidth in Hz for down-converted data.

TriggerBandwidth

The output bandwidth in Hz for down-converted trigger.

Remarks

For the M9202A, when in digital downconversion acquisition mode, the following applies:

The Read/Fetch methods in Real64 are supported for all sample rates. The Read/Fetch methods in Int16 are supported for all sample rates. (The Int variants correspond to the data format as stored in module memory).

For these methods, the parameter ActualPoints is given in data samples, i.e. twice the number of I-Q data point pairs, or complex samples. The FirstValidPoint parameter, which is primarily intended for dealing with memory alignment, is always given in array elements, like the WaveformArraySize parameter.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1ChannelDigitalDownconversion Interface
Agilent.AgMD1.Interop Namespace


DataBandwidth Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelDigitalDownconversion..::.DataBandwidth Property
IAgMD1ChannelDigitalDownconversion See Also

The output bandwidth in Hz for down-converted data. Range: 250e6, 200e6, 100e6, 50e6 etc following progression f(n+1) = f(n)/ 2, down to 2GHz/(2^21) = about 1 kHz. Requires Model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property DataBandwidth As Double
C#
public double  DataBandwidth { get; set; }
Visual C++
HRESULT get_DataBandwidth(
    double*  val
);
HRESULT put_DataBandwidth(
    double  val
);

Remarks

Please refer to the Remarks in the DigitalDownconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1ChannelDigitalDownconversion Interface
Agilent.AgMD1.Interop Namespace


DoubleDataRateEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelDigitalDownconversion..::.DoubleDataRateEnabled Property
IAgMD1ChannelDigitalDownconversion See Also

False = simple data rate (Samples / second = 1.25*bandwidth), True = double data rate (Samples / second = 2.5*bandwidth) Note: only applies for DataBandwidth values of 1.0e8 and below. Requires Model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property DoubleDataRateEnabled As Boolean
C#
public bool  DoubleDataRateEnabled { get; set; }
Visual C++
HRESULT get_DoubleDataRateEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_DoubleDataRateEnabled(
    VARIANT_BOOL  val
);

Remarks

Please refer to the Remarks in the DigitalDownconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1ChannelDigitalDownconversion Interface
Agilent.AgMD1.Interop Namespace


FlipBandEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelDigitalDownconversion..::.FlipBandEnabled Property
IAgMD1ChannelDigitalDownconversion See Also

True = First frequency shift is by -500MHz. False = First frequency shift is by +500MHz. Requires Model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property FlipBandEnabled As Boolean
C#
public bool  FlipBandEnabled { get; set; }
Visual C++
HRESULT get_FlipBandEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_FlipBandEnabled(
    VARIANT_BOOL  val
);

Remarks

Please refer to the Remarks in the DigitalDownconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1ChannelDigitalDownconversion Interface
Agilent.AgMD1.Interop Namespace


FrequencyShift Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelDigitalDownconversion..::.FrequencyShift Property
IAgMD1ChannelDigitalDownconversion See Also

Decoded to set up the frequency shift blocks of the down converter. The value of this attribute corresponds to the data frequency shift; trigger frequency shift is the nearest value available with the given TriggerBandwidth. I. e. the trigger frequency shift equals FrequencyShift if TriggerBandwidth <= DataBandwidth; otherwise it is rounded to the nearest multiple of TriggerBandwidth*2.5/4. Range: -125e6 to +125e6, step = DataBandwidth *2.5 / 4. Requires Model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property FrequencyShift As Double
C#
public double  FrequencyShift { get; set; }
Visual C++
HRESULT get_FrequencyShift(
    double*  val
);
HRESULT put_FrequencyShift(
    double  val
);

Remarks

Please refer to the Remarks in the DigitalDownconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1ChannelDigitalDownconversion Interface
Agilent.AgMD1.Interop Namespace


TriggerBandwidth Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelDigitalDownconversion..::.TriggerBandwidth Property
IAgMD1ChannelDigitalDownconversion See Also

The output bandwidth in Hz for down-converted trigger. Requires Model: M9202A

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property TriggerBandwidth As Double
C#
public double  TriggerBandwidth { get; set; }
Visual C++
HRESULT get_TriggerBandwidth(
    double*  val
);
HRESULT put_TriggerBandwidth(
    double  val
);

Remarks

Please refer to the Remarks in the DigitalDownconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1ChannelDigitalDownconversion Interface
Agilent.AgMD1.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Enabled Property
IAgMD1Channel See Also

Specifies whether the digitizer acquires a waveform for the channel.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Filter Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Filter Property
IAgMD1Channel See Also

Pointer to the IIviDigitizerFilterinterface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Filter As IAgMD1ChannelFilter
C#
public IAgMD1ChannelFilter  Filter { get; }
Visual C++
HRESULT get_Filter(
    IAgMD1ChannelFilter**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Bypass Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelFilter..::.Bypass Property
IAgMD1ChannelFilter See Also

Specifies whether or not to bypass the input filter.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Bypass As Boolean
C#
public bool  Bypass { get; set; }
Visual C++
HRESULT get_Bypass(
    VARIANT_BOOL*  val
);
HRESULT put_Bypass(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelFilter Interface
Agilent.AgMD1.Interop Namespace


MaxFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelFilter..::.MaxFrequency Property
IAgMD1ChannelFilter See Also

Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property MaxFrequency As Double
C#
public double  MaxFrequency { get; set; }
Visual C++
HRESULT get_MaxFrequency(
    double*  val
);
HRESULT put_MaxFrequency(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelFilter Interface
Agilent.AgMD1.Interop Namespace


InputConnectorSelection Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.InputConnectorSelection Property
IAgMD1Channel See Also

Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1 (connector A), 2 (connector B).

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property InputConnectorSelection As Integer
C#
public int  InputConnectorSelection { get; set; }
Visual C++
HRESULT get_InputConnectorSelection(
    long*  val
);
HRESULT put_InputConnectorSelection(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


InputFrequencyMax Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.InputFrequencyMax Property
IAgMD1Channel See Also

The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth).

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property InputFrequencyMax As Double
C#
public double  InputFrequencyMax { get; set; }
Visual C++
HRESULT get_InputFrequencyMax(
    double*  val
);
HRESULT put_InputFrequencyMax(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


InputImpedance Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.InputImpedance Property
IAgMD1Channel See Also

The input impedance of this channel. The units are Ohms.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property InputImpedance As Double
C#
public double  InputImpedance { get; set; }
Visual C++
HRESULT get_InputImpedance(
    double*  val
);
HRESULT put_InputImpedance(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Measurement Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Measurement Property
IAgMD1Channel See Also

Pointer to the IAgMD1ChannelMeasurement interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Measurement As IAgMD1ChannelMeasurement
C#
public IAgMD1ChannelMeasurement  Measurement { get; }
Visual C++
HRESULT get_Measurement(
    IAgMD1ChannelMeasurement**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


FetchWaveformInt16 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.FetchWaveformInt16 Method
IAgMD1ChannelMeasurement See Also

This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformInt16 ( _
    ByRef  WaveformArray As Short()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchWaveformInt16(
    ref short[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchWaveformInt16(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


FetchWaveformInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.FetchWaveformInt32 Method
IAgMD1ChannelMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformInt32 ( _
    ByRef  WaveformArray As Integer()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchWaveformInt32(
    ref int[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchWaveformInt32(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


FetchWaveformInt8 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.FetchWaveformInt8 Method
IAgMD1ChannelMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformInt8 ( _
    ByRef  WaveformArray As Byte()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchWaveformInt8(
    ref byte[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchWaveformInt8(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


FetchWaveformMeasurement Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.FetchWaveformMeasurement Method
IAgMD1ChannelMeasurement See Also

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformMeasurement ( _
    ByVal  MeasFunction As AgMD1MeasurementEnum  _
    ByRef  Measurement As Double  _
)
C#
public void  FetchWaveformMeasurement(
    AgMD1MeasurementEnum  MeasFunction,
    ref double  Measurement
)
Visual C++
HRESULT FetchWaveformMeasurement(
    AgMD1MeasurementEnum  MeasFunction,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


FetchWaveformReal64 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.FetchWaveformReal64 Method
IAgMD1ChannelMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformReal64 ( _
    ByRef  WaveformArray As Double()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveformReal64(
    ref double[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveformReal64(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


ReadWaveformInt16 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.ReadWaveformInt16 Method
IAgMD1ChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformInt16 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Short()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  ReadWaveformInt16(
    int  MaxTimeMilliseconds,
    ref short[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT ReadWaveformInt16(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


ReadWaveformInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.ReadWaveformInt32 Method
IAgMD1ChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformInt32 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Integer()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  ReadWaveformInt32(
    int  MaxTimeMilliseconds,
    ref int[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT ReadWaveformInt32(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


ReadWaveformInt8 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.ReadWaveformInt8 Method
IAgMD1ChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformInt8 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Byte()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  ReadWaveformInt8(
    int  MaxTimeMilliseconds,
    ref byte[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT ReadWaveformInt8(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


ReadWaveformMeasurement Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.ReadWaveformMeasurement Method
IAgMD1ChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformMeasurement ( _
    ByVal  MeasFunction As AgMD1MeasurementEnum  _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  Measurement As Double  _
)
C#
public void  ReadWaveformMeasurement(
    AgMD1MeasurementEnum  MeasFunction,
    int  MaxTimeMilliseconds,
    ref double  Measurement
)
Visual C++
HRESULT ReadWaveformMeasurement(
    AgMD1MeasurementEnum  MeasFunction,
    long  MaxTimeMilliseconds,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


ReadWaveformReal64 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.ReadWaveformReal64 Method
IAgMD1ChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformReal64 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Double()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveformReal64(
    int  MaxTimeMilliseconds,
    ref double[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveformReal64(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualPoints and FirstValidPoint to extract measurement data.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


WaveformType Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement..::.WaveformType Property
IAgMD1ChannelMeasurement See Also

The waveform type used to calculate the various measurement functions by the FetchWaveformMeasurement and ReadWaveformMeasurement methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property WaveformType As AgMD1MeasurementWaveformTypeEnum
C#
public AgMD1MeasurementWaveformTypeEnum  WaveformType { get; set; }
Visual C++
HRESULT get_WaveformType(
    AgMD1MeasurementWaveformTypeEnum*  val
);
HRESULT put_WaveformType(
    AgMD1MeasurementWaveformTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMeasurement Interface
Agilent.AgMD1.Interop Namespace


MultiRecordMeasurement Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.MultiRecordMeasurement Property
IAgMD1Channel See Also

Pointer to the IAgMD1ChannelMultiRecordMeasurement interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MultiRecordMeasurement As IAgMD1ChannelMultiRecordMeasurement
C#
public IAgMD1ChannelMultiRecordMeasurement  MultiRecordMeasurement { get; }
Visual C++
HRESULT get_MultiRecordMeasurement(
    IAgMD1ChannelMultiRecordMeasurement**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


FetchMultiRecordWaveformInt16 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformInt16 Method
IAgMD1ChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformInt16 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Short()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchMultiRecordWaveformInt16(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref short[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchMultiRecordWaveformInt16(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

FirstRecord

Specifies the number of the first record to read. Range: 0 to (NumRecords-1)

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualRecords, ActualPoints, and FirstValidPoint to extract measurement data.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMultiRecordMeasurement Interface
Agilent.AgMD1.Interop Namespace


FetchMultiRecordWaveformInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformInt32 Method
IAgMD1ChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformInt32 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Integer()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchMultiRecordWaveformInt32(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref int[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchMultiRecordWaveformInt32(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

FirstRecord

Specifies the number of the first record to read. Range: 0 to (NumRecords-1)

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualRecords, ActualPoints, and FirstValidPoint to extract measurement data.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1ChannelMultiRecordMeasurement Interface
Agilent.AgMD1.Interop Namespace


FetchMultiRecordWaveformInt8 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformInt8 Method
IAgMD1ChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformInt8 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Byte()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchMultiRecordWaveformInt8(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref byte[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchMultiRecordWaveformInt8(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

FirstRecord

Specifies the number of the first record to read. Range: 0 to (NumRecords-1)

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved. Zero based.

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Array size is larger than data returned. Use ActualRecords, ActualPoints, and FirstValidPoint to extract measurement data.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMultiRecordMeasurement Interface
Agilent.AgMD1.Interop Namespace


FetchMultiRecordWaveformReal64 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformReal64 Method
IAgMD1ChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformReal64 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Double()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchMultiRecordWaveformReal64(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref double[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement
)
Visual C++
HRESULT FetchMultiRecordWaveformReal64(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement
);

Parameters

FirstRecord

Specifies the number of the first record to read. Range: 0 to (NumRecords-1)

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored. Array size is larger than data returned. Use ActualRecords, ActualPoints, and FirstValidPoint to extract measurement data.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ChannelMultiRecordMeasurement Interface
Agilent.AgMD1.Interop Namespace


Offset Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Offset Property
IAgMD1Channel See Also

The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


ProbeAttenuation Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.ProbeAttenuation Property
IAgMD1Channel See Also

The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ProbeAttenuation As Double
C#
public double  ProbeAttenuation { get; set; }
Visual C++
HRESULT get_ProbeAttenuation(
    double*  val
);
HRESULT put_ProbeAttenuation(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


ProbeSense Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.ProbeSense Property
IAgMD1Channel See Also

The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ProbeSense As Double
C#
public double  ProbeSense { get; }
Visual C++
HRESULT get_ProbeSense(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Range Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Range Property
IAgMD1Channel See Also

The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Temperature Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.Temperature Property
IAgMD1Channel See Also

Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Temperature As Double
C#
public double  Temperature { get; }
Visual C++
HRESULT get_Temperature(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


TimeInterleavedChannelList Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel..::.TimeInterleavedChannelList Property
IAgMD1Channel See Also

This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property TimeInterleavedChannelList As String
C#
public string  TimeInterleavedChannelList { get; set; }
Visual C++
HRESULT get_TimeInterleavedChannelList(
    BSTR*  val
);
HRESULT put_TimeInterleavedChannelList(
    BSTR  val
);

Remarks

For valid channel name values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel Interface
Agilent.AgMD1.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels..::.Name Property
IAgMD1Channels See Also

Returns the Channel name for a given index.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of Channels.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels Interface
Agilent.AgMD1.Interop Namespace


ReferenceChannel Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels..::.ReferenceChannel Property
IAgMD1Channels See Also

The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ...

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ReferenceChannel As String
C#
public string  ReferenceChannel { get; set; }
Visual C++
HRESULT get_ReferenceChannel(
    BSTR*  val
);
HRESULT put_ReferenceChannel(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels Interface
Agilent.AgMD1.Interop Namespace


Channels2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex..::.Channels2 Property
IAgMD1Ex See Also

Pointer to the IAgMD1Channels interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Channels2 As IAgMD1Channels2
C#
public IAgMD1Channels2  Channels2 { get; }
Visual C++
HRESULT get_Channels2(
    IAgMD1Channels2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex Interface
Agilent.AgMD1.Interop Namespace


Item2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels2..::.Item2 Property
IAgMD1Channels2 See Also

Pointer to the IAgMD1Channel interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item2( _
    ByVal  Name As String  _
) As IAgMD1Channel2
C#
public IAgMD1Channel2  get_Item2(
    string  Name
)
Visual C++
HRESULT get_Item2(
    BSTR  Name,
    IAgMD1Channel2**  val
);

Parameters

Name

The name of a Channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels2 Interface
Agilent.AgMD1.Interop Namespace


Counter Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel2..::.Counter Property
IAgMD1Channel2 See Also

Pointer to the IAgMD1Channel2Counter interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Counter As IAgMD1Channel2Counter
C#
public IAgMD1Channel2Counter  Counter { get; }
Visual C++
HRESULT get_Counter(
    IAgMD1Channel2Counter**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channel2 Interface
Agilent.AgMD1.Interop Namespace


ApertureTime Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel2Counter..::.ApertureTime Property
IAgMD1Channel2Counter See Also

The minimum measurement time for Frequency and Period modes. The duration to count input pulses for TotalizeGate mode. The Counter.Read method will wait this time before returning measurement data. Units are seconds.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ApertureTime As Double
C#
public double  ApertureTime { get; set; }
Visual C++
HRESULT get_ApertureTime(
    double*  val
);
HRESULT put_ApertureTime(
    double  val
);

Requirements

Supported Models

DC135, DC135HZ, DC140, DC140HZ

See Also

Reference

IAgMD1Channel2Counter Interface
Agilent.AgMD1.Interop Namespace


Mode Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel2Counter..::.Mode Property
IAgMD1Channel2Counter See Also

The mode for counter measurements, Frequency, Period, TotalizeTime, or TotalizeGate.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Mode As AgMD1CounterModeEnum
C#
public AgMD1CounterModeEnum  Mode { get; set; }
Visual C++
HRESULT get_Mode(
    AgMD1CounterModeEnum*  val
);
HRESULT put_Mode(
    AgMD1CounterModeEnum  val
);

Requirements

Supported Models

DC135, DC135HZ, DC140, DC140HZ

See Also

Reference

IAgMD1Channel2Counter Interface
Agilent.AgMD1.Interop Namespace


Read Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel2Counter..::.Read Method
IAgMD1Channel2Counter See Also

Counter measurement results for the current mode. Counter must be enabled by setting Acquisition.Mode = AgMD1AcquisitionModeCounter. The Read method will wait the current ApertureTime before returning measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Function Read ( _
) As Double
C#
public double  Read(
)
Visual C++
HRESULT Read(
    double*  retval
);

Return Value

Measurement data.Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.

Requirements

Supported Models

DC135, DC135HZ, DC140, DC140HZ

See Also

Reference

IAgMD1Channel2Counter Interface
Agilent.AgMD1.Interop Namespace


Channels3 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex2..::.Channels3 Property
IAgMD1Ex2 See Also

Pointer to the IAgMD1Channels interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Channels3 As IAgMD1Channels3
C#
public IAgMD1Channels3  Channels3 { get; }
Visual C++
HRESULT get_Channels3(
    IAgMD1Channels3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex2 Interface
Agilent.AgMD1.Interop Namespace


Item3 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels3..::.Item3 Property
IAgMD1Channels3 See Also

Pointer to the IAgMD1Channel interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item3( _
    ByVal  Name As String  _
) As IAgMD1Channel3
C#
public IAgMD1Channel3  get_Item3(
    string  Name
)
Visual C++
HRESULT get_Item3(
    BSTR  Name,
    IAgMD1Channel3**  val
);

Parameters

Name

The name of a Channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Channels3 Interface
Agilent.AgMD1.Interop Namespace


Downconversion Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel3..::.Downconversion Property
IAgMD1Channel3 See Also

Pointer to the IIviDigitizerDownconversion interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Downconversion As IAgMD1Channel3Downconversion
C#
public IAgMD1Channel3Downconversion  Downconversion { get; }
Visual C++
HRESULT get_Downconversion(
    IAgMD1Channel3Downconversion**  val
);

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1Channel3 Interface
Agilent.AgMD1.Interop Namespace


CenterFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel3Downconversion..::.CenterFrequency Property
IAgMD1Channel3Downconversion See Also

Specifies the center frequency, in Hz, from which the digitizer should downconvert.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property CenterFrequency As Double
C#
public double  CenterFrequency { get; set; }
Visual C++
HRESULT get_CenterFrequency(
    double*  val
);
HRESULT put_CenterFrequency(
    double  val
);

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1Channel3Downconversion Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel3Downconversion..::.Configure Method
IAgMD1Channel3Downconversion See Also

Configures how the digitizer performs downconversion.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Enabled As Boolean  _
    ByVal  CenterFrequency As Double  _
)
C#
public void  Configure(
    bool  Enabled,
    double  CenterFrequency
)
Visual C++
HRESULT Configure(
    VARIANT_BOOL  Enabled,
    double  CenterFrequency
);

Parameters

Enabled

Enables or disables downversion. The driver uses this value to set the Downconversion Enabled attribute. See the attribute description for more details.

CenterFrequency

Specifies the center frequency, in Hz, from which the digitizer should downconvert. The driver uses this value to set the Downconversion Center Frequency attribute. See the attribute description for more details.

Remarks

For the M9703A, when downconversion is enabled, the following applies:

The Read/Fetch/FetchMulti methods in Real64 are supported for all sample rates. The Read/Fetch/FetchMulti methods in Int16 are supported for the highest sample rate only. The Read/Fetch/FetchMulti methods in Int32 are supported for all except the highest sample rates. (The Int variants correspond to the respective data format as stored in module memory).

For these methods, the parameter ActualPoints is given in number of I-Q data point pairs, or complex samples. For the FetchMulti methods, the units of the OffsetWithinRecord and NumPointsPerRecord parameters are also complex samples. The FirstValidPoint parameter, which is primarily intended for dealing with memory alignment, is always given in array elements, like the WaveformArraySize parameter.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1Channel3Downconversion Interface
Agilent.AgMD1.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel3Downconversion..::.Enabled Property
IAgMD1Channel3Downconversion See Also

Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1Channel3Downconversion Interface
Agilent.AgMD1.Interop Namespace


IQInterleaved Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel3Downconversion..::.IQInterleaved Property
IAgMD1Channel3Downconversion See Also

Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property IQInterleaved As Boolean
C#
public bool  IQInterleaved { get; set; }
Visual C++
HRESULT get_IQInterleaved(
    VARIANT_BOOL*  val
);
HRESULT put_IQInterleaved(
    VARIANT_BOOL  val
);

Remarks

Note that the M9703A only supports interleaved I-Q data points, and each I-Q pair is treated as one complex sample.

Please refer to the Remarks in the Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1Channel3Downconversion Interface
Agilent.AgMD1.Interop Namespace


Close Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriver..::.Close Method
IIviDriver See Also

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Close ( _
)
C#
public void  Close(
)
Visual C++
HRESULT Close(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


ControlIO Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.ControlIO Property
IAgMD1 See Also

Pointer to the IAgMD1ControlIO interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ControlIO As IAgMD1ControlIO
C#
public IAgMD1ControlIO  ControlIO { get; }
Visual C++
HRESULT get_ControlIO(
    IAgMD1ControlIO**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


SignalA Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ControlIO..::.SignalA Property
IAgMD1ControlIO See Also

Signal present on Control IO connector A. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SignalA As String
C#
public string  SignalA { get; set; }
Visual C++
HRESULT get_SignalA(
    BSTR*  val
);
HRESULT put_SignalA(
    BSTR  val
);

Requirements

Supported Models

DC110, DC122, DC122HF, DC122HZ, DC135, DC135HZ, DC140, DC140HZ, DC152, DC152HZ, DC211, DC211A, DC222, DC222HF, DC222HZ, DC240, DC241, DC241A, DC252, DC252HF, DC252HZ, DC265, DC270, DC271, DC271A, DC271AR, DC282, DC282HZ, DC436, DC438, DC440, DP105, DP106, DP110, DP111, DP1400, DP210, DP211, DP212, DP214, DP235, DP240, DP306, DP308, DP310, M9210A, M9211A, M9703A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IAgMD1ControlIO Interface
Agilent.AgMD1.Interop Namespace


SignalB Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ControlIO..::.SignalB Property
IAgMD1ControlIO See Also

Signal present on Control IO connector B. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SignalB As String
C#
public string  SignalB { get; set; }
Visual C++
HRESULT get_SignalB(
    BSTR*  val
);
HRESULT put_SignalB(
    BSTR  val
);

Requirements

Supported Models

DC110, DC122, DC122HF, DC122HZ, DC135, DC135HZ, DC140, DC140HZ, DC152, DC152HZ, DC211, DC211A, DC222, DC222HF, DC222HZ, DC240, DC241, DC241A, DC252, DC252HF, DC252HZ, DC265, DC270, DC271, DC271A, DC271AR, DC282, DC282HZ, DC436, DC438, DC440, DP105, DP106, DP110, DP111, DP1400, DP210, DP211, DP212, DP214, DP235, DP240, DP306, DP308, DP310, M9210A, M9211A, M9703A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IAgMD1ControlIO Interface
Agilent.AgMD1.Interop Namespace


SignalC Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ControlIO..::.SignalC Property
IAgMD1ControlIO See Also

Signal present on Control IO connector C if present. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SignalC As String
C#
public string  SignalC { get; set; }
Visual C++
HRESULT get_SignalC(
    BSTR*  val
);
HRESULT put_SignalC(
    BSTR  val
);

Requirements

Supported Models

U1084A001, U1084A002, U1084A003

See Also

Reference

IAgMD1ControlIO Interface
Agilent.AgMD1.Interop Namespace


DriverOperation Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriver..::.DriverOperation Property
IIviDriver See Also

Pointer to the IIviDriverOperation interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property DriverOperation As IIviDriverOperation
C#
public IIviDriverOperation  DriverOperation { get; }
Visual C++
HRESULT get_DriverOperation(
    IIviDriverOperation**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Cache Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.Cache Property
IIviDriverOperation See Also

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property Cache As Boolean
C#
public bool  Cache { get; set; }
Visual C++
HRESULT get_Cache(
    VARIANT_BOOL*  val
);
HRESULT put_Cache(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


ClearInterchangeWarnings Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.ClearInterchangeWarnings Method
IIviDriverOperation See Also

-- NOT SUPPORTED -- Clears the list of interchangeability warnings that the IVI specific driver maintains.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ClearInterchangeWarnings ( _
)
C#
public void  ClearInterchangeWarnings(
)
Visual C++
HRESULT ClearInterchangeWarnings(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


DriverSetup Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.DriverSetup Property
IIviDriverOperation See Also

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property DriverSetup As String
C#
public string  DriverSetup { get; }
Visual C++
HRESULT get_DriverSetup(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


GetNextCoercionRecord Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.GetNextCoercionRecord Method
IIviDriverOperation See Also

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Function GetNextCoercionRecord ( _
) As String
C#
public string  GetNextCoercionRecord(
)
Visual C++
HRESULT GetNextCoercionRecord(
    BSTR*  retval
);

Return Value

The coercion record string shall contain the following information: (1) The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant. (2) If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.(3) If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.(4) The value that the user specified for the attribute.(5) The value to which the attribute was coerced.

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


GetNextInterchangeWarning Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.GetNextInterchangeWarning Method
IIviDriverOperation See Also

-- NOT SUPPORTED -- Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Function GetNextInterchangeWarning ( _
) As String
C#
public string  GetNextInterchangeWarning(
)
Visual C++
HRESULT GetNextInterchangeWarning(
    BSTR*  retval
);

Return Value

A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


InterchangeCheck Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.InterchangeCheck Property
IIviDriverOperation See Also

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property InterchangeCheck As Boolean
C#
public bool  InterchangeCheck { get; set; }
Visual C++
HRESULT get_InterchangeCheck(
    VARIANT_BOOL*  val
);
HRESULT put_InterchangeCheck(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


InvalidateAllAttributes Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.InvalidateAllAttributes Method
IIviDriverOperation See Also

Invalidates all of the driver's cached values.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub InvalidateAllAttributes ( _
)
C#
public void  InvalidateAllAttributes(
)
Visual C++
HRESULT InvalidateAllAttributes(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


IoResourceDescriptor Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.IoResourceDescriptor Property
IIviDriverOperation See Also

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property IoResourceDescriptor As String
C#
public string  IoResourceDescriptor { get; }
Visual C++
HRESULT get_IoResourceDescriptor(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


LogicalName Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.LogicalName Property
IIviDriverOperation See Also

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property LogicalName As String
C#
public string  LogicalName { get; }
Visual C++
HRESULT get_LogicalName(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


QueryInstrumentStatus Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.QueryInstrumentStatus Property
IIviDriverOperation See Also

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property QueryInstrumentStatus As Boolean
C#
public bool  QueryInstrumentStatus { get; set; }
Visual C++
HRESULT get_QueryInstrumentStatus(
    VARIANT_BOOL*  val
);
HRESULT put_QueryInstrumentStatus(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


RangeCheck Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.RangeCheck Property
IIviDriverOperation See Also

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property RangeCheck As Boolean
C#
public bool  RangeCheck { get; set; }
Visual C++
HRESULT get_RangeCheck(
    VARIANT_BOOL*  val
);
HRESULT put_RangeCheck(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


RecordCoercions Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.RecordCoercions Property
IIviDriverOperation See Also

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property RecordCoercions As Boolean
C#
public bool  RecordCoercions { get; set; }
Visual C++
HRESULT get_RecordCoercions(
    VARIANT_BOOL*  val
);
HRESULT put_RecordCoercions(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


ResetInterchangeCheck Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.ResetInterchangeCheck Method
IIviDriverOperation See Also

-- NOT SUPPORTED -- Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ResetInterchangeCheck ( _
)
C#
public void  ResetInterchangeCheck(
)
Visual C++
HRESULT ResetInterchangeCheck(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


Simulate Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation..::.Simulate Property
IIviDriverOperation See Also

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Property Simulate As Boolean
C#
public bool  Simulate { get; set; }
Visual C++
HRESULT get_Simulate(
    VARIANT_BOOL*  val
);
HRESULT put_Simulate(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverOperation Interface
Ivi.Driver.Interop Namespace


Identity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriver..::.Identity Property
IIviDriver See Also

Pointer to the IIviDriverIdentity interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Identity As IIviDriverIdentity
C#
public IIviDriverIdentity  Identity { get; }
Visual C++
HRESULT get_Identity(
    IIviDriverIdentity**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Description Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviComponentIdentity..::.Description Property
IIviComponentIdentity See Also

A brief description of the implementing component. Description is limted to 256 bytes.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Description As String
C#
public string  Description { get; }
Visual C++
HRESULT get_Description(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviComponentIdentity Interface
Ivi.Driver.Interop Namespace


GroupCapabilities Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.GroupCapabilities Property
IIviDriverIdentity See Also

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property GroupCapabilities As String
C#
public string  GroupCapabilities { get; }
Visual C++
HRESULT get_GroupCapabilities(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


Identifier Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.Identifier Property
IIviDriverIdentity See Also

The case-sensitive unique identifier of the implementing IVI-COM instrument driver.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Identifier As String
C#
public string  Identifier { get; }
Visual C++
HRESULT get_Identifier(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


InstrumentFirmwareRevision Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.InstrumentFirmwareRevision Property
IIviDriverIdentity See Also

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property InstrumentFirmwareRevision As String
C#
public string  InstrumentFirmwareRevision { get; }
Visual C++
HRESULT get_InstrumentFirmwareRevision(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


InstrumentManufacturer Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.InstrumentManufacturer Property
IIviDriverIdentity See Also

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property InstrumentManufacturer As String
C#
public string  InstrumentManufacturer { get; }
Visual C++
HRESULT get_InstrumentManufacturer(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


InstrumentModel Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.InstrumentModel Property
IIviDriverIdentity See Also

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property InstrumentModel As String
C#
public string  InstrumentModel { get; }
Visual C++
HRESULT get_InstrumentModel(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


Revision Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviComponentIdentity..::.Revision Property
IIviComponentIdentity See Also

The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Revision As String
C#
public string  Revision { get; }
Visual C++
HRESULT get_Revision(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviComponentIdentity Interface
Ivi.Driver.Interop Namespace


SpecificationMajorVersion Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.SpecificationMajorVersion Property
IIviDriverIdentity See Also

For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property SpecificationMajorVersion As Integer
C#
public int  SpecificationMajorVersion { get; }
Visual C++
HRESULT get_SpecificationMajorVersion(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


SpecificationMinorVersion Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.SpecificationMinorVersion Property
IIviDriverIdentity See Also

For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property SpecificationMinorVersion As Integer
C#
public int  SpecificationMinorVersion { get; }
Visual C++
HRESULT get_SpecificationMinorVersion(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


SupportedInstrumentModels Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity..::.SupportedInstrumentModels Property
IIviDriverIdentity See Also

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property SupportedInstrumentModels As String
C#
public string  SupportedInstrumentModels { get; }
Visual C++
HRESULT get_SupportedInstrumentModels(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverIdentity Interface
Ivi.Driver.Interop Namespace


Vendor Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviComponentIdentity..::.Vendor Property
IIviComponentIdentity See Also

The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Vendor As String
C#
public string  Vendor { get; }
Visual C++
HRESULT get_Vendor(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviComponentIdentity Interface
Ivi.Driver.Interop Namespace


Initialize Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriver..::.Initialize Method
IIviDriver See Also

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Initialize ( _
    ByVal  ResourceName As String  _
    ByVal  IdQuery As Boolean  _
    ByVal  Reset As Boolean  _
    ByVal  OptionString As String  _
)
C#
public void  Initialize(
    string  ResourceName,
    bool  IdQuery,
    bool  Reset,
    string  OptionString
)
Visual C++
HRESULT Initialize(
    BSTR  ResourceName,
    VARIANT_BOOL  IdQuery,
    VARIANT_BOOL  Reset,
    BSTR  OptionString
);

Parameters

ResourceName

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

IdQuery

Specifies whether to verify the ID of the instrument.

Reset

Specifies whether to reset the instrument.

OptionString

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck,or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the DriverSetup attribute, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

Remarks

Specific DriverSetup options
Option Name | Description | Default
Dma | If true, data transfers are performed in DMA mode. | true
Cal | If true, a calibration is performed during initialization. | true
For for other DriverSetup options and parameter usage see: Initializing the IVI-COM Driver

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Initialized Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriver..::.Initialized Property
IIviDriver See Also

Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Initialized As Boolean
C#
public bool  Initialized { get; }
Visual C++
HRESULT get_Initialized(
    VARIANT_BOOL*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


InstrumentInfo Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.InstrumentInfo Property
IAgMD1 See Also

Pointer to the IAgMD1SystemInstrumentInfo interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property InstrumentInfo As IAgMD1InstrumentInfo
C#
public IAgMD1InstrumentInfo  InstrumentInfo { get; }
Visual C++
HRESULT get_InstrumentInfo(
    IAgMD1InstrumentInfo**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


AqDrvVersion Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.AqDrvVersion Property
IAgMD1InstrumentInfo See Also

Version of the AqDrv Device Driver. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property AqDrvVersion As String
C#
public string  AqDrvVersion { get; }
Visual C++
HRESULT get_AqDrvVersion(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


AqIOVersion Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.AqIOVersion Property
IAgMD1InstrumentInfo See Also

Version of the Agilent Acqiris IO Driver. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property AqIOVersion As String
C#
public string  AqIOVersion { get; }
Visual C++
HRESULT get_AqIOVersion(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


BusNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.BusNumber Property
IAgMD1InstrumentInfo See Also

PCI Bus number. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property BusNumber As Integer
C#
public int  BusNumber { get; }
Visual C++
HRESULT get_BusNumber(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


CPLDFirmwareRev Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.CPLDFirmwareRev Property
IAgMD1InstrumentInfo See Also

Revision of the CPLD Firmware. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property CPLDFirmwareRev As String
C#
public string  CPLDFirmwareRev { get; }
Visual C++
HRESULT get_CPLDFirmwareRev(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


CrateNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.CrateNumber Property
IAgMD1InstrumentInfo See Also

Crate number. Starts at 121000 for autodetected CC121 crates. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property CrateNumber As Integer
C#
public int  CrateNumber { get; }
Visual C++
HRESULT get_CrateNumber(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


DeviceID Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.DeviceID Property
IAgMD1InstrumentInfo See Also

PCI Device ID. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property DeviceID As Integer
C#
public int  DeviceID { get; }
Visual C++
HRESULT get_DeviceID(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


EEPROMCommonSectionRev Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.EEPROMCommonSectionRev Property
IAgMD1InstrumentInfo See Also

Revision of the EEPROM Common Section. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property EEPROMCommonSectionRev As String
C#
public string  EEPROMCommonSectionRev { get; }
Visual C++
HRESULT get_EEPROMCommonSectionRev(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


EEPROMDigitizerSectionRev Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.EEPROMDigitizerSectionRev Property
IAgMD1InstrumentInfo See Also

Revision of the EEPROM Digitizer Section. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property EEPROMDigitizerSectionRev As String
C#
public string  EEPROMDigitizerSectionRev { get; }
Visual C++
HRESULT get_EEPROMDigitizerSectionRev(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


HasHighResSampleRate Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.HasHighResSampleRate Property
IAgMD1InstrumentInfo See Also

True if the instrument features a high resolution sampling rate. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property HasHighResSampleRate As Boolean
C#
public bool  HasHighResSampleRate { get; }
Visual C++
HRESULT get_HasHighResSampleRate(
    VARIANT_BOOL*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


NbrADCBits Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.NbrADCBits Property
IAgMD1InstrumentInfo See Also

Number of bits of data per sample from this module's ADCs. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NbrADCBits As Integer
C#
public int  NbrADCBits { get; }
Visual C++
HRESULT get_NbrADCBits(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


NbrExternalTriggers Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.NbrExternalTriggers Property
IAgMD1InstrumentInfo See Also

Number of external trigger sources. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NbrExternalTriggers As Integer
C#
public int  NbrExternalTriggers { get; }
Visual C++
HRESULT get_NbrExternalTriggers(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


NbrInternalTriggers Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.NbrInternalTriggers Property
IAgMD1InstrumentInfo See Also

Number of internal trigger sources. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NbrInternalTriggers As Integer
C#
public int  NbrInternalTriggers { get; }
Visual C++
HRESULT get_NbrInternalTriggers(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


NbrModulesInInstrument Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.NbrModulesInInstrument Property
IAgMD1InstrumentInfo See Also

Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NbrModulesInInstrument As Integer
C#
public int  NbrModulesInInstrument { get; }
Visual C++
HRESULT get_NbrModulesInInstrument(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


Options Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.Options Property
IAgMD1InstrumentInfo See Also

List of comma separated options installed in this instrument. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Options As String
C#
public string  Options { get; }
Visual C++
HRESULT get_Options(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


SerialNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.SerialNumber Property
IAgMD1InstrumentInfo See Also

Deprecated - Do not use. Use SerialNumberString. The serial number of the instrument. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialNumber As Integer
C#
public int  SerialNumber { get; }
Visual C++
HRESULT get_SerialNumber(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


SlotNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo..::.SlotNumber Property
IAgMD1InstrumentInfo See Also

The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates). Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SlotNumber As Integer
C#
public int  SlotNumber { get; }
Visual C++
HRESULT get_SlotNumber(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo Interface
Agilent.AgMD1.Interop Namespace


InstrumentInfo2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex..::.InstrumentInfo2 Property
IAgMD1Ex See Also

Pointer to the IAgMD1SystemInstrumentInfo2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property InstrumentInfo2 As IAgMD1InstrumentInfo2
C#
public IAgMD1InstrumentInfo2  InstrumentInfo2 { get; }
Visual C++
HRESULT get_InstrumentInfo2(
    IAgMD1InstrumentInfo2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex Interface
Agilent.AgMD1.Interop Namespace


FundamentalHandle Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo2..::.FundamentalHandle Property
IAgMD1InstrumentInfo2 See Also

Returns the Int32 equivalent ViSession handle to the fundamental API used to control the module hardware. Never call the fundamental Acqrs_close or Acqrs_closeAll functions with this handle or the driver will cease to operate. Use the IVI driver's Close method instead.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property FundamentalHandle As Integer
C#
public int  FundamentalHandle { get; }
Visual C++
HRESULT get_FundamentalHandle(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo2 Interface
Agilent.AgMD1.Interop Namespace


SerialNumberString Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo2..::.SerialNumberString Property
IAgMD1InstrumentInfo2 See Also

The serial number string of the instrument. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SerialNumberString As String
C#
public string  SerialNumberString { get; }
Visual C++
HRESULT get_SerialNumberString(
    BSTR*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1InstrumentInfo2 Interface
Agilent.AgMD1.Interop Namespace


LogicDevices Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex2..::.LogicDevices Property
IAgMD1Ex2 See Also

Pointer to the IAgMD1LogicDevices interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property LogicDevices As IAgMD1LogicDevices
C#
public IAgMD1LogicDevices  LogicDevices { get; }
Visual C++
HRESULT get_LogicDevices(
    IAgMD1LogicDevices**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex2 Interface
Agilent.AgMD1.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevices..::.Count Property
IAgMD1LogicDevices See Also

Returns the number of logic devices.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1LogicDevices Interface
Agilent.AgMD1.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevices..::.Item Property
IAgMD1LogicDevices See Also

Pointer to the IAgMD1LogicDevice interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgMD1LogicDevice
C#
public IAgMD1LogicDevice  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgMD1LogicDevice**  val
);

Parameters

Name

The name of a logicdevice. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the LogicDevice repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1LogicDevices Interface
Agilent.AgMD1.Interop Namespace


LoadLogicDeviceFromFile Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevice..::.LoadLogicDeviceFromFile Method
IAgMD1LogicDevice See Also

Loads the bit file at the file system path Path into the FPGA(s) identified by the LogicDevice repeated capability.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub LoadLogicDeviceFromFile ( _
    ByVal  Path As String  _
)
C#
public void  LoadLogicDeviceFromFile(
    string  Path
)
Visual C++
HRESULT LoadLogicDeviceFromFile(
    BSTR  Path
);

Parameters

Path

The file system path where the file to load is.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1LogicDevice Interface
Agilent.AgMD1.Interop Namespace


ReadIndirectInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevice..::.ReadIndirectInt32 Method
IAgMD1LogicDevice See Also

Reads up to NumElements 32 bit integers of the Indirect Buffer with identifier Id from the FPGA identified by LogicDevice repeated capagility into the memory referenced by Data.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ReadIndirectInt32 ( _
    ByVal  Id As Integer  _
    ByVal  StartAddress As Integer  _
    ByVal  NumElements As Integer  _
    ByRef  Data As Integer()   _
)
C#
public void  ReadIndirectInt32(
    int  Id,
    int  StartAddress,
    int  NumElements,
    ref int[]   Data
)
Visual C++
HRESULT ReadIndirectInt32(
    long  Id,
    long  StartAddress,
    long  NumElements,
    SAFEARRAY**  Data
);

Parameters

Id

The firmware indirect buffer id.

StartAddress

The start address in the FPGA where the data will be read.

NumElements

Number of elements to read.

Data

Will contain the data read from the buffer.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1LogicDevice Interface
Agilent.AgMD1.Interop Namespace


ReadRegisterInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevice..::.ReadRegisterInt32 Method
IAgMD1LogicDevice See Also

Reads a 32 bits integer value from the register at Offset in the FPGA identified by LogicDevice repeated capability.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ReadRegisterInt32 ( _
    ByVal  Offset As Integer  _
    ByRef  Value As Integer  _
)
C#
public void  ReadRegisterInt32(
    int  Offset,
    ref int  Value
)
Visual C++
HRESULT ReadRegisterInt32(
    long  Offset,
    long*  Value
);

Parameters

Offset

Address in the FPGA where the register will be read.

Value

Will contain the value read from the register.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1LogicDevice Interface
Agilent.AgMD1.Interop Namespace


WriteIndirectInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevice..::.WriteIndirectInt32 Method
IAgMD1LogicDevice See Also

Writes the contents of Data to the Indirect Buffer with identifier Id of the FPGA identified by LogicDevice repeated capability.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub WriteIndirectInt32 ( _
    ByVal  Id As Integer  _
    ByVal  StartAddress As Integer  _
    ByVal  NumElements As Integer  _
    ByVal  Data As Integer()   _
)
C#
public void  WriteIndirectInt32(
    int  Id,
    int  StartAddress,
    int  NumElements,
    int[]   Data
)
Visual C++
HRESULT WriteIndirectInt32(
    long  Id,
    long  StartAddress,
    long  NumElements,
    SAFEARRAY**  Data
);

Parameters

Id

The firmware indirect buffer id.

StartAddress

The start address in the FPGA where the data will be written.

NumElements

Number of elements to write.

Data

Buffer containing data to write into the firmware indirect buffer.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1LogicDevice Interface
Agilent.AgMD1.Interop Namespace


WriteRegisterInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevice..::.WriteRegisterInt32 Method
IAgMD1LogicDevice See Also

Writes the 32 bits integer value Value to the register at Offset in the FPGA identified by LogicDevice repeated capability.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub WriteRegisterInt32 ( _
    ByVal  Offset As Integer  _
    ByVal  Value As Integer  _
)
C#
public void  WriteRegisterInt32(
    int  Offset,
    int  Value
)
Visual C++
HRESULT WriteRegisterInt32(
    long  Offset,
    long  Value
);

Parameters

Offset

Address in the FPGA where the register will be written.

Value

Value to write into the register.

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1LogicDevice Interface
Agilent.AgMD1.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevices..::.Name Property
IAgMD1LogicDevices See Also

Returns the logic device name for a given index.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of logic devices.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1LogicDevices Interface
Agilent.AgMD1.Interop Namespace


ReferenceLevel Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.ReferenceLevel Property
IAgMD1 See Also

Pointer to the IAgMD1ReferenceLevel interface

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ReferenceLevel As IAgMD1ReferenceLevel
C#
public IAgMD1ReferenceLevel  ReferenceLevel { get; }
Visual C++
HRESULT get_ReferenceLevel(
    IAgMD1ReferenceLevel**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceLevel..::.Configure Method
IAgMD1ReferenceLevel See Also

Configures the reference levels for waveform measurements, low, mid, and high.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Low As Double  _
    ByVal  Mid As Double  _
    ByVal  High As Double  _
)
C#
public void  Configure(
    double  Low,
    double  Mid,
    double  High
)
Visual C++
HRESULT Configure(
    double  Low,
    double  Mid,
    double  High
);

Parameters

Low

Measurement low reference. This value sets the Meas Low Ref property

Mid

Measurement mid reference. This value sets the Meas Mid Ref property.

High

Measurement high reference. This value sets the Meas High Ref property.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ReferenceLevel Interface
Agilent.AgMD1.Interop Namespace


High Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceLevel..::.High Property
IAgMD1ReferenceLevel See Also

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property High As Double
C#
public double  High { get; set; }
Visual C++
HRESULT get_High(
    double*  val
);
HRESULT put_High(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ReferenceLevel Interface
Agilent.AgMD1.Interop Namespace


Low Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceLevel..::.Low Property
IAgMD1ReferenceLevel See Also

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Low As Double
C#
public double  Low { get; set; }
Visual C++
HRESULT get_Low(
    double*  val
);
HRESULT put_Low(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ReferenceLevel Interface
Agilent.AgMD1.Interop Namespace


Mid Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceLevel..::.Mid Property
IAgMD1ReferenceLevel See Also

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Mid As Double
C#
public double  Mid { get; set; }
Visual C++
HRESULT get_Mid(
    double*  val
);
HRESULT put_Mid(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ReferenceLevel Interface
Agilent.AgMD1.Interop Namespace


ReferenceOscillator Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.ReferenceOscillator Property
IAgMD1 See Also

Pointer to the IAgMD1Reference Oscillator interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ReferenceOscillator As IAgMD1ReferenceOscillator
C#
public IAgMD1ReferenceOscillator  ReferenceOscillator { get; }
Visual C++
HRESULT get_ReferenceOscillator(
    IAgMD1ReferenceOscillator**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


ExternalFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceOscillator..::.ExternalFrequency Property
IAgMD1ReferenceOscillator See Also

Read only. The frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ExternalFrequency As Double
C#
public double  ExternalFrequency { get; }
Visual C++
HRESULT get_ExternalFrequency(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ReferenceOscillator Interface
Agilent.AgMD1.Interop Namespace


OutputEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceOscillator..::.OutputEnabled Property
IAgMD1ReferenceOscillator See Also

Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property OutputEnabled As Boolean
C#
public bool  OutputEnabled { get; set; }
Visual C++
HRESULT get_OutputEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_OutputEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

DC110, DC122, DC122HF, DC122HZ, DC135, DC135HZ, DC140, DC140HZ, DC152, DC152HZ, DC211, DC211A, DC222, DC222HF, DC222HZ, DC240, DC241, DC241A, DC252, DC252HF, DC252HZ, DC265, DC270, DC271, DC271A, DC271AR, DC282, DC282HZ, DC436, DC438, DC440, DP105, DP106, DP110, DP111, DP1400, DP210, DP211, DP212, DP214, DP235, DP240, DP306, DP308, DP310, M9210A, M9211A, M9703A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IAgMD1ReferenceOscillator Interface
Agilent.AgMD1.Interop Namespace


Source Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceOscillator..::.Source Property
IAgMD1ReferenceOscillator See Also

Specifies the reference frequency source used.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Source As AgMD1ReferenceOscillatorSourceEnum
C#
public AgMD1ReferenceOscillatorSourceEnum  Source { get; set; }
Visual C++
HRESULT get_Source(
    AgMD1ReferenceOscillatorSourceEnum*  val
);
HRESULT put_Source(
    AgMD1ReferenceOscillatorSourceEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1ReferenceOscillator Interface
Agilent.AgMD1.Interop Namespace


SampleClock Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.SampleClock Property
IAgMD1 See Also

Pointer to the IAgMD1SampleClock interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleClock As IAgMD1SampleClock
C#
public IAgMD1SampleClock  SampleClock { get; }
Visual C++
HRESULT get_SampleClock(
    IAgMD1SampleClock**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1SampleClock..::.Configure Method
IAgMD1SampleClock See Also

Configures the digitizer's sample clock.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As AgMD1SampleClockSourceEnum  _
    ByVal  Frequency As Double  _
)
C#
public void  Configure(
    AgMD1SampleClockSourceEnum  Source,
    double  Frequency
)
Visual C++
HRESULT Configure(
    AgMD1SampleClockSourceEnum  Source,
    double  Frequency
);

Parameters

Source

Specifies the source of the sample clock signal. The driver uses this value to set the Sample Clock Source attribute. See the attribute description for more details.

Frequency

Specifies the frequency of the external sample clock. This parameter is only used if the Sample Clock Source attribute is set to External. The driver uses this value to set the External Sample Clock Frequency attribute. See the attribute description for more details.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1SampleClock Interface
Agilent.AgMD1.Interop Namespace


ExternalDivider Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1SampleClock..::.ExternalDivider Property
IAgMD1SampleClock See Also

Read only, the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ExternalDivider As Double
C#
public double  ExternalDivider { get; }
Visual C++
HRESULT get_ExternalDivider(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1SampleClock Interface
Agilent.AgMD1.Interop Namespace


ExternalFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1SampleClock..::.ExternalFrequency Property
IAgMD1SampleClock See Also

Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ExternalFrequency As Double
C#
public double  ExternalFrequency { get; set; }
Visual C++
HRESULT get_ExternalFrequency(
    double*  val
);
HRESULT put_ExternalFrequency(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1SampleClock Interface
Agilent.AgMD1.Interop Namespace


Source Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1SampleClock..::.Source Property
IAgMD1SampleClock See Also

Specifies the clock used to pace acquisition sampling.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Source As AgMD1SampleClockSourceEnum
C#
public AgMD1SampleClockSourceEnum  Source { get; set; }
Visual C++
HRESULT get_Source(
    AgMD1SampleClockSourceEnum*  val
);
HRESULT put_Source(
    AgMD1SampleClockSourceEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1SampleClock Interface
Agilent.AgMD1.Interop Namespace


System Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.System Property
IAgMD1 See Also

Pointer to the IAgMD1System interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property System As IAgMD1System
C#
public IAgMD1System  System { get; }
Visual C++
HRESULT get_System(
    IAgMD1System**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


NbrInstruments Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1System..::.NbrInstruments Property
IAgMD1System See Also

The number of instruments supporting the AgMD1 driver in the system. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NbrInstruments As Integer
C#
public int  NbrInstruments { get; }
Visual C++
HRESULT get_NbrInstruments(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1System Interface
Agilent.AgMD1.Interop Namespace


PowerOffAll Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1System..::.PowerOffAll Method
IAgMD1System See Also

Forces all instruments to prepare and enter the system power down state. Suspend all other calling threads. If a thread is performing a long operation which cannot be completed within milliseconds (e.g. a self-calibration), it will be interrupted immediately and will return the status 'ACQIRIS_ERROR_OPERATION_INTERRUPTED'. Note that if an acquisition is still running when the PowerOffAll method is invoked, it might be incomplete or corrupted.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub PowerOffAll ( _
)
C#
public void  PowerOffAll(
)
Visual C++
HRESULT PowerOffAll(
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1System Interface
Agilent.AgMD1.Interop Namespace


PowerOnAll Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1System..::.PowerOnAll Method
IAgMD1System See Also

Forces all instruments power up and return from the system power down state. Re-enable the instruments at the same state as they were before the PowerOffAll method was invoked. Threads which were suspended will be resumed. However, interrupted operations which returned an error 'ACQIRIS_ERROR_OPERATION_INTERRUPTED' will have to be redone.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub PowerOnAll ( _
)
C#
public void  PowerOnAll(
)
Visual C++
HRESULT PowerOnAll(
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1System Interface
Agilent.AgMD1.Interop Namespace


ResumeControl Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1System..::.ResumeControl Method
IAgMD1System See Also

Resume the control of an instrument that was suspended (see SuspendControl).

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub ResumeControl ( _
)
C#
public void  ResumeControl(
)
Visual C++
HRESULT ResumeControl(
);

Remarks

This function reacquires the driver lock of the instrument and allows calls to it from the current process. The error code ACQIRIS_ERROR_DEVICE_ALREADY_OPEN is returned when calling an instrument already locked by another process. After successfully calling ResumeControl, the module will be set to a default hardware state. It will have no valid data and the timestamp will be set to 0. When the next acquisition is started, the module will be configured with all of the unmodified settings from before the SuspendControl was invoked.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1System Interface
Agilent.AgMD1.Interop Namespace


SuspendControl Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1System..::.SuspendControl Method
IAgMD1System See Also

Suspend control of an instrument to allow using it from another process. NOTE: This is only available for Windows operating systems.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub SuspendControl ( _
)
C#
public void  SuspendControl(
)
Visual C++
HRESULT SuspendControl(
);

Remarks

This function releases the driver lock of the instrument and prevents all further calls from the current process. The error code ACQIRIS_ERROR_INVALID_HANDLE is returned when calling functions on a suspended instrument. Use ResumeControl to reacquire the control of the instrument. Once suspended, this instrument can be used from another process. However, if this is the first time this other process is used, all desired acquisition settings must be defined and a calibration will be needed.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1System Interface
Agilent.AgMD1.Interop Namespace


TraceEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1System..::.TraceEnabled Property
IAgMD1System See Also

If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property TraceEnabled As Boolean
C#
public bool  TraceEnabled { get; set; }
Visual C++
HRESULT get_TraceEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_TraceEnabled(
    VARIANT_BOOL  val
);

Remarks

You may also enable tracing, specify a file name and path, and additional trace options when initializing the driver. For complete information on Initialize tracing options see the 'DriverSetup' section on the Initializing the IVI-COM Driver page.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1System Interface
Agilent.AgMD1.Interop Namespace


Temperature Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.Temperature Property
IAgMD1 See Also

Pointer to the IAgMD1Temperature interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Temperature As IAgMD1Temperature
C#
public IAgMD1Temperature  Temperature { get; }
Visual C++
HRESULT get_Temperature(
    IAgMD1Temperature**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


BoardTemperature Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Temperature..::.BoardTemperature Property
IAgMD1Temperature See Also

Indicates the temperature of the entire board. The units are governed by the Temperature.Units property. Read only

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property BoardTemperature As Double
C#
public double  BoardTemperature { get; }
Visual C++
HRESULT get_BoardTemperature(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Temperature Interface
Agilent.AgMD1.Interop Namespace


GetModuleTemperature Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Temperature..::.GetModuleTemperature Method
IAgMD1Temperature See Also

Temperature of the specified module. The units are governed by the Temperature.Units property.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Function GetModuleTemperature ( _
    ByVal  ModuleNumber As Integer  _
) As Integer
C#
public int  GetModuleTemperature(
    int  ModuleNumber
)
Visual C++
HRESULT GetModuleTemperature(
    long  ModuleNumber
    long*  retval
);

Parameters

ModuleNumber

The module number in a Multi-Instrument (ASBus), runs from 0 to (nbr of modules - 1).

Return Value

The module temperature.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Temperature Interface
Agilent.AgMD1.Interop Namespace


Units Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Temperature..::.Units Property
IAgMD1Temperature See Also

Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Units As AgMD1TemperatureUnitsEnum
C#
public AgMD1TemperatureUnitsEnum  Units { get; set; }
Visual C++
HRESULT get_Units(
    AgMD1TemperatureUnitsEnum*  val
);
HRESULT put_Units(
    AgMD1TemperatureUnitsEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Temperature Interface
Agilent.AgMD1.Interop Namespace


Trigger Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1..::.Trigger Property
IAgMD1 See Also

Pointer to the IAgMD1Trigger interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger As IAgMD1Trigger
C#
public IAgMD1Trigger  Trigger { get; }
Visual C++
HRESULT get_Trigger(
    IAgMD1Trigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1 Interface
Agilent.AgMD1.Interop Namespace


ActiveSource Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.ActiveSource Property
IAgMD1Trigger See Also

Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ActiveSource As String
C#
public string  ActiveSource { get; set; }
Visual C++
HRESULT get_ActiveSource(
    BSTR*  val
);
HRESULT put_ActiveSource(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


Delay Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.Delay Property
IAgMD1Trigger See Also

Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Delay As Double
C#
public double  Delay { get; set; }
Visual C++
HRESULT get_Delay(
    double*  val
);
HRESULT put_Delay(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


Holdoff Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.Holdoff Property
IAgMD1Trigger See Also

-- NOT SUPPORTED -- Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Holdoff As Double
C#
public double  Holdoff { get; set; }
Visual C++
HRESULT get_Holdoff(
    double*  val
);
HRESULT put_Holdoff(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


Modifier Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.Modifier Property
IAgMD1Trigger See Also

Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Modifier As AgMD1TriggerModifierEnum
C#
public AgMD1TriggerModifierEnum  Modifier { get; set; }
Visual C++
HRESULT get_Modifier(
    AgMD1TriggerModifierEnum*  val
);
HRESULT put_Modifier(
    AgMD1TriggerModifierEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


MultiTrigger Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.MultiTrigger Property
IAgMD1Trigger See Also

Pointer to the IAgMD1MultiTrigger interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MultiTrigger As IAgMD1MultiTrigger
C#
public IAgMD1MultiTrigger  MultiTrigger { get; }
Visual C++
HRESULT get_MultiTrigger(
    IAgMD1MultiTrigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1MultiTrigger..::.Configure Method
IAgMD1MultiTrigger See Also

Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  SourceList As String  _
    ByVal  Operator As AgMD1TriggerSourceOperatorEnum  _
)
C#
public void  Configure(
    string  SourceList,
    AgMD1TriggerSourceOperatorEnum  Operator
)
Visual C++
HRESULT Configure(
    BSTR  SourceList,
    AgMD1TriggerSourceOperatorEnum  Operator
);

Parameters

SourceList

A comma separated list of source names to be used in a multi trigger scenario. The driver uses this value to set the Trigger Source List attribute.

Operator

Specifies the boolean operation to apply to the trigger sources specified by the SourceList parameter. The driver uses this value to set the Trigger Source Operator attribute.

Requirements

Supported Models

DC122, DC122HF, DC122HZ, DC152, DC152HZ, DC222, DC222HF, DC222HZ, DC252, DC252HF, DC252HZ, DC282, DC282HZ, DP1400, M9210A, M9211A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IAgMD1MultiTrigger Interface
Agilent.AgMD1.Interop Namespace


SourceList Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1MultiTrigger..::.SourceList Property
IAgMD1MultiTrigger See Also

A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SourceList As String
C#
public string  SourceList { get; set; }
Visual C++
HRESULT get_SourceList(
    BSTR*  val
);
HRESULT put_SourceList(
    BSTR  val
);

Requirements

Supported Models

DC122, DC122HF, DC122HZ, DC152, DC152HZ, DC222, DC222HF, DC222HZ, DC252, DC252HF, DC252HZ, DC282, DC282HZ, DP1400, M9210A, M9211A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IAgMD1MultiTrigger Interface
Agilent.AgMD1.Interop Namespace


SourceOperator Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1MultiTrigger..::.SourceOperator Property
IAgMD1MultiTrigger See Also

Specifies the boolean operation to apply to the arm sources specified by the SourceList property. If set to None, muti triggering is disabled. A valid SourceList must be set before setting the SourceOperator to AND or OR. See the help for SourceList for more info.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SourceOperator As AgMD1TriggerSourceOperatorEnum
C#
public AgMD1TriggerSourceOperatorEnum  SourceOperator { get; set; }
Visual C++
HRESULT get_SourceOperator(
    AgMD1TriggerSourceOperatorEnum*  val
);
HRESULT put_SourceOperator(
    AgMD1TriggerSourceOperatorEnum  val
);

Requirements

Supported Models

DC122, DC122HF, DC122HZ, DC152, DC152HZ, DC222, DC222HF, DC222HZ, DC252, DC252HF, DC252HZ, DC282, DC282HZ, DP1400, M9210A, M9211A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IAgMD1MultiTrigger Interface
Agilent.AgMD1.Interop Namespace


Output Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.Output Property
IAgMD1Trigger See Also

Pointer to the IAgMD1TriggerOutput interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Output As IAgMD1TriggerOutput
C#
public IAgMD1TriggerOutput  Output { get; }
Visual C++
HRESULT get_Output(
    IAgMD1TriggerOutput**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerOutput..::.Enabled Property
IAgMD1TriggerOutput See Also

Specifies whether or not an accepted trigger appears at an output of the digitizer.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerOutput Interface
Agilent.AgMD1.Interop Namespace


Offset Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerOutput..::.Offset Property
IAgMD1TriggerOutput See Also

Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerOutput Interface
Agilent.AgMD1.Interop Namespace


ResyncEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerOutput..::.ResyncEnabled Property
IAgMD1TriggerOutput See Also

Controls whether the trigger out signal is resynchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false).

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ResyncEnabled As Boolean
C#
public bool  ResyncEnabled { get; set; }
Visual C++
HRESULT get_ResyncEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_ResyncEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerOutput Interface
Agilent.AgMD1.Interop Namespace


PxiTrigOutEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.PxiTrigOutEnabled Property
IAgMD1Trigger See Also

If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property PxiTrigOutEnabled As Boolean
C#
public bool  PxiTrigOutEnabled { get; set; }
Visual C++
HRESULT get_PxiTrigOutEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_PxiTrigOutEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


PxiTrigSlope Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.PxiTrigSlope Property
IAgMD1Trigger See Also

Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR".

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property PxiTrigSlope As AgMD1TriggerSlopeEnum
C#
public AgMD1TriggerSlopeEnum  PxiTrigSlope { get; set; }
Visual C++
HRESULT get_PxiTrigSlope(
    AgMD1TriggerSlopeEnum*  val
);
HRESULT put_PxiTrigSlope(
    AgMD1TriggerSlopeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


SendSoftwareTrigger Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.SendSoftwareTrigger Method
IAgMD1Trigger See Also

Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub SendSoftwareTrigger ( _
)
C#
public void  SendSoftwareTrigger(
)
Visual C++
HRESULT SendSoftwareTrigger(
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


Sources Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger..::.Sources Property
IAgMD1Trigger See Also

Pointer to the IAgMD1TriggerSources interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Sources As IAgMD1TriggerSources
C#
public IAgMD1TriggerSources  Sources { get; }
Visual C++
HRESULT get_Sources(
    IAgMD1TriggerSources**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger Interface
Agilent.AgMD1.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources..::.Count Property
IAgMD1TriggerSources See Also

Returns the number of TriggerSources.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSources Interface
Agilent.AgMD1.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources..::.Item Property
IAgMD1TriggerSources See Also

Pointer to the IAgMD1TriggerSource interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IAgMD1TriggerSource
C#
public IAgMD1TriggerSource  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IAgMD1TriggerSource**  val
);

Parameters

Name

The name of a TriggerSource. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the TriggerSource repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSources Interface
Agilent.AgMD1.Interop Namespace


Coupling Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource..::.Coupling Property
IAgMD1TriggerSource See Also

Specifies how the digitizer couples the trigger source.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As AgMD1TriggerCouplingEnum
C#
public AgMD1TriggerCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    AgMD1TriggerCouplingEnum*  val
);
HRESULT put_Coupling(
    AgMD1TriggerCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSource Interface
Agilent.AgMD1.Interop Namespace


Edge Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource..::.Edge Property
IAgMD1TriggerSource See Also

Pointer to the IAgMD1TriggerEdge interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Edge As IAgMD1TriggerEdge
C#
public IAgMD1TriggerEdge  Edge { get; }
Visual C++
HRESULT get_Edge(
    IAgMD1TriggerEdge**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSource Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerEdge..::.Configure Method
IAgMD1TriggerEdge See Also

This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  Slope As AgMD1TriggerSlopeEnum  _
)
C#
public void  Configure(
    double  Level,
    AgMD1TriggerSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    double  Level,
    AgMD1TriggerSlopeEnum  Slope
);

Parameters

Level

Specifies the trigger level. This value sets the Trigger Level attribute.

Slope

Specifies the trigger slope. This value sets the Trigger Slope attribute.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerEdge Interface
Agilent.AgMD1.Interop Namespace


Slope Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerEdge..::.Slope Property
IAgMD1TriggerEdge See Also

Specifies whether a rising or a falling edge triggers the digitizer.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgMD1TriggerSlopeEnum
C#
public AgMD1TriggerSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgMD1TriggerSlopeEnum*  val
);
HRESULT put_Slope(
    AgMD1TriggerSlopeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerEdge Interface
Agilent.AgMD1.Interop Namespace


ExtTrigRange Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource..::.ExtTrigRange Property
IAgMD1TriggerSource See Also

The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property ExtTrigRange As Double
C#
public double  ExtTrigRange { get; set; }
Visual C++
HRESULT get_ExtTrigRange(
    double*  val
);
HRESULT put_ExtTrigRange(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSource Interface
Agilent.AgMD1.Interop Namespace


Hysteresis Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource..::.Hysteresis Property
IAgMD1TriggerSource See Also

Specifies the trigger hysteresis in Volts.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Hysteresis As Double
C#
public double  Hysteresis { get; set; }
Visual C++
HRESULT get_Hysteresis(
    double*  val
);
HRESULT put_Hysteresis(
    double  val
);

Requirements

Supported Models

M9202A, M9703A

See Also

Reference

IAgMD1TriggerSource Interface
Agilent.AgMD1.Interop Namespace


Level Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource..::.Level Property
IAgMD1TriggerSource See Also

Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge or Magnitude. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge or Magnitude Trigger.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Level As Double
C#
public double  Level { get; set; }
Visual C++
HRESULT get_Level(
    double*  val
);
HRESULT put_Level(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSource Interface
Agilent.AgMD1.Interop Namespace


TV Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource..::.TV Property
IAgMD1TriggerSource See Also

Pointer to the IAgMD1TriggerTV interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TV As IAgMD1TriggerTV
C#
public IAgMD1TriggerTV  TV { get; }
Visual C++
HRESULT get_TV(
    IAgMD1TriggerTV**  val
);

Requirements

Supported Models

DC436, DC438, DC440, DP306, DP308, DP310

See Also

Reference

IAgMD1TriggerSource Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerTV..::.Configure Method
IAgMD1TriggerTV See Also

This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  SignalFormat As AgMD1TVSignalFormatEnum  _
    ByVal  Event As AgMD1TVTriggerEventEnum  _
    ByVal  Polarity As AgMD1TVTriggerPolarityEnum  _
)
C#
public void  Configure(
    AgMD1TVSignalFormatEnum  SignalFormat,
    AgMD1TVTriggerEventEnum  Event,
    AgMD1TVTriggerPolarityEnum  Polarity
)
Visual C++
HRESULT Configure(
    AgMD1TVSignalFormatEnum  SignalFormat,
    AgMD1TVTriggerEventEnum  Event,
    AgMD1TVTriggerPolarityEnum  Polarity
);

Parameters

SignalFormat

Specifies the TV trigger signal format. This value sets the TV Trigger Signal Format attribute.

Event

Specifies the TV trigger event. This value sets the TV Trigger Event attribute.

Polarity

Specifies the polarity of the TV trigger. This value sets the TV Trigger Polarity attribute.

Requirements

Supported Models

DC436, DC438, DC440, DP306, DP308, DP310

See Also

Reference

IAgMD1TriggerTV Interface
Agilent.AgMD1.Interop Namespace


Event Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerTV..::.Event Property
IAgMD1TriggerTV See Also

Specifies the event on which the digitizer triggers.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Event As AgMD1TVTriggerEventEnum
C#
public AgMD1TVTriggerEventEnum  Event { get; set; }
Visual C++
HRESULT get_Event(
    AgMD1TVTriggerEventEnum*  val
);
HRESULT put_Event(
    AgMD1TVTriggerEventEnum  val
);

Requirements

Supported Models

DC436, DC438, DC440, DP306, DP308, DP310

See Also

Reference

IAgMD1TriggerTV Interface
Agilent.AgMD1.Interop Namespace


LineNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerTV..::.LineNumber Property
IAgMD1TriggerTV See Also

Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property LineNumber As Integer
C#
public int  LineNumber { get; set; }
Visual C++
HRESULT get_LineNumber(
    long*  val
);
HRESULT put_LineNumber(
    long  val
);

Requirements

Supported Models

DC436, DC438, DC440, DP306, DP308, DP310

See Also

Reference

IAgMD1TriggerTV Interface
Agilent.AgMD1.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerTV..::.Polarity Property
IAgMD1TriggerTV See Also

Specifies the polarity of the TV signal.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As AgMD1TVTriggerPolarityEnum
C#
public AgMD1TVTriggerPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    AgMD1TVTriggerPolarityEnum*  val
);
HRESULT put_Polarity(
    AgMD1TVTriggerPolarityEnum  val
);

Requirements

Supported Models

DC436, DC438, DC440, DP306, DP308, DP310

See Also

Reference

IAgMD1TriggerTV Interface
Agilent.AgMD1.Interop Namespace


SignalFormat Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerTV..::.SignalFormat Property
IAgMD1TriggerTV See Also

Specifies the format of TV signal on which the digitizer triggers.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property SignalFormat As AgMD1TVSignalFormatEnum
C#
public AgMD1TVSignalFormatEnum  SignalFormat { get; set; }
Visual C++
HRESULT get_SignalFormat(
    AgMD1TVSignalFormatEnum*  val
);
HRESULT put_SignalFormat(
    AgMD1TVSignalFormatEnum  val
);

Requirements

Supported Models

DC436, DC438, DC440, DP306, DP308, DP310

See Also

Reference

IAgMD1TriggerTV Interface
Agilent.AgMD1.Interop Namespace


Type Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource..::.Type Property
IAgMD1TriggerSource See Also

The kind of event that triggers the digitizer. TV triggering requires External trigger source.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Type As AgMD1TriggerTypeEnum
C#
public AgMD1TriggerTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    AgMD1TriggerTypeEnum*  val
);
HRESULT put_Type(
    AgMD1TriggerTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSource Interface
Agilent.AgMD1.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources..::.Name Property
IAgMD1TriggerSources See Also

Returns the TriggerSource name for a given index.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of TriggerSources.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSources Interface
Agilent.AgMD1.Interop Namespace


Trigger2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex..::.Trigger2 Property
IAgMD1Ex See Also

Pointer to the IAgMD1Trigger interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger2 As IAgMD1Trigger2
C#
public IAgMD1Trigger2  Trigger2 { get; }
Visual C++
HRESULT get_Trigger2(
    IAgMD1Trigger2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex Interface
Agilent.AgMD1.Interop Namespace


Output2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger2..::.Output2 Property
IAgMD1Trigger2 See Also

Pointer to the IAgMD1TriggerOutput interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Output2 As IAgMD1TriggerOutput2
C#
public IAgMD1TriggerOutput2  Output2 { get; }
Visual C++
HRESULT get_Output2(
    IAgMD1TriggerOutput2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger2 Interface
Agilent.AgMD1.Interop Namespace


MultiModuleSyncEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerOutput2..::.MultiModuleSyncEnabled Property
IAgMD1TriggerOutput2 See Also

M9202A Multi Module Synchronization. Enable a M9202A to be the trigger master to synchronize multiple other M9202A modules (the trigger slaves modules). For all modules to synchronize, only one module can be the trigger master module while all others must be trigger slave modules.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property MultiModuleSyncEnabled As Boolean
C#
public bool  MultiModuleSyncEnabled { get; set; }
Visual C++
HRESULT get_MultiModuleSyncEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_MultiModuleSyncEnabled(
    VARIANT_BOOL  val
);

Remarks

The trigger master module will drive the front panel TRG OUT output connector with a trigger signal that must be connected to the external trigger input:

  • TRG1 of the slave modules and TRG1 of the master module, when the trigger Type of the master modules is set to Magnitude trigger. In this case, all modules will show an identical trigger delay and will be tightly synchronized.
  • TRG1 of the slaves modules only, when the master module is configured in External trigger, i.e. ActiveSource = "External1" or "External2" (TRG1 or TRG2). In this case, the master module will show a trigger delay of -25 ns compared to the slave modules. The trigger delay difference can be compensated using the trigger delay controls.

Requirements

Supported Models

M9202A

See Also

Reference

IAgMD1TriggerOutput2 Interface
Agilent.AgMD1.Interop Namespace


Source Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerOutput2..::.Source Property
IAgMD1TriggerOutput2 See Also

Select the trigger source to drive the TRG OUT output connector on the front panel. Possible values are Channel1, ..., Channel<n> or External1, ..., External<n> trigger sources where <n> is the number of available channels or external trigger inputs. For M9703A, possible values are TriggerCompare, TriggerAccepted, AXIe_TRIG0, AXIe_TRIG1, ..., AXIe_TRIG11, AXIe_STRIG, HighLevel, LowLevel.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerOutput2 Interface
Agilent.AgMD1.Interop Namespace


Sources2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger2..::.Sources2 Property
IAgMD1Trigger2 See Also

Pointer to the IAgMD1TriggerSources interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Sources2 As IAgMD1TriggerSources2
C#
public IAgMD1TriggerSources2  Sources2 { get; }
Visual C++
HRESULT get_Sources2(
    IAgMD1TriggerSources2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger2 Interface
Agilent.AgMD1.Interop Namespace


Item2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources2..::.Item2 Property
IAgMD1TriggerSources2 See Also

Pointer to the IAgMD1TriggerSource interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item2( _
    ByVal  Name As String  _
) As IAgMD1TriggerSource2
C#
public IAgMD1TriggerSource2  get_Item2(
    string  Name
)
Visual C++
HRESULT get_Item2(
    BSTR  Name,
    IAgMD1TriggerSource2**  val
);

Parameters

Name

The name of a TriggerSource. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the TriggerSource repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSources2 Interface
Agilent.AgMD1.Interop Namespace


Magnitude Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource2..::.Magnitude Property
IAgMD1TriggerSource2 See Also

Pointer to the IAgMD1TriggerMagnitude interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Magnitude As IAgMD1TriggerMagnitude
C#
public IAgMD1TriggerMagnitude  Magnitude { get; }
Visual C++
HRESULT get_Magnitude(
    IAgMD1TriggerMagnitude**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSource2 Interface
Agilent.AgMD1.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerMagnitude..::.Configure Method
IAgMD1TriggerMagnitude See Also

This function sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  Hysteresis As Double  _
    ByVal  Slope As AgMD1TriggerSlopeEnum  _
)
C#
public void  Configure(
    double  Level,
    double  Hysteresis,
    AgMD1TriggerSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    double  Level,
    double  Hysteresis,
    AgMD1TriggerSlopeEnum  Slope
);

Parameters

Level

Specifies the trigger level in Volts.

Hysteresis

Specifies the trigger hysteresis in Volts.

Slope

Specifies whether a rising (Positive) or a falling (Negative) edge triggers the digitizer.

Remarks

Re-triggering is prevented until the magnitude of the signal has met the following criteria:
If magnitude < Threshold - Hysteresis (when positive trigger slope is selected)
If magnitude > Threshold + Hysteresis (when negative trigger slope is selected)

Requirements

Supported Models

M9202A, M9703A

See Also

Reference

IAgMD1TriggerMagnitude Interface
Agilent.AgMD1.Interop Namespace


Slope Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerMagnitude..::.Slope Property
IAgMD1TriggerMagnitude See Also

Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property Slope As AgMD1TriggerSlopeEnum
C#
public AgMD1TriggerSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    AgMD1TriggerSlopeEnum*  val
);
HRESULT put_Slope(
    AgMD1TriggerSlopeEnum  val
);

Requirements

Supported Models

M9202A, M9703A

See Also

Reference

IAgMD1TriggerMagnitude Interface
Agilent.AgMD1.Interop Namespace


Trigger3 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex2..::.Trigger3 Property
IAgMD1Ex2 See Also

Pointer to the IAgMD1Trigger interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger3 As IAgMD1Trigger3
C#
public IAgMD1Trigger3  Trigger3 { get; }
Visual C++
HRESULT get_Trigger3(
    IAgMD1Trigger3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Ex2 Interface
Agilent.AgMD1.Interop Namespace


Sources3 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger3..::.Sources3 Property
IAgMD1Trigger3 See Also

Pointer to the IAgMD1TriggerSources interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Sources3 As IAgMD1TriggerSources3
C#
public IAgMD1TriggerSources3  Sources3 { get; }
Visual C++
HRESULT get_Sources3(
    IAgMD1TriggerSources3**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1Trigger3 Interface
Agilent.AgMD1.Interop Namespace


Item3 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources3..::.Item3 Property
IAgMD1TriggerSources3 See Also

Pointer to the IAgMD1TriggerSource interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item3( _
    ByVal  Name As String  _
) As IAgMD1TriggerSource3
C#
public IAgMD1TriggerSource3  get_Item3(
    string  Name
)
Visual C++
HRESULT get_Item3(
    BSTR  Name,
    IAgMD1TriggerSource3**  val
);

Parameters

Name

The name of a TriggerSource. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the TriggerSource repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSources3 Interface
Agilent.AgMD1.Interop Namespace


Magnitude2 Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource3..::.Magnitude2 Property
IAgMD1TriggerSource3 See Also

Pointer to the IAgMD1TriggerMagnitude interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Magnitude2 As IAgMD1TriggerMagnitude2
C#
public IAgMD1TriggerMagnitude2  Magnitude2 { get; }
Visual C++
HRESULT get_Magnitude2(
    IAgMD1TriggerMagnitude2**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IAgMD1TriggerSource3 Interface
Agilent.AgMD1.Interop Namespace


DwellTimeSamples Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerMagnitude2..::.DwellTimeSamples Property
IAgMD1TriggerMagnitude2 See Also

Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Property DwellTimeSamples As Integer
C#
public int  DwellTimeSamples { get; set; }
Visual C++
HRESULT get_DwellTimeSamples(
    long*  val
);
HRESULT put_DwellTimeSamples(
    long  val
);

Requirements

Supported Models

M9703A

See Also

Reference

IAgMD1TriggerMagnitude2 Interface
Agilent.AgMD1.Interop Namespace


Utility Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriver..::.Utility Property
IIviDriver See Also

Pointer to the IIviDriverUtility interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property Utility As IIviDriverUtility
C#
public IIviDriverUtility  Utility { get; }
Visual C++
HRESULT get_Utility(
    IIviDriverUtility**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriver Interface
Ivi.Driver.Interop Namespace


Disable Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility..::.Disable Method
IIviDriverUtility See Also

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Disable ( _
)
C#
public void  Disable(
)
Visual C++
HRESULT Disable(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


ErrorQuery Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility..::.ErrorQuery Method
IIviDriverUtility See Also

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ErrorQuery ( _
    ByRef  ErrorCode As Integer  _
    ByRef  ErrorMessage As String  _
)
C#
public void  ErrorQuery(
    ref int  ErrorCode,
    ref string  ErrorMessage
)
Visual C++
HRESULT ErrorQuery(
    long*  ErrorCode,
    BSTR*  ErrorMessage
);

Parameters

ErrorCode

Instrument error code

ErrorMessage

Instrument error message

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


LockObject Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility..::.LockObject Method
IIviDriverUtility See Also

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub LockObject ( _
)
C#
public void  LockObject(
)
Visual C++
HRESULT LockObject(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


Reset Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility..::.Reset Method
IIviDriverUtility See Also

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub Reset ( _
)
C#
public void  Reset(
)
Visual C++
HRESULT Reset(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


ResetWithDefaults Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility..::.ResetWithDefaults Method
IIviDriverUtility See Also

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub ResetWithDefaults ( _
)
C#
public void  ResetWithDefaults(
)
Visual C++
HRESULT ResetWithDefaults(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


SelfTest Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility..::.SelfTest Method
IIviDriverUtility See Also

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub SelfTest ( _
    ByRef  TestResult As Integer  _
    ByRef  TestMessage As String  _
)
C#
public void  SelfTest(
    ref int  TestResult,
    ref string  TestMessage
)
Visual C++
HRESULT SelfTest(
    long*  TestResult,
    BSTR*  TestMessage
);

Parameters

TestResult

The numeric result from the self test operation. 0 = no error (test passed)

TestMessage

The self test status message

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


UnlockObject Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility..::.UnlockObject Method
IIviDriverUtility See Also

Releases a previously obtained mutlithread lock.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub UnlockObject ( _
)
C#
public void  UnlockObject(
)
Visual C++
HRESULT UnlockObject(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDriverUtility Interface
Ivi.Driver.Interop Namespace


IIviDriver Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriver Interface
See Also

IVI Driver root interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriver
C#
public interface IIviDriver
Visual C++
__interface IIviDriver

Properties

 | Name | Description
Public property | DriverOperation | Pointer to the IIviDriverOperation interface
Public property | Identity | Pointer to the IIviDriverIdentity interface
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times.
Public property | Utility | Pointer to the IIviDriverUtility interface
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


IIviDigitizer Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer Interface
See Also

IVI Digitizer class-compliant root interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizer
   Inherits IIviDriver
C#
public interface IIviDigitizer : IIviDriver
Visual C++
__interface IIviDigitizer : IIviDriver

Properties

 | Name | Description
Public property | Acquisition | Pointer to the class-compliant IIviDigitizerAcquistion interface.
Public property | Arm | Pointer to the class-compliant IIviDigitizerArm
Public property | Calibration | Pointer to the class-compliant IIviDigitizerCalibration interface.
Public property | Channels | Pointer to the IIviDigitizerChannels interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | ReferenceOscillator | Pointer to the class-compliant IIviDigitizerReference Oscillator interface.
Public property | SampleClock | Pointer to the class-compliant IIviDigitizerSampleClock interface.
Public property | Temperature | Pointer to the class-compliant IIviDigitizerTemperature interface.
Public property | Trigger | Pointer to the class-compliant IIviDigitizerTrigger interface.
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


Acquisition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.Acquisition Property
IIviDigitizer See Also

Pointer to the class-compliant IIviDigitizerAcquistion interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition As IIviDigitizerAcquisition
C#
public IIviDigitizerAcquisition  Acquisition { get; }
Visual C++
HRESULT get_Acquisition(
    IIviDigitizerAcquisition**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


Abort Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.Abort Method
IIviDigitizerAcquisition See Also

Aborts an acquisition and returns the digitizer to the Idle state.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Abort ( _
)
C#
public void  Abort(
)
Visual C++
HRESULT Abort(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


ConfigureAcquisition Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.ConfigureAcquisition Method
IIviDigitizerAcquisition See Also

This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureAcquisition ( _
    ByVal  NumRecordsToAcquire As Long  _
    ByVal  RecordSize As Long  _
    ByVal  SampleRate As Double  _
)
C#
public void  ConfigureAcquisition(
    long  NumRecordsToAcquire,
    long  RecordSize,
    double  SampleRate
)
Visual C++
HRESULT ConfigureAcquisition(
    __int64  NumRecordsToAcquire,
    __int64  RecordSize,
    double  SampleRate
);

Parameters

NumRecordsToAcquire

Specifies the number of records in the acquisition. This value sets the Num Records to Acquire attribute.

RecordSize

Specifies the number of samples in each record. This value sets the Record Size attribute.

SampleRate

Specifies the sample rate in samples per second. This value sets the Sample Rate attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


Initiate Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.Initiate Method
IIviDigitizerAcquisition See Also

Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Initiate ( _
)
C#
public void  Initiate(
)
Visual C++
HRESULT Initiate(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


MaxFirstValidPointValue Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.MaxFirstValidPointValue Property
IIviDigitizerAcquisition See Also

Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property MaxFirstValidPointValue As Long
C#
public long  MaxFirstValidPointValue { get; set; }
Visual C++
HRESULT get_MaxFirstValidPointValue(
    __int64*  val
);
HRESULT put_MaxFirstValidPointValue(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


MaxSamplesPerChannel Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.MaxSamplesPerChannel Property
IIviDigitizerAcquisition See Also

Returns the maximum number of samples per channel that can be captured.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MaxSamplesPerChannel As Long
C#
public long  MaxSamplesPerChannel { get; }
Visual C++
HRESULT get_MaxSamplesPerChannel(
    __int64*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


MinRecordSize Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.MinRecordSize Property
IIviDigitizerAcquisition See Also

Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MinRecordSize As Long
C#
public long  MinRecordSize { get; }
Visual C++
HRESULT get_MinRecordSize(
    __int64*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


NumAcquiredRecords Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.NumAcquiredRecords Property
IIviDigitizerAcquisition See Also

Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property NumAcquiredRecords As Long
C#
public long  NumAcquiredRecords { get; }
Visual C++
HRESULT get_NumAcquiredRecords(
    __int64*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


NumRecordsToAcquire Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.NumRecordsToAcquire Property
IIviDigitizerAcquisition See Also

Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property NumRecordsToAcquire As Long
C#
public long  NumRecordsToAcquire { get; set; }
Visual C++
HRESULT get_NumRecordsToAcquire(
    __int64*  val
);
HRESULT put_NumRecordsToAcquire(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


QueryMinWaveformMemory Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.QueryMinWaveformMemory Method
IIviDigitizerAcquisition See Also

This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Function QueryMinWaveformMemory ( _
    ByVal  DataWidth As Integer  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
) As Long
C#
public long  QueryMinWaveformMemory(
    int  DataWidth,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord
)
Visual C++
HRESULT QueryMinWaveformMemory(
    long  DataWidth,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord
    __int64*  retval
);

Parameters

DataWidth

Specifies the size of the sampled data that will be retrieved. The value of this parameter must be 8, 16, 32 or 64, corresponding to the intended Read/Fetch function.

NumRecords

Specifies the number of records that will be read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved.

NumPointsPerRecord

Specifies the number of data points to return.

Return Value

The minimum buffer size in samples needed for a subsequent Read or Fetch call with the same readout parameters.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


RecordSize Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.RecordSize Property
IIviDigitizerAcquisition See Also

Specifies the number of samples to acquire in each waveform record.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property RecordSize As Long
C#
public long  RecordSize { get; set; }
Visual C++
HRESULT get_RecordSize(
    __int64*  val
);
HRESULT put_RecordSize(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


SampleMode Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.SampleMode Property
IIviDigitizerAcquisition See Also

-- NOT SUPPORTED, Always RealTime mode -- Specifies the sample mode used by the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SampleMode As IviDigitizerSampleModeEnum
C#
public IviDigitizerSampleModeEnum  SampleMode { get; set; }
Visual C++
HRESULT get_SampleMode(
    IviDigitizerSampleModeEnum*  val
);
HRESULT put_SampleMode(
    IviDigitizerSampleModeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


SampleRate Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.SampleRate Property
IIviDigitizerAcquisition See Also

Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SampleRate As Double
C#
public double  SampleRate { get; set; }
Visual C++
HRESULT get_SampleRate(
    double*  val
);
HRESULT put_SampleRate(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


Status Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.Status Property
IIviDigitizerAcquisition See Also

Pointer to the IIviDigitizerAcquisitionStatus interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Status As IIviDigitizerAcquisitionStatus
C#
public IIviDigitizerAcquisitionStatus  Status { get; }
Visual C++
HRESULT get_Status(
    IIviDigitizerAcquisitionStatus**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


IsIdle Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisitionStatus..::.IsIdle Property
IIviDigitizerAcquisitionStatus See Also

Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsIdle As IviDigitizerAcquisitionStatusResultEnum
C#
public IviDigitizerAcquisitionStatusResultEnum  IsIdle { get; }
Visual C++
HRESULT get_IsIdle(
    IviDigitizerAcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisitionStatus Interface
Ivi.Digitizer.Interop Namespace


IsMeasuring Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisitionStatus..::.IsMeasuring Property
IIviDigitizerAcquisitionStatus See Also

Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsMeasuring As IviDigitizerAcquisitionStatusResultEnum
C#
public IviDigitizerAcquisitionStatusResultEnum  IsMeasuring { get; }
Visual C++
HRESULT get_IsMeasuring(
    IviDigitizerAcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisitionStatus Interface
Ivi.Digitizer.Interop Namespace


IsWaitingForArm Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisitionStatus..::.IsWaitingForArm Property
IIviDigitizerAcquisitionStatus See Also

Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsWaitingForArm As IviDigitizerAcquisitionStatusResultEnum
C#
public IviDigitizerAcquisitionStatusResultEnum  IsWaitingForArm { get; }
Visual C++
HRESULT get_IsWaitingForArm(
    IviDigitizerAcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisitionStatus Interface
Ivi.Digitizer.Interop Namespace


IsWaitingForTrigger Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisitionStatus..::.IsWaitingForTrigger Property
IIviDigitizerAcquisitionStatus See Also

Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property IsWaitingForTrigger As IviDigitizerAcquisitionStatusResultEnum
C#
public IviDigitizerAcquisitionStatusResultEnum  IsWaitingForTrigger { get; }
Visual C++
HRESULT get_IsWaitingForTrigger(
    IviDigitizerAcquisitionStatusResultEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisitionStatus Interface
Ivi.Digitizer.Interop Namespace


TimeInterleavedChannelListAuto Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.TimeInterleavedChannelListAuto Property
IIviDigitizerAcquisition See Also

-- NOT SUPPORTED, Always false -- Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property TimeInterleavedChannelListAuto As Boolean
C#
public bool  TimeInterleavedChannelListAuto { get; set; }
Visual C++
HRESULT get_TimeInterleavedChannelListAuto(
    VARIANT_BOOL*  val
);
HRESULT put_TimeInterleavedChannelListAuto(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


WaitForAcquisitionComplete Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition..::.WaitForAcquisitionComplete Method
IIviDigitizerAcquisition See Also

Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub WaitForAcquisitionComplete ( _
    ByVal  MaxTimeMilliseconds As Integer  _
)
C#
public void  WaitForAcquisitionComplete(
    int  MaxTimeMilliseconds
)
Visual C++
HRESULT WaitForAcquisitionComplete(
    long  MaxTimeMilliseconds
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this function to complete. The units are milliseconds. Defined values:IviDigitizerTimeOutInfinite (-1) - The function waits indefinitely for the acquisition to complete.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerAcquisition Interface
Ivi.Digitizer.Interop Namespace


Arm Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.Arm Property
IIviDigitizer See Also

Pointer to the class-compliant IIviDigitizerArm

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Arm As IIviDigitizerArm
C#
public IIviDigitizerArm  Arm { get; }
Visual C++
HRESULT get_Arm(
    IIviDigitizerArm**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


ActiveSource Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm..::.ActiveSource Property
IIviDigitizerArm See Also

-- NOT SUPPORTED -- Specifies the source the digitizer monitors for the arm event. The value specified here must be one of the valid repeated capability names for the ArmSource repeated capability.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ActiveSource As String
C#
public string  ActiveSource { get; set; }
Visual C++
HRESULT get_ActiveSource(
    BSTR*  val
);
HRESULT put_ActiveSource(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArm Interface
Ivi.Digitizer.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm..::.Count Property
IIviDigitizerArm See Also

-- NOT SUPPORTED -- Specifies the number of times the arm has to occur to complete the arm loop; that is, the number of arms that are accepted before the acquisition must be initiated again.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Count As Integer
C#
public int  Count { get; set; }
Visual C++
HRESULT get_Count(
    long*  val
);
HRESULT put_Count(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArm Interface
Ivi.Digitizer.Interop Namespace


Delay Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm..::.Delay Property
IIviDigitizerArm See Also

-- NOT SUPPORTED -- Specifies the delay from when the arm logic is satisfied until the waiting for trigger state is entered. The units are seconds.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Delay As Double
C#
public double  Delay { get; set; }
Visual C++
HRESULT get_Delay(
    double*  val
);
HRESULT put_Delay(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArm Interface
Ivi.Digitizer.Interop Namespace


MultiArm Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm..::.MultiArm Property
IIviDigitizerArm See Also

Pointer to the class-compliant IIviDigitizerArmMultiArm interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MultiArm As IIviDigitizerMultiArm
C#
public IIviDigitizerMultiArm  MultiArm { get; }
Visual C++
HRESULT get_MultiArm(
    IIviDigitizerMultiArm**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArm Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiArm..::.Configure Method
IIviDigitizerMultiArm See Also

-- NOT SUPPORTED -- Configures the digitizer to arm based on multiple arm sources. The digitizer can be instructed to arm when any one of multiple arm source conditions are met or when all specified arm source conditions are met.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  SourceList As String  _
    ByVal  Operator As IviDigitizerArmSourceOperatorEnum  _
)
C#
public void  Configure(
    string  SourceList,
    IviDigitizerArmSourceOperatorEnum  Operator
)
Visual C++
HRESULT Configure(
    BSTR  SourceList,
    IviDigitizerArmSourceOperatorEnum  Operator
);

Parameters

SourceList

A comma separated list of source names to be used in a multi arm scenario. The driver uses this value to set the Arm Source List attribute.

Operator

Specifies the boolean operation to apply to the arm sources specified by the SourceList parameter. The driver uses this value to set the Arm Source Operator attribute

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerMultiArm Interface
Ivi.Digitizer.Interop Namespace


SourceList Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiArm..::.SourceList Property
IIviDigitizerMultiArm See Also

-- NOT SUPPORTED -- A comma separated list of source names to be used in a multi arm scenario. This attribute only affects instrument behavior when the Arm Source Operator attribute is set to AND or OR. When Arm Source Operator is set to AND, the arm conditions associated with each source in this list must be simultaneously satsified in order to arm the digitizer. When Arm Source Operator is set to OR, the first arm source in the list that satisfies its arm conditions will arm the digitizer. Any valid name used for the Arm Source attribute may be used in this list. An arm source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SourceList As String
C#
public string  SourceList { get; set; }
Visual C++
HRESULT get_SourceList(
    BSTR*  val
);
HRESULT put_SourceList(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerMultiArm Interface
Ivi.Digitizer.Interop Namespace


SourceOperator Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiArm..::.SourceOperator Property
IIviDigitizerMultiArm See Also

-- NOT SUPPORTED -- Specifies the boolean operation to apply to the arm sources specified by the Arm Source List attribute. See the definition of that attribute for details.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SourceOperator As IviDigitizerArmSourceOperatorEnum
C#
public IviDigitizerArmSourceOperatorEnum  SourceOperator { get; set; }
Visual C++
HRESULT get_SourceOperator(
    IviDigitizerArmSourceOperatorEnum*  val
);
HRESULT put_SourceOperator(
    IviDigitizerArmSourceOperatorEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerMultiArm Interface
Ivi.Digitizer.Interop Namespace


OutputEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm..::.OutputEnabled Property
IIviDigitizerArm See Also

-- NOT SUPPORTED -- Specifies whether or not an accepted arm appears at an output of the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property OutputEnabled As Boolean
C#
public bool  OutputEnabled { get; set; }
Visual C++
HRESULT get_OutputEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_OutputEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArm Interface
Ivi.Digitizer.Interop Namespace


SendSoftwareArm Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm..::.SendSoftwareArm Method
IIviDigitizerArm See Also

This function follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub SendSoftwareArm ( _
)
C#
public void  SendSoftwareArm(
)
Visual C++
HRESULT SendSoftwareArm(
);

Requirements

Supported Models

M9202A

See Also

Reference

IIviDigitizerArm Interface
Ivi.Digitizer.Interop Namespace


Sources Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm..::.Sources Property
IIviDigitizerArm See Also

Pointer to the IIviDigitizerArmSources interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Sources As IIviDigitizerArmSources
C#
public IIviDigitizerArmSources  Sources { get; }
Visual C++
HRESULT get_Sources(
    IIviDigitizerArmSources**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArm Interface
Ivi.Digitizer.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSources..::.Count Property
IIviDigitizerArmSources See Also

The number of sources.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSources Interface
Ivi.Digitizer.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSources..::.Item Property
IIviDigitizerArmSources See Also

An interface reference pointer to the IIviDigitizerArmSource interface which is selected by the source name.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IIviDigitizerArmSource
C#
public IIviDigitizerArmSource  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IIviDigitizerArmSource**  val
);

Parameters

Name

The name of a source. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the ArmSource repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSources Interface
Ivi.Digitizer.Interop Namespace


Coupling Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Coupling Property
IIviDigitizerArmSource See Also

-- NOT SUPPORTED -- Specifies how the digitizer couples the arm source.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As IviDigitizerTriggerCouplingEnum
C#
public IviDigitizerTriggerCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    IviDigitizerTriggerCouplingEnum*  val
);
HRESULT put_Coupling(
    IviDigitizerTriggerCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Edge Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Edge Property
IIviDigitizerArmSource See Also

Pointer to the class-compliant IIviDigitizerArmEdge interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Edge As IIviDigitizerArmEdge
C#
public IIviDigitizerArmEdge  Edge { get; }
Visual C++
HRESULT get_Edge(
    IIviDigitizerArmEdge**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmEdge..::.Configure Method
IIviDigitizerArmEdge See Also

-- NOT SUPPORTED -- This function sets the edge arming attributes. An edge occurs when the arm signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the Level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Arm Type is Edge Arm. Set the Arm Type and Arm Coupling before calling this function. If the arm source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  Slope As IviDigitizerTriggerSlopeEnum  _
)
C#
public void  Configure(
    double  Level,
    IviDigitizerTriggerSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    double  Level,
    IviDigitizerTriggerSlopeEnum  Slope
);

Parameters

Level

Specifies the arm level. This value sets the Trigger Level attribute.

Slope

Specifies the trigger slope. This value sets the Trigger Slope attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmEdge Interface
Ivi.Digitizer.Interop Namespace


Slope Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmEdge..::.Slope Property
IIviDigitizerArmEdge See Also

-- NOT SUPPORTED -- Specifies whether a rising or a falling edge arms the digitizer. This attribute affects instrument operation only when the Arm Type attribute is set to Edge Arm.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Slope As IviDigitizerTriggerSlopeEnum
C#
public IviDigitizerTriggerSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    IviDigitizerTriggerSlopeEnum*  val
);
HRESULT put_Slope(
    IviDigitizerTriggerSlopeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmEdge Interface
Ivi.Digitizer.Interop Namespace


Glitch Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Glitch Property
IIviDigitizerArmSource See Also

Pointer to the class-compliant IIviDigitizerArmGlitch interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Glitch As IIviDigitizerArmGlitch
C#
public IIviDigitizerArmGlitch  Glitch { get; }
Visual C++
HRESULT get_Glitch(
    IIviDigitizerArmGlitch**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmGlitch..::.Condition Property
IIviDigitizerArmGlitch See Also

-- NOT SUPPORTED -- Specifies the glitch condition. This attribute determines whether the glitch arm happens when the digitizer detects a pulse with a width less than or greater than the width value.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Condition As IviDigitizerGlitchConditionEnum
C#
public IviDigitizerGlitchConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    IviDigitizerGlitchConditionEnum*  val
);
HRESULT put_Condition(
    IviDigitizerGlitchConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmGlitch Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmGlitch..::.Configure Method
IIviDigitizerArmGlitch See Also

-- NOT SUPPORTED -- This function configures the glitch arm. A glitch arm occurs when the arm signal has a pulse with a width that is less than or greater than the glitch width. The end user specifies which comparison criterion to use with the GlitchCondition parameter. The end-user specifies the glitch width with the GlitchWidth parameter. The end-user specifies the polarity of the pulse with the GlitchPolarity parameter. The arm does not actually occur until the edge of a pulse that corresponds to the GlitchWidth and GlitchPolarity crosses the threshold the end-user specifies in the TriggerLevel parameter. This function affects instrument behavior only if the arm type is Glitch Arm. Set the arm type and arm coupling before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  Width As Double  _
    ByVal  Polarity As IviDigitizerGlitchPolarityEnum  _
    ByVal  Condition As IviDigitizerGlitchConditionEnum  _
)
C#
public void  Configure(
    double  Level,
    double  Width,
    IviDigitizerGlitchPolarityEnum  Polarity,
    IviDigitizerGlitchConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    double  Level,
    double  Width,
    IviDigitizerGlitchPolarityEnum  Polarity,
    IviDigitizerGlitchConditionEnum  Condition
);

Parameters

Level

Specifies the arm level. This value sets the Arm Level attribute.

Width

Specifies the glitch arming glitch width in seconds. This value sets the Glitch Width attribute.

Polarity

Specifies the glitch polarity. This value sets the Glitch Polarity attribute.

Condition

Specifies the glitch condition. This value sets the Glitch Condition attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmGlitch Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmGlitch..::.Polarity Property
IIviDigitizerArmGlitch See Also

-- NOT SUPPORTED -- Specifies the polarity of the glitch that arms the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerGlitchPolarityEnum
C#
public IviDigitizerGlitchPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerGlitchPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerGlitchPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmGlitch Interface
Ivi.Digitizer.Interop Namespace


Width Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmGlitch..::.Width Property
IIviDigitizerArmGlitch See Also

-- NOT SUPPORTED -- Specifies the glitch width. The units are seconds. The digitizer triggers when it detects a pulse with a width less than or greater than this value, depending on the Glitch Condition attribute.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Width As Double
C#
public double  Width { get; set; }
Visual C++
HRESULT get_Width(
    double*  val
);
HRESULT put_Width(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmGlitch Interface
Ivi.Digitizer.Interop Namespace


Hysteresis Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Hysteresis Property
IIviDigitizerArmSource See Also

-- NOT SUPPORTED -- Specifies the arm hysteresis in Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Hysteresis As Double
C#
public double  Hysteresis { get; set; }
Visual C++
HRESULT get_Hysteresis(
    double*  val
);
HRESULT put_Hysteresis(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Level Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Level Property
IIviDigitizerArmSource See Also

-- NOT SUPPORTED -- Specifies the voltage threshold for the arm sub-system. The units are Volts. This attribute affects instrument behavior only when the Arm Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger.This attribute, along with the Arm Slope, Arm Source, and Arm Coupling attributes, defines the trigger event when the Arm Type is set to Edge Trigger.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Level As Double
C#
public double  Level { get; set; }
Visual C++
HRESULT get_Level(
    double*  val
);
HRESULT put_Level(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Runt Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Runt Property
IIviDigitizerArmSource See Also

Pointer to the class-compliant IIviDigitizerArmRunt interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Runt As IIviDigitizerArmRunt
C#
public IIviDigitizerArmRunt  Runt { get; }
Visual C++
HRESULT get_Runt(
    IIviDigitizerArmRunt**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmRunt..::.Configure Method
IIviDigitizerArmRunt See Also

-- NOT SUPPORTED -- This function configures the runt arm. A runt occurs when the arm signal crosses one of the runt thresholds twice without crossing the other runt threshold. The end-user specifies the runt thresholds with the RuntLowThreshold and RuntHighThreshold parameters. The end-user specifies the polarity of the runt with the RuntPolarity parameter. This function affects instrument behavior only if the arm type is Runt Trigger. Set the arm type and trigger coupling before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Polarity As IviDigitizerRuntPolarityEnum  _
)
C#
public void  Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerRuntPolarityEnum  Polarity
)
Visual C++
HRESULT Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerRuntPolarityEnum  Polarity
);

Parameters

ThresholdLow

Sets the runt triggering low threshold in volts.

ThresholdHigh

Sets the runt triggering high threshold in volts.

Polarity

Sets the runt polarity.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmRunt Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmRunt..::.Polarity Property
IIviDigitizerArmRunt See Also

-- NOT SUPPORTED -- Specifies the polarity of the runt that arms the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerRuntPolarityEnum
C#
public IviDigitizerRuntPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerRuntPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerRuntPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmRunt Interface
Ivi.Digitizer.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmRunt..::.ThresholdHigh Property
IIviDigitizerArmRunt See Also

-- NOT SUPPORTED -- The high threshold the digitizer uses for runt arming. The units are Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmRunt Interface
Ivi.Digitizer.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmRunt..::.ThresholdLow Property
IIviDigitizerArmRunt See Also

-- NOT SUPPORTED -- The low threshold the digitizer uses for runt arming. The units are Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmRunt Interface
Ivi.Digitizer.Interop Namespace


TV Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.TV Property
IIviDigitizerArmSource See Also

Pointer to the class-compliant IIviDigitizerArmTV interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TV As IIviDigitizerArmTV
C#
public IIviDigitizerArmTV  TV { get; }
Visual C++
HRESULT get_TV(
    IIviDigitizerArmTV**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmTV..::.Configure Method
IIviDigitizerArmTV See Also

-- NOT SUPPORTED -- This function configures the digitizer for TV arming. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the arm type is TV Arm. Set the Arm Type and Arm Coupling before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  SignalFormat As IviDigitizerTVSignalFormatEnum  _
    ByVal  Event As IviDigitizerTVTriggerEventEnum  _
    ByVal  Polarity As IviDigitizerTVTriggerPolarityEnum  _
)
C#
public void  Configure(
    IviDigitizerTVSignalFormatEnum  SignalFormat,
    IviDigitizerTVTriggerEventEnum  Event,
    IviDigitizerTVTriggerPolarityEnum  Polarity
)
Visual C++
HRESULT Configure(
    IviDigitizerTVSignalFormatEnum  SignalFormat,
    IviDigitizerTVTriggerEventEnum  Event,
    IviDigitizerTVTriggerPolarityEnum  Polarity
);

Parameters

SignalFormat

Specifies the TV arm signal format. This value sets the TV Arm Signal Format attribute.

Event

Specifies the TV arm event. This value sets the TV Arm Event attribute.

Polarity

Specifies the polarity of the TV arm signal. This value sets the TV Arm Polarity attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmTV Interface
Ivi.Digitizer.Interop Namespace


Event Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmTV..::.Event Property
IIviDigitizerArmTV See Also

-- NOT SUPPORTED -- Specifies the event on which the digitizer arms.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Event As IviDigitizerTVTriggerEventEnum
C#
public IviDigitizerTVTriggerEventEnum  Event { get; set; }
Visual C++
HRESULT get_Event(
    IviDigitizerTVTriggerEventEnum*  val
);
HRESULT put_Event(
    IviDigitizerTVTriggerEventEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmTV Interface
Ivi.Digitizer.Interop Namespace


LineNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmTV..::.LineNumber Property
IIviDigitizerArmTV See Also

-- NOT SUPPORTED -- Specifies the line on which the digitizer arms. The driver uses this attribute when the TV Arm Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to arm on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property LineNumber As Integer
C#
public int  LineNumber { get; set; }
Visual C++
HRESULT get_LineNumber(
    long*  val
);
HRESULT put_LineNumber(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmTV Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmTV..::.Polarity Property
IIviDigitizerArmTV See Also

-- NOT SUPPORTED -- Specifies the polarity of the TV signal.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerTVTriggerPolarityEnum
C#
public IviDigitizerTVTriggerPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerTVTriggerPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerTVTriggerPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmTV Interface
Ivi.Digitizer.Interop Namespace


SignalFormat Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmTV..::.SignalFormat Property
IIviDigitizerArmTV See Also

-- NOT SUPPORTED -- Specifies the format of TV signal on which the digitizer arms.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SignalFormat As IviDigitizerTVSignalFormatEnum
C#
public IviDigitizerTVSignalFormatEnum  SignalFormat { get; set; }
Visual C++
HRESULT get_SignalFormat(
    IviDigitizerTVSignalFormatEnum*  val
);
HRESULT put_SignalFormat(
    IviDigitizerTVSignalFormatEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmTV Interface
Ivi.Digitizer.Interop Namespace


Type Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Type Property
IIviDigitizerArmSource See Also

-- NOT SUPPORTED -- The kind of event that arms the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Type As IviDigitizerArmTypeEnum
C#
public IviDigitizerArmTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    IviDigitizerArmTypeEnum*  val
);
HRESULT put_Type(
    IviDigitizerArmTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Width Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Width Property
IIviDigitizerArmSource See Also

Pointer to the class-compliant IIviDigitizerArmWidth interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Width As IIviDigitizerArmWidth
C#
public IIviDigitizerArmWidth  Width { get; }
Visual C++
HRESULT get_Width(
    IIviDigitizerArmWidth**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWidth..::.Condition Property
IIviDigitizerArmWidth See Also

-- NOT SUPPORTED -- Specifies whether a pulse that is within or outside the high and low thresholds arms the digitizer. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold attributes.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Condition As IviDigitizerWidthConditionEnum
C#
public IviDigitizerWidthConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    IviDigitizerWidthConditionEnum*  val
);
HRESULT put_Condition(
    IviDigitizerWidthConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWidth Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWidth..::.Configure Method
IIviDigitizerArmWidth See Also

-- NOT SUPPORTED -- Configures the width arm Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width arm occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Polarity As IviDigitizerWidthPolarityEnum  _
    ByVal  Condition As IviDigitizerWidthConditionEnum  _
)
C#
public void  Configure(
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWidthPolarityEnum  Polarity,
    IviDigitizerWidthConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWidthPolarityEnum  Polarity,
    IviDigitizerWidthConditionEnum  Condition
);

Parameters

Level

Arm Level. This value sets the Arm Level attribute.

ThresholdLow

Sets the width arming low threshold in seconds. This value sets the Width Low Threshold attribute.

ThresholdHigh

Sets the width arming high threshold in seconds. This value sets the Width High Threshold attribute.

Polarity

Sets the width polarity. This value sets the Width Polarity attribute.

Condition

Specifies whether a pulse that is within or outside the user-specified thresholds arm waveform acquisition. This value sets the Width Condition attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWidth Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWidth..::.Polarity Property
IIviDigitizerArmWidth See Also

-- NOT SUPPORTED -- Specifies the polarity of the pulse that arms the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerWidthPolarityEnum
C#
public IviDigitizerWidthPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerWidthPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerWidthPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWidth Interface
Ivi.Digitizer.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWidth..::.ThresholdHigh Property
IIviDigitizerArmWidth See Also

-- NOT SUPPORTED -- Specifies the high width threshold time in seconds.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWidth Interface
Ivi.Digitizer.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWidth..::.ThresholdLow Property
IIviDigitizerArmWidth See Also

-- NOT SUPPORTED -- Specifies the low width threshold time in seconds.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWidth Interface
Ivi.Digitizer.Interop Namespace


Window Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource..::.Window Property
IIviDigitizerArmSource See Also

Pointer to the class-compliant IIviDigitizerArmWindow interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Window As IIviDigitizerArmWindow
C#
public IIviDigitizerArmWindow  Window { get; }
Visual C++
HRESULT get_Window(
    IIviDigitizerArmWindow**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSource Interface
Ivi.Digitizer.Interop Namespace


Condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWindow..::.Condition Property
IIviDigitizerArmWindow See Also

-- NOT SUPPORTED -- Specifies whether a signal that is entering or leaving the voltage window defined by the high and low thresholds arms the digitizer. The end-user specifies the high and low thresholds with the Window High Threshold and Window Low Threshold attributes.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Condition As IviDigitizerWindowConditionEnum
C#
public IviDigitizerWindowConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    IviDigitizerWindowConditionEnum*  val
);
HRESULT put_Condition(
    IviDigitizerWindowConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWindow Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWindow..::.Configure Method
IIviDigitizerArmWindow See Also

-- NOT SUPPORTED -- Configures the window Arm Source, ThresholdLow, ThresholdHigh, and Condition. A window arm occurs when a signal that enters or leaves a given voltage range is detected.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Condition As IviDigitizerWindowConditionEnum  _
)
C#
public void  Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWindowConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWindowConditionEnum  Condition
);

Parameters

ThresholdLow

Sets the window arming low threshold in Volts. This value sets the Window Low Threshold attribute.

ThresholdHigh

Sets the window arming high threshold in Volts. This value sets the Window High Threshold attribute.

Condition

Specifies whether a pulse that is within or outside the user-specified thresholds arm waveform acquisition. This value sets the Width Condition attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWindow Interface
Ivi.Digitizer.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWindow..::.ThresholdHigh Property
IIviDigitizerArmWindow See Also

-- NOT SUPPORTED -- Specifies the high window threshold voltage in Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWindow Interface
Ivi.Digitizer.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWindow..::.ThresholdLow Property
IIviDigitizerArmWindow See Also

-- NOT SUPPORTED -- Specifies the low window threshold voltage in Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmWindow Interface
Ivi.Digitizer.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSources..::.Name Property
IIviDigitizerArmSources See Also

The source name for a given index.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of sources.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerArmSources Interface
Ivi.Digitizer.Interop Namespace


Calibration Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.Calibration Property
IIviDigitizer See Also

Pointer to the class-compliant IIviDigitizerCalibration interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Calibration As IIviDigitizerCalibration
C#
public IIviDigitizerCalibration  Calibration { get; }
Visual C++
HRESULT get_Calibration(
    IIviDigitizerCalibration**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


SelfCalibrate Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerCalibration..::.SelfCalibrate Method
IIviDigitizerCalibration See Also

Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub SelfCalibrate ( _
)
C#
public void  SelfCalibrate(
)
Visual C++
HRESULT SelfCalibrate(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerCalibration Interface
Ivi.Digitizer.Interop Namespace


Channels Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.Channels Property
IIviDigitizer See Also

Pointer to the IIviDigitizerChannels interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Channels As IIviDigitizerChannels
C#
public IIviDigitizerChannels  Channels { get; }
Visual C++
HRESULT get_Channels(
    IIviDigitizerChannels**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannels..::.Count Property
IIviDigitizerChannels See Also

Returns the number of channels available on the device.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannels Interface
Ivi.Digitizer.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannels..::.Item Property
IIviDigitizerChannels See Also

An interface reference pointer to the IIviDigitizerChannel interface which is selected by the channel name.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IIviDigitizerChannel
C#
public IIviDigitizerChannel  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IIviDigitizerChannel**  val
);

Parameters

Name

The name of a channel. It may be either a name returned by the Name attribute or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannels Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Configure Method
IIviDigitizerChannel See Also

This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Range As Double  _
    ByVal  Offset As Double  _
    ByVal  Coupling As IviDigitizerVerticalCouplingEnum  _
    ByVal  Enabled As Boolean  _
)
C#
public void  Configure(
    double  Range,
    double  Offset,
    IviDigitizerVerticalCouplingEnum  Coupling,
    bool  Enabled
)
Visual C++
HRESULT Configure(
    double  Range,
    double  Offset,
    IviDigitizerVerticalCouplingEnum  Coupling,
    VARIANT_BOOL  Enabled
);

Parameters

Range

Specifies the vertical range. This value sets the Vertical Range attribute.

Offset

Specifies the vertical offset. This value sets the Vertical Offset attribute.

Coupling

Specifies how to couple the input signal. This value sets the Vertical

Enabled

Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Coupling Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Coupling Property
IIviDigitizerChannel See Also

Specifies how the digitizer couples the input signal for the channel.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As IviDigitizerVerticalCouplingEnum
C#
public IviDigitizerVerticalCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    IviDigitizerVerticalCouplingEnum*  val
);
HRESULT put_Coupling(
    IviDigitizerVerticalCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


DataInterleavedChannelList Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.DataInterleavedChannelList Property
IIviDigitizerChannel See Also

-- NOT SUPPORTED -- This attribute is used to combine this channel with one or more other channels to interleave the returned data. The string provided here specifies which channels should operate in combined mode with the current channel.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property DataInterleavedChannelList As String
C#
public string  DataInterleavedChannelList { get; set; }
Visual C++
HRESULT get_DataInterleavedChannelList(
    BSTR*  val
);
HRESULT put_DataInterleavedChannelList(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Downconversion Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Downconversion Property
IIviDigitizerChannel See Also

Pointer to the IIviDigitizerDownconversion interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Downconversion As IIviDigitizerChannelDownconversion
C#
public IIviDigitizerChannelDownconversion  Downconversion { get; }
Visual C++
HRESULT get_Downconversion(
    IIviDigitizerChannelDownconversion**  val
);

Remarks

Please refer to the Remarks in the instrument specific AgMD1 Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


CenterFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelDownconversion..::.CenterFrequency Property
IIviDigitizerChannelDownconversion See Also

Specifies the center frequency, in Hz, from which the digitizer should downconvert.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property CenterFrequency As Double
C#
public double  CenterFrequency { get; set; }
Visual C++
HRESULT get_CenterFrequency(
    double*  val
);
HRESULT put_CenterFrequency(
    double  val
);

Remarks

Please refer to the Remarks in the instrument specific AgMD1 Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IIviDigitizerChannelDownconversion Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelDownconversion..::.Configure Method
IIviDigitizerChannelDownconversion See Also

Configures how the digitizer performs downconversion.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Enabled As Boolean  _
    ByVal  CenterFrequency As Double  _
)
C#
public void  Configure(
    bool  Enabled,
    double  CenterFrequency
)
Visual C++
HRESULT Configure(
    VARIANT_BOOL  Enabled,
    double  CenterFrequency
);

Parameters

Enabled

Enables or disables downversion. The driver uses this value to set the Downconversion Enabled attribute. See the attribute description for more details.

CenterFrequency

Specifies the center frequency, in Hz, from which the digitizer should downconvert. The driver uses this value to set the Downconversion Center Frequency attribute. See the attribute description for more details.

Remarks

Please refer to the Remarks in the instrument specific AgMD1 Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IIviDigitizerChannelDownconversion Interface
Ivi.Digitizer.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelDownconversion..::.Enabled Property
IIviDigitizerChannelDownconversion See Also

Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Remarks

Please refer to the Remarks in the instrument specific AgMD1 Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IIviDigitizerChannelDownconversion Interface
Ivi.Digitizer.Interop Namespace


IQInterleaved Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelDownconversion..::.IQInterleaved Property
IIviDigitizerChannelDownconversion See Also

Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property IQInterleaved As Boolean
C#
public bool  IQInterleaved { get; set; }
Visual C++
HRESULT get_IQInterleaved(
    VARIANT_BOOL*  val
);
HRESULT put_IQInterleaved(
    VARIANT_BOOL  val
);

Remarks

Note that the M9703A only supports interleaved I-Q data points, and each I-Q pair is treated as one complex sample.

Please refer to the Remarks in the instrument specific AgMD1 Downconversion.Configure method for detailed information on the usage of Read/Fetch methods and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

IIviDigitizerChannelDownconversion Interface
Ivi.Digitizer.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Enabled Property
IIviDigitizerChannel See Also

Specifies whether the digitizer acquires a waveform for the channel.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Filter Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Filter Property
IIviDigitizerChannel See Also

Pointer to the IIviDigitizerFilterinterface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Filter As IIviDigitizerChannelFilter
C#
public IIviDigitizerChannelFilter  Filter { get; }
Visual C++
HRESULT get_Filter(
    IIviDigitizerChannelFilter**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Bypass Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelFilter..::.Bypass Property
IIviDigitizerChannelFilter See Also

Specifies whether or not to bypass the input filter.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Bypass As Boolean
C#
public bool  Bypass { get; set; }
Visual C++
HRESULT get_Bypass(
    VARIANT_BOOL*  val
);
HRESULT put_Bypass(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelFilter Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelFilter..::.Configure Method
IIviDigitizerChannelFilter See Also

-- NOT_SUPPORTED -- This function is used to configure the minimum and maximum input filter frequencies for a specified channel.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  MinFrequency As Double  _
    ByVal  MaxFrequency As Double  _
)
C#
public void  Configure(
    double  MinFrequency,
    double  MaxFrequency
)
Visual C++
HRESULT Configure(
    double  MinFrequency,
    double  MaxFrequency
);

Parameters

MinFrequency

Specifies the minimum input filter frequency. This value sets the Input Filter Min Frequency attribute. See the attribute description for more details.

MaxFrequency

Specifies the maximum input filter frequency. This value sets the Input Filter Max Frequency attribute. See the attribute description for more details.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelFilter Interface
Ivi.Digitizer.Interop Namespace


MaxFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelFilter..::.MaxFrequency Property
IIviDigitizerChannelFilter See Also

Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property MaxFrequency As Double
C#
public double  MaxFrequency { get; set; }
Visual C++
HRESULT get_MaxFrequency(
    double*  val
);
HRESULT put_MaxFrequency(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelFilter Interface
Ivi.Digitizer.Interop Namespace


MinFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelFilter..::.MinFrequency Property
IIviDigitizerChannelFilter See Also

-- NOT_SUPPORTED -- Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property MinFrequency As Double
C#
public double  MinFrequency { get; set; }
Visual C++
HRESULT get_MinFrequency(
    double*  val
);
HRESULT put_MinFrequency(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelFilter Interface
Ivi.Digitizer.Interop Namespace


InputConnectorSelection Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.InputConnectorSelection Property
IIviDigitizerChannel See Also

Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1, 2

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property InputConnectorSelection As Integer
C#
public int  InputConnectorSelection { get; set; }
Visual C++
HRESULT get_InputConnectorSelection(
    long*  val
);
HRESULT put_InputConnectorSelection(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


InputImpedance Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.InputImpedance Property
IIviDigitizerChannel See Also

The input impedance of this channel. The units are Ohms.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property InputImpedance As Double
C#
public double  InputImpedance { get; set; }
Visual C++
HRESULT get_InputImpedance(
    double*  val
);
HRESULT put_InputImpedance(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Measurement Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Measurement Property
IIviDigitizerChannel See Also

Pointer to the class-compliant IIviDigitizerChannelMeasurement interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Measurement As IIviDigitizerChannelMeasurement
C#
public IIviDigitizerChannelMeasurement  Measurement { get; }
Visual C++
HRESULT get_Measurement(
    IIviDigitizerChannelMeasurement**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


FetchWaveformInt16 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.FetchWaveformInt16 Method
IIviDigitizerChannelMeasurement See Also

This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformInt16 ( _
    ByRef  WaveformArray As Short()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchWaveformInt16(
    ref short[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchWaveformInt16(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


FetchWaveformInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.FetchWaveformInt32 Method
IIviDigitizerChannelMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformInt32 ( _
    ByRef  WaveformArray As Integer()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchWaveformInt32(
    ref int[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchWaveformInt32(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


FetchWaveformInt8 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.FetchWaveformInt8 Method
IIviDigitizerChannelMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformInt8 ( _
    ByRef  WaveformArray As Byte()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchWaveformInt8(
    ref byte[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchWaveformInt8(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


FetchWaveformReal64 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.FetchWaveformReal64 Method
IIviDigitizerChannelMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformReal64 ( _
    ByRef  WaveformArray As Double()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveformReal64(
    ref double[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveformReal64(
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement
);

Parameters

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


ReadWaveformInt16 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.ReadWaveformInt16 Method
IIviDigitizerChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformInt16 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Short()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  ReadWaveformInt16(
    int  MaxTimeMilliseconds,
    ref short[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT ReadWaveformInt16(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


ReadWaveformInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.ReadWaveformInt32 Method
IIviDigitizerChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformInt32 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Integer()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  ReadWaveformInt32(
    int  MaxTimeMilliseconds,
    ref int[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT ReadWaveformInt32(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


ReadWaveformInt8 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.ReadWaveformInt8 Method
IIviDigitizerChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformInt8 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Byte()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  ReadWaveformInt8(
    int  MaxTimeMilliseconds,
    ref byte[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT ReadWaveformInt8(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


ReadWaveformReal64 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement..::.ReadWaveformReal64 Method
IIviDigitizerChannelMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformReal64 ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Double()   _
    ByRef  ActualPoints As Long  _
    ByRef  FirstValidPoint As Long  _
    ByRef  InitialXOffset As Double  _
    ByRef  InitialXTimeSeconds As Double  _
    ByRef  InitialXTimeFraction As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveformReal64(
    int  MaxTimeMilliseconds,
    ref double[]   WaveformArray,
    ref long  ActualPoints,
    ref long  FirstValidPoint,
    ref double  InitialXOffset,
    ref double  InitialXTimeSeconds,
    ref double  InitialXTimeFraction,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveformReal64(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualPoints,
    __int64*  FirstValidPoint,
    double*  InitialXOffset,
    double*  InitialXTimeSeconds,
    double*  InitialXTimeFraction,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMeasurement Interface
Ivi.Digitizer.Interop Namespace


MultiRecordMeasurement Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.MultiRecordMeasurement Property
IIviDigitizerChannel See Also

Pointer to the IIviDigitizerChannelMultiRecordMeasurement interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MultiRecordMeasurement As IIviDigitizerChannelMultiRecordMeasurement
C#
public IIviDigitizerChannelMultiRecordMeasurement  MultiRecordMeasurement { get; }
Visual C++
HRESULT get_MultiRecordMeasurement(
    IIviDigitizerChannelMultiRecordMeasurement**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


FetchMultiRecordWaveformInt16 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformInt16 Method
IIviDigitizerChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformInt16 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Short()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchMultiRecordWaveformInt16(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref short[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchMultiRecordWaveformInt16(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMultiRecordMeasurement Interface
Ivi.Digitizer.Interop Namespace


FetchMultiRecordWaveformInt32 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformInt32 Method
IIviDigitizerChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformInt32 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Integer()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchMultiRecordWaveformInt32(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref int[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchMultiRecordWaveformInt32(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMultiRecordMeasurement Interface
Ivi.Digitizer.Interop Namespace


FetchMultiRecordWaveformInt8 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformInt8 Method
IIviDigitizerChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformInt8 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Byte()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
    ByRef  ScaleFactor As Double  _
    ByRef  ScaleOffset As Double  _
)
C#
public void  FetchMultiRecordWaveformInt8(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref byte[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement,
    ref double  ScaleFactor,
    ref double  ScaleOffset
)
Visual C++
HRESULT FetchMultiRecordWaveformInt8(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement,
    double*  ScaleFactor,
    double*  ScaleOffset
);

Parameters

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMultiRecordMeasurement Interface
Ivi.Digitizer.Interop Namespace


FetchMultiRecordWaveformReal64 Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMultiRecordMeasurement..::.FetchMultiRecordWaveformReal64 Method
IIviDigitizerChannelMultiRecordMeasurement See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub FetchMultiRecordWaveformReal64 ( _
    ByVal  FirstRecord As Long  _
    ByVal  NumRecords As Long  _
    ByVal  OffsetWithinRecord As Long  _
    ByVal  NumPointsPerRecord As Long  _
    ByRef  WaveformArray As Double()   _
    ByRef  ActualRecords As Long  _
    ByRef  ActualPoints As Long()   _
    ByRef  FirstValidPoint As Long()   _
    ByRef  InitialXOffset As Double()   _
    ByRef  InitialXTimeSeconds As Double()   _
    ByRef  InitialXTimeFraction As Double()   _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchMultiRecordWaveformReal64(
    long  FirstRecord,
    long  NumRecords,
    long  OffsetWithinRecord,
    long  NumPointsPerRecord,
    ref double[]   WaveformArray,
    ref long  ActualRecords,
    ref long[]   ActualPoints,
    ref long[]   FirstValidPoint,
    ref double[]   InitialXOffset,
    ref double[]   InitialXTimeSeconds,
    ref double[]   InitialXTimeFraction,
    ref double  XIncrement
)
Visual C++
HRESULT FetchMultiRecordWaveformReal64(
    __int64  FirstRecord,
    __int64  NumRecords,
    __int64  OffsetWithinRecord,
    __int64  NumPointsPerRecord,
    SAFEARRAY**  WaveformArray,
    __int64*  ActualRecords,
    SAFEARRAY**  ActualPoints,
    SAFEARRAY**  FirstValidPoint,
    SAFEARRAY**  InitialXOffset,
    SAFEARRAY**  InitialXTimeSeconds,
    SAFEARRAY**  InitialXTimeFraction,
    double*  XIncrement
);

Parameters

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannelMultiRecordMeasurement Interface
Ivi.Digitizer.Interop Namespace


Offset Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Offset Property
IIviDigitizerChannel See Also

The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Range Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Range Property
IIviDigitizerChannel See Also

The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Temperature Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.Temperature Property
IIviDigitizerChannel See Also

Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Temperature As Double
C#
public double  Temperature { get; }
Visual C++
HRESULT get_Temperature(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


TimeInterleavedChannelList Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel..::.TimeInterleavedChannelList Property
IIviDigitizerChannel See Also

This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property TimeInterleavedChannelList As String
C#
public string  TimeInterleavedChannelList { get; set; }
Visual C++
HRESULT get_TimeInterleavedChannelList(
    BSTR*  val
);
HRESULT put_TimeInterleavedChannelList(
    BSTR  val
);

Remarks

For valid channel name values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannel Interface
Ivi.Digitizer.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannels..::.Name Property
IIviDigitizerChannels See Also

Returns the physical repeated capability identifier defined by the specific driver for the Channel that corresponds to the one-based index that the user specifies. Valid values for the Index parameter are between one and the value of the Channel Count attribute. If the user passes an invalid value for the Index parameter, the value of this attribute is an empty string.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of channels.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerChannels Interface
Ivi.Digitizer.Interop Namespace


ReferenceOscillator Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.ReferenceOscillator Property
IIviDigitizer See Also

Pointer to the class-compliant IIviDigitizerReference Oscillator interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ReferenceOscillator As IIviDigitizerReferenceOscillator
C#
public IIviDigitizerReferenceOscillator  ReferenceOscillator { get; }
Visual C++
HRESULT get_ReferenceOscillator(
    IIviDigitizerReferenceOscillator**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerReferenceOscillator..::.Configure Method
IIviDigitizerReferenceOscillator See Also

-- NOT SUPPORTED -- Configures the digitizer's reference oscillator.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As IviDigitizerReferenceOscillatorSourceEnum  _
    ByVal  Frequency As Double  _
)
C#
public void  Configure(
    IviDigitizerReferenceOscillatorSourceEnum  Source,
    double  Frequency
)
Visual C++
HRESULT Configure(
    IviDigitizerReferenceOscillatorSourceEnum  Source,
    double  Frequency
);

Parameters

Source

Specifies the source of the reference frequency signal. The driver uses this value to set the Reference Oscillator Source attribute. See the attribute description for more details.

Frequency

Specifies the frequency of the external reference oscillator. This parameter is only used if the Source is set to External. The driver uses this value to set the Reference Oscillator Frequency attribute. See the attribute description for more details.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerReferenceOscillator Interface
Ivi.Digitizer.Interop Namespace


ExternalFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerReferenceOscillator..::.ExternalFrequency Property
IIviDigitizerReferenceOscillator See Also

Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ExternalFrequency As Double
C#
public double  ExternalFrequency { get; set; }
Visual C++
HRESULT get_ExternalFrequency(
    double*  val
);
HRESULT put_ExternalFrequency(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerReferenceOscillator Interface
Ivi.Digitizer.Interop Namespace


OutputEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerReferenceOscillator..::.OutputEnabled Property
IIviDigitizerReferenceOscillator See Also

Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property OutputEnabled As Boolean
C#
public bool  OutputEnabled { get; set; }
Visual C++
HRESULT get_OutputEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_OutputEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerReferenceOscillator Interface
Ivi.Digitizer.Interop Namespace


Source Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerReferenceOscillator..::.Source Property
IIviDigitizerReferenceOscillator See Also

Specifies the reference frequency source used.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Source As IviDigitizerReferenceOscillatorSourceEnum
C#
public IviDigitizerReferenceOscillatorSourceEnum  Source { get; set; }
Visual C++
HRESULT get_Source(
    IviDigitizerReferenceOscillatorSourceEnum*  val
);
HRESULT put_Source(
    IviDigitizerReferenceOscillatorSourceEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerReferenceOscillator Interface
Ivi.Digitizer.Interop Namespace


SampleClock Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.SampleClock Property
IIviDigitizer See Also

Pointer to the class-compliant IIviDigitizerSampleClock interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleClock As IIviDigitizerSampleClock
C#
public IIviDigitizerSampleClock  SampleClock { get; }
Visual C++
HRESULT get_SampleClock(
    IIviDigitizerSampleClock**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerSampleClock..::.Configure Method
IIviDigitizerSampleClock See Also

Configures the digitizer's sample clock.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As IviDigitizerSampleClockSourceEnum  _
    ByVal  Frequency As Double  _
    ByVal  Divider As Double  _
)
C#
public void  Configure(
    IviDigitizerSampleClockSourceEnum  Source,
    double  Frequency,
    double  Divider
)
Visual C++
HRESULT Configure(
    IviDigitizerSampleClockSourceEnum  Source,
    double  Frequency,
    double  Divider
);

Parameters

Source

Specifies the source of the sample clock signal. The driver uses this value to set the Sample Clock Source attribute. See the attribute description for more details.

Frequency

Specifies the frequency of the external sample clock. This parameter is only used if the Sample Clock Source attribute is set to External. The driver uses this value to set the External Sample Clock Frequency attribute. See the attribute description for more details.

Divider

Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerSampleClock Interface
Ivi.Digitizer.Interop Namespace


ExternalDivider Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerSampleClock..::.ExternalDivider Property
IIviDigitizerSampleClock See Also

Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.x

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ExternalDivider As Double
C#
public double  ExternalDivider { get; set; }
Visual C++
HRESULT get_ExternalDivider(
    double*  val
);
HRESULT put_ExternalDivider(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerSampleClock Interface
Ivi.Digitizer.Interop Namespace


ExternalFrequency Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerSampleClock..::.ExternalFrequency Property
IIviDigitizerSampleClock See Also

Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ExternalFrequency As Double
C#
public double  ExternalFrequency { get; set; }
Visual C++
HRESULT get_ExternalFrequency(
    double*  val
);
HRESULT put_ExternalFrequency(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerSampleClock Interface
Ivi.Digitizer.Interop Namespace


OutputEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerSampleClock..::.OutputEnabled Property
IIviDigitizerSampleClock See Also

-- NOT SUPPORTED -- Specifies whether or not the sample clock appears at a reference output of the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property OutputEnabled As Boolean
C#
public bool  OutputEnabled { get; set; }
Visual C++
HRESULT get_OutputEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_OutputEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerSampleClock Interface
Ivi.Digitizer.Interop Namespace


Source Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerSampleClock..::.Source Property
IIviDigitizerSampleClock See Also

Specifies the clock used to pace acquisition sampling.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Source As IviDigitizerSampleClockSourceEnum
C#
public IviDigitizerSampleClockSourceEnum  Source { get; set; }
Visual C++
HRESULT get_Source(
    IviDigitizerSampleClockSourceEnum*  val
);
HRESULT put_Source(
    IviDigitizerSampleClockSourceEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerSampleClock Interface
Ivi.Digitizer.Interop Namespace


Temperature Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.Temperature Property
IIviDigitizer See Also

Pointer to the class-compliant IIviDigitizerTemperature interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Temperature As IIviDigitizerTemperature
C#
public IIviDigitizerTemperature  Temperature { get; }
Visual C++
HRESULT get_Temperature(
    IIviDigitizerTemperature**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


BoardTemperature Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTemperature..::.BoardTemperature Property
IIviDigitizerTemperature See Also

Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property BoardTemperature As Double
C#
public double  BoardTemperature { get; }
Visual C++
HRESULT get_BoardTemperature(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTemperature Interface
Ivi.Digitizer.Interop Namespace


Units Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTemperature..::.Units Property
IIviDigitizerTemperature See Also

Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Units As IviDigitizerTemperatureUnitsEnum
C#
public IviDigitizerTemperatureUnitsEnum  Units { get; set; }
Visual C++
HRESULT get_Units(
    IviDigitizerTemperatureUnitsEnum*  val
);
HRESULT put_Units(
    IviDigitizerTemperatureUnitsEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTemperature Interface
Ivi.Digitizer.Interop Namespace


Trigger Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizer..::.Trigger Property
IIviDigitizer See Also

Pointer to the class-compliant IIviDigitizerTrigger interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger As IIviDigitizerTrigger
C#
public IIviDigitizerTrigger  Trigger { get; }
Visual C++
HRESULT get_Trigger(
    IIviDigitizerTrigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizer Interface
Ivi.Digitizer.Interop Namespace


ActiveSource Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.ActiveSource Property
IIviDigitizerTrigger See Also

Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ActiveSource As String
C#
public string  ActiveSource { get; set; }
Visual C++
HRESULT get_ActiveSource(
    BSTR*  val
);
HRESULT put_ActiveSource(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


Delay Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.Delay Property
IIviDigitizerTrigger See Also

Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Delay As Double
C#
public double  Delay { get; set; }
Visual C++
HRESULT get_Delay(
    double*  val
);
HRESULT put_Delay(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


Holdoff Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.Holdoff Property
IIviDigitizerTrigger See Also

-- NOT SUPPORTED -- Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Holdoff As Double
C#
public double  Holdoff { get; set; }
Visual C++
HRESULT get_Holdoff(
    double*  val
);
HRESULT put_Holdoff(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


Modifier Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.Modifier Property
IIviDigitizerTrigger See Also

Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Modifier As IviDigitizerTriggerModifierEnum
C#
public IviDigitizerTriggerModifierEnum  Modifier { get; set; }
Visual C++
HRESULT get_Modifier(
    IviDigitizerTriggerModifierEnum*  val
);
HRESULT put_Modifier(
    IviDigitizerTriggerModifierEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


MultiTrigger Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.MultiTrigger Property
IIviDigitizerTrigger See Also

Pointer to the class-compliant IIviDigitizerMultiTrigger interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property MultiTrigger As IIviDigitizerMultiTrigger
C#
public IIviDigitizerMultiTrigger  MultiTrigger { get; }
Visual C++
HRESULT get_MultiTrigger(
    IIviDigitizerMultiTrigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiTrigger..::.Configure Method
IIviDigitizerMultiTrigger See Also

Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  SourceList As String  _
    ByVal  Operator As IviDigitizerTriggerSourceOperatorEnum  _
)
C#
public void  Configure(
    string  SourceList,
    IviDigitizerTriggerSourceOperatorEnum  Operator
)
Visual C++
HRESULT Configure(
    BSTR  SourceList,
    IviDigitizerTriggerSourceOperatorEnum  Operator
);

Parameters

SourceList

A comma separated list of source names to be used in a multi trigger scenario. The driver uses this value to set the Trigger Source List attribute.

Operator

Specifies the boolean operation to apply to the trigger sources specified by the SourceList parameter. The driver uses this value to set the Trigger Source Operator attribute.

Requirements

Supported Models

DC122, DC122HF, DC122HZ, DC152, DC152HZ, DC222, DC222HF, DC222HZ, DC252, DC252HF, DC252HZ, DC282, DC282HZ, DP1400, M9210A, M9211A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IIviDigitizerMultiTrigger Interface
Ivi.Digitizer.Interop Namespace


SourceList Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiTrigger..::.SourceList Property
IIviDigitizerMultiTrigger See Also

A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SourceList As String
C#
public string  SourceList { get; set; }
Visual C++
HRESULT get_SourceList(
    BSTR*  val
);
HRESULT put_SourceList(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerMultiTrigger Interface
Ivi.Digitizer.Interop Namespace


SourceOperator Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiTrigger..::.SourceOperator Property
IIviDigitizerMultiTrigger See Also

Specifies the boolean operation to apply to the arm sources specified by the SourceList property. If set to None, muti triggering is disabled. A valid SourceList must be set before setting the SourceOperator to AND or OR. See the help for SourceList for more info.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SourceOperator As IviDigitizerTriggerSourceOperatorEnum
C#
public IviDigitizerTriggerSourceOperatorEnum  SourceOperator { get; set; }
Visual C++
HRESULT get_SourceOperator(
    IviDigitizerTriggerSourceOperatorEnum*  val
);
HRESULT put_SourceOperator(
    IviDigitizerTriggerSourceOperatorEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerMultiTrigger Interface
Ivi.Digitizer.Interop Namespace


OutputEnabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.OutputEnabled Property
IIviDigitizerTrigger See Also

Specifies whether or not an accepted trigger appears at an output of the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property OutputEnabled As Boolean
C#
public bool  OutputEnabled { get; set; }
Visual C++
HRESULT get_OutputEnabled(
    VARIANT_BOOL*  val
);
HRESULT put_OutputEnabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


PretriggerSamples Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.PretriggerSamples Property
IIviDigitizerTrigger See Also

-- NOT SUPPORTED -- Specifies the number of samples that must be collected before a trigger event will be recognized. The Pretrigger Samples attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and Pretrigger Samples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property PretriggerSamples As Long
C#
public long  PretriggerSamples { get; set; }
Visual C++
HRESULT get_PretriggerSamples(
    __int64*  val
);
HRESULT put_PretriggerSamples(
    __int64  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


SendSoftwareTrigger Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.SendSoftwareTrigger Method
IIviDigitizerTrigger See Also

Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub SendSoftwareTrigger ( _
)
C#
public void  SendSoftwareTrigger(
)
Visual C++
HRESULT SendSoftwareTrigger(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


Sources Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger..::.Sources Property
IIviDigitizerTrigger See Also

Pointer to the IIviDigitizerTriggerSources interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Sources As IIviDigitizerTriggerSources
C#
public IIviDigitizerTriggerSources  Sources { get; }
Visual C++
HRESULT get_Sources(
    IIviDigitizerTriggerSources**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTrigger Interface
Ivi.Digitizer.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSources..::.Count Property
IIviDigitizerTriggerSources See Also

The number of trigger sources.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSources Interface
Ivi.Digitizer.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSources..::.Item Property
IIviDigitizerTriggerSources See Also

An interface reference pointer to the IIviDigitizerTriggerSource interface which is selected by the source name.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IIviDigitizerTriggerSource
C#
public IIviDigitizerTriggerSource  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IIviDigitizerTriggerSource**  val
);

Parameters

Name

The name of a source. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the TriggerSource repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSources Interface
Ivi.Digitizer.Interop Namespace


Coupling Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Coupling Property
IIviDigitizerTriggerSource See Also

Specifies how the digitizer couples the trigger source.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As IviDigitizerTriggerCouplingEnum
C#
public IviDigitizerTriggerCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    IviDigitizerTriggerCouplingEnum*  val
);
HRESULT put_Coupling(
    IviDigitizerTriggerCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Edge Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Edge Property
IIviDigitizerTriggerSource See Also

Pointer to the class-compliant IIviDigitizerTriggerEdge interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Edge As IIviDigitizerTriggerEdge
C#
public IIviDigitizerTriggerEdge  Edge { get; }
Visual C++
HRESULT get_Edge(
    IIviDigitizerTriggerEdge**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerEdge..::.Configure Method
IIviDigitizerTriggerEdge See Also

This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  Slope As IviDigitizerTriggerSlopeEnum  _
)
C#
public void  Configure(
    double  Level,
    IviDigitizerTriggerSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    double  Level,
    IviDigitizerTriggerSlopeEnum  Slope
);

Parameters

Level

Specifies the trigger level. This value sets the Trigger Level attribute.

Slope

Specifies the trigger slope. This value sets the Trigger Slope attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerEdge Interface
Ivi.Digitizer.Interop Namespace


Slope Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerEdge..::.Slope Property
IIviDigitizerTriggerEdge See Also

Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Slope As IviDigitizerTriggerSlopeEnum
C#
public IviDigitizerTriggerSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    IviDigitizerTriggerSlopeEnum*  val
);
HRESULT put_Slope(
    IviDigitizerTriggerSlopeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerEdge Interface
Ivi.Digitizer.Interop Namespace


Glitch Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Glitch Property
IIviDigitizerTriggerSource See Also

Pointer to the class-compliant IIviDigitizerTriggerGlitch interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Glitch As IIviDigitizerTriggerGlitch
C#
public IIviDigitizerTriggerGlitch  Glitch { get; }
Visual C++
HRESULT get_Glitch(
    IIviDigitizerTriggerGlitch**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerGlitch..::.Condition Property
IIviDigitizerTriggerGlitch See Also

-- NOT SUPPORTED -- Specifies the glitch condition. This attribute determines whether the glitch trigger happens when the digitizer detects a pulse with a width less than or greater than the width value.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Condition As IviDigitizerGlitchConditionEnum
C#
public IviDigitizerGlitchConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    IviDigitizerGlitchConditionEnum*  val
);
HRESULT put_Condition(
    IviDigitizerGlitchConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerGlitch Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerGlitch..::.Configure Method
IIviDigitizerTriggerGlitch See Also

-- NOT SUPPORTED -- This function configures the glitch trigger. A glitch trigger occurs when the trigger signal has a pulse with a width that is less than or greater than the glitch width. The end user specifies which comparison criterion to use with the GlitchCondition parameter. The end-user specifies the glitch width with the GlitchWidth parameter. The end-user specifies the polarity of the pulse with the GlitchPolarity parameter. The trigger does not actually occur until the edge of a pulse that corresponds to the GlitchWidth and GlitchPolarity crosses the threshold the end-user specifies in the TriggerLevel parameter. This function affects instrument behavior only if the trigger type is Glitch Trigger. Set the trigger type and trigger coupling before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  Width As Double  _
    ByVal  Polarity As IviDigitizerGlitchPolarityEnum  _
    ByVal  Condition As IviDigitizerGlitchConditionEnum  _
)
C#
public void  Configure(
    double  Level,
    double  Width,
    IviDigitizerGlitchPolarityEnum  Polarity,
    IviDigitizerGlitchConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    double  Level,
    double  Width,
    IviDigitizerGlitchPolarityEnum  Polarity,
    IviDigitizerGlitchConditionEnum  Condition
);

Parameters

Level

Specifies the trigger level. This value sets the Trigger Level attribute.

Width

Specifies the glitch triggering glitch width in seconds. This value sets the Glitch Width attribute.

Polarity

Specifies the glitch polarity. This value sets the Glitch Polarity attribute.

Condition

Specifies the glitch condition. This value sets the Glitch Condition attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerGlitch Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerGlitch..::.Polarity Property
IIviDigitizerTriggerGlitch See Also

-- NOT SUPPORTED -- Specifies the polarity of the glitch that triggers the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerGlitchPolarityEnum
C#
public IviDigitizerGlitchPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerGlitchPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerGlitchPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerGlitch Interface
Ivi.Digitizer.Interop Namespace


Width Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerGlitch..::.Width Property
IIviDigitizerTriggerGlitch See Also

-- NOT SUPPORTED -- Specifies the glitch width. The units are seconds. The digitizer triggers when it detects a pulse with a width less than or greater than this value, depending on the Glitch Condition attribute.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Width As Double
C#
public double  Width { get; set; }
Visual C++
HRESULT get_Width(
    double*  val
);
HRESULT put_Width(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerGlitch Interface
Ivi.Digitizer.Interop Namespace


Hysteresis Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Hysteresis Property
IIviDigitizerTriggerSource See Also

Specifies the trigger hysteresis in Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Hysteresis As Double
C#
public double  Hysteresis { get; set; }
Visual C++
HRESULT get_Hysteresis(
    double*  val
);
HRESULT put_Hysteresis(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Level Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Level Property
IIviDigitizerTriggerSource See Also

Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Level As Double
C#
public double  Level { get; set; }
Visual C++
HRESULT get_Level(
    double*  val
);
HRESULT put_Level(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Runt Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Runt Property
IIviDigitizerTriggerSource See Also

Pointer to the class-compliant IIviDigitizerTriggerRunt interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Runt As IIviDigitizerTriggerRunt
C#
public IIviDigitizerTriggerRunt  Runt { get; }
Visual C++
HRESULT get_Runt(
    IIviDigitizerTriggerRunt**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerRunt..::.Configure Method
IIviDigitizerTriggerRunt See Also

-- NOT SUPPORTED -- This function configures the runt trigger. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold. The end-user specifies the runt thresholds with the RuntLowThreshold and RuntHighThreshold parameters. The end-user specifies the polarity of the runt with the RuntPolarity parameter. This function affects instrument behavior only if the trigger type is Runt Trigger. Set the trigger type and trigger coupling before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Polarity As IviDigitizerRuntPolarityEnum  _
)
C#
public void  Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerRuntPolarityEnum  Polarity
)
Visual C++
HRESULT Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerRuntPolarityEnum  Polarity
);

Parameters

ThresholdLow

Sets the runt triggering low threshold in volts.

ThresholdHigh

Sets the runt triggering high threshold in volts.

Polarity

Sets the runt polarity.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerRunt Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerRunt..::.Polarity Property
IIviDigitizerTriggerRunt See Also

-- NOT SUPPORTED -- Specifies the polarity of the runt that triggers the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerRuntPolarityEnum
C#
public IviDigitizerRuntPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerRuntPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerRuntPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerRunt Interface
Ivi.Digitizer.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerRunt..::.ThresholdHigh Property
IIviDigitizerTriggerRunt See Also

-- NOT SUPPORTED -- The high threshold the digitizer uses for runt triggering. The units are Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerRunt Interface
Ivi.Digitizer.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerRunt..::.ThresholdLow Property
IIviDigitizerTriggerRunt See Also

-- NOT SUPPORTED -- The low threshold the digitizer uses for runt triggering. The units are Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerRunt Interface
Ivi.Digitizer.Interop Namespace


TV Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.TV Property
IIviDigitizerTriggerSource See Also

Pointer to the class-compliant IIviDigitizerTriggerTV interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TV As IIviDigitizerTriggerTV
C#
public IIviDigitizerTriggerTV  TV { get; }
Visual C++
HRESULT get_TV(
    IIviDigitizerTriggerTV**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerTV..::.Configure Method
IIviDigitizerTriggerTV See Also

This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  SignalFormat As IviDigitizerTVSignalFormatEnum  _
    ByVal  Event As IviDigitizerTVTriggerEventEnum  _
    ByVal  Polarity As IviDigitizerTVTriggerPolarityEnum  _
)
C#
public void  Configure(
    IviDigitizerTVSignalFormatEnum  SignalFormat,
    IviDigitizerTVTriggerEventEnum  Event,
    IviDigitizerTVTriggerPolarityEnum  Polarity
)
Visual C++
HRESULT Configure(
    IviDigitizerTVSignalFormatEnum  SignalFormat,
    IviDigitizerTVTriggerEventEnum  Event,
    IviDigitizerTVTriggerPolarityEnum  Polarity
);

Parameters

SignalFormat

Specifies the TV trigger signal format. This value sets the TV Trigger Signal Format attribute.

Event

Specifies the TV trigger event. This value sets the TV Trigger Event attribute.

Polarity

Specifies the polarity of the TV trigger. This value sets the TV Trigger Polarity attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerTV Interface
Ivi.Digitizer.Interop Namespace


Event Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerTV..::.Event Property
IIviDigitizerTriggerTV See Also

Specifies the event on which the digitizer triggers.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Event As IviDigitizerTVTriggerEventEnum
C#
public IviDigitizerTVTriggerEventEnum  Event { get; set; }
Visual C++
HRESULT get_Event(
    IviDigitizerTVTriggerEventEnum*  val
);
HRESULT put_Event(
    IviDigitizerTVTriggerEventEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerTV Interface
Ivi.Digitizer.Interop Namespace


LineNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerTV..::.LineNumber Property
IIviDigitizerTriggerTV See Also

Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property LineNumber As Integer
C#
public int  LineNumber { get; set; }
Visual C++
HRESULT get_LineNumber(
    long*  val
);
HRESULT put_LineNumber(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerTV Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerTV..::.Polarity Property
IIviDigitizerTriggerTV See Also

Specifies the polarity of the TV signal.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerTVTriggerPolarityEnum
C#
public IviDigitizerTVTriggerPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerTVTriggerPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerTVTriggerPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerTV Interface
Ivi.Digitizer.Interop Namespace


SignalFormat Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerTV..::.SignalFormat Property
IIviDigitizerTriggerTV See Also

Specifies the format of TV signal on which the digitizer triggers.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property SignalFormat As IviDigitizerTVSignalFormatEnum
C#
public IviDigitizerTVSignalFormatEnum  SignalFormat { get; set; }
Visual C++
HRESULT get_SignalFormat(
    IviDigitizerTVSignalFormatEnum*  val
);
HRESULT put_SignalFormat(
    IviDigitizerTVSignalFormatEnum  val
);

Requirements

Supported Models

DC110, DC122, DC122HF, DC122HZ, DC135, DC135HZ, DC140, DC140HZ, DC152, DC152HZ, DC436, DC438, DC440, DP105, DP106, DP110, DP111, DP1400, DP210, DP211, DP212, DP214, DP235, DP240, DP306, DP308, DP310, M9202A, M9203A, M9210A, M9211A, M9703A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

IIviDigitizerTriggerTV Interface
Ivi.Digitizer.Interop Namespace


Type Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Type Property
IIviDigitizerTriggerSource See Also

The kind of event that triggers the digitizer. TV triggering requires External trigger source.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Type As IviDigitizerTriggerTypeEnum
C#
public IviDigitizerTriggerTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    IviDigitizerTriggerTypeEnum*  val
);
HRESULT put_Type(
    IviDigitizerTriggerTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Width Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Width Property
IIviDigitizerTriggerSource See Also

Pointer to the class-compliant IIviDigitizerTriggerWidth interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Width As IIviDigitizerTriggerWidth
C#
public IIviDigitizerTriggerWidth  Width { get; }
Visual C++
HRESULT get_Width(
    IIviDigitizerTriggerWidth**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWidth..::.Condition Property
IIviDigitizerTriggerWidth See Also

-- NOT SUPPORTED -- Specifies whether a pulse that is within or outside the high and low thresholds triggers the digitizer. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold attributes.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Condition As IviDigitizerWidthConditionEnum
C#
public IviDigitizerWidthConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    IviDigitizerWidthConditionEnum*  val
);
HRESULT put_Condition(
    IviDigitizerWidthConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWidth Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWidth..::.Configure Method
IIviDigitizerTriggerWidth See Also

-- NOT SUPPORTED -- Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Level As Double  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Polarity As IviDigitizerWidthPolarityEnum  _
    ByVal  Condition As IviDigitizerWidthConditionEnum  _
)
C#
public void  Configure(
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWidthPolarityEnum  Polarity,
    IviDigitizerWidthConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWidthPolarityEnum  Polarity,
    IviDigitizerWidthConditionEnum  Condition
);

Parameters

Level

Trigger Level. This value sets the Trigger Level attribute.

ThresholdLow

Sets the width triggering low threshold in seconds. This value sets the Width Low Threshold attribute.

ThresholdHigh

Sets the width triggering high threshold in seconds. This value sets the Width High Threshold attribute.

Polarity

Sets the width polarity. This value sets the Width Polarity attribute.

Condition

Specifies whether a pulse that is within or outside the user-specified thresholds trigger waveform acquisition. This value sets the Width Condition attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWidth Interface
Ivi.Digitizer.Interop Namespace


Polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWidth..::.Polarity Property
IIviDigitizerTriggerWidth See Also

-- NOT SUPPORTED -- Specifies the polarity of the pulse that triggers the digitizer.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Polarity As IviDigitizerWidthPolarityEnum
C#
public IviDigitizerWidthPolarityEnum  Polarity { get; set; }
Visual C++
HRESULT get_Polarity(
    IviDigitizerWidthPolarityEnum*  val
);
HRESULT put_Polarity(
    IviDigitizerWidthPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWidth Interface
Ivi.Digitizer.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWidth..::.ThresholdHigh Property
IIviDigitizerTriggerWidth See Also

-- NOT SUPPORTED -- Specifies the high width threshold time in seconds.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWidth Interface
Ivi.Digitizer.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWidth..::.ThresholdLow Property
IIviDigitizerTriggerWidth See Also

-- NOT SUPPORTED -- Specifies the low width threshold time in seconds.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWidth Interface
Ivi.Digitizer.Interop Namespace


Window Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource..::.Window Property
IIviDigitizerTriggerSource See Also

Pointer to the class-compliant IIviDigitizerTriggerWindow interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Window As IIviDigitizerTriggerWindow
C#
public IIviDigitizerTriggerWindow  Window { get; }
Visual C++
HRESULT get_Window(
    IIviDigitizerTriggerWindow**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSource Interface
Ivi.Digitizer.Interop Namespace


Condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWindow..::.Condition Property
IIviDigitizerTriggerWindow See Also

-- NOT SUPPORTED -- Specifies whether a signal that is entering or leaving the voltage window defined by the high and low thresholds triggers the digitizer. The end-user specifies the high and low thresholds with the Window High Threshold and Window Low Threshold attributes.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property Condition As IviDigitizerWindowConditionEnum
C#
public IviDigitizerWindowConditionEnum  Condition { get; set; }
Visual C++
HRESULT get_Condition(
    IviDigitizerWindowConditionEnum*  val
);
HRESULT put_Condition(
    IviDigitizerWindowConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWindow Interface
Ivi.Digitizer.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWindow..::.Configure Method
IIviDigitizerTriggerWindow See Also

-- NOT SUPPORTED -- Configures the window trigger Source, ThresholdLow, ThresholdHigh, and Condition. A window trigger occurs when a signal that enters or leaves a given voltage range is detected.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  Condition As IviDigitizerWindowConditionEnum  _
)
C#
public void  Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWindowConditionEnum  Condition
)
Visual C++
HRESULT Configure(
    double  ThresholdLow,
    double  ThresholdHigh,
    IviDigitizerWindowConditionEnum  Condition
);

Parameters

ThresholdLow

Sets the window triggering low threshold in Volts. This value sets the Window Low Threshold attribute.

ThresholdHigh

Sets the window triggering high threshold in Volts. This value sets the Window High Threshold attribute.

Condition

Specifies whether a pulse that is within or outside the user-specified thresholds trigger waveform acquisition. This value sets the Width Condition attribute.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWindow Interface
Ivi.Digitizer.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWindow..::.ThresholdHigh Property
IIviDigitizerTriggerWindow See Also

-- NOT SUPPORTED -- Specifies the high window threshold voltage in Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWindow Interface
Ivi.Digitizer.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWindow..::.ThresholdLow Property
IIviDigitizerTriggerWindow See Also

-- NOT SUPPORTED -- Specifies the low window threshold voltage in Volts.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerWindow Interface
Ivi.Digitizer.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSources..::.Name Property
IIviDigitizerTriggerSources See Also

The source name for a given index.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of sources.

Requirements

Supported Models

All supported

See Also

Reference

IIviDigitizerTriggerSources Interface
Ivi.Digitizer.Interop Namespace


IIviScope Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScope Interface
See Also

IVI Scope class-compliant root interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScope
   Inherits IIviDriver
C#
public interface IIviScope : IIviDriver
Visual C++
__interface IIviScope : IIviDriver

Properties

 | Name | Description
Public property | Acquisition | Pointer to the class-compliant IIviScopeAcquisition interface
Public property | Channels | Pointer to the class-compliant IIviScopeChannels interface
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | Measurements | Pointer to the class-compliant IIviScopeMeasurements interface
Public property | ReferenceLevel | Pointer to the class-compliant IIviScopeReferenceLevel interface
Public property | Trigger | Pointer to the class-compliant IIviScopeTrigger interface
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Ivi.Scope.Interop Namespace


Acquisition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScope..::.Acquisition Property
IIviScope See Also

Pointer to the class-compliant IIviScopeAcquisition interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Acquisition As IIviScopeAcquisition
C#
public IIviScopeAcquisition  Acquisition { get; }
Visual C++
HRESULT get_Acquisition(
    IIviScopeAcquisition**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


ConfigureRecord Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.ConfigureRecord Method
IIviScopeAcquisition See Also

Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureRecord ( _
    ByVal  TimePerRecord As Double  _
    ByVal  MinNumPts As Integer  _
    ByVal  AcquisitionStartTime As Double  _
)
C#
public void  ConfigureRecord(
    double  TimePerRecord,
    int  MinNumPts,
    double  AcquisitionStartTime
)
Visual C++
HRESULT ConfigureRecord(
    double  TimePerRecord,
    long  MinNumPts,
    double  AcquisitionStartTime
);

Parameters

TimePerRecord

Specifies the time per record. This value sets the Horizontal Time Per Record property.

MinNumPts

Specifies the minimum number of points the end-user allows in the waveform recorded. This value sets the Horizontal Minimum Number of Points property.

AcquisitionStartTime

Specifies the position of the first point in the waveform record relative to the trigger event. This value sets the Acquisition Start Time property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


Interpolation Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.Interpolation Property
IIviScopeAcquisition See Also

-- NOT SUPPORTED -- The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Interpolation As IviScopeInterpolationEnum
C#
public IviScopeInterpolationEnum  Interpolation { get; set; }
Visual C++
HRESULT get_Interpolation(
    IviScopeInterpolationEnum*  val
);
HRESULT put_Interpolation(
    IviScopeInterpolationEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


NumberOfAverages Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.NumberOfAverages Property
IIviScopeAcquisition See Also

The number of waveforms the oscilloscope acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfAverages As Integer
C#
public int  NumberOfAverages { get; set; }
Visual C++
HRESULT get_NumberOfAverages(
    long*  val
);
HRESULT put_NumberOfAverages(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


NumberOfEnvelopes Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.NumberOfEnvelopes Property
IIviScopeAcquisition See Also

-- NOT SUPPORTED -- The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfEnvelopes As Integer
C#
public int  NumberOfEnvelopes { get; set; }
Visual C++
HRESULT get_NumberOfEnvelopes(
    long*  val
);
HRESULT put_NumberOfEnvelopes(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


NumberOfPointsMin Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.NumberOfPointsMin Property
IIviScopeAcquisition See Also

The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property NumberOfPointsMin As Integer
C#
public int  NumberOfPointsMin { get; set; }
Visual C++
HRESULT get_NumberOfPointsMin(
    long*  val
);
HRESULT put_NumberOfPointsMin(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


RecordLength Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.RecordLength Property
IIviScopeAcquisition See Also

The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimun Number of Points property.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property RecordLength As Integer
C#
public int  RecordLength { get; }
Visual C++
HRESULT get_RecordLength(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


SampleMode Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.SampleMode Property
IIviScopeAcquisition See Also

The sample mode the oscilloscope is currently using.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleMode As IviScopeSampleModeEnum
C#
public IviScopeSampleModeEnum  SampleMode { get; }
Visual C++
HRESULT get_SampleMode(
    IviScopeSampleModeEnum*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


SampleRate Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.SampleRate Property
IIviScopeAcquisition See Also

The effective digitizing rate using the current configuration. The units are samples per second.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property SampleRate As Double
C#
public double  SampleRate { get; }
Visual C++
HRESULT get_SampleRate(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


StartTime Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.StartTime Property
IIviScopeAcquisition See Also

The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property StartTime As Double
C#
public double  StartTime { get; set; }
Visual C++
HRESULT get_StartTime(
    double*  val
);
HRESULT put_StartTime(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


TimePerRecord Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.TimePerRecord Property
IIviScopeAcquisition See Also

The time in seconds that corresponds to the record length.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property TimePerRecord As Double
C#
public double  TimePerRecord { get; set; }
Visual C++
HRESULT get_TimePerRecord(
    double*  val
);
HRESULT put_TimePerRecord(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


Type Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition..::.Type Property
IIviScopeAcquisition See Also

How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms. When set to TypeAverage, averaged waveforms must be read uisng the Measurement ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Type As IviScopeAcquisitionTypeEnum
C#
public IviScopeAcquisitionTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    IviScopeAcquisitionTypeEnum*  val
);
HRESULT put_Type(
    IviScopeAcquisitionTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeAcquisition Interface
Ivi.Scope.Interop Namespace


Channels Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScope..::.Channels Property
IIviScope See Also

Pointer to the class-compliant IIviScopeChannels interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Channels As IIviScopeChannels
C#
public IIviScopeChannels  Channels { get; }
Visual C++
HRESULT get_Channels(
    IIviScopeChannels**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannels..::.Count Property
IIviScopeChannels See Also

The number of channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannels Interface
Ivi.Scope.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannels..::.Item Property
IIviScopeChannels See Also

An interface reference pointer to one of the IviScopeChannel interfaces which is selected by the channel name.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IIviScopeChannel
C#
public IIviScopeChannel  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IIviScopeChannel**  val
);

Parameters

Name

The name of a channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannels Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.Configure Method
IIviScopeChannel See Also

Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Range As Double  _
    ByVal  Offset As Double  _
    ByVal  Coupling As IviScopeVerticalCouplingEnum  _
    ByVal  ProbeAttenuation As Double  _
    ByVal  Enabled As Boolean  _
)
C#
public void  Configure(
    double  Range,
    double  Offset,
    IviScopeVerticalCouplingEnum  Coupling,
    double  ProbeAttenuation,
    bool  Enabled
)
Visual C++
HRESULT Configure(
    double  Range,
    double  Offset,
    IviScopeVerticalCouplingEnum  Coupling,
    double  ProbeAttenuation,
    VARIANT_BOOL  Enabled
);

Parameters

Range

Specifies the vertical range. This value sets the Vertical Range property.

Offset

Specifies the vertical offset. This value sets the Vertical Offset property.

Coupling

Specifies how to couple the input signal. This value sets the Vertical

ProbeAttenuation

Specifies the probe attenuation. This value sets the Probe Attenuation property.

Enabled

Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


ConfigureCharacteristics Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.ConfigureCharacteristics Method
IIviScopeChannel See Also

Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ConfigureCharacteristics ( _
    ByVal  InputImpedance As Double  _
    ByVal  InputFrequencyMax As Double  _
)
C#
public void  ConfigureCharacteristics(
    double  InputImpedance,
    double  InputFrequencyMax
)
Visual C++
HRESULT ConfigureCharacteristics(
    double  InputImpedance,
    double  InputFrequencyMax
);

Parameters

InputImpedance

The input impedance for the channel. The driver sets the Input Impedance to this value.

InputFrequencyMax

The maximum input frequency for the channel. The driver sets the Max Input Frequency to this value.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Coupling Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.Coupling Property
IIviScopeChannel See Also

How the oscilloscope couples the input signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As IviScopeVerticalCouplingEnum
C#
public IviScopeVerticalCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    IviScopeVerticalCouplingEnum*  val
);
HRESULT put_Coupling(
    IviScopeVerticalCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Enabled Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.Enabled Property
IIviScopeChannel See Also

If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Enabled As Boolean
C#
public bool  Enabled { get; set; }
Visual C++
HRESULT get_Enabled(
    VARIANT_BOOL*  val
);
HRESULT put_Enabled(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


InputFrequencyMax Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.InputFrequencyMax Property
IIviScopeChannel See Also

The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property InputFrequencyMax As Double
C#
public double  InputFrequencyMax { get; set; }
Visual C++
HRESULT get_InputFrequencyMax(
    double*  val
);
HRESULT put_InputFrequencyMax(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


InputImpedance Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.InputImpedance Property
IIviScopeChannel See Also

The input impedance of this channel. The units are ohms.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property InputImpedance As Double
C#
public double  InputImpedance { get; set; }
Visual C++
HRESULT get_InputImpedance(
    double*  val
);
HRESULT put_InputImpedance(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Offset Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.Offset Property
IIviScopeChannel See Also

The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Offset As Double
C#
public double  Offset { get; set; }
Visual C++
HRESULT get_Offset(
    double*  val
);
HRESULT put_Offset(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


ProbeAttenuation Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.ProbeAttenuation Property
IIviScopeChannel See Also

The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ProbeAttenuation As Double
C#
public double  ProbeAttenuation { get; set; }
Visual C++
HRESULT get_ProbeAttenuation(
    double*  val
);
HRESULT put_ProbeAttenuation(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


ProbeSense Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.ProbeSense Property
IIviScopeChannel See Also

The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ProbeSense As Double
C#
public double  ProbeSense { get; }
Visual C++
HRESULT get_ProbeSense(
    double*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Range Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel..::.Range Property
IIviScopeChannel See Also

The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Range As Double
C#
public double  Range { get; set; }
Visual C++
HRESULT get_Range(
    double*  val
);
HRESULT put_Range(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannel Interface
Ivi.Scope.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannels..::.Name Property
IIviScopeChannels See Also

The channel name for a given index.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of channels.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeChannels Interface
Ivi.Scope.Interop Namespace


Measurements Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScope..::.Measurements Property
IIviScope See Also

Pointer to the class-compliant IIviScopeMeasurements interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Measurements As IIviScopeMeasurements
C#
public IIviScopeMeasurements  Measurements { get; }
Visual C++
HRESULT get_Measurements(
    IIviScopeMeasurements**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


Abort Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.Abort Method
IIviScopeMeasurements See Also

Aborts an acquisition and returns the oscilloscope to the Idle state.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Abort ( _
)
C#
public void  Abort(
)
Visual C++
HRESULT Abort(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


AutoSetup Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.AutoSetup Method
IIviScopeMeasurements See Also

-- NOT SUPPORTED -- Automatically configures all the oscilloscopes settings based on the input signals.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub AutoSetup ( _
)
C#
public void  AutoSetup(
)
Visual C++
HRESULT AutoSetup(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Count Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.Count Property
IIviScopeMeasurements See Also

The number of measurements.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Count As Integer
C#
public int  Count { get; }
Visual C++
HRESULT get_Count(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Initiate Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.Initiate Method
IIviScopeMeasurements See Also

Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Initiate ( _
)
C#
public void  Initiate(
)
Visual C++
HRESULT Initiate(
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


IsWaveformElementInvalid Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.IsWaveformElementInvalid Method
IIviScopeMeasurements See Also

-- NOT SUPPORTED -- Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Function IsWaveformElementInvalid ( _
    ByVal  Element As Double  _
) As Boolean
C#
public bool  IsWaveformElementInvalid(
    double  Element
)
Visual C++
HRESULT IsWaveformElementInvalid(
    double  Element
    VARIANT_BOOL*  retval
);

Parameters

Element

Pass one of the values from the waveform array returned by the read and fetch waveform methods.

Return Value

True if an element in the waveform array is invalid. False otherwise.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Item Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.Item Property
IIviScopeMeasurements See Also

An interface reference pointer to one of the IviScopeMeasurement interfaces which is selected by the channel name.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Item( _
    ByVal  Name As String  _
) As IIviScopeMeasurement
C#
public IIviScopeMeasurement  get_Item(
    string  Name
)
Visual C++
HRESULT get_Item(
    BSTR  Name,
    IIviScopeMeasurement**  val
);

Parameters

Name

The name of a channel. It may be either a name returned by the Name property or a name mapped to a particular repeated capability in the session in the configuration store.For valid values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


FetchWaveform Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurement..::.FetchWaveform Method
IIviScopeMeasurement See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveform ( _
    ByRef  WaveformArray As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveform(
    ref double[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveform(
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement
);

Parameters

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


FetchWaveformMeasurement Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurement..::.FetchWaveformMeasurement Method
IIviScopeMeasurement See Also

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformMeasurement ( _
    ByVal  MeasFunction As IviScopeMeasurementEnum  _
    ByRef  Measurement As Double  _
)
C#
public void  FetchWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    ref double  Measurement
)
Visual C++
HRESULT FetchWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


FetchWaveformMinMax Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurement..::.FetchWaveformMinMax Method
IIviScopeMeasurement See Also

-- NOT SUPPORTED -- Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub FetchWaveformMinMax ( _
    ByRef  MinWaveform As Double()   _
    ByRef  MaxWaveform As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  FetchWaveformMinMax(
    ref double[]   MinWaveform,
    ref double[]   MaxWaveform,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT FetchWaveformMinMax(
    SAFEARRAY**  MinWaveform,
    SAFEARRAY**  MaxWaveform,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


ReadWaveform Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurement..::.ReadWaveform Method
IIviScopeMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveform ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  WaveformArray As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveform(
    int  MaxTimeMilliseconds,
    ref double[]   WaveformArray,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveform(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  WaveformArray,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

WaveformArray

The array contains the acquired waveform.. Units for the individual array elements are in volts.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

XIncrement

The effective time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


ReadWaveformMeasurement Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurement..::.ReadWaveformMeasurement Method
IIviScopeMeasurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformMeasurement ( _
    ByVal  MeasFunction As IviScopeMeasurementEnum  _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  Measurement As Double  _
)
C#
public void  ReadWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    int  MaxTimeMilliseconds,
    ref double  Measurement
)
Visual C++
HRESULT ReadWaveformMeasurement(
    IviScopeMeasurementEnum  MeasFunction,
    long  MaxTimeMilliseconds,
    double*  Measurement
);

Parameters

MeasFunction

Characteristic of the acquired waveform to be measured.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


ReadWaveformMinMax Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurement..::.ReadWaveformMinMax Method
IIviScopeMeasurement See Also

-- NOT SUPPORTED -- Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub ReadWaveformMinMax ( _
    ByVal  MaxTimeMilliseconds As Integer  _
    ByRef  MinWaveform As Double()   _
    ByRef  MaxWaveform As Double()   _
    ByRef  InitialX As Double  _
    ByRef  XIncrement As Double  _
)
C#
public void  ReadWaveformMinMax(
    int  MaxTimeMilliseconds,
    ref double[]   MinWaveform,
    ref double[]   MaxWaveform,
    ref double  InitialX,
    ref double  XIncrement
)
Visual C++
HRESULT ReadWaveformMinMax(
    long  MaxTimeMilliseconds,
    SAFEARRAY**  MinWaveform,
    SAFEARRAY**  MaxWaveform,
    double*  InitialX,
    double*  XIncrement
);

Parameters

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

MinWaveform

This array contains the min waveform.

MaxWaveform

This array contains the max waveform.

InitialX

The time in relation to the Trigger Event of the first point in the waveform in seconds.

XIncrement

The time between points in the acquired waveform in seconds.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurement Interface
Ivi.Scope.Interop Namespace


Name Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.Name Property
IIviScopeMeasurements See Also

The measurement name for given index.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Name( _
    ByVal  Index As Integer  _
) As String
C#
public string  get_Name(
    int  Index
)
Visual C++
HRESULT get_Name(
    long  Index,
    BSTR*  val
);

Parameters

Index

One based index into the collection of measurements.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


Status Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements..::.Status Method
IIviScopeMeasurements See Also

Returns whether an acquisition is in progress, complete, or if the status is unknown.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Function Status ( _
) As IviScopeAcquisitionStatusEnum
C#
public IviScopeAcquisitionStatusEnum  Status(
)
Visual C++
HRESULT Status(
    IviScopeAcquisitionStatusEnum*  retval
);

Return Value

The acquisition status.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeMeasurements Interface
Ivi.Scope.Interop Namespace


ReferenceLevel Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScope..::.ReferenceLevel Property
IIviScope See Also

Pointer to the class-compliant IIviScopeReferenceLevel interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property ReferenceLevel As IIviScopeReferenceLevel
C#
public IIviScopeReferenceLevel  ReferenceLevel { get; }
Visual C++
HRESULT get_ReferenceLevel(
    IIviScopeReferenceLevel**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeReferenceLevel..::.Configure Method
IIviScopeReferenceLevel See Also

Configures the reference levels for waveform measurements, low, mid, and high.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Low As Double  _
    ByVal  Mid As Double  _
    ByVal  High As Double  _
)
C#
public void  Configure(
    double  Low,
    double  Mid,
    double  High
)
Visual C++
HRESULT Configure(
    double  Low,
    double  Mid,
    double  High
);

Parameters

Low

Measurement low reference. This value sets the Meas Low Ref property

Mid

Measurement mid reference. This value sets the Meas Mid Ref property.

High

Measurement high reference. This value sets the Meas High Ref property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


High Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeReferenceLevel..::.High Property
IIviScopeReferenceLevel See Also

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property High As Double
C#
public double  High { get; set; }
Visual C++
HRESULT get_High(
    double*  val
);
HRESULT put_High(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


Low Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeReferenceLevel..::.Low Property
IIviScopeReferenceLevel See Also

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Low As Double
C#
public double  Low { get; set; }
Visual C++
HRESULT get_Low(
    double*  val
);
HRESULT put_Low(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


Mid Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeReferenceLevel..::.Mid Property
IIviScopeReferenceLevel See Also

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Mid As Double
C#
public double  Mid { get; set; }
Visual C++
HRESULT get_Mid(
    double*  val
);
HRESULT put_Mid(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeReferenceLevel Interface
Ivi.Scope.Interop Namespace


Trigger Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScope..::.Trigger Property
IIviScope See Also

Pointer to the class-compliant IIviScopeTrigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Trigger As IIviScopeTrigger
C#
public IIviScopeTrigger  Trigger { get; }
Visual C++
HRESULT get_Trigger(
    IIviScopeTrigger**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScope Interface
Ivi.Scope.Interop Namespace


AcLine Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.AcLine Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerAcLine interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property AcLine As IIviScopeTriggerAcLine
C#
public IIviScopeTriggerAcLine  AcLine { get; }
Visual C++
HRESULT get_AcLine(
    IIviScopeTriggerAcLine**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Slope Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerAcLine..::.Slope Property
IIviScopeTriggerAcLine See Also

-- NOT SUPPORTED -- The slope of the zero crossing upon which the scope triggers.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Slope As IviScopeACLineSlopeEnum
C#
public IviScopeACLineSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    IviScopeACLineSlopeEnum*  val
);
HRESULT put_Slope(
    IviScopeACLineSlopeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerAcLine Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Configure Method
IIviScopeTrigger See Also

-- Not Supported -- Configures trigger Type and Holdoff. Holdoff units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Type As IviScopeTriggerTypeEnum  _
    ByVal  Holdoff As Double  _
)
C#
public void  Configure(
    IviScopeTriggerTypeEnum  Type,
    double  Holdoff
)
Visual C++
HRESULT Configure(
    IviScopeTriggerTypeEnum  Type,
    double  Holdoff
);

Parameters

Type

Specifies the trigger type. This value sets the Trigger Type property.

Holdoff

Specifies the trigger hold-off. This value sets the Trigger Holdoff property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Continuous Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Continuous Property
IIviScopeTrigger See Also

If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediatley enters the wait for trigger state without passing through the idle state.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Continuous As Boolean
C#
public bool  Continuous { get; set; }
Visual C++
HRESULT get_Continuous(
    VARIANT_BOOL*  val
);
HRESULT put_Continuous(
    VARIANT_BOOL  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Coupling Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Coupling Property
IIviScopeTrigger See Also

How the oscilloscope couples the trigger source.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Coupling As IviScopeTriggerCouplingEnum
C#
public IviScopeTriggerCouplingEnum  Coupling { get; set; }
Visual C++
HRESULT get_Coupling(
    IviScopeTriggerCouplingEnum*  val
);
HRESULT put_Coupling(
    IviScopeTriggerCouplingEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Edge Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Edge Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerEdge interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Edge As IIviScopeTriggerEdge
C#
public IIviScopeTriggerEdge  Edge { get; }
Visual C++
HRESULT get_Edge(
    IIviScopeTriggerEdge**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerEdge..::.Configure Method
IIviScopeTriggerEdge See Also

Configures the conidtions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  Slope As IviScopeTriggerSlopeEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    IviScopeTriggerSlopeEnum  Slope
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    IviScopeTriggerSlopeEnum  Slope
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

Slope

Specifies the trigger slope. This value sets the Trigger Slope property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerEdge Interface
Ivi.Scope.Interop Namespace


Slope Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerEdge..::.Slope Property
IIviScopeTriggerEdge See Also

The slope, a rising or a falling edge, that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Slope As IviScopeTriggerSlopeEnum
C#
public IviScopeTriggerSlopeEnum  Slope { get; set; }
Visual C++
HRESULT get_Slope(
    IviScopeTriggerSlopeEnum*  val
);
HRESULT put_Slope(
    IviScopeTriggerSlopeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerEdge Interface
Ivi.Scope.Interop Namespace


Glitch Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Glitch Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerGlitch interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Glitch As IIviScopeTriggerGlitch
C#
public IIviScopeTriggerGlitch  Glitch { get; }
Visual C++
HRESULT get_Glitch(
    IIviScopeTriggerGlitch**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerGlitch..::.condition Property
IIviScopeTriggerGlitch See Also

-- NOT SUPPORTED -- The glitch condition detemermines whether the oscilloscope triggers on a a pulse with a width less than or greater than the glitch width value.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property condition As IviScopeGlitchConditionEnum
C#
public IviScopeGlitchConditionEnum  condition { get; set; }
Visual C++
HRESULT get_condition(
    IviScopeGlitchConditionEnum*  val
);
HRESULT put_condition(
    IviScopeGlitchConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerGlitch..::.Configure Method
IIviScopeTriggerGlitch See Also

-- NOT SUPPORTED -- Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  Width As Double  _
    ByVal  polarity As IviScopeGlitchPolarityEnum  _
    ByVal  condition As IviScopeGlitchConditionEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    double  Width,
    IviScopeGlitchPolarityEnum  polarity,
    IviScopeGlitchConditionEnum  condition
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    double  Width,
    IviScopeGlitchPolarityEnum  polarity,
    IviScopeGlitchConditionEnum  condition
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

Level

Specifies the trigger level. This value sets the Trigger Level property.

Width

Specifies the glitch triggering glitch width in seconds. This value sets the Glitch Width property.

polarity

Specifies the glitch polarity. This value sets the Glitch Polarity property.

condition

Specifies the glitch condition. This value sets the Glitch Condition property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerGlitch..::.polarity Property
IIviScopeTriggerGlitch See Also

-- NOT SUPPORTED -- The polarity of the glitch that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeGlitchPolarityEnum
C#
public IviScopeGlitchPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeGlitchPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeGlitchPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


Width Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerGlitch..::.Width Property
IIviScopeTriggerGlitch See Also

-- NOT SUPPORTED -- The glitch width. The units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Width As Double
C#
public double  Width { get; set; }
Visual C++
HRESULT get_Width(
    double*  val
);
HRESULT put_Width(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerGlitch Interface
Ivi.Scope.Interop Namespace


Holdoff Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Holdoff Property
IIviScopeTrigger See Also

-- NOT SUPPORTED -- The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Holdoff As Double
C#
public double  Holdoff { get; set; }
Visual C++
HRESULT get_Holdoff(
    double*  val
);
HRESULT put_Holdoff(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Level Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Level Property
IIviScopeTrigger See Also

The voltage threshold for the trigger subsystem. The units are volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Level As Double
C#
public double  Level { get; set; }
Visual C++
HRESULT get_Level(
    double*  val
);
HRESULT put_Level(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Modifier Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Modifier Property
IIviScopeTrigger See Also

The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Modifier As IviScopeTriggerModifierEnum
C#
public IviScopeTriggerModifierEnum  Modifier { get; set; }
Visual C++
HRESULT get_Modifier(
    IviScopeTriggerModifierEnum*  val
);
HRESULT put_Modifier(
    IviScopeTriggerModifierEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Runt Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Runt Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerRunt interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Runt As IIviScopeTriggerRunt
C#
public IIviScopeTriggerRunt  Runt { get; }
Visual C++
HRESULT get_Runt(
    IIviScopeTriggerRunt**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerRunt..::.Configure Method
IIviScopeTriggerRunt See Also

-- NOT SUPPORTED -- Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  polarity As IviScopeRuntPolarityEnum  _
)
C#
public void  Configure(
    string  Source,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeRuntPolarityEnum  polarity
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeRuntPolarityEnum  polarity
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

ThresholdLow

Sets the runt triggering low threshold in volts.

ThresholdHigh

Sets the runt triggering high threshold in volts.

polarity

Sets the runt polarity.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerRunt..::.polarity Property
IIviScopeTriggerRunt See Also

-- NOT SUPPORTED -- The polarity of the runt that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeRuntPolarityEnum
C#
public IviScopeRuntPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeRuntPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeRuntPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerRunt..::.ThresholdHigh Property
IIviScopeTriggerRunt See Also

-- NOT SUPPORTED -- The high threshold the oscilloscope uses for runt triggering. The units are volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerRunt..::.ThresholdLow Property
IIviScopeTriggerRunt See Also

-- NOT SUPPORTED -- The low threshold the oscilloscope uses for runt triggering. The units are volts.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerRunt Interface
Ivi.Scope.Interop Namespace


Source Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Source Property
IIviScopeTrigger See Also

The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Source As String
C#
public string  Source { get; set; }
Visual C++
HRESULT get_Source(
    BSTR*  val
);
HRESULT put_Source(
    BSTR  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


TV Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.TV Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerTv interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property TV As IIviScopeTriggerTv
C#
public IIviScopeTriggerTv  TV { get; }
Visual C++
HRESULT get_TV(
    IIviScopeTriggerTv**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerTv..::.Configure Method
IIviScopeTriggerTv See Also

Configures the TV trigger source, signal format, event and polarity.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  SignalFormat As IviScopeTVSignalFormatEnum  _
    ByVal  Event As IviScopeTVTriggerEventEnum  _
    ByVal  polarity As IviScopeTVTriggerPolarityEnum  _
)
C#
public void  Configure(
    string  Source,
    IviScopeTVSignalFormatEnum  SignalFormat,
    IviScopeTVTriggerEventEnum  Event,
    IviScopeTVTriggerPolarityEnum  polarity
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    IviScopeTVSignalFormatEnum  SignalFormat,
    IviScopeTVTriggerEventEnum  Event,
    IviScopeTVTriggerPolarityEnum  polarity
);

Parameters

Source

Specifies the trigger source. This value sets the Trigger Source property.

SignalFormat

Specifies the TV trigger signal format. This value sets the TV Trigger Signal Format property.

Event

Specifies the TV trigger event. This value sets the TV Trigger Event property.

polarity

Specifies the polarity of the TV trigger. This value sets the TV Trigger Polarity property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


Event Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerTv..::.Event Property
IIviScopeTriggerTv See Also

The event on which the oscilloscope triggers.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Event As IviScopeTVTriggerEventEnum
C#
public IviScopeTVTriggerEventEnum  Event { get; set; }
Visual C++
HRESULT get_Event(
    IviScopeTVTriggerEventEnum*  val
);
HRESULT put_Event(
    IviScopeTVTriggerEventEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


LineNumber Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerTv..::.LineNumber Property
IIviScopeTriggerTv See Also

The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property LineNumber As Integer
C#
public int  LineNumber { get; set; }
Visual C++
HRESULT get_LineNumber(
    long*  val
);
HRESULT put_LineNumber(
    long  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerTv..::.polarity Property
IIviScopeTriggerTv See Also

The polarity of the TV signal.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeTVTriggerPolarityEnum
C#
public IviScopeTVTriggerPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeTVTriggerPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeTVTriggerPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


SignalFormat Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerTv..::.SignalFormat Property
IIviScopeTriggerTv See Also

The format of the TV signal on which the oscilloscope triggers.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property SignalFormat As IviScopeTVSignalFormatEnum
C#
public IviScopeTVSignalFormatEnum  SignalFormat { get; set; }
Visual C++
HRESULT get_SignalFormat(
    IviScopeTVSignalFormatEnum*  val
);
HRESULT put_SignalFormat(
    IviScopeTVSignalFormatEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerTv Interface
Ivi.Scope.Interop Namespace


Type Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Type Property
IIviScopeTrigger See Also

The kind of event that triggers the osciolloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property Type As IviScopeTriggerTypeEnum
C#
public IviScopeTriggerTypeEnum  Type { get; set; }
Visual C++
HRESULT get_Type(
    IviScopeTriggerTypeEnum*  val
);
HRESULT put_Type(
    IviScopeTriggerTypeEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


Width Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger..::.Width Property
IIviScopeTrigger See Also

Pointer to the class-compliant IIviScopeTriggerWidth interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public ReadOnly Property Width As IIviScopeTriggerWidth
C#
public IIviScopeTriggerWidth  Width { get; }
Visual C++
HRESULT get_Width(
    IIviScopeTriggerWidth**  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTrigger Interface
Ivi.Scope.Interop Namespace


condition Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerWidth..::.condition Property
IIviScopeTriggerWidth See Also

-- NOT SUPPORTED -- The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property condition As IviScopeWidthConditionEnum
C#
public IviScopeWidthConditionEnum  condition { get; set; }
Visual C++
HRESULT get_condition(
    IviScopeWidthConditionEnum*  val
);
HRESULT put_condition(
    IviScopeWidthConditionEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


Configure Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerWidth..::.Configure Method
IIviScopeTriggerWidth See Also

-- NOT SUPPORTED -- Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Sub Configure ( _
    ByVal  Source As String  _
    ByVal  Level As Double  _
    ByVal  ThresholdLow As Double  _
    ByVal  ThresholdHigh As Double  _
    ByVal  polarity As IviScopeWidthPolarityEnum  _
    ByVal  condition As IviScopeWidthConditionEnum  _
)
C#
public void  Configure(
    string  Source,
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeWidthPolarityEnum  polarity,
    IviScopeWidthConditionEnum  condition
)
Visual C++
HRESULT Configure(
    BSTR  Source,
    double  Level,
    double  ThresholdLow,
    double  ThresholdHigh,
    IviScopeWidthPolarityEnum  polarity,
    IviScopeWidthConditionEnum  condition
);

Parameters

Source

Specifies the trigger source. The driver uses this value to set the Trigger Source attribute. See the attribute description for more information.

Level

Trigger Level. This value sets the Trigger Level property.

ThresholdLow

Sets the width triggering low threshold in seconds. This value sets the Width Low Threshold property.

ThresholdHigh

Sets the width triggering high threshold in seconds. This value sets the Width High Threshold property.

polarity

Sets the width polarity. This value sets the Width Polarity property.

condition

Specifies whether a pulse that is within or outside the user-specified thresholds trigger waveform acquisition. This value sets the Width Condition property.

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


polarity Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerWidth..::.polarity Property
IIviScopeTriggerWidth See Also

-- NOT SUPPORTED -- The polarity of the pulse that triggers the oscilloscope.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property polarity As IviScopeWidthPolarityEnum
C#
public IviScopeWidthPolarityEnum  polarity { get; set; }
Visual C++
HRESULT get_polarity(
    IviScopeWidthPolarityEnum*  val
);
HRESULT put_polarity(
    IviScopeWidthPolarityEnum  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


ThresholdHigh Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerWidth..::.ThresholdHigh Property
IIviScopeTriggerWidth See Also

-- NOT SUPPORTED -- The high width threshold time. The units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdHigh As Double
C#
public double  ThresholdHigh { get; set; }
Visual C++
HRESULT get_ThresholdHigh(
    double*  val
);
HRESULT put_ThresholdHigh(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


ThresholdLow Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerWidth..::.ThresholdLow Property
IIviScopeTriggerWidth See Also

-- NOT SUPPORTED -- The low width threshold time. The units are seconds.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Property ThresholdLow As Double
C#
public double  ThresholdLow { get; set; }
Visual C++
HRESULT get_ThresholdLow(
    double*  val
);
HRESULT put_ThresholdLow(
    double  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviScopeTriggerWidth Interface
Ivi.Scope.Interop Namespace


IVI-COM Interfaces

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IVI-COM Interfaces

This section presents the functionality of the AgMD1 driver presented in a flat list of interfaces, organized by namespace. Each link below represents a namespace containing the interface definitions for instrument-specific interfaces, inherent capabilities (IIviDriver), etc.

Namespaces

Namespace
Agilent.AgMD1.Interop
Ivi.Driver.Interop
Ivi.Digitizer.Interop
Ivi.Scope.Interop
Top


Agilent.AgMD1.Interop Namespace

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Agilent.AgMD1.Interop Namespace

IVI AgMD1 1.4 Type Library

Classes

 | Class | Description
Public class | AgMD1 |
Public class | AgMD1ArmSource |
Public class | AgMD1Channel |
Public class | AgMD1DelayControl |
Public class | AgMD1LogicDevice |
Public class | AgMD1TriggerSource |

Interfaces

 | Interface | Description
Public interface | IAgMD1 | AgMD1 root interface.
Public interface | IAgMD1Acquisition | AgMD1 instrument-specific acquistion interface.
Public interface | IAgMD1Acquisition2 | IAgMD1Acquisition2 interface.
Public interface | IAgMD1AcquisitionStatus | AgMD1 instrument-specific acquistion status interface.
Public interface | IAgMD1Arm | IAgMD1Arm interface.
Public interface | IAgMD1Calibration | AgMD1 instrument-specific calibration interface.
Public interface | IAgMD1Calibration2 | IAgMD1Calibration2 interface.
Public interface | IAgMD1Channel | AgMD1 instrument-specific channel interface.
Public interface | IAgMD1Channel2 | IAgMD1Channel2 interface.
Public interface | IAgMD1Channel2Counter | IAgMD1Channel2Counter interface.
Public interface | IAgMD1Channel3 | IAgMD1Channel3 interface.
Public interface | IAgMD1Channel3Downconversion | IVI Digitizer class-compliant downconversion interface.
Public interface | IAgMD1ChannelDigitalDownconversion | IAgMD1ChannelDigitalDownconversion interface.
Public interface | IAgMD1ChannelFilter | AgMD1 instrument-specific channel filter interface.
Public interface | IAgMD1ChannelMeasurement | AgMD1 instrument-specific measurement interface.
Public interface | IAgMD1ChannelMultiRecordMeasurement | AgMD1 instrument-specific multi-record measurement interface.
Public interface | IAgMD1Channels | AgMD1 instrument-specific channels repeated capability collection interface.
Public interface | IAgMD1Channels2 | IAgMD1Channels2 interface.
Public interface | IAgMD1Channels3 | IAgMD1Channels3 interface.
Public interface | IAgMD1ControlIO | IAgMD1ControlIO interface.
Public interface | IAgMD1DelayControl | IAgMD1DelayControl interface.
Public interface | IAgMD1DelayControls | IAgMD1DelayControls interface.
Public interface | IAgMD1Ex | IAgMD1Ex interface.
Public interface | IAgMD1Ex2 | IAgMD1Ex2 interface.
Public interface | IAgMD1InstrumentInfo | IAgMD1SystemInstrumentInfo interface.
Public interface | IAgMD1InstrumentInfo2 | IAgMD1InstrumentInfo2 interface.
Public interface | IAgMD1LogicDevice | IAgMD1LogicDevice interface.
Public interface | IAgMD1LogicDevices | IAgMD1LogicDevices interface.
Public interface | IAgMD1MultiTrigger | AgMD1 instrument-specific multi-trigger interface.
Public interface | IAgMD1ReferenceLevel | AgMD1 instrument-specific reference level interface.
Public interface | IAgMD1ReferenceOscillator | AgMD1 instrument-specific reference oscillator interface.
Public interface | IAgMD1SampleClock | AgMD1 instrument-specific sample clock interface.
Public interface | IAgMD1System | AgMD1 instrument-specific system interface.
Public interface | IAgMD1Temperature | AgMD1 instrument-specific temperature interface.
Public interface | IAgMD1Trigger | AgMD1 instrument-specific trigger interface.
Public interface | IAgMD1Trigger2 | IAgMD1Trigger2 interface.
Public interface | IAgMD1Trigger3 | IAgMD1Trigger3 interface.
Public interface | IAgMD1TriggerEdge | AgMD1 instrument-specific edge triggering interface.
Public interface | IAgMD1TriggerMagnitude | IAgMD1TriggerMagnitude interface.
Public interface | IAgMD1TriggerMagnitude2 | IAgMD1TriggerMagnitude2 interface.
Public interface | IAgMD1TriggerOutput | IAgMD1TriggerOutput interface.
Public interface | IAgMD1TriggerOutput2 | IAgMD1TriggerOutput2 interface.
Public interface | IAgMD1TriggerSource | AgMD1 instrument-specific trigger source interface.
Public interface | IAgMD1TriggerSource2 | IAgMD1TriggerSource2 interface.
Public interface | IAgMD1TriggerSource3 | IAgMD1TriggerSource3 interface.
Public interface | IAgMD1TriggerSources | AgMD1 instrument-specific trigger sources repeated capability collection interface.
Public interface | IAgMD1TriggerSources2 | IAgMD1TriggerSources2 interface.
Public interface | IAgMD1TriggerSources3 | IAgMD1TriggerSources3 interface.
Public interface | IAgMD1TriggerTV | AgMD1 instrument-specific TV triggering interface.

Enumerations

 | Enumeration | Description
Public enumeration | AgMD1AcquisitionModeEnum | Defined values for the acquisition mode.
Public enumeration | AgMD1AcquisitionStatusResultEnum | Defined values for the acquisition status result.
Public enumeration | AgMD1AcquisitionTypeEnum | Defined values for scope Acquisition Type
Public enumeration | AgMD1CalibrateTypeEnum | Supported calibration types for the SelfCalibrate method.
Public enumeration | AgMD1CounterModeEnum | Defined values for the counter mode.
Public enumeration | AgMD1DelayControlRangeEnum |
Public enumeration | AgMD1ErrorCodesEnum |
Public enumeration | AgMD1MeasurementEnum | Defined values for the MeasFunction parameter of the ReadWaveformMeasurement and FetchWaveformMeasurement methods.
Public enumeration | AgMD1MeasurementWaveformTypeEnum | Waveform type used to calculate measurement function values by the FetchWaveformMeasuerment and ReadWaveformMeasurement methods.
Public enumeration | AgMD1ReferenceOscillatorSourceEnum | Defined values for the reference oscillator source.
Public enumeration | AgMD1SampleClockSourceEnum | Defined values for the sample clock source.
Public enumeration | AgMD1SampleModeEnum | Defined values for acquisition SampleMode.
Public enumeration | AgMD1TemperatureUnitsEnum | Defined values for the temperature units.
Public enumeration | AgMD1TimeOutEnum | Defined values for maxTime parameter of the measurement Read and Fetch methods.
Public enumeration | AgMD1TriggerCouplingEnum | Defined values for trigger Coupling.
Public enumeration | AgMD1TriggerModifierEnum | Defined values for trigger modifier.
Public enumeration | AgMD1TriggerSlopeEnum | Defined values for edge trigger slope.
Public enumeration | AgMD1TriggerSourceOperatorEnum | Defined values for the trigger source operator.
Public enumeration | AgMD1TriggerTypeEnum | Defined values for trigger type
Public enumeration | AgMD1TVSignalFormatEnum | Defined values for TV trigger SignalFormat
Public enumeration | AgMD1TVTriggerEventEnum | Defined values for TV trigger Event
Public enumeration | AgMD1TVTriggerPolarityEnum | Defined values for TV trigger Polarity
Public enumeration | AgMD1VerticalCouplingEnum | Defined values for channel Coupling.


AgMD1 Class

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1 Class
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Class AgMD1
C#
public class AgMD1
Visual C++
class AgMD1

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1ArmSource Class

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1ArmSource Class
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Class AgMD1ArmSource
C#
public class AgMD1ArmSource
Visual C++
class AgMD1ArmSource

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1Channel Class

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1Channel Class
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Class AgMD1Channel
C#
public class AgMD1Channel
Visual C++
class AgMD1Channel

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1DelayControl Class

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1DelayControl Class
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Class AgMD1DelayControl
C#
public class AgMD1DelayControl
Visual C++
class AgMD1DelayControl

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1LogicDevice Class

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1LogicDevice Class
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Class AgMD1LogicDevice
C#
public class AgMD1LogicDevice
Visual C++
class AgMD1LogicDevice

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TriggerSource Class

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TriggerSource Class
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Class AgMD1TriggerSource
C#
public class AgMD1TriggerSource
Visual C++
class AgMD1TriggerSource

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1 Interface
See Also

AgMD1 root interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1
   Inherits IIviDriver
C#
public interface IAgMD1 : IIviDriver
Visual C++
__interface IAgMD1 : IIviDriver

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgMD1Acquistion interface.
Public property | Arm | Pointer to the IAgMD1Arm interface.
Public property | Calibration | Pointer to the IAgMD1Calibration interface.
Public property | Channels | Pointer to the IAgMD1Channels interface.
Public property | ControlIO | Pointer to the IAgMD1ControlIO interface.
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | InstrumentInfo | Pointer to the IAgMD1SystemInstrumentInfo interface.
Public property | ReferenceLevel | Pointer to the IAgMD1ReferenceLevel interface
Public property | ReferenceOscillator | Pointer to the IAgMD1Reference Oscillator interface.
Public property | SampleClock | Pointer to the IAgMD1SampleClock interface.
Public property | System | Pointer to the IAgMD1System interface.
Public property | Temperature | Pointer to the IAgMD1Temperature interface.
Public property | Trigger | Pointer to the IAgMD1Trigger interface.
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Acquisition Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition Interface
See Also

AgMD1 instrument-specific acquistion interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Acquisition
C#
public interface IAgMD1Acquisition
Visual C++
__interface IAgMD1Acquisition

Properties

 | Name | Description
Public property | DitherEnabled | If true, enables dithering. Requires model: M9202A
Public property | DitherRange | Sets amplitude of dithering signal. Range: 0 to 31. 0 = dithering amplitude is 0 (i. e. no dithering). 31 = dithering amplitude is Full Scale/2 = 500 mV. Requires model: M9202A
Public property | MaxFirstValidPointValue | Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
Public property | MaxSamplesPerChannel | Returns the maximum number of samples per channel that can be captured.
Public property | MinRecordSize | Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.
Public property | Mode | The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
Public property | NumAcquiredRecords | Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.
Public property | NumberOfAverages | The number of waveforms the digitizer acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.
Public property | NumRecordsToAcquire | Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
Public property | RecordSize | Specifies the number of samples to acquire in each waveform record.
Public property | SampleMode | -- Always RealTime mode -- Specifies the sample mode used by the digitizer.
Public property | SampleRate | Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Public property | Status | Pointer to the IAgMD1AcquisitionStatus interface.
Public property | TimeInterleavedChannelListAuto | -- Always false -- Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
Public property | TimePerRecord | The time in seconds that corresponds to the record length.
Public property | Type | How the oscilloscope acquires data and fills the waveform record. When set to TypeAverage, averaged waveforms must be read uisng the Measurement ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods.
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the digitizer to the Idle state.
Public method | ConfigureAcquisition | This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Public method | Initiate | Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.
Public method | QueryMinWaveformMemory | This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.
Public method | WaitForAcquisitionComplete | Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Acquisition2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Acquisition2 Interface
See Also

IAgMD1Acquisition2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Acquisition2
   Inherits IAgMD1Acquisition
C#
public interface IAgMD1Acquisition2 : IAgMD1Acquisition
Visual C++
__interface IAgMD1Acquisition2 : IAgMD1Acquisition

Properties

 | Name | Description
Public property | DitherEnabled | If true, enables dithering. Requires model: M9202A (Inherited from IAgMD1Acquisition.)
Public property | DitherRange | Sets amplitude of dithering signal. Range: 0 to 31. 0 = dithering amplitude is 0 (i. e. no dithering). 31 = dithering amplitude is Full Scale/2 = 500 mV. Requires model: M9202A (Inherited from IAgMD1Acquisition.)
Public property | DownconversionDataScalingEnabled | Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
Public property | MaxFirstValidPointValue | Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition. (Inherited from IAgMD1Acquisition.)
Public property | MaxSamplesPerChannel | Returns the maximum number of samples per channel that can be captured. (Inherited from IAgMD1Acquisition.)
Public property | MinRecordSize | Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1. (Inherited from IAgMD1Acquisition.)
Public property | Mode | The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A (Inherited from IAgMD1Acquisition.)
Public property | NumAcquiredRecords | Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress. (Inherited from IAgMD1Acquisition.)
Public property | NumberOfAverages | The number of waveforms the digitizer acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage. (Inherited from IAgMD1Acquisition.)
Public property | NumRecordsToAcquire | Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger. (Inherited from IAgMD1Acquisition.)
Public property | RecordSize | Specifies the number of samples to acquire in each waveform record. (Inherited from IAgMD1Acquisition.)
Public property | SampleMode | -- Always RealTime mode -- Specifies the sample mode used by the digitizer. (Inherited from IAgMD1Acquisition.)
Public property | SampleRate | Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record. (Inherited from IAgMD1Acquisition.)
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger. (Inherited from IAgMD1Acquisition.)
Public property | Status | Pointer to the IAgMD1AcquisitionStatus interface. (Inherited from IAgMD1Acquisition.)
Public property | TimeInterleavedChannelListAuto | -- Always false -- Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute. (Inherited from IAgMD1Acquisition.)
Public property | TimePerRecord | The time in seconds that corresponds to the record length. (Inherited from IAgMD1Acquisition.)
Public property | Type | How the oscilloscope acquires data and fills the waveform record. When set to TypeAverage, averaged waveforms must be read uisng the Measurement ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. (Inherited from IAgMD1Acquisition.)
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the digitizer to the Idle state. (Inherited from IAgMD1Acquisition.)
Public method | ConfigureAcquisition | This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate. (Inherited from IAgMD1Acquisition.)
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time. (Inherited from IAgMD1Acquisition.)
Public method | Initiate | Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel. (Inherited from IAgMD1Acquisition.)
Public method | QueryMinWaveformMemory | This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance. (Inherited from IAgMD1Acquisition.)
Public method | WaitForAcquisitionComplete | Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error. (Inherited from IAgMD1Acquisition.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1AcquisitionStatus Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1AcquisitionStatus Interface
See Also

AgMD1 instrument-specific acquistion status interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1AcquisitionStatus
C#
public interface IAgMD1AcquisitionStatus
Visual C++
__interface IAgMD1AcquisitionStatus

Properties

 | Name | Description
Public property | IsIdle | Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Public property | IsMeasuring | Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Public property | IsWaitingForArm | Returns whether the device is currently in the Waiting For Arm state. If true, acquisition has been initiated and is waiting for an arm signal from Arm.SendSoftwareArm method to enable triggering. Requires model: M9202A
Public property | IsWaitingForTrigger | Returns whether the device is currently in the Waiting For Trigger state. If true, acquisition has been initiated, armed, and is waiting for a trigger. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Arm Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Arm Interface
See Also

IAgMD1Arm interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Arm
C#
public interface IAgMD1Arm
Visual C++
__interface IAgMD1Arm

Properties

 | Name | Description
Public property | Enabled | If true, auto arming is enabled. If false, after an acquisition has been initiated, SendSoftwareArm method must be called before any triggers will be accepted. Requires model: M9202A
Top

Methods

 | Name | Description
Public method | SendSoftwareArm | When Arm.Enabled is true and an acquisition has been initiated, arms the system to accept triggers. Requires model: M9202A
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Calibration Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration Interface
See Also

AgMD1 instrument-specific calibration interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Calibration
C#
public interface IAgMD1Calibration
Visual C++
__interface IAgMD1Calibration

Methods

 | Name | Description
Public method | CalRequired | Check if a self calibration is needed on the specified channel.
Public method | Cancel | Abort any running self-calibration and return.
Public method | LoadCal | Load calibration values and info from file.
Public method | SaveCal | Save calibration values and info in a binary file.
Public method | SelfCalibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Calibration2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Calibration2 Interface
See Also

IAgMD1Calibration2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Calibration2
   Inherits IAgMD1Calibration
C#
public interface IAgMD1Calibration2 : IAgMD1Calibration
Visual C++
__interface IAgMD1Calibration2 : IAgMD1Calibration

Properties

 | Name | Description
Public property | DelayControls | Pointer to the IAgMD1DelayControls interface.
Top

Methods

 | Name | Description
Public method | CalRequired | Check if a self calibration is needed on the specified channel. (Inherited from IAgMD1Calibration.)
Public method | Cancel | Abort any running self-calibration and return. (Inherited from IAgMD1Calibration.)
Public method | LoadCal | Load calibration values and info from file. (Inherited from IAgMD1Calibration.)
Public method | SaveCal | Save calibration values and info in a binary file. (Inherited from IAgMD1Calibration.)
Public method | SelfCalibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds. (Inherited from IAgMD1Calibration.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channel Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel Interface
See Also

AgMD1 instrument-specific channel interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channel
C#
public interface IAgMD1Channel
Visual C++
__interface IAgMD1Channel

Properties

 | Name | Description
Public property | ConnectorName | The connector name as it appears on the instrument's front panel.
Public property | Coupling | Specifies how the digitizer couples the input signal for the channel.
Public property | DigitalDownconversion | Pointer to the IAgMD1ChannelDigitalDownconversion interface. Requires Model: M9202A
Public property | Enabled | Specifies whether the digitizer acquires a waveform for the channel.
Public property | Filter | Pointer to the IIviDigitizerFilterinterface.
Public property | InputConnectorSelection | Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1 (connector A), 2 (connector B).
Public property | InputFrequencyMax | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth).
Public property | InputImpedance | The input impedance of this channel. The units are Ohms.
Public property | Measurement | Pointer to the IAgMD1ChannelMeasurement interface.
Public property | MultiRecordMeasurement | Pointer to the IAgMD1ChannelMultiRecordMeasurement interface.
Public property | Offset | The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Public property | ProbeSense | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Public property | Range | The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Public property | Temperature | Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.
Public property | TimeInterleavedChannelList | This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.
Top

Methods

 | Name | Description
Public method | Configure | This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channel2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel2 Interface
See Also

IAgMD1Channel2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channel2
   Inherits IAgMD1Channel
C#
public interface IAgMD1Channel2 : IAgMD1Channel
Visual C++
__interface IAgMD1Channel2 : IAgMD1Channel

Properties

 | Name | Description
Public property | ConnectorName | The connector name as it appears on the instrument's front panel. (Inherited from IAgMD1Channel.)
Public property | Counter | Pointer to the IAgMD1Channel2Counter interface.
Public property | Coupling | Specifies how the digitizer couples the input signal for the channel. (Inherited from IAgMD1Channel.)
Public property | DigitalDownconversion | Pointer to the IAgMD1ChannelDigitalDownconversion interface. Requires Model: M9202A (Inherited from IAgMD1Channel.)
Public property | Enabled | Specifies whether the digitizer acquires a waveform for the channel. (Inherited from IAgMD1Channel.)
Public property | Filter | Pointer to the IIviDigitizerFilterinterface. (Inherited from IAgMD1Channel.)
Public property | InputConnectorSelection | Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1 (connector A), 2 (connector B). (Inherited from IAgMD1Channel.)
Public property | InputFrequencyMax | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth). (Inherited from IAgMD1Channel.)
Public property | InputImpedance | The input impedance of this channel. The units are Ohms. (Inherited from IAgMD1Channel.)
Public property | Measurement | Pointer to the IAgMD1ChannelMeasurement interface. (Inherited from IAgMD1Channel.)
Public property | MultiRecordMeasurement | Pointer to the IAgMD1ChannelMultiRecordMeasurement interface. (Inherited from IAgMD1Channel.)
Public property | Offset | The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts. (Inherited from IAgMD1Channel.)
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0. (Inherited from IAgMD1Channel.)
Public property | ProbeSense | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting. (Inherited from IAgMD1Channel.)
Public property | Range | The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts. (Inherited from IAgMD1Channel.)
Public property | Temperature | Indicates the temperature of the channel. The units are governed by the Temperature Units attribute. (Inherited from IAgMD1Channel.)
Public property | TimeInterleavedChannelList | This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names. (Inherited from IAgMD1Channel.)
Top

Methods

 | Name | Description
Public method | Configure | This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled. (Inherited from IAgMD1Channel.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channel2Counter Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel2Counter Interface
See Also

IAgMD1Channel2Counter interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channel2Counter
C#
public interface IAgMD1Channel2Counter
Visual C++
__interface IAgMD1Channel2Counter

Properties

 | Name | Description
Public property | ApertureTime | The minimum measurement time for Frequency and Period modes. The duration to count input pulses for TotalizeGate mode. The Counter.Read method will wait this time before returning measurement data. Units are seconds.
Public property | Mode | The mode for counter measurements, Frequency, Period, TotalizeTime, or TotalizeGate.
Top

Methods

 | Name | Description
Public method | Read | Counter measurement results for the current mode. Counter must be enabled by setting Acquisition.Mode = AgMD1AcquisitionModeCounter. The Read method will wait the current ApertureTime before returning measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channel3 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel3 Interface
See Also

IAgMD1Channel3 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channel3
   Inherits IAgMD1Channel2
C#
public interface IAgMD1Channel3 : IAgMD1Channel2
Visual C++
__interface IAgMD1Channel3 : IAgMD1Channel2

Properties

 | Name | Description
Public property | ConnectorName | The connector name as it appears on the instrument's front panel. (Inherited from IAgMD1Channel.)
Public property | Counter | Pointer to the IAgMD1Channel2Counter interface. (Inherited from IAgMD1Channel2.)
Public property | Coupling | Specifies how the digitizer couples the input signal for the channel. (Inherited from IAgMD1Channel.)
Public property | DigitalDownconversion | Pointer to the IAgMD1ChannelDigitalDownconversion interface. Requires Model: M9202A (Inherited from IAgMD1Channel.)
Public property | Downconversion | Pointer to the IIviDigitizerDownconversion interface.
Public property | Enabled | Specifies whether the digitizer acquires a waveform for the channel. (Inherited from IAgMD1Channel.)
Public property | Filter | Pointer to the IIviDigitizerFilterinterface. (Inherited from IAgMD1Channel.)
Public property | InputConnectorSelection | Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1 (connector A), 2 (connector B). (Inherited from IAgMD1Channel.)
Public property | InputFrequencyMax | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth). (Inherited from IAgMD1Channel.)
Public property | InputImpedance | The input impedance of this channel. The units are Ohms. (Inherited from IAgMD1Channel.)
Public property | Measurement | Pointer to the IAgMD1ChannelMeasurement interface. (Inherited from IAgMD1Channel.)
Public property | MultiRecordMeasurement | Pointer to the IAgMD1ChannelMultiRecordMeasurement interface. (Inherited from IAgMD1Channel.)
Public property | Offset | The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts. (Inherited from IAgMD1Channel.)
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0. (Inherited from IAgMD1Channel.)
Public property | ProbeSense | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting. (Inherited from IAgMD1Channel.)
Public property | Range | The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts. (Inherited from IAgMD1Channel.)
Public property | Temperature | Indicates the temperature of the channel. The units are governed by the Temperature Units attribute. (Inherited from IAgMD1Channel.)
Public property | TimeInterleavedChannelList | This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names. (Inherited from IAgMD1Channel.)
Top

Methods

 | Name | Description
Public method | Configure | This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled. (Inherited from IAgMD1Channel.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channel3Downconversion Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channel3Downconversion Interface
See Also

IVI Digitizer class-compliant downconversion interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channel3Downconversion
C#
public interface IAgMD1Channel3Downconversion
Visual C++
__interface IAgMD1Channel3Downconversion

Properties

 | Name | Description
Public property | CenterFrequency | Specifies the center frequency, in Hz, from which the digitizer should downconvert.
Public property | Enabled | Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.
Public property | IQInterleaved | Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.
Top

Methods

 | Name | Description
Public method | Configure | Configures how the digitizer performs downconversion.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1ChannelDigitalDownconversion Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelDigitalDownconversion Interface
See Also

IAgMD1ChannelDigitalDownconversion interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1ChannelDigitalDownconversion
C#
public interface IAgMD1ChannelDigitalDownconversion
Visual C++
__interface IAgMD1ChannelDigitalDownconversion

Properties

 | Name | Description
Public property | DataBandwidth | The output bandwidth in Hz for down-converted data. Range: 250e6, 200e6, 100e6, 50e6 etc following progression f(n+1) = f(n)/ 2, down to 2GHz/(2^21) = about 1 kHz. Requires Model: M9202A
Public property | DoubleDataRateEnabled | False = simple data rate (Samples / second = 1.25*bandwidth), True = double data rate (Samples / second = 2.5*bandwidth) Note: only applies for DataBandwidth values of 1.0e8 and below. Requires Model: M9202A
Public property | FlipBandEnabled | True = First frequency shift is by -500MHz. False = First frequency shift is by +500MHz. Requires Model: M9202A
Public property | FrequencyShift | Decoded to set up the frequency shift blocks of the down converter. The value of this attribute corresponds to the data frequency shift; trigger frequency shift is the nearest value available with the given TriggerBandwidth. I. e. the trigger frequency shift equals FrequencyShift if TriggerBandwidth <= DataBandwidth; otherwise it is rounded to the nearest multiple of TriggerBandwidth*2.5/4. Range: -125e6 to +125e6, step = DataBandwidth *2.5 / 4. Requires Model: M9202A
Public property | TriggerBandwidth | The output bandwidth in Hz for down-converted trigger. Requires Model: M9202A
Top

Methods

 | Name | Description
Public method | Configure | Configures the DigitalDownconverson DataBandwidth and TriggerBandwidth. Requires Model: M9202A
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1ChannelFilter Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelFilter Interface
See Also

AgMD1 instrument-specific channel filter interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1ChannelFilter
C#
public interface IAgMD1ChannelFilter
Visual C++
__interface IAgMD1ChannelFilter

Properties

 | Name | Description
Public property | Bypass | Specifies whether or not to bypass the input filter.
Public property | MaxFrequency | Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1ChannelMeasurement Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMeasurement Interface
See Also

AgMD1 instrument-specific measurement interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1ChannelMeasurement
C#
public interface IAgMD1ChannelMeasurement
Visual C++
__interface IAgMD1ChannelMeasurement

Properties

 | Name | Description
Public property | WaveformType | The waveform type used to calculate the various measurement functions by the FetchWaveformMeasurement and ReadWaveformMeasurement methods.
Top

Methods

 | Name | Description
Public method | FetchWaveformInt16 | This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchWaveformInt32 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchWaveformInt8 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Public method | FetchWaveformReal64 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.
Public method | ReadWaveformInt16 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | ReadWaveformInt32 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | ReadWaveformInt8 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Public method | ReadWaveformReal64 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1ChannelMultiRecordMeasurement Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ChannelMultiRecordMeasurement Interface
See Also

AgMD1 instrument-specific multi-record measurement interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1ChannelMultiRecordMeasurement
C#
public interface IAgMD1ChannelMultiRecordMeasurement
Visual C++
__interface IAgMD1ChannelMultiRecordMeasurement

Methods

 | Name | Description
Public method | FetchMultiRecordWaveformInt16 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchMultiRecordWaveformInt32 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchMultiRecordWaveformInt8 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchMultiRecordWaveformReal64 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channels Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels Interface
See Also

AgMD1 instrument-specific channels repeated capability collection interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channels
C#
public interface IAgMD1Channels
Visual C++
__interface IAgMD1Channels

Properties

 | Name | Description
Public property | ActiveInputs | String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc.
Public property | ConvertersPerChannel | The number of converters currently assigned to each channel.
Public property | Count | Returns the number of Channels.
Public property | Item | Pointer to the IAgMD1Channel interface.
Public property | Name | Returns the Channel name for a given index.
Public property | ReferenceChannel | The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ...
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channels2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels2 Interface
See Also

IAgMD1Channels2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channels2
   Inherits IAgMD1Channels
C#
public interface IAgMD1Channels2 : IAgMD1Channels
Visual C++
__interface IAgMD1Channels2 : IAgMD1Channels

Properties

 | Name | Description
Public property | ActiveInputs | String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc. (Inherited from IAgMD1Channels.)
Public property | ConvertersPerChannel | The number of converters currently assigned to each channel. (Inherited from IAgMD1Channels.)
Public property | Count | Returns the number of Channels. (Inherited from IAgMD1Channels.)
Public property | Item | Pointer to the IAgMD1Channel interface. (Inherited from IAgMD1Channels.)
Public property | Item2 | Pointer to the IAgMD1Channel interface.
Public property | Name | Returns the Channel name for a given index. (Inherited from IAgMD1Channels.)
Public property | ReferenceChannel | The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ... (Inherited from IAgMD1Channels.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Channels3 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Channels3 Interface
See Also

IAgMD1Channels3 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Channels3
   Inherits IAgMD1Channels2
C#
public interface IAgMD1Channels3 : IAgMD1Channels2
Visual C++
__interface IAgMD1Channels3 : IAgMD1Channels2

Properties

 | Name | Description
Public property | ActiveInputs | String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc. (Inherited from IAgMD1Channels.)
Public property | ConvertersPerChannel | The number of converters currently assigned to each channel. (Inherited from IAgMD1Channels.)
Public property | Count | Returns the number of Channels. (Inherited from IAgMD1Channels.)
Public property | Item | Pointer to the IAgMD1Channel interface. (Inherited from IAgMD1Channels.)
Public property | Item2 | Pointer to the IAgMD1Channel interface. (Inherited from IAgMD1Channels2.)
Public property | Item3 | Pointer to the IAgMD1Channel interface.
Public property | Name | Returns the Channel name for a given index. (Inherited from IAgMD1Channels.)
Public property | ReferenceChannel | The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ... (Inherited from IAgMD1Channels.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1ControlIO Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ControlIO Interface
See Also

IAgMD1ControlIO interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1ControlIO
C#
public interface IAgMD1ControlIO
Visual C++
__interface IAgMD1ControlIO

Properties

 | Name | Description
Public property | SignalA | Signal present on Control IO connector A. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Public property | SignalB | Signal present on Control IO connector B. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Public property | SignalC | Signal present on Control IO connector C if present. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1DelayControl Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControl Interface
See Also

IAgMD1DelayControl interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1DelayControl
C#
public interface IAgMD1DelayControl
Visual C++
__interface IAgMD1DelayControl

Properties

 | Name | Description
Public property | Max | Maximum value (DAC code) that can be set for the delay control.
Public property | Min | Minimum value (DAC code) that can be set for the delay control.
Public property | Range | Selects the range for the delay control. Useful only for delay controls with multiple ranges.
Public property | Value | The value (DAC code) set for the delay control.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1DelayControls Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1DelayControls Interface
See Also

IAgMD1DelayControls interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1DelayControls
C#
public interface IAgMD1DelayControls
Visual C++
__interface IAgMD1DelayControls

Properties

 | Name | Description
Public property | Count | Returns the number of delay controls.
Public property | Enabled | Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
Public property | Item | Pointer to the IAgMD1DelayControl interface.
Public property | Name | Returns the delay control name for a given index.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Ex Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Ex Interface
See Also

IAgMD1Ex interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Ex
   Inherits IAgMD1
C#
public interface IAgMD1Ex : IAgMD1
Visual C++
__interface IAgMD1Ex : IAgMD1

Properties

 | Name | Description
Public property | Acquisition | Pointer to the IAgMD1Acquistion interface. (Inherited from IAgMD1.)
Public property | Arm | Pointer to the IAgMD1Arm interface. (Inherited from IAgMD1.)
Public property | Calibration | Pointer to the IAgMD1Calibration interface. (Inherited from IAgMD1.)
Public property | Channels | Pointer to the IAgMD1Channels interface. (Inherited from IAgMD1.)
Public property | Channels2 | Pointer to the IAgMD1Channels interface.
Public property | ControlIO | Pointer to the IAgMD1ControlIO interface. (Inherited from IAgMD1.)
Public property | DriverOperation | Pointer to the IIviDriverOperation interface (Inherited from IIviDriver.)
Public property | Identity | Pointer to the IIviDriverIdentity interface (Inherited from IIviDriver.)
Public property | Initialized | Initialized is True between a successful call to the Initialize method and a successful call to the Close method, and False at all other times. (Inherited from IIviDriver.)
Public property | InstrumentInfo | Pointer to the IAgMD1SystemInstrumentInfo interface. (Inherited from IAgMD1.)
Public property | InstrumentInfo2 | Pointer to the IAgMD1SystemInstrumentInfo2 interface.
Public property | ReferenceLevel | Pointer to the IAgMD1ReferenceLevel interface (Inherited from IAgMD1.)
Public property | ReferenceOscillator | Pointer to the IAgMD1Reference Oscillator interface. (Inherited from IAgMD1.)
Public property | SampleClock | Pointer to the IAgMD1SampleClock interface. (Inherited from IAgMD1.)
Public property | System | Pointer to the IAgMD1System interface. (Inherited from IAgMD1.)
Public property | Temperature | Pointer to the IAgMD1Temperature interface. (Inherited from IAgMD1.)
Public property | Trigger | Pointer to the IAgMD1Trigger interface. (Inherited from IAgMD1.)
Public property | Trigger2 | Pointer to the IAgMD1Trigger interface.
Public property | Utility | Pointer to the IIviDriverUtility interface (Inherited from IIviDriver.)
Top

Methods

 | Name | Description
Public method | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called. (Inherited from IIviDriver.)
Public method | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model. (Inherited from IIviDriver.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1InstrumentInfo Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo Interface
See Also

IAgMD1SystemInstrumentInfo interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1InstrumentInfo
C#
public interface IAgMD1InstrumentInfo
Visual C++
__interface IAgMD1InstrumentInfo

Properties

 | Name | Description
Public property | AqDrvVersion | Version of the AqDrv Device Driver. Read only
Public property | AqIOVersion | Version of the Agilent Acqiris IO Driver. Read only
Public property | BusNumber | PCI Bus number. Read only
Public property | CPLDFirmwareRev | Revision of the CPLD Firmware. Read only
Public property | CrateNumber | Crate number. Starts at 121000 for autodetected CC121 crates. Read only
Public property | DeviceID | PCI Device ID. Read only
Public property | EEPROMCommonSectionRev | Revision of the EEPROM Common Section. Read only
Public property | EEPROMDigitizerSectionRev | Revision of the EEPROM Digitizer Section. Read only
Public property | HasHighResSampleRate | True if the instrument features a high resolution sampling rate. Read only
Public property | NbrADCBits | Number of bits of data per sample from this module's ADCs. Read only
Public property | NbrExternalTriggers | Number of external trigger sources. Read only
Public property | NbrInternalTriggers | Number of internal trigger sources. Read only
Public property | NbrModulesInInstrument | Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1. Read only
Public property | Options | List of comma separated options installed in this instrument. Read only
Public property | SerialNumber | Deprecated - Do not use. Use SerialNumberString. The serial number of the instrument. Read only
Public property | SlotNumber | The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates). Read only
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1InstrumentInfo2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1InstrumentInfo2 Interface
See Also

IAgMD1InstrumentInfo2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1InstrumentInfo2
   Inherits IAgMD1InstrumentInfo
C#
public interface IAgMD1InstrumentInfo2 : IAgMD1InstrumentInfo
Visual C++
__interface IAgMD1InstrumentInfo2 : IAgMD1InstrumentInfo

Properties

 | Name | Description
Public property | AqDrvVersion | Version of the AqDrv Device Driver. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | AqIOVersion | Version of the Agilent Acqiris IO Driver. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | BusNumber | PCI Bus number. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | CPLDFirmwareRev | Revision of the CPLD Firmware. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | CrateNumber | Crate number. Starts at 121000 for autodetected CC121 crates. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | DeviceID | PCI Device ID. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | EEPROMCommonSectionRev | Revision of the EEPROM Common Section. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | EEPROMDigitizerSectionRev | Revision of the EEPROM Digitizer Section. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | FundamentalHandle | Returns the Int32 equivalent ViSession handle to the fundamental API used to control the module hardware. Never call the fundamental Acqrs_close or Acqrs_closeAll functions with this handle or the driver will cease to operate. Use the IVI driver's Close method instead.
Public property | HasHighResSampleRate | True if the instrument features a high resolution sampling rate. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | NbrADCBits | Number of bits of data per sample from this module's ADCs. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | NbrExternalTriggers | Number of external trigger sources. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | NbrInternalTriggers | Number of internal trigger sources. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | NbrModulesInInstrument | Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | Options | List of comma separated options installed in this instrument. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | SerialNumber | Deprecated - Do not use. Use SerialNumberString. The serial number of the instrument. Read only (Inherited from IAgMD1InstrumentInfo.)
Public property | SerialNumberString | The serial number string of the instrument. Read only
Public property | SlotNumber | The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates). Read only (Inherited from IAgMD1InstrumentInfo.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1LogicDevice Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevice Interface
See Also

IAgMD1LogicDevice interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1LogicDevice
C#
public interface IAgMD1LogicDevice
Visual C++
__interface IAgMD1LogicDevice

Methods

 | Name | Description
Public method | LoadLogicDeviceFromFile | Loads the bit file at the file system path Path into the FPGA(s) identified by the LogicDevice repeated capability.
Public method | ReadIndirectInt32 | Reads up to NumElements 32 bit integers of the Indirect Buffer with identifier Id from the FPGA identified by LogicDevice repeated capagility into the memory referenced by Data.
Public method | ReadRegisterInt32 | Reads a 32 bits integer value from the register at Offset in the FPGA identified by LogicDevice repeated capability.
Public method | WriteIndirectInt32 | Writes the contents of Data to the Indirect Buffer with identifier Id of the FPGA identified by LogicDevice repeated capability.
Public method | WriteRegisterInt32 | Writes the 32 bits integer value Value to the register at Offset in the FPGA identified by LogicDevice repeated capability.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1LogicDevices Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1LogicDevices Interface
See Also

IAgMD1LogicDevices interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1LogicDevices
C#
public interface IAgMD1LogicDevices
Visual C++
__interface IAgMD1LogicDevices

Properties

 | Name | Description
Public property | Count | Returns the number of logic devices.
Public property | Item | Pointer to the IAgMD1LogicDevice interface.
Public property | Name | Returns the logic device name for a given index.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1MultiTrigger Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1MultiTrigger Interface
See Also

AgMD1 instrument-specific multi-trigger interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1MultiTrigger
C#
public interface IAgMD1MultiTrigger
Visual C++
__interface IAgMD1MultiTrigger

Properties

 | Name | Description
Public property | SourceList | A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.
Public property | SourceOperator | Specifies the boolean operation to apply to the arm sources specified by the SourceList property. If set to None, muti triggering is disabled. A valid SourceList must be set before setting the SourceOperator to AND or OR. See the help for SourceList for more info.
Top

Methods

 | Name | Description
Public method | Configure | Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1ReferenceLevel Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceLevel Interface
See Also

AgMD1 instrument-specific reference level interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1ReferenceLevel
C#
public interface IAgMD1ReferenceLevel
Visual C++
__interface IAgMD1ReferenceLevel

Properties

 | Name | Description
Public property | High | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Low | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Mid | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Top

Methods

 | Name | Description
Public method | Configure | Configures the reference levels for waveform measurements, low, mid, and high.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1ReferenceOscillator Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1ReferenceOscillator Interface
See Also

AgMD1 instrument-specific reference oscillator interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1ReferenceOscillator
C#
public interface IAgMD1ReferenceOscillator
Visual C++
__interface IAgMD1ReferenceOscillator

Properties

 | Name | Description
Public property | ExternalFrequency | Read only. The frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
Public property | OutputEnabled | Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.
Public property | Source | Specifies the reference frequency source used.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1SampleClock Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1SampleClock Interface
See Also

AgMD1 instrument-specific sample clock interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1SampleClock
C#
public interface IAgMD1SampleClock
Visual C++
__interface IAgMD1SampleClock

Properties

 | Name | Description
Public property | ExternalDivider | Read only, the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
Public property | ExternalFrequency | Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
Public property | Source | Specifies the clock used to pace acquisition sampling.
Top

Methods

 | Name | Description
Public method | Configure | Configures the digitizer's sample clock.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1System Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1System Interface
See Also

AgMD1 instrument-specific system interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1System
C#
public interface IAgMD1System
Visual C++
__interface IAgMD1System

Properties

 | Name | Description
Public property | NbrInstruments | The number of instruments supporting the AgMD1 driver in the system. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Read only
Public property | TraceEnabled | If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.
Top

Methods

 | Name | Description
Public method | PowerOffAll | Forces all instruments to prepare and enter the system power down state. Suspend all other calling threads. If a thread is performing a long operation which cannot be completed within milliseconds (e.g. a self-calibration), it will be interrupted immediately and will return the status 'ACQIRIS_ERROR_OPERATION_INTERRUPTED'. Note that if an acquisition is still running when the PowerOffAll method is invoked, it might be incomplete or corrupted.
Public method | PowerOnAll | Forces all instruments power up and return from the system power down state. Re-enable the instruments at the same state as they were before the PowerOffAll method was invoked. Threads which were suspended will be resumed. However, interrupted operations which returned an error 'ACQIRIS_ERROR_OPERATION_INTERRUPTED' will have to be redone.
Public method | ResumeControl | Resume the control of an instrument that was suspended (see SuspendControl).
Public method | SuspendControl | Suspend control of an instrument to allow using it from another process. NOTE: This is only available for Windows operating systems.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Temperature Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Temperature Interface
See Also

AgMD1 instrument-specific temperature interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Temperature
C#
public interface IAgMD1Temperature
Visual C++
__interface IAgMD1Temperature

Properties

 | Name | Description
Public property | BoardTemperature | Indicates the temperature of the entire board. The units are governed by the Temperature.Units property. Read only
Public property | Units | Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Top

Methods

 | Name | Description
Public method | GetModuleTemperature | Temperature of the specified module. The units are governed by the Temperature.Units property.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Trigger Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger Interface
See Also

AgMD1 instrument-specific trigger interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Trigger
C#
public interface IAgMD1Trigger
Visual C++
__interface IAgMD1Trigger

Properties

 | Name | Description
Public property | ActiveSource | Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".
Public property | Delay | Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
Public property | Holdoff | -- NOT SUPPORTED -- Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute.
Public property | Modifier | Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.
Public property | MultiTrigger | Pointer to the IAgMD1MultiTrigger interface.
Public property | Output | Pointer to the IAgMD1TriggerOutput interface.
Public property | PxiTrigOutEnabled | If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input.
Public property | PxiTrigSlope | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR".
Public property | Sources | Pointer to the IAgMD1TriggerSources interface.
Top

Methods

 | Name | Description
Public method | SendSoftwareTrigger | Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Trigger2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger2 Interface
See Also

IAgMD1Trigger2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Trigger2
   Inherits IAgMD1Trigger
C#
public interface IAgMD1Trigger2 : IAgMD1Trigger
Visual C++
__interface IAgMD1Trigger2 : IAgMD1Trigger

Properties

 | Name | Description
Public property | ActiveSource | Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR". (Inherited from IAgMD1Trigger.)
Public property | Delay | Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds. (Inherited from IAgMD1Trigger.)
Public property | Holdoff | -- NOT SUPPORTED -- Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute. (Inherited from IAgMD1Trigger.)
Public property | Modifier | Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger. (Inherited from IAgMD1Trigger.)
Public property | MultiTrigger | Pointer to the IAgMD1MultiTrigger interface. (Inherited from IAgMD1Trigger.)
Public property | Output | Pointer to the IAgMD1TriggerOutput interface. (Inherited from IAgMD1Trigger.)
Public property | Output2 | Pointer to the IAgMD1TriggerOutput interface.
Public property | PxiTrigOutEnabled | If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input. (Inherited from IAgMD1Trigger.)
Public property | PxiTrigSlope | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR". (Inherited from IAgMD1Trigger.)
Public property | Sources | Pointer to the IAgMD1TriggerSources interface. (Inherited from IAgMD1Trigger.)
Public property | Sources2 | Pointer to the IAgMD1TriggerSources interface.
Top

Methods

 | Name | Description
Public method | SendSoftwareTrigger | Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function. (Inherited from IAgMD1Trigger.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1Trigger3 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1Trigger3 Interface
See Also

IAgMD1Trigger3 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1Trigger3
   Inherits IAgMD1Trigger2
C#
public interface IAgMD1Trigger3 : IAgMD1Trigger2
Visual C++
__interface IAgMD1Trigger3 : IAgMD1Trigger2

Properties

 | Name | Description
Public property | ActiveSource | Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR". (Inherited from IAgMD1Trigger.)
Public property | Delay | Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds. (Inherited from IAgMD1Trigger.)
Public property | Holdoff | -- NOT SUPPORTED -- Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute. (Inherited from IAgMD1Trigger.)
Public property | Modifier | Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger. (Inherited from IAgMD1Trigger.)
Public property | MultiTrigger | Pointer to the IAgMD1MultiTrigger interface. (Inherited from IAgMD1Trigger.)
Public property | Output | Pointer to the IAgMD1TriggerOutput interface. (Inherited from IAgMD1Trigger.)
Public property | Output2 | Pointer to the IAgMD1TriggerOutput interface. (Inherited from IAgMD1Trigger2.)
Public property | PxiTrigOutEnabled | If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input. (Inherited from IAgMD1Trigger.)
Public property | PxiTrigSlope | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR". (Inherited from IAgMD1Trigger.)
Public property | Sources | Pointer to the IAgMD1TriggerSources interface. (Inherited from IAgMD1Trigger.)
Public property | Sources2 | Pointer to the IAgMD1TriggerSources interface. (Inherited from IAgMD1Trigger2.)
Public property | Sources3 | Pointer to the IAgMD1TriggerSources interface.
Top

Methods

 | Name | Description
Public method | SendSoftwareTrigger | Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function. (Inherited from IAgMD1Trigger.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerEdge Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerEdge Interface
See Also

AgMD1 instrument-specific edge triggering interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerEdge
C#
public interface IAgMD1TriggerEdge
Visual C++
__interface IAgMD1TriggerEdge

Properties

 | Name | Description
Public property | Slope | Specifies whether a rising or a falling edge triggers the digitizer.
Top

Methods

 | Name | Description
Public method | Configure | This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerMagnitude Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerMagnitude Interface
See Also

IAgMD1TriggerMagnitude interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerMagnitude
C#
public interface IAgMD1TriggerMagnitude
Visual C++
__interface IAgMD1TriggerMagnitude

Properties

 | Name | Description
Public property | Slope | Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
Top

Methods

 | Name | Description
Public method | Configure | This function sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerMagnitude2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerMagnitude2 Interface
See Also

IAgMD1TriggerMagnitude2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerMagnitude2
   Inherits IAgMD1TriggerMagnitude
C#
public interface IAgMD1TriggerMagnitude2 : IAgMD1TriggerMagnitude
Visual C++
__interface IAgMD1TriggerMagnitude2 : IAgMD1TriggerMagnitude

Properties

 | Name | Description
Public property | DwellTimeSamples | Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
Public property | Slope | Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer. (Inherited from IAgMD1TriggerMagnitude.)
Top

Methods

 | Name | Description
Public method | Configure | This function sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function. (Inherited from IAgMD1TriggerMagnitude.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerOutput Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerOutput Interface
See Also

IAgMD1TriggerOutput interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerOutput
C#
public interface IAgMD1TriggerOutput
Visual C++
__interface IAgMD1TriggerOutput

Properties

 | Name | Description
Public property | Enabled | Specifies whether or not an accepted trigger appears at an output of the digitizer.
Public property | Offset | Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).
Public property | ResyncEnabled | Controls whether the trigger out signal is resynchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false).
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerOutput2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerOutput2 Interface
See Also

IAgMD1TriggerOutput2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerOutput2
   Inherits IAgMD1TriggerOutput
C#
public interface IAgMD1TriggerOutput2 : IAgMD1TriggerOutput
Visual C++
__interface IAgMD1TriggerOutput2 : IAgMD1TriggerOutput

Properties

 | Name | Description
Public property | Enabled | Specifies whether or not an accepted trigger appears at an output of the digitizer. (Inherited from IAgMD1TriggerOutput.)
Public property | MultiModuleSyncEnabled | M9202A Multi Module Synchronization. Enable a M9202A to be the trigger master to synchronize multiple other M9202A modules (the trigger slaves modules). For all modules to synchronize, only one module can be the trigger master module while all others must be trigger slave modules.
Public property | Offset | Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range). (Inherited from IAgMD1TriggerOutput.)
Public property | ResyncEnabled | Controls whether the trigger out signal is resynchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false). (Inherited from IAgMD1TriggerOutput.)
Public property | Source | Select the trigger source to drive the TRG OUT output connector on the front panel. Possible values are Channel1, ..., Channel<n> or External1, ..., External<n> trigger sources where <n> is the number of available channels or external trigger inputs. For M9703A, possible values are TriggerCompare, TriggerAccepted, AXIe_TRIG0, AXIe_TRIG1, ..., AXIe_TRIG11, AXIe_STRIG, HighLevel, LowLevel.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerSource Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource Interface
See Also

AgMD1 instrument-specific trigger source interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerSource
C#
public interface IAgMD1TriggerSource
Visual C++
__interface IAgMD1TriggerSource

Properties

 | Name | Description
Public property | Coupling | Specifies how the digitizer couples the trigger source.
Public property | Edge | Pointer to the IAgMD1TriggerEdge interface.
Public property | ExtTrigRange | The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Public property | Hysteresis | Specifies the trigger hysteresis in Volts.
Public property | Level | Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge or Magnitude. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge or Magnitude Trigger.
Public property | TV | Pointer to the IAgMD1TriggerTV interface.
Public property | Type | The kind of event that triggers the digitizer. TV triggering requires External trigger source.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerSource2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource2 Interface
See Also

IAgMD1TriggerSource2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerSource2
   Inherits IAgMD1TriggerSource
C#
public interface IAgMD1TriggerSource2 : IAgMD1TriggerSource
Visual C++
__interface IAgMD1TriggerSource2 : IAgMD1TriggerSource

Properties

 | Name | Description
Public property | Coupling | Specifies how the digitizer couples the trigger source. (Inherited from IAgMD1TriggerSource.)
Public property | Edge | Pointer to the IAgMD1TriggerEdge interface. (Inherited from IAgMD1TriggerSource.)
Public property | ExtTrigRange | The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts. (Inherited from IAgMD1TriggerSource.)
Public property | Hysteresis | Specifies the trigger hysteresis in Volts. (Inherited from IAgMD1TriggerSource.)
Public property | Level | Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge or Magnitude. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge or Magnitude Trigger. (Inherited from IAgMD1TriggerSource.)
Public property | Magnitude | Pointer to the IAgMD1TriggerMagnitude interface.
Public property | TV | Pointer to the IAgMD1TriggerTV interface. (Inherited from IAgMD1TriggerSource.)
Public property | Type | The kind of event that triggers the digitizer. TV triggering requires External trigger source. (Inherited from IAgMD1TriggerSource.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerSource3 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSource3 Interface
See Also

IAgMD1TriggerSource3 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerSource3
   Inherits IAgMD1TriggerSource2
C#
public interface IAgMD1TriggerSource3 : IAgMD1TriggerSource2
Visual C++
__interface IAgMD1TriggerSource3 : IAgMD1TriggerSource2

Properties

 | Name | Description
Public property | Coupling | Specifies how the digitizer couples the trigger source. (Inherited from IAgMD1TriggerSource.)
Public property | Edge | Pointer to the IAgMD1TriggerEdge interface. (Inherited from IAgMD1TriggerSource.)
Public property | ExtTrigRange | The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts. (Inherited from IAgMD1TriggerSource.)
Public property | Hysteresis | Specifies the trigger hysteresis in Volts. (Inherited from IAgMD1TriggerSource.)
Public property | Level | Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge or Magnitude. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge or Magnitude Trigger. (Inherited from IAgMD1TriggerSource.)
Public property | Magnitude | Pointer to the IAgMD1TriggerMagnitude interface. (Inherited from IAgMD1TriggerSource2.)
Public property | Magnitude2 | Pointer to the IAgMD1TriggerMagnitude interface.
Public property | TV | Pointer to the IAgMD1TriggerTV interface. (Inherited from IAgMD1TriggerSource.)
Public property | Type | The kind of event that triggers the digitizer. TV triggering requires External trigger source. (Inherited from IAgMD1TriggerSource.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerSources Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources Interface
See Also

AgMD1 instrument-specific trigger sources repeated capability collection interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerSources
C#
public interface IAgMD1TriggerSources
Visual C++
__interface IAgMD1TriggerSources

Properties

 | Name | Description
Public property | Count | Returns the number of TriggerSources.
Public property | Item | Pointer to the IAgMD1TriggerSource interface.
Public property | Name | Returns the TriggerSource name for a given index.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerSources2 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources2 Interface
See Also

IAgMD1TriggerSources2 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerSources2
   Inherits IAgMD1TriggerSources
C#
public interface IAgMD1TriggerSources2 : IAgMD1TriggerSources
Visual C++
__interface IAgMD1TriggerSources2 : IAgMD1TriggerSources

Properties

 | Name | Description
Public property | Count | Returns the number of TriggerSources. (Inherited from IAgMD1TriggerSources.)
Public property | Item | Pointer to the IAgMD1TriggerSource interface. (Inherited from IAgMD1TriggerSources.)
Public property | Item2 | Pointer to the IAgMD1TriggerSource interface.
Public property | Name | Returns the TriggerSource name for a given index. (Inherited from IAgMD1TriggerSources.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerSources3 Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerSources3 Interface
See Also

IAgMD1TriggerSources3 interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerSources3
   Inherits IAgMD1TriggerSources2
C#
public interface IAgMD1TriggerSources3 : IAgMD1TriggerSources2
Visual C++
__interface IAgMD1TriggerSources3 : IAgMD1TriggerSources2

Properties

 | Name | Description
Public property | Count | Returns the number of TriggerSources. (Inherited from IAgMD1TriggerSources.)
Public property | Item | Pointer to the IAgMD1TriggerSource interface. (Inherited from IAgMD1TriggerSources.)
Public property | Item2 | Pointer to the IAgMD1TriggerSource interface. (Inherited from IAgMD1TriggerSources2.)
Public property | Item3 | Pointer to the IAgMD1TriggerSource interface.
Public property | Name | Returns the TriggerSource name for a given index. (Inherited from IAgMD1TriggerSources.)
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


IAgMD1TriggerTV Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IAgMD1TriggerTV Interface
See Also

AgMD1 instrument-specific TV triggering interface.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Interface IAgMD1TriggerTV
C#
public interface IAgMD1TriggerTV
Visual C++
__interface IAgMD1TriggerTV

Properties

 | Name | Description
Public property | Event | Specifies the event on which the digitizer triggers.
Public property | LineNumber | Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).
Public property | Polarity | Specifies the polarity of the TV signal.
Public property | SignalFormat | Specifies the format of TV signal on which the digitizer triggers.
Top

Methods

 | Name | Description
Public method | Configure | This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.
Top

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1AcquisitionModeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1AcquisitionModeEnum Enumeration
See Also

Defined values for the acquisition mode.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1AcquisitionModeEnum
C#
public enum AgMD1AcquisitionModeEnum
Visual C++
public enum class AgMD1AcquisitionModeEnum

Members

Member name | Value | Description
AgMD1AcquisitionModeNormal | 0x00000000 | Normal digitizer mode
AgMD1AcquisitionModeDownconverter | 0x0000000C | Digital Downconverter (DDC) mode. Requires model: M9202A
AgMD1AcquisitionModeCounter | 0x00000006 | Frequency counter mode
AgMD1AcquisitionModeUserFDK | 0x0000000F | User FDK mode. Requires model M9703A with FDK option.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1AcquisitionStatusResultEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1AcquisitionStatusResultEnum Enumeration
See Also

Defined values for the acquisition status result.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1AcquisitionStatusResultEnum
C#
public enum AgMD1AcquisitionStatusResultEnum
Visual C++
public enum class AgMD1AcquisitionStatusResultEnum

Members

Member name | Value | Description
AgMD1AcquisitionStatusResultTrue | 0x00000001 | The state of the status condition is true.
AgMD1AcquisitionStatusResultFalse | 0x00000002 | The state of the status condition is false.
AgMD1AcquisitionStatusResultUnknown | 0x00000003 | The state of the status conditon could not be determined.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1AcquisitionTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1AcquisitionTypeEnum Enumeration
See Also

Defined values for scope Acquisition Type

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1AcquisitionTypeEnum
C#
public enum AgMD1AcquisitionTypeEnum
Visual C++
public enum class AgMD1AcquisitionTypeEnum

Members

Member name | Value | Description
AgMD1AcquisitionTypeNormal | 0x00000000 | Configures the oscilloscope to acquire one sample for each point in the waveform record. The oscilloscope uses real-time or equivalent time sampling.
AgMD1AcquisitionTypeAverage | 0x00000004 | Configures the oscilloscope to acquire multiple waveforms and calculate the average value for each point in the waveform record. The end-user specifies the number of waveforms to acquire with the NumberOfAverages property. The oscilloscope uses real-time or equivalent time sampling.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1CalibrateTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1CalibrateTypeEnum Enumeration
See Also

Supported calibration types for the SelfCalibrate method.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1CalibrateTypeEnum
C#
public enum AgMD1CalibrateTypeEnum
Visual C++
public enum class AgMD1CalibrateTypeEnum

Members

Member name | Value | Description
AgMD1CalibrateTypeFull | 0x00000000 | Calibrate the entire instrument.
AgMD1CalibrateTypeChannelConfiguration | 0x00000001 | Calibrate only the current channel configuration.
AgMD1CalibrateTypeExtClockTiming | 0x00000002 | Calibrate external clock timing. Requires operation in External Clock (Continuous).
AgMD1CalibrateTypeCurrentFrequency | 0x00000003 | Calibrate only at the current frequency (only instruments with fine resolution timebases).
AgMD1CalibrateTypeFast | 0x00000004 | FastCal: calibrate only at the current settings (if supported). Warning: in this mode, any change of range, max input frequency, channel combine, input impedance or coupling, will require a new calibration.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1CounterModeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1CounterModeEnum Enumeration
See Also

Defined values for the counter mode.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1CounterModeEnum
C#
public enum AgMD1CounterModeEnum
Visual C++
public enum class AgMD1CounterModeEnum

Members

Member name | Value | Description
AgMD1CounterModeFrequency | 0x00000000 | Counter measures the frequency of the input signal.
AgMD1CounterModePeriod | 0x00000001 | Counter measures the period of the input signal.
AgMD1CounterModeTotalizeTime | 0x00000002 | Counts input pulses during interval defined by Counter.AperatureTime property.
AgMD1CounterModeTotalizeGate | 0x00000003 | Counts input pulses during interval defined by control I/O A or B input.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1DelayControlRangeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1DelayControlRangeEnum Enumeration
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1DelayControlRangeEnum
C#
public enum AgMD1DelayControlRangeEnum
Visual C++
public enum class AgMD1DelayControlRangeEnum

Members

Member name | Value | Description
AgMD1DelayControlRangeDefault | 0x00000000 |
AgMD1DelayControlRangeExtended | 0x00000001 |

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1ErrorCodesEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1ErrorCodesEnum Enumeration
See Also

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1ErrorCodesEnum
C#
public enum AgMD1ErrorCodesEnum
Visual C++
public enum class AgMD1ErrorCodesEnum

Members

Member name | Value | Description
E_AGMD1_IO_GENERAL | 0x80044214 | I/O error.
E_AGMD1_IO_TIMEOUT | 0x80044215 | I/O timeout error.
E_AGMD1_MODEL_NOT_SUPPORTED | 0x80044216 | Instrument model does not support this feature.
E_AGMD1_PERSONALITY_NOT_ACTIVE | 0x80044211 | Personality is not active.
E_AGMD1_PERSONALITY_NOT_LICENSED | 0x80044213 | Personality is not licensed.
E_AGMD1_PERSONALITY_NOT_INSTALLED | 0x80044212 | Personality is not installed.
E_AGMD1_MODULE_API | 0x80044217 | An error was returned from the module fundamental API.
S_AGMD1_CALIBRATED_WITH_INTERNAL_CLOCK | 0x00044001 |

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1MeasurementEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1MeasurementEnum Enumeration
See Also

Defined values for the MeasFunction parameter of the ReadWaveformMeasurement and FetchWaveformMeasurement methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1MeasurementEnum
C#
public enum AgMD1MeasurementEnum
Visual C++
public enum class AgMD1MeasurementEnum

Members

Member name | Value | Description
AgMD1MeasurementRiseTime | 0x00000000 | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AgMD1MeasurementFallTime | 0x00000001 | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AgMD1MeasurementFrequency | 0x00000002 | The frequency of one complete cycle in the waveform. The units are Hertz.
AgMD1MeasurementPeriod | 0x00000003 | The length of time of one complete cycle in the waveform. The units are seconds.
AgMD1MeasurementVoltageRMS | 0x00000004 | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AgMD1MeasurementVoltagePeakToPeak | 0x00000005 | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AgMD1MeasurementVoltageMax | 0x00000006 | The maximum amplitude found in the entire waveform. The units are Volts.
AgMD1MeasurementVoltageMin | 0x00000007 | The minimum amplitude found in the entire waveform. The units are Volts.
AgMD1MeasurementVoltageHigh | 0x00000008 | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.
AgMD1MeasurementVoltageLow | 0x00000009 | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.
AgMD1MeasurementVoltageAverage | 0x0000000A | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AgMD1MeasurementWidthNeg | 0x0000000B | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AgMD1MeasurementWidthPos | 0x0000000C | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AgMD1MeasurementDutyCycleNeg | 0x0000000D | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AgMD1MeasurementDutyCyclePos | 0x0000000E | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AgMD1MeasurementAmplitude | 0x0000000F | The Voltage High less the Voltage Low in Volts over the entire waveform.
AgMD1MeasurementVoltageCycleRMS | 0x00000010 | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AgMD1MeasurementVoltageCycleAverage | 0x00000011 | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AgMD1MeasurementOverShoot | 0x00000012 | The relative waveform distortion that follows an edge transition.
AgMD1MeasurementPreshoot | 0x00000013 | The relative waveform distortion that precedes an edge transition.
AgMD1MeasurementDCOffset | 0x00000014 | The DC Offset depends on the Measurement.WaveformType. It is equal to Vmin for PulsedDC and Step. It is equal to (Vmax+Vmin)/2 for all other waveform types.
AgMD1MeasurementPhaseAngle | 0x00000015 | Phase angle in radians of the waveform relative to a reference signal on another channel, as set with the Channels.ReferenceChannel property.
AgMD1MeasurementPulseRepetitionFrequency | 0x00000016 | Pulse repetition frequency of a pulsed DC signal.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1MeasurementWaveformTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1MeasurementWaveformTypeEnum Enumeration
See Also

Waveform type used to calculate measurement function values by the FetchWaveformMeasuerment and ReadWaveformMeasurement methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1MeasurementWaveformTypeEnum
C#
public enum AgMD1MeasurementWaveformTypeEnum
Visual C++
public enum class AgMD1MeasurementWaveformTypeEnum

Members

Member name | Value | Description
AgMD1MeasurementWaveformTypeUnknown | 0x00000000 | This value indicates that the signal is of an unspecified waveform type.
AgMD1MeasurementWaveformTypeSine | 0x00000001 | The signal is a sine waveform.
AgMD1MeasurementWaveformTypeSquare | 0x00000002 | The signal is a square waveform.
AgMD1MeasurementWaveformTypeRamp | 0x00000003 | The signal is a ramp or triangle waveform.
AgMD1MeasurementWaveformTypePulsedDC | 0x00000004 | The signal is a pulsed DC waveform.
AgMD1MeasurementWaveformTypeStep | 0x00000005 | The signal is a pulsed DC waveform.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1ReferenceOscillatorSourceEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1ReferenceOscillatorSourceEnum Enumeration
See Also

Defined values for the reference oscillator source.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1ReferenceOscillatorSourceEnum
C#
public enum AgMD1ReferenceOscillatorSourceEnum
Visual C++
public enum class AgMD1ReferenceOscillatorSourceEnum

Members

Member name | Value | Description
AgMD1ReferenceOscillatorSourceInternal | 0x00000000 | The internal reference oscillator is used.
AgMD1ReferenceOscillatorSourceExternal | 0x00000001 | An external reference oscillator is used.
AgMD1ReferenceOscillatorSourcePXIClk10 | 0x00000002 | PXIClk10 reference oscillator is used.
AgMD1ReferenceOscillatorSourcePXIeClk100 | 0x00000003 | PXIeClk100 reference oscillator is used. Not supported yet.
AgMD1ReferenceOscillatorSourceAXIeClk100 | 0x00000004 | AXIeClk100 reference oscillator is used.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1SampleClockSourceEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1SampleClockSourceEnum Enumeration
See Also

Defined values for the sample clock source.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1SampleClockSourceEnum
C#
public enum AgMD1SampleClockSourceEnum
Visual C++
public enum class AgMD1SampleClockSourceEnum

Members

Member name | Value | Description
AgMD1SampleClockSourceInternal | 0x00000000 | The internal sample clock is used.
AgMD1SampleClockSourceExternal | 0x00000001 | An external sample clock is used.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1SampleModeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1SampleModeEnum Enumeration
See Also

Defined values for acquisition SampleMode.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1SampleModeEnum
C#
public enum AgMD1SampleModeEnum
Visual C++
public enum class AgMD1SampleModeEnum

Members

Member name | Value | Description
AgMD1SampleModeRealTime | 0x00000000 | Real-time sampling is used.
AgMD1SampleModeEquivalentTime | 0x00000001 | Equivalent-time sampling is used.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TemperatureUnitsEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TemperatureUnitsEnum Enumeration
See Also

Defined values for the temperature units.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TemperatureUnitsEnum
C#
public enum AgMD1TemperatureUnitsEnum
Visual C++
public enum class AgMD1TemperatureUnitsEnum

Members

Member name | Value | Description
AgMD1TemperatureUnitsCelsius | 0x00000000 | Temperature values returned from the digitizer are in degrees Celsius.
AgMD1TemperatureUnitsFahrenheit | 0x00000001 | Temperature values returned from the digitizer are in degrees Fahrenheit.
AgMD1TemperatureUnitsKelvin | 0x00000002 | Temperature values returned from the digitizer are in degrees Kelvin.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TimeOutEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TimeOutEnum Enumeration
See Also

Defined values for maxTime parameter of the measurement Read and Fetch methods.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TimeOutEnum
C#
public enum AgMD1TimeOutEnum
Visual C++
public enum class AgMD1TimeOutEnum

Members

Member name | Value | Description
AgMD1TimeOutInfinite | 0xFFFFFFFF | The method waits indefinitely for the measurement to complete.
AgMD1TimeOutImmediate | 0x00000000 | The method returns immediately. If no valid measurement value exists, the method returns an error.

Remarks

Re-triggering is prevented until the magnitude of the signal has met the following criteria:
If magnitude < Threshold - Hysteresis (when positive trigger slope is selected)
If magnitude > Threshold + Hysteresis (when negative trigger slope is selected)

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TriggerCouplingEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TriggerCouplingEnum Enumeration
See Also

Defined values for trigger Coupling.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TriggerCouplingEnum
C#
public enum AgMD1TriggerCouplingEnum
Visual C++
public enum class AgMD1TriggerCouplingEnum

Members

Member name | Value | Description
AgMD1TriggerCouplingAC | 0x00000000 | The digitizer AC couples the trigger signal.
AgMD1TriggerCouplingDC | 0x00000001 | The digitizer DC couples the trigger signal.
AgMD1TriggerCouplingHFReject | 0x00000002 | The digitizer filters out the high frequencies from the arm signal.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TriggerModifierEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TriggerModifierEnum Enumeration
See Also

Defined values for trigger modifier.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TriggerModifierEnum
C#
public enum AgMD1TriggerModifierEnum
Visual C++
public enum class AgMD1TriggerModifierEnum

Members

Member name | Value | Description
AgMD1TriggerModifierNone | 0x00000001 | The digitizer waits until the trigger the end-user specifies occurs.
AgMD1TriggerModifierAuto | 0x00000002 | The digitizer automatically triggers if the configured trigger does not occur within the digitizer timeout period.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TriggerSlopeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TriggerSlopeEnum Enumeration
See Also

Defined values for edge trigger slope.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TriggerSlopeEnum
C#
public enum AgMD1TriggerSlopeEnum
Visual C++
public enum class AgMD1TriggerSlopeEnum

Members

Member name | Value | Description
AgMD1TriggerSlopeNegative | 0x00000000 | A negative (falling) edge passing through the trigger level triggers the digitizer.
AgMD1TriggerSlopePositive | 0x00000001 | A positive (rising) edge passing through the trigger level triggers the digitizer.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TriggerSourceOperatorEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TriggerSourceOperatorEnum Enumeration
See Also

Defined values for the trigger source operator.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TriggerSourceOperatorEnum
C#
public enum AgMD1TriggerSourceOperatorEnum
Visual C++
public enum class AgMD1TriggerSourceOperatorEnum

Members

Member name | Value | Description
AgMD1TriggerSourceOperatorAND | 0x00000000 | Trigger sources are AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
AgMD1TriggerSourceOperatorOR | 0x00000001 | Trigger sources are OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
AgMD1TriggerSourceOperatorNone | 0x00000002 | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Trigger Source attribute, and its associated trigger conditions are satisfied.
AgMD1TriggerSourceOperatorNAND | 0x000003E9 | Trigger sources are NAND'd together. The digitizer triggers when at least one configured trigger source condition is not satisfied.
AgMD1TriggerSourceOperatorNOR | 0x000003EA | Trigger sources are NOR'd together. The digitizer triggers when all configured trigger source conditions are not satisfied.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TriggerTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TriggerTypeEnum Enumeration
See Also

Defined values for trigger type

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TriggerTypeEnum
C#
public enum AgMD1TriggerTypeEnum
Visual C++
public enum class AgMD1TriggerTypeEnum

Members

Member name | Value | Description
AgMD1TriggerEdge | 0x00000001 | Configures the digitizer for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source attribute passes the voltage threshold specified with the Trigger Level attribute and has the slope specified with the Trigger Slope attribute.
AgMD1TriggerTV | 0x00000005 | Configures the digitizer for triggering on TV signals. Use the IAgMD1TriggerTV properties and methods to configure the trigger. Requires External trigger source.
AgMD1TriggerImmediate | 0x000003E9 | Configures the digitizer for immediate triggering. The digitizer does not wait for trigger of any kind upon initialization.
AgMD1TriggerMagnitude | 0x000003EA | Magnitude triggering. Only valid when Acquisition.Mode = AgMD1AcquisitionModeDownconverter. Requires model: M9202A

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TVSignalFormatEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TVSignalFormatEnum Enumeration
See Also

Defined values for TV trigger SignalFormat

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TVSignalFormatEnum
C#
public enum AgMD1TVSignalFormatEnum
Visual C++
public enum class AgMD1TVSignalFormatEnum

Members

Member name | Value | Description
AgMD1TVSignalFormatNTSC | 0x00000001 | Configures the digitizer to trigger on the NTSC signal format.
AgMD1TVSignalFormatPAL | 0x00000002 | Configures the digitizer to trigger on the PAL signal format
AgMD1TVSignalFormatSECAM | 0x00000003 | Configures the digitizer to trigger on the SECAM signal format

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TVTriggerEventEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TVTriggerEventEnum Enumeration
See Also

Defined values for TV trigger Event

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TVTriggerEventEnum
C#
public enum AgMD1TVTriggerEventEnum
Visual C++
public enum class AgMD1TVTriggerEventEnum

Members

Member name | Value | Description
AgMD1TVTriggerEventField1 | 0x00000001 | Sets the digitizer to trigger on field 1 of the video signal.
AgMD1TVTriggerEventField2 | 0x00000002 | Sets the digitizer to trigger on field 2 of the video signal.
AgMD1TVTriggerEventLineNumber | 0x00000005 | Sets the digitizer to trigger on a specific line number you specify with the TV Trigger Line Number attribute.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1TVTriggerPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1TVTriggerPolarityEnum Enumeration
See Also

Defined values for TV trigger Polarity

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1TVTriggerPolarityEnum
C#
public enum AgMD1TVTriggerPolarityEnum
Visual C++
public enum class AgMD1TVTriggerPolarityEnum

Members

Member name | Value | Description
AgMD1TVTriggerPolarityPositive | 0x00000001 | Configures the digitizer to trigger on a positive video sync pulse.
AgMD1TVTriggerPolarityNegative | 0x00000002 | Configures the digitizer to trigger on a negative video sync pulse.

See Also

Reference

Agilent.AgMD1.Interop Namespace


AgMD1VerticalCouplingEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1VerticalCouplingEnum Enumeration
See Also

Defined values for channel Coupling.

Namespace: Agilent.AgMD1.Interop
Assembly: Agilent.AgMD1.Interop (in Agilent.AgMD1.Interop.dll)

Syntax

Visual Basic
Public Enumeration AgMD1VerticalCouplingEnum
C#
public enum AgMD1VerticalCouplingEnum
Visual C++
public enum class AgMD1VerticalCouplingEnum

Members

Member name | Value | Description
AgMD1VerticalCouplingAC | 0x00000000 | The digitizer AC couples the input signal.
AgMD1VerticalCouplingDC | 0x00000001 | The digitizer DC couples the input signal.
AgMD1VerticalCouplingGnd | 0x00000002 | The digitizer couples the channel to the ground.

See Also

Reference

Agilent.AgMD1.Interop Namespace


Ivi.Driver.Interop Namespace

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Ivi.Driver.Interop Namespace

Interfaces

 | Interface | Description
Public interface | IIviClassWrapper | IVI Driver class wrapper interface
Public interface | IIviComponentIdentity | IVI Driver component identity interface
Public interface | IIviDriver | IVI Driver root interface
Public interface | IIviDriverIdentity | IVI Driver identity interface
Public interface | IIviDriverOperation | IVI Driver operation interface
Public interface | IIviDriverUtility | IVI Driver utility interface

Enumerations

 | Enumeration | Description
Public enumeration | IviDriver_ErrorCodes | IVI Driver (inherent features) defined HRESULTS


IIviClassWrapper Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviClassWrapper Interface
See Also

IVI Driver class wrapper interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviClassWrapper
C#
public interface IIviClassWrapper
Visual C++
__interface IIviClassWrapper

Properties

 | Name | Description
Public property | NativeCHandle | The C session handle that the COM wrapper is currently using to communicate with an IVI-C specific driver.
Top

Methods

 | Name | Description
Public method | AttachToExistingCSession | Binds a COM wrapper object to an existing IVI-C specific driver session.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


AttachToExistingCSession Method

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviClassWrapper..::.AttachToExistingCSession Method
IIviClassWrapper See Also

Binds a COM wrapper object to an existing IVI-C specific driver session.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Sub AttachToExistingCSession ( _
    ByVal  Vi As Integer  _
)
C#
public void  AttachToExistingCSession(
    int  Vi
)
Visual C++
HRESULT AttachToExistingCSession(
    long  Vi
);

Parameters

Vi

Requirements

Supported Models

All supported

See Also

Reference

IIviClassWrapper Interface
Ivi.Driver.Interop Namespace


NativeCHandle Property

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviClassWrapper..::.NativeCHandle Property
IIviClassWrapper See Also

The C session handle that the COM wrapper is currently using to communicate with an IVI-C specific driver.

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public ReadOnly Property NativeCHandle As Integer
C#
public int  NativeCHandle { get; }
Visual C++
HRESULT get_NativeCHandle(
    long*  val
);

Requirements

Supported Models

All supported

See Also

Reference

IIviClassWrapper Interface
Ivi.Driver.Interop Namespace


IIviComponentIdentity Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviComponentIdentity Interface
See Also

IVI Driver component identity interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviComponentIdentity
C#
public interface IIviComponentIdentity
Visual C++
__interface IIviComponentIdentity

Properties

 | Name | Description
Public property | Description | A brief description of the implementing component. Description is limted to 256 bytes.
Public property | Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes.
Public property | Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


IIviDriverIdentity Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverIdentity Interface
See Also

IVI Driver identity interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriverIdentity
   Inherits IIviComponentIdentity
C#
public interface IIviDriverIdentity : IIviComponentIdentity
Visual C++
__interface IIviDriverIdentity : IIviComponentIdentity

Properties

 | Name | Description
Public property | Description | A brief description of the implementing component. Description is limted to 256 bytes. (Inherited from IIviComponentIdentity.)
Public property | GroupCapabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Public property | Identifier | The case-sensitive unique identifier of the implementing IVI-COM instrument driver.
Public property | InstrumentFirmwareRevision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Public property | InstrumentManufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
Public property | InstrumentModel | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Public property | Revision | The revision of the implementing component. Refer to IVI 3.1, Section 3.1.2.2, for a description of revision syntax and semantics. Revision is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Public property | SpecificationMajorVersion | For IVI class-compliant drivers, the major version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
Public property | SpecificationMinorVersion | For IVI class-compliant drivers, the minor version number of the instrument class specification. If the driver is not class compliant, the driver returns zero.
Public property | SupportedInstrumentModels | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Public property | Vendor | The name of the vendor that supplies the implementing component. Vendor is limited to 256 bytes. (Inherited from IIviComponentIdentity.)
Top

See Also

Reference

Ivi.Driver.Interop Namespace


IIviDriverOperation Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverOperation Interface
See Also

IVI Driver operation interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriverOperation
C#
public interface IIviDriverOperation
Visual C++
__interface IIviDriverOperation

Properties

 | Name | Description
Public property | Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Public property | DriverSetup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Public property | InterchangeCheck | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Public property | IoResourceDescriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Public property | LogicalName | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
Public property | QueryInstrumentStatus | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Public property | RangeCheck | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Public property | RecordCoercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Public property | Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Top

Methods

 | Name | Description
Public method | ClearInterchangeWarnings | -- NOT SUPPORTED -- Clears the list of interchangeability warnings that the IVI specific driver maintains.
Public method | GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Public method | GetNextInterchangeWarning | -- NOT SUPPORTED -- Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
Public method | InvalidateAllAttributes | Invalidates all of the driver's cached values.
Public method | ResetInterchangeCheck | -- NOT SUPPORTED -- Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


IIviDriverUtility Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDriverUtility Interface
See Also

IVI Driver utility interface

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Interface IIviDriverUtility
C#
public interface IIviDriverUtility
Visual C++
__interface IIviDriverUtility

Methods

 | Name | Description
Public method | Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Public method | ErrorQuery | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Public method | LockObject | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Public method | Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Public method | ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Public method | SelfTest | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Public method | UnlockObject | Releases a previously obtained mutlithread lock.
Top

See Also

Reference

Ivi.Driver.Interop Namespace


IviDriver_ErrorCodes Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDriver_ErrorCodes Enumeration
See Also

IVI Driver (inherent features) defined HRESULTS

Namespace: Ivi.Driver.Interop
Assembly: Ivi.Driver.Interop (in Ivi.Driver.Interop.DLL)

Syntax

Visual Basic
Public Enumeration IviDriver_ErrorCodes
C#
public enum IviDriver_ErrorCodes
Visual C++
public enum class IviDriver_ErrorCodes

Members

Member name | Value | Description
S_IVI_SUCCESS | 0x00000000 | Success.
E_IVI_CANNOT_RECOVER | 0x80047000 | Unrecoverable failure.
E_IVI_INSTRUMENT_STATUS | 0x80047001 | Instrument error detected.
E_IVI_CANNOT_OPEN_FILE | 0x80047002 | File could not be opened.
E_IVI_READING_FILE | 0x80047003 | File could not be read.
E_IVI_WRITING_FILE | 0x80047004 | File could not be written.
E_IVI_INVALID_PATHNAME | 0x8004700B | The path name is invalid.
E_IVI_INVALID_VALUE | 0x80047010 | Invalid value for parameter or property.
E_IVI_METHOD_NOT_SUPPORTED | 0x80047011 | Method not supported.
E_IVI_PROPERTY_NOT_SUPPORTED | 0x80047012 | Property not supported.
E_IVI_VALUE_NOT_SUPPORTED | 0x80047013 | The enumeration value for the parameter is not supported.
E_IVI_NOT_INITIALIZED | 0x8004701D | A connection to the instrument has not been initialized.
E_IVI_UNKNOWN_CHANNEL_NAME | 0x80047020 | Channel or repeated capability name specified is not valid for the instrument.
E_IVI_TOO_MANY_OPEN_FILES | 0x80047023 | Too many files opened.
E_IVI_CHANNEL_NAME_REQUIRED | 0x80047044 | Channel or repeated capability name required.
E_IVI_MISSING_OPTION_NAME | 0x80047049 | The option string contains an entry without a name.
E_IVI_MISSING_OPTION_VALUE | 0x8004704A | The option string contains an entry without a value.
E_IVI_BAD_OPTION_NAME | 0x8004704B | The option string contains an entry with an unknown option name.
E_IVI_BAD_OPTION_VALUE | 0x8004704C | The option string contains an entry with an unknown option value.
E_IVI_OUT_OF_MEMORY | 0x80047056 | The necessary memory could not be allocated.
E_IVI_OPERATION_PENDING | 0x80047057 | Operation in progress.
E_IVI_NULL_POINTER | 0x80047058 | Null pointer passed for parameter or property.
E_IVI_UNEXPECTED_RESPONSE | 0x80047059 | Unexpected response from the instrument.
E_IVI_FILE_NOT_FOUND | 0x8004705B | File not found.
E_IVI_INVALID_FILE_FORMAT | 0x8004705C | The file format is invalid.
E_IVI_STATUS_NOT_AVAILABLE | 0x8004705D | The instrument status is not available.
E_IVI_ID_QUERY_FAILED | 0x8004705E | Instrument ID query failed.
E_IVI_RESET_FAILED | 0x8004705F | Instrument reset failed.
E_IVI_RESOURCE_UNKNOWN | 0x80047060 | Insufficient location information or resource not present in the system.
E_IVI_ALREADY_INITIALIZED | 0x80047061 | The driver is already initialized.
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | 0x80047062 | The simulation state cannot be changed.
E_IVI_INVALID_NUMBER_OF_LEVELS_IN_SELECTOR | 0x80047063 | The number of levels in the selector is not valid for the repeated capability.
E_IVI_INVALID_RANGE_IN_SELECTOR | 0x80047064 | The range is not valid for the repeated capability.
E_IVI_UNKNOWN_NAME_IN_SELECTOR | 0x80047065 | Unknown name in selector.
E_IVI_BADLY_FORMED_SELECTOR | 0x80047066 | The repeated capability selector is badly-formed.
E_IVI_UNKNOWN_PHYSICAL_IDENTIFIER | 0x80047067 | Unknown physical repeated capability selector.
S_IVI_NSUP_ID_QUERY | 0x00047065 | Identification query not supported.
S_IVI_NSUP_RESET | 0x00047066 | Reset operation not supported.
S_IVI_NSUP_SELF_TEST | 0x00047067 | Self test operation not supported.
S_IVI_NSUP_ERROR_QUERY | 0x00047068 | Error query operation not supported.
S_IVI_NSUP_REV_QUERY | 0x00047069 | Revision query not supported.

See Also

Reference

Ivi.Driver.Interop Namespace


Ivi.Digitizer.Interop Namespace

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Ivi.Digitizer.Interop Namespace

IviDigitizer 1.0 Type Library

Interfaces

 | Interface | Description
Public interface | IIviDigitizer | IVI Digitizer class-compliant root interface.
Public interface | IIviDigitizerAcquisition | IVI Digitizer class-compliant acquistion interface.
Public interface | IIviDigitizerAcquisitionStatus | IVI Digitizer class-compliant acquistion status interface.
Public interface | IIviDigitizerArm | IVI Digitizer class-compliant arm interface.
Public interface | IIviDigitizerArmEdge | IVI Digitizer class-compliant edge arming interface.
Public interface | IIviDigitizerArmGlitch | IVI Digitizer class-compliant glitch arming interface.
Public interface | IIviDigitizerArmRunt | IVI Digitizer class-compliant runt arming interface.
Public interface | IIviDigitizerArmSource | IVI Digitizer class-compliant arm source interface.
Public interface | IIviDigitizerArmSources | IVI Digitizer class-compliant arm source collection interface.
Public interface | IIviDigitizerArmTV | IVI Digitizer class-compliant TV arming interface.
Public interface | IIviDigitizerArmWidth | IVI Digitizer class-compliant width arming interface.
Public interface | IIviDigitizerArmWindow | IVI Digitizer class-compliant window arming interface.
Public interface | IIviDigitizerCalibration | IVI Digitizer class-compliant calibration interface.
Public interface | IIviDigitizerChannel | IVI Digitizer class-compliant channel interface.
Public interface | IIviDigitizerChannelDownconversion | IVI Digitizer class-compliant downconversion interface.
Public interface | IIviDigitizerChannelFilter | IVI Digitizer class-compliant channel filter interface.
Public interface | IIviDigitizerChannelMeasurement | IVI Digitizer class-compliant measurement interface.
Public interface | IIviDigitizerChannelMultiRecordMeasurement | IVI Digitizer class-compliant multi-record measurement interface.
Public interface | IIviDigitizerChannels | IVI Digitizer class-compliant channel collection interface.
Public interface | IIviDigitizerMultiArm | IVI Digitizer class-compliant multi-arm interface.
Public interface | IIviDigitizerMultiTrigger | IVI Digitizer class-compliant multi-trigger interface.
Public interface | IIviDigitizerReferenceOscillator | IVI Digitizer class-compliant reference oscillator interface.
Public interface | IIviDigitizerSampleClock | IVI Digitizer class-compliant sample clock interface.
Public interface | IIviDigitizerTemperature | IVI Digitizer class-compliant temperature interface.
Public interface | IIviDigitizerTrigger | IVI Digitizer class-compliant trigger interface.
Public interface | IIviDigitizerTriggerEdge | IVI Digitizer class-compliant edge triggering interface.
Public interface | IIviDigitizerTriggerGlitch | IVI Digitizer class-compliant glitch triggering interface.
Public interface | IIviDigitizerTriggerRunt | IVI Digitizer class-compliant runt triggering interface.
Public interface | IIviDigitizerTriggerSource | IVI Digitizer class-compliant trigger source interface.
Public interface | IIviDigitizerTriggerSources | IVI Digitizer class-compliant trigger source collection interface.
Public interface | IIviDigitizerTriggerTV | IVI Digitizer class-compliant TV triggering interface.
Public interface | IIviDigitizerTriggerWidth | IVI Digitizer class-compliant width triggering interface.
Public interface | IIviDigitizerTriggerWindow | IVI Digitizer class-compliant window triggering interface.

Enumerations

 | Enumeration | Description
Public enumeration | IviDigitizerAcquisitionStatusResultEnum | Defined values for the acquisition status result.
Public enumeration | IviDigitizerArmSourceOperatorEnum | Defined values for the arm source operator.
Public enumeration | IviDigitizerArmTypeEnum | Defined values for trigger type
Public enumeration | IviDigitizerErrorCodesEnum | IVI Digitizer class-defined HRESULTS
Public enumeration | IviDigitizerGlitchConditionEnum | Defined values values for glitch trigger condition.
Public enumeration | IviDigitizerGlitchPolarityEnum | Defined values for glitch trigger Polarity
Public enumeration | IviDigitizerReferenceOscillatorSourceEnum | Defined values for the reference oscillator source.
Public enumeration | IviDigitizerRuntPolarityEnum | Defined values for runt trigger polarity
Public enumeration | IviDigitizerSampleClockSourceEnum | Defined values for the sample clock source.
Public enumeration | IviDigitizerSampleModeEnum | Defined values for acquisition SampleMode.
Public enumeration | IviDigitizerTemperatureUnitsEnum | Defined values for the temperature units.
Public enumeration | IviDigitizerTimeOutEnum | Defined values for the MaxTimeMilliseconds parameter of the measurement Read and Fetch methods.
Public enumeration | IviDigitizerTriggerCouplingEnum | Defined values for trigger Coupling.
Public enumeration | IviDigitizerTriggerModifierEnum | Defined values for trigger modifier.
Public enumeration | IviDigitizerTriggerSlopeEnum | Defined values for edge trigger slope.
Public enumeration | IviDigitizerTriggerSourceOperatorEnum | Defined values for the trigger source operator.
Public enumeration | IviDigitizerTriggerTypeEnum | Defined values for trigger type
Public enumeration | IviDigitizerTVSignalFormatEnum | Defined values for TV trigger SignalFormat
Public enumeration | IviDigitizerTVTriggerEventEnum | Defined values for TV trigger Event
Public enumeration | IviDigitizerTVTriggerPolarityEnum | Defined values for TV trigger Polarity
Public enumeration | IviDigitizerVerticalCouplingEnum | Defined values for channel Coupling.
Public enumeration | IviDigitizerWidthConditionEnum | Defined values for width trigger Condition
Public enumeration | IviDigitizerWidthPolarityEnum | Defined values for width trigger Polarity
Public enumeration | IviDigitizerWindowConditionEnum | Defined values for window trigger Condition.


IIviDigitizerAcquisition Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisition Interface
See Also

IVI Digitizer class-compliant acquistion interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerAcquisition
C#
public interface IIviDigitizerAcquisition
Visual C++
__interface IIviDigitizerAcquisition

Properties

 | Name | Description
Public property | MaxFirstValidPointValue | Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
Public property | MaxSamplesPerChannel | Returns the maximum number of samples per channel that can be captured.
Public property | MinRecordSize | Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.
Public property | NumAcquiredRecords | Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.
Public property | NumRecordsToAcquire | Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
Public property | RecordSize | Specifies the number of samples to acquire in each waveform record.
Public property | SampleMode | -- NOT SUPPORTED, Always RealTime mode -- Specifies the sample mode used by the digitizer.
Public property | SampleRate | Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
Public property | Status | Pointer to the IIviDigitizerAcquisitionStatus interface.
Public property | TimeInterleavedChannelListAuto | -- NOT SUPPORTED, Always false -- Specifies whether or not the instrument should automatically combine enabled channels to satisfy user-specified sample rates. When set to True, the instrument will automatically combine channels to meet the sample rate requirements specified via the Sample Rate attribute.
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the digitizer to the Idle state.
Public method | ConfigureAcquisition | This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.
Public method | Initiate | Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.
Public method | QueryMinWaveformMemory | This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.
Public method | WaitForAcquisitionComplete | Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerAcquisitionStatus Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerAcquisitionStatus Interface
See Also

IVI Digitizer class-compliant acquistion status interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerAcquisitionStatus
C#
public interface IIviDigitizerAcquisitionStatus
Visual C++
__interface IIviDigitizerAcquisitionStatus

Properties

 | Name | Description
Public property | IsIdle | Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Public property | IsMeasuring | Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Public property | IsWaitingForArm | Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Public property | IsWaitingForTrigger | Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArm Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArm Interface
See Also

IVI Digitizer class-compliant arm interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArm
C#
public interface IIviDigitizerArm
Visual C++
__interface IIviDigitizerArm

Properties

 | Name | Description
Public property | ActiveSource | -- NOT SUPPORTED -- Specifies the source the digitizer monitors for the arm event. The value specified here must be one of the valid repeated capability names for the ArmSource repeated capability.
Public property | Count | -- NOT SUPPORTED -- Specifies the number of times the arm has to occur to complete the arm loop; that is, the number of arms that are accepted before the acquisition must be initiated again.
Public property | Delay | -- NOT SUPPORTED -- Specifies the delay from when the arm logic is satisfied until the waiting for trigger state is entered. The units are seconds.
Public property | MultiArm | Pointer to the class-compliant IIviDigitizerArmMultiArm interface.
Public property | OutputEnabled | -- NOT SUPPORTED -- Specifies whether or not an accepted arm appears at an output of the digitizer.
Public property | Sources | Pointer to the IIviDigitizerArmSources interface.
Top

Methods

 | Name | Description
Public method | SendSoftwareArm | This function follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmEdge Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmEdge Interface
See Also

IVI Digitizer class-compliant edge arming interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmEdge
C#
public interface IIviDigitizerArmEdge
Visual C++
__interface IIviDigitizerArmEdge

Properties

 | Name | Description
Public property | Slope | -- NOT SUPPORTED -- Specifies whether a rising or a falling edge arms the digitizer. This attribute affects instrument operation only when the Arm Type attribute is set to Edge Arm.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- This function sets the edge arming attributes. An edge occurs when the arm signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the Level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Arm Type is Edge Arm. Set the Arm Type and Arm Coupling before calling this function. If the arm source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmGlitch Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmGlitch Interface
See Also

IVI Digitizer class-compliant glitch arming interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmGlitch
C#
public interface IIviDigitizerArmGlitch
Visual C++
__interface IIviDigitizerArmGlitch

Properties

 | Name | Description
Public property | Condition | -- NOT SUPPORTED -- Specifies the glitch condition. This attribute determines whether the glitch arm happens when the digitizer detects a pulse with a width less than or greater than the width value.
Public property | Polarity | -- NOT SUPPORTED -- Specifies the polarity of the glitch that arms the digitizer.
Public property | Width | -- NOT SUPPORTED -- Specifies the glitch width. The units are seconds. The digitizer triggers when it detects a pulse with a width less than or greater than this value, depending on the Glitch Condition attribute.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- This function configures the glitch arm. A glitch arm occurs when the arm signal has a pulse with a width that is less than or greater than the glitch width. The end user specifies which comparison criterion to use with the GlitchCondition parameter. The end-user specifies the glitch width with the GlitchWidth parameter. The end-user specifies the polarity of the pulse with the GlitchPolarity parameter. The arm does not actually occur until the edge of a pulse that corresponds to the GlitchWidth and GlitchPolarity crosses the threshold the end-user specifies in the TriggerLevel parameter. This function affects instrument behavior only if the arm type is Glitch Arm. Set the arm type and arm coupling before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmRunt Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmRunt Interface
See Also

IVI Digitizer class-compliant runt arming interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmRunt
C#
public interface IIviDigitizerArmRunt
Visual C++
__interface IIviDigitizerArmRunt

Properties

 | Name | Description
Public property | Polarity | -- NOT SUPPORTED -- Specifies the polarity of the runt that arms the digitizer.
Public property | ThresholdHigh | -- NOT SUPPORTED -- The high threshold the digitizer uses for runt arming. The units are Volts.
Public property | ThresholdLow | -- NOT SUPPORTED -- The low threshold the digitizer uses for runt arming. The units are Volts.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- This function configures the runt arm. A runt occurs when the arm signal crosses one of the runt thresholds twice without crossing the other runt threshold. The end-user specifies the runt thresholds with the RuntLowThreshold and RuntHighThreshold parameters. The end-user specifies the polarity of the runt with the RuntPolarity parameter. This function affects instrument behavior only if the arm type is Runt Trigger. Set the arm type and trigger coupling before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmSource Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSource Interface
See Also

IVI Digitizer class-compliant arm source interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmSource
C#
public interface IIviDigitizerArmSource
Visual C++
__interface IIviDigitizerArmSource

Properties

 | Name | Description
Public property | Coupling | -- NOT SUPPORTED -- Specifies how the digitizer couples the arm source.
Public property | Edge | Pointer to the class-compliant IIviDigitizerArmEdge interface.
Public property | Glitch | Pointer to the class-compliant IIviDigitizerArmGlitch interface.
Public property | Hysteresis | -- NOT SUPPORTED -- Specifies the arm hysteresis in Volts.
Public property | Level | -- NOT SUPPORTED -- Specifies the voltage threshold for the arm sub-system. The units are Volts. This attribute affects instrument behavior only when the Arm Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger.This attribute, along with the Arm Slope, Arm Source, and Arm Coupling attributes, defines the trigger event when the Arm Type is set to Edge Trigger.
Public property | Runt | Pointer to the class-compliant IIviDigitizerArmRunt interface.
Public property | TV | Pointer to the class-compliant IIviDigitizerArmTV interface.
Public property | Type | -- NOT SUPPORTED -- The kind of event that arms the digitizer.
Public property | Width | Pointer to the class-compliant IIviDigitizerArmWidth interface.
Public property | Window | Pointer to the class-compliant IIviDigitizerArmWindow interface.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmSources Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmSources Interface
See Also

IVI Digitizer class-compliant arm source collection interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmSources
C#
public interface IIviDigitizerArmSources
Visual C++
__interface IIviDigitizerArmSources

Properties

 | Name | Description
Public property | Count | The number of sources.
Public property | Item | An interface reference pointer to the IIviDigitizerArmSource interface which is selected by the source name.
Public property | Name | The source name for a given index.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmTV Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmTV Interface
See Also

IVI Digitizer class-compliant TV arming interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmTV
C#
public interface IIviDigitizerArmTV
Visual C++
__interface IIviDigitizerArmTV

Properties

 | Name | Description
Public property | Event | -- NOT SUPPORTED -- Specifies the event on which the digitizer arms.
Public property | LineNumber | -- NOT SUPPORTED -- Specifies the line on which the digitizer arms. The driver uses this attribute when the TV Arm Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to arm on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).
Public property | Polarity | -- NOT SUPPORTED -- Specifies the polarity of the TV signal.
Public property | SignalFormat | -- NOT SUPPORTED -- Specifies the format of TV signal on which the digitizer arms.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- This function configures the digitizer for TV arming. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the arm type is TV Arm. Set the Arm Type and Arm Coupling before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmWidth Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWidth Interface
See Also

IVI Digitizer class-compliant width arming interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmWidth
C#
public interface IIviDigitizerArmWidth
Visual C++
__interface IIviDigitizerArmWidth

Properties

 | Name | Description
Public property | Condition | -- NOT SUPPORTED -- Specifies whether a pulse that is within or outside the high and low thresholds arms the digitizer. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold attributes.
Public property | Polarity | -- NOT SUPPORTED -- Specifies the polarity of the pulse that arms the digitizer.
Public property | ThresholdHigh | -- NOT SUPPORTED -- Specifies the high width threshold time in seconds.
Public property | ThresholdLow | -- NOT SUPPORTED -- Specifies the low width threshold time in seconds.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the width arm Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width arm occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerArmWindow Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerArmWindow Interface
See Also

IVI Digitizer class-compliant window arming interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerArmWindow
C#
public interface IIviDigitizerArmWindow
Visual C++
__interface IIviDigitizerArmWindow

Properties

 | Name | Description
Public property | Condition | -- NOT SUPPORTED -- Specifies whether a signal that is entering or leaving the voltage window defined by the high and low thresholds arms the digitizer. The end-user specifies the high and low thresholds with the Window High Threshold and Window Low Threshold attributes.
Public property | ThresholdHigh | -- NOT SUPPORTED -- Specifies the high window threshold voltage in Volts.
Public property | ThresholdLow | -- NOT SUPPORTED -- Specifies the low window threshold voltage in Volts.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the window Arm Source, ThresholdLow, ThresholdHigh, and Condition. A window arm occurs when a signal that enters or leaves a given voltage range is detected.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerCalibration Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerCalibration Interface
See Also

IVI Digitizer class-compliant calibration interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerCalibration
C#
public interface IIviDigitizerCalibration
Visual C++
__interface IIviDigitizerCalibration

Methods

 | Name | Description
Public method | SelfCalibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerChannel Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannel Interface
See Also

IVI Digitizer class-compliant channel interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerChannel
C#
public interface IIviDigitizerChannel
Visual C++
__interface IIviDigitizerChannel

Properties

 | Name | Description
Public property | Coupling | Specifies how the digitizer couples the input signal for the channel.
Public property | DataInterleavedChannelList | -- NOT SUPPORTED -- This attribute is used to combine this channel with one or more other channels to interleave the returned data. The string provided here specifies which channels should operate in combined mode with the current channel.
Public property | Downconversion | Pointer to the IIviDigitizerDownconversion interface.
Public property | Enabled | Specifies whether the digitizer acquires a waveform for the channel.
Public property | Filter | Pointer to the IIviDigitizerFilterinterface.
Public property | InputConnectorSelection | Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1, 2
Public property | InputImpedance | The input impedance of this channel. The units are Ohms.
Public property | Measurement | Pointer to the class-compliant IIviDigitizerChannelMeasurement interface.
Public property | MultiRecordMeasurement | Pointer to the IIviDigitizerChannelMultiRecordMeasurement interface.
Public property | Offset | The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Public property | Range | The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Public property | Temperature | Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.
Public property | TimeInterleavedChannelList | This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.
Top

Methods

 | Name | Description
Public method | Configure | This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerChannelDownconversion Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelDownconversion Interface
See Also

IVI Digitizer class-compliant downconversion interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerChannelDownconversion
C#
public interface IIviDigitizerChannelDownconversion
Visual C++
__interface IIviDigitizerChannelDownconversion

Properties

 | Name | Description
Public property | CenterFrequency | Specifies the center frequency, in Hz, from which the digitizer should downconvert.
Public property | Enabled | Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.
Public property | IQInterleaved | Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.
Top

Methods

 | Name | Description
Public method | Configure | Configures how the digitizer performs downconversion.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerChannelFilter Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelFilter Interface
See Also

IVI Digitizer class-compliant channel filter interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerChannelFilter
C#
public interface IIviDigitizerChannelFilter
Visual C++
__interface IIviDigitizerChannelFilter

Properties

 | Name | Description
Public property | Bypass | Specifies whether or not to bypass the input filter.
Public property | MaxFrequency | Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
Public property | MinFrequency | -- NOT_SUPPORTED -- Specifies the minimum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT_SUPPORTED -- This function is used to configure the minimum and maximum input filter frequencies for a specified channel.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerChannelMeasurement Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMeasurement Interface
See Also

IVI Digitizer class-compliant measurement interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerChannelMeasurement
C#
public interface IIviDigitizerChannelMeasurement
Visual C++
__interface IIviDigitizerChannelMeasurement

Methods

 | Name | Description
Public method | FetchWaveformInt16 | This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchWaveformInt32 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchWaveformInt8 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchWaveformReal64 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.
Public method | ReadWaveformInt16 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | ReadWaveformInt32 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | ReadWaveformInt8 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | ReadWaveformReal64 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerChannelMultiRecordMeasurement Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannelMultiRecordMeasurement Interface
See Also

IVI Digitizer class-compliant multi-record measurement interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerChannelMultiRecordMeasurement
C#
public interface IIviDigitizerChannelMultiRecordMeasurement
Visual C++
__interface IIviDigitizerChannelMultiRecordMeasurement

Methods

 | Name | Description
Public method | FetchMultiRecordWaveformInt16 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchMultiRecordWaveformInt32 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchMultiRecordWaveformInt8 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Public method | FetchMultiRecordWaveformReal64 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerChannels Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerChannels Interface
See Also

IVI Digitizer class-compliant channel collection interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerChannels
C#
public interface IIviDigitizerChannels
Visual C++
__interface IIviDigitizerChannels

Properties

 | Name | Description
Public property | Count | Returns the number of channels available on the device.
Public property | Item | An interface reference pointer to the IIviDigitizerChannel interface which is selected by the channel name.
Public property | Name | Returns the physical repeated capability identifier defined by the specific driver for the Channel that corresponds to the one-based index that the user specifies. Valid values for the Index parameter are between one and the value of the Channel Count attribute. If the user passes an invalid value for the Index parameter, the value of this attribute is an empty string.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerMultiArm Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiArm Interface
See Also

IVI Digitizer class-compliant multi-arm interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerMultiArm
C#
public interface IIviDigitizerMultiArm
Visual C++
__interface IIviDigitizerMultiArm

Properties

 | Name | Description
Public property | SourceList | -- NOT SUPPORTED -- A comma separated list of source names to be used in a multi arm scenario. This attribute only affects instrument behavior when the Arm Source Operator attribute is set to AND or OR. When Arm Source Operator is set to AND, the arm conditions associated with each source in this list must be simultaneously satsified in order to arm the digitizer. When Arm Source Operator is set to OR, the first arm source in the list that satisfies its arm conditions will arm the digitizer. Any valid name used for the Arm Source attribute may be used in this list. An arm source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.
Public property | SourceOperator | -- NOT SUPPORTED -- Specifies the boolean operation to apply to the arm sources specified by the Arm Source List attribute. See the definition of that attribute for details.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the digitizer to arm based on multiple arm sources. The digitizer can be instructed to arm when any one of multiple arm source conditions are met or when all specified arm source conditions are met.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerMultiTrigger Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerMultiTrigger Interface
See Also

IVI Digitizer class-compliant multi-trigger interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerMultiTrigger
C#
public interface IIviDigitizerMultiTrigger
Visual C++
__interface IIviDigitizerMultiTrigger

Properties

 | Name | Description
Public property | SourceList | A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.
Public property | SourceOperator | Specifies the boolean operation to apply to the arm sources specified by the SourceList property. If set to None, muti triggering is disabled. A valid SourceList must be set before setting the SourceOperator to AND or OR. See the help for SourceList for more info.
Top

Methods

 | Name | Description
Public method | Configure | Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerReferenceOscillator Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerReferenceOscillator Interface
See Also

IVI Digitizer class-compliant reference oscillator interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerReferenceOscillator
C#
public interface IIviDigitizerReferenceOscillator
Visual C++
__interface IIviDigitizerReferenceOscillator

Properties

 | Name | Description
Public property | ExternalFrequency | Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
Public property | OutputEnabled | Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.
Public property | Source | Specifies the reference frequency source used.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the digitizer's reference oscillator.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerSampleClock Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerSampleClock Interface
See Also

IVI Digitizer class-compliant sample clock interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerSampleClock
C#
public interface IIviDigitizerSampleClock
Visual C++
__interface IIviDigitizerSampleClock

Properties

 | Name | Description
Public property | ExternalDivider | Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.x
Public property | ExternalFrequency | Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
Public property | OutputEnabled | -- NOT SUPPORTED -- Specifies whether or not the sample clock appears at a reference output of the digitizer.
Public property | Source | Specifies the clock used to pace acquisition sampling.
Top

Methods

 | Name | Description
Public method | Configure | Configures the digitizer's sample clock.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTemperature Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTemperature Interface
See Also

IVI Digitizer class-compliant temperature interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTemperature
C#
public interface IIviDigitizerTemperature
Visual C++
__interface IIviDigitizerTemperature

Properties

 | Name | Description
Public property | BoardTemperature | Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.
Public property | Units | Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTrigger Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTrigger Interface
See Also

IVI Digitizer class-compliant trigger interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTrigger
C#
public interface IIviDigitizerTrigger
Visual C++
__interface IIviDigitizerTrigger

Properties

 | Name | Description
Public property | ActiveSource | Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".
Public property | Delay | Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
Public property | Holdoff | -- NOT SUPPORTED -- Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute.
Public property | Modifier | Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.
Public property | MultiTrigger | Pointer to the class-compliant IIviDigitizerMultiTrigger interface.
Public property | OutputEnabled | Specifies whether or not an accepted trigger appears at an output of the digitizer.
Public property | PretriggerSamples | -- NOT SUPPORTED -- Specifies the number of samples that must be collected before a trigger event will be recognized. The Pretrigger Samples attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and Pretrigger Samples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger.
Public property | Sources | Pointer to the IIviDigitizerTriggerSources interface.
Top

Methods

 | Name | Description
Public method | SendSoftwareTrigger | Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerEdge Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerEdge Interface
See Also

IVI Digitizer class-compliant edge triggering interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerEdge
C#
public interface IIviDigitizerTriggerEdge
Visual C++
__interface IIviDigitizerTriggerEdge

Properties

 | Name | Description
Public property | Slope | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
Top

Methods

 | Name | Description
Public method | Configure | This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerGlitch Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerGlitch Interface
See Also

IVI Digitizer class-compliant glitch triggering interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerGlitch
C#
public interface IIviDigitizerTriggerGlitch
Visual C++
__interface IIviDigitizerTriggerGlitch

Properties

 | Name | Description
Public property | Condition | -- NOT SUPPORTED -- Specifies the glitch condition. This attribute determines whether the glitch trigger happens when the digitizer detects a pulse with a width less than or greater than the width value.
Public property | Polarity | -- NOT SUPPORTED -- Specifies the polarity of the glitch that triggers the digitizer.
Public property | Width | -- NOT SUPPORTED -- Specifies the glitch width. The units are seconds. The digitizer triggers when it detects a pulse with a width less than or greater than this value, depending on the Glitch Condition attribute.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- This function configures the glitch trigger. A glitch trigger occurs when the trigger signal has a pulse with a width that is less than or greater than the glitch width. The end user specifies which comparison criterion to use with the GlitchCondition parameter. The end-user specifies the glitch width with the GlitchWidth parameter. The end-user specifies the polarity of the pulse with the GlitchPolarity parameter. The trigger does not actually occur until the edge of a pulse that corresponds to the GlitchWidth and GlitchPolarity crosses the threshold the end-user specifies in the TriggerLevel parameter. This function affects instrument behavior only if the trigger type is Glitch Trigger. Set the trigger type and trigger coupling before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerRunt Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerRunt Interface
See Also

IVI Digitizer class-compliant runt triggering interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerRunt
C#
public interface IIviDigitizerTriggerRunt
Visual C++
__interface IIviDigitizerTriggerRunt

Properties

 | Name | Description
Public property | Polarity | -- NOT SUPPORTED -- Specifies the polarity of the runt that triggers the digitizer.
Public property | ThresholdHigh | -- NOT SUPPORTED -- The high threshold the digitizer uses for runt triggering. The units are Volts.
Public property | ThresholdLow | -- NOT SUPPORTED -- The low threshold the digitizer uses for runt triggering. The units are Volts.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- This function configures the runt trigger. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold. The end-user specifies the runt thresholds with the RuntLowThreshold and RuntHighThreshold parameters. The end-user specifies the polarity of the runt with the RuntPolarity parameter. This function affects instrument behavior only if the trigger type is Runt Trigger. Set the trigger type and trigger coupling before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerSource Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSource Interface
See Also

IVI Digitizer class-compliant trigger source interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerSource
C#
public interface IIviDigitizerTriggerSource
Visual C++
__interface IIviDigitizerTriggerSource

Properties

 | Name | Description
Public property | Coupling | Specifies how the digitizer couples the trigger source.
Public property | Edge | Pointer to the class-compliant IIviDigitizerTriggerEdge interface.
Public property | Glitch | Pointer to the class-compliant IIviDigitizerTriggerGlitch interface.
Public property | Hysteresis | Specifies the trigger hysteresis in Volts.
Public property | Level | Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
Public property | Runt | Pointer to the class-compliant IIviDigitizerTriggerRunt interface.
Public property | TV | Pointer to the class-compliant IIviDigitizerTriggerTV interface.
Public property | Type | The kind of event that triggers the digitizer. TV triggering requires External trigger source.
Public property | Width | Pointer to the class-compliant IIviDigitizerTriggerWidth interface.
Public property | Window | Pointer to the class-compliant IIviDigitizerTriggerWindow interface.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerSources Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerSources Interface
See Also

IVI Digitizer class-compliant trigger source collection interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerSources
C#
public interface IIviDigitizerTriggerSources
Visual C++
__interface IIviDigitizerTriggerSources

Properties

 | Name | Description
Public property | Count | The number of trigger sources.
Public property | Item | An interface reference pointer to the IIviDigitizerTriggerSource interface which is selected by the source name.
Public property | Name | The source name for a given index.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerTV Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerTV Interface
See Also

IVI Digitizer class-compliant TV triggering interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerTV
C#
public interface IIviDigitizerTriggerTV
Visual C++
__interface IIviDigitizerTriggerTV

Properties

 | Name | Description
Public property | Event | Specifies the event on which the digitizer triggers.
Public property | LineNumber | Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).
Public property | Polarity | Specifies the polarity of the TV signal.
Public property | SignalFormat | Specifies the format of TV signal on which the digitizer triggers.
Top

Methods

 | Name | Description
Public method | Configure | This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerWidth Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWidth Interface
See Also

IVI Digitizer class-compliant width triggering interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerWidth
C#
public interface IIviDigitizerTriggerWidth
Visual C++
__interface IIviDigitizerTriggerWidth

Properties

 | Name | Description
Public property | Condition | -- NOT SUPPORTED -- Specifies whether a pulse that is within or outside the high and low thresholds triggers the digitizer. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold attributes.
Public property | Polarity | -- NOT SUPPORTED -- Specifies the polarity of the pulse that triggers the digitizer.
Public property | ThresholdHigh | -- NOT SUPPORTED -- Specifies the high width threshold time in seconds.
Public property | ThresholdLow | -- NOT SUPPORTED -- Specifies the low width threshold time in seconds.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IIviDigitizerTriggerWindow Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviDigitizerTriggerWindow Interface
See Also

IVI Digitizer class-compliant window triggering interface.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Interface IIviDigitizerTriggerWindow
C#
public interface IIviDigitizerTriggerWindow
Visual C++
__interface IIviDigitizerTriggerWindow

Properties

 | Name | Description
Public property | Condition | -- NOT SUPPORTED -- Specifies whether a signal that is entering or leaving the voltage window defined by the high and low thresholds triggers the digitizer. The end-user specifies the high and low thresholds with the Window High Threshold and Window Low Threshold attributes.
Public property | ThresholdHigh | -- NOT SUPPORTED -- Specifies the high window threshold voltage in Volts.
Public property | ThresholdLow | -- NOT SUPPORTED -- Specifies the low window threshold voltage in Volts.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the window trigger Source, ThresholdLow, ThresholdHigh, and Condition. A window trigger occurs when a signal that enters or leaves a given voltage range is detected.
Top

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerAcquisitionStatusResultEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerAcquisitionStatusResultEnum Enumeration
See Also

Defined values for the acquisition status result.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerAcquisitionStatusResultEnum
C#
public enum IviDigitizerAcquisitionStatusResultEnum
Visual C++
public enum class IviDigitizerAcquisitionStatusResultEnum

Members

Member name | Value | Description
IviDigitizerAcquisitionStatusResultTrue | 0x00000001 | The state of the status condition is true.
IviDigitizerAcquisitionStatusResultFalse | 0x00000002 | The state of the status condition is false.
IviDigitizerAcquisitionStatusResultUnknown | 0x00000003 | The state of the status condition could not be determined.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerArmSourceOperatorEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerArmSourceOperatorEnum Enumeration
See Also

Defined values for the arm source operator.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerArmSourceOperatorEnum
C#
public enum IviDigitizerArmSourceOperatorEnum
Visual C++
public enum class IviDigitizerArmSourceOperatorEnum

Members

Member name | Value | Description
IviDigitizerArmSourceOperatorAND | 0x00000000 | Arm sources are AND'd together. The digitizer arms when all configured arm source conditions are satisfied.
IviDigitizerArmSourceOperatorOR | 0x00000001 | Arm sources are OR'd together. The digitizer arms when the first configured arm source condition is satisfied.
IviDigitizerArmSourceOperatorNone | 0x00000002 | No operator is applied to the configured list of arm sources. The arm source list is ignored, and the digitizer arms when the currently configured arm source, given by the Arm Source attribute, and its associated arm conditions are satisfied.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerArmTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerArmTypeEnum Enumeration
See Also

Defined values for trigger type

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerArmTypeEnum
C#
public enum IviDigitizerArmTypeEnum
Visual C++
public enum class IviDigitizerArmTypeEnum

Members

Member name | Value | Description
IviDigitizerArmEdge | 0x00000001 | Configures the digitizer for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source attribute passes the voltage threshold specified with the Trigger Level attribute and has the slope specified with the Trigger Slope attribute.
IviDigitizerArmWidth | 0x00000002 | Configures the digitizer for width triggering. Use the IviDigitizerWidthTrigger extension properties and methods to configure the trigger.
IviDigitizerArmRunt | 0x00000003 | Configures the digitizer for runt triggering. Use the IviDigitizerRuntTrigger extension properties and methods to configure the trigger.
IviDigitizerArmGlitch | 0x00000004 | Configures the digitizer for glitch triggering. Use the IviDigitizerGlitchTrigger extension properties and methods to configure the trigger.
IviDigitizerArmTV | 0x00000005 | Configures the digitizer for triggering on TV signals. Use the IviDigitizerTVTrigger extension properties and methods to configure the trigger.
IviDigitizerArmWindow | 0x00000006 | Configures the digitizer for window triggering. Use the IviDigitizerWindowTrigger extension properties and methods to configure the trigger.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerErrorCodesEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerErrorCodesEnum Enumeration
See Also

IVI Digitizer class-defined HRESULTS

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerErrorCodesEnum
C#
public enum IviDigitizerErrorCodesEnum
Visual C++
public enum class IviDigitizerErrorCodesEnum

Members

Member name | Value | Description
E_IVIDIGITIZER_CHANNEL_NOT_ENABLED | 0x80042001 |
E_IVIDIGITIZER_MAX_TIME_EXCEEDED | 0x80042002 |
E_IVIDIGITIZER_TRIGGER_NOT_SOFTWARE | 0x80041001 |
E_IVIDIGITIZER_ARM_NOT_SOFTWARE | 0x80042003 |
E_IVIDIGITIZER_INCOMPATIBLE_FETCH | 0x80042004 |

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerGlitchConditionEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerGlitchConditionEnum Enumeration
See Also

Defined values values for glitch trigger condition.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerGlitchConditionEnum
C#
public enum IviDigitizerGlitchConditionEnum
Visual C++
public enum class IviDigitizerGlitchConditionEnum

Members

Member name | Value | Description
IviDigitizerGlitchConditionLessThan | 0x00000001 | The digitizer triggers when the pulse width is less than the value you specify with the Glitch Width attribute.
IviDigitizerGlitchConditionGreaterThan | 0x00000002 | The digitizer triggers when the pulse width is greater than the value you specify with the Glitch Width attribute.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerGlitchPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerGlitchPolarityEnum Enumeration
See Also

Defined values for glitch trigger Polarity

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerGlitchPolarityEnum
C#
public enum IviDigitizerGlitchPolarityEnum
Visual C++
public enum class IviDigitizerGlitchPolarityEnum

Members

Member name | Value | Description
IviDigitizerGlitchPolarityPositive | 0x00000001 | The digitizer triggers on a positive glitch.
IviDigitizerGlitchPolarityNegative | 0x00000002 | The digitizer triggers on a negative glitch.
IviDigitizerGlitchPolarityEither | 0x00000003 | The digitizer triggers on either a positive or negative glitch.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerReferenceOscillatorSourceEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerReferenceOscillatorSourceEnum Enumeration
See Also

Defined values for the reference oscillator source.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerReferenceOscillatorSourceEnum
C#
public enum IviDigitizerReferenceOscillatorSourceEnum
Visual C++
public enum class IviDigitizerReferenceOscillatorSourceEnum

Members

Member name | Value | Description
IviDigitizerReferenceOscillatorSourceInternal | 0x00000000 | The internal reference oscillator is used.
IviDigitizerReferenceOscillatorSourceExternal | 0x00000001 | An external reference oscillator is used.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerRuntPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerRuntPolarityEnum Enumeration
See Also

Defined values for runt trigger polarity

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerRuntPolarityEnum
C#
public enum IviDigitizerRuntPolarityEnum
Visual C++
public enum class IviDigitizerRuntPolarityEnum

Members

Member name | Value | Description
IviDigitizerRuntPolarityPositive | 0x00000001 | The digitizer triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
IviDigitizerRuntPolarityNegative | 0x00000002 | The digitizer triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
IviDigitizerRuntPolarityEither | 0x00000003 | The digitizer triggers on either a positive or negative runt.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerSampleClockSourceEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerSampleClockSourceEnum Enumeration
See Also

Defined values for the sample clock source.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerSampleClockSourceEnum
C#
public enum IviDigitizerSampleClockSourceEnum
Visual C++
public enum class IviDigitizerSampleClockSourceEnum

Members

Member name | Value | Description
IviDigitizerSampleClockSourceInternal | 0x00000000 | The internal sample clock is used.
IviDigitizerSampleClockSourceExternal | 0x00000001 | An external sample clock is used.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerSampleModeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerSampleModeEnum Enumeration
See Also

Defined values for acquisition SampleMode.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerSampleModeEnum
C#
public enum IviDigitizerSampleModeEnum
Visual C++
public enum class IviDigitizerSampleModeEnum

Members

Member name | Value | Description
IviDigitizerSampleModeRealTime | 0x00000000 | Real-time sampling is used.
IviDigitizerSampleModeEquivalentTime | 0x00000001 | Equivalent-time sampling is used.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTemperatureUnitsEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTemperatureUnitsEnum Enumeration
See Also

Defined values for the temperature units.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTemperatureUnitsEnum
C#
public enum IviDigitizerTemperatureUnitsEnum
Visual C++
public enum class IviDigitizerTemperatureUnitsEnum

Members

Member name | Value | Description
IviDigitizerTemperatureUnitsCelsius | 0x00000000 | Temperature values returned from the digitizer are in degrees Celsius.
IviDigitizerTemperatureUnitsFahrenheit | 0x00000001 | Temperature values returned from the digitizer are in degrees Fahrenheit.
IviDigitizerTemperatureUnitsKelvin | 0x00000002 | Temperature values returned from the digitizer are in degrees Kelvin.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTimeOutEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTimeOutEnum Enumeration
See Also

Defined values for the MaxTimeMilliseconds parameter of the measurement Read and Fetch methods.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTimeOutEnum
C#
public enum IviDigitizerTimeOutEnum
Visual C++
public enum class IviDigitizerTimeOutEnum

Members

Member name | Value | Description
IviDigitizerTimeOutImmediate | 0x00000000 | The method returns immediately. If no valid measurement value exists, the method returns an error.
IviDigitizerTimeOutInfinite | 0xFFFFFFFF | The method waits indefinitely for the measurement to complete.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTriggerCouplingEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTriggerCouplingEnum Enumeration
See Also

Defined values for trigger Coupling.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTriggerCouplingEnum
C#
public enum IviDigitizerTriggerCouplingEnum
Visual C++
public enum class IviDigitizerTriggerCouplingEnum

Members

Member name | Value | Description
IviDigitizerTriggerCouplingAC | 0x00000000 | The digitizer AC couples the trigger signal.
IviDigitizerTriggerCouplingDC | 0x00000001 | The digitizer DC couples the trigger signal.
IviDigitizerTriggerCouplingNoiseReject | 0x00000004 | -- NOT SUPPORTED -- The digitizer filters out the noise from the arm signal.
IviDigitizerTriggerCouplingHFReject | 0x00000002 | The digitizer filters out the high frequencies from the arm signal.
IviDigitizerTriggerCouplingLFReject | 0x00000003 | -- NOT SUPPORTED -- The digitizer filters out the low frequencies from the arm signal.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTriggerModifierEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTriggerModifierEnum Enumeration
See Also

Defined values for trigger modifier.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTriggerModifierEnum
C#
public enum IviDigitizerTriggerModifierEnum
Visual C++
public enum class IviDigitizerTriggerModifierEnum

Members

Member name | Value | Description
IviDigitizerTriggerModifierNone | 0x00000001 | The digitizer waits until the trigger the end-user specifies occurs.
IviDigitizerTriggerModifierAuto | 0x00000002 | The digitizer automatically triggers if the configured trigger does not occur within the digitizer timeout period.
IviDigitizerTriggerModifierAutoLevel | 0x00000003 | The digitizer adjusts the trigger level if the trigger the end-user specifies does not occur.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTriggerSlopeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTriggerSlopeEnum Enumeration
See Also

Defined values for edge trigger slope.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTriggerSlopeEnum
C#
public enum IviDigitizerTriggerSlopeEnum
Visual C++
public enum class IviDigitizerTriggerSlopeEnum

Members

Member name | Value | Description
IviDigitizerTriggerSlopeNegative | 0x00000000 | A negative (falling) edge passing through the trigger level triggers the digitizer.
IviDigitizerTriggerSlopePositive | 0x00000001 | A positive (rising) edge passing through the trigger level triggers the digitizer.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTriggerSourceOperatorEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTriggerSourceOperatorEnum Enumeration
See Also

Defined values for the trigger source operator.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTriggerSourceOperatorEnum
C#
public enum IviDigitizerTriggerSourceOperatorEnum
Visual C++
public enum class IviDigitizerTriggerSourceOperatorEnum

Members

Member name | Value | Description
IviDigitizerTriggerSourceOperatorAND | 0x00000000 | Trigger sources are AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
IviDigitizerTriggerSourceOperatorOR | 0x00000001 | Trigger sources are OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
IviDigitizerTriggerSourceOperatorNone | 0x00000002 | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Trigger Source attribute, and its associated trigger conditions are satisfied.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTriggerTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTriggerTypeEnum Enumeration
See Also

Defined values for trigger type

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTriggerTypeEnum
C#
public enum IviDigitizerTriggerTypeEnum
Visual C++
public enum class IviDigitizerTriggerTypeEnum

Members

Member name | Value | Description
IviDigitizerTriggerEdge | 0x00000001 | Configures the digitizer for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source attribute passes the voltage threshold specified with the Trigger Level attribute and has the slope specified with the Trigger Slope attribute.
IviDigitizerTriggerWidth | 0x00000002 | -- NOT SUPPORTED -- Configures the digitizer for width triggering. Use the IviDigitizerWidthTrigger extension properties and methods to configure the trigger.
IviDigitizerTriggerRunt | 0x00000003 | -- NOT SUPPORTED -- Configures the digitizer for runt triggering. Use the IviDigitizerRuntTrigger extension properties and methods to configure the trigger.
IviDigitizerTriggerGlitch | 0x00000004 | -- NOT SUPPORTED -- Configures the digitizer for glitch triggering. Use the IviDigitizerGlitchTrigger extension properties and methods to configure the trigger.
IviDigitizerTriggerTV | 0x00000005 | Configures the digitizer for triggering on TV signals. Use the IviDigitizerTVTrigger extension properties and methods to configure the trigger.
IviDigitizerTriggerWindow | 0x00000006 | -- NOT SUPPORTED -- Configures the digitizer for window triggering. Use the IviDigitizerWindowTrigger extension properties and methods to configure the trigger.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTVSignalFormatEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTVSignalFormatEnum Enumeration
See Also

Defined values for TV trigger SignalFormat

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTVSignalFormatEnum
C#
public enum IviDigitizerTVSignalFormatEnum
Visual C++
public enum class IviDigitizerTVSignalFormatEnum

Members

Member name | Value | Description
IviDigitizerTVSignalFormatNTSC | 0x00000001 | Configures the digitizer to trigger on the NTSC signal format.
IviDigitizerTVSignalFormatPAL | 0x00000002 | Configures the digitizer to trigger on the PAL signal format
IviDigitizerTVSignalFormatSECAM | 0x00000003 | Configures the digitizer to trigger on the SECAM signal format

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTVTriggerEventEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTVTriggerEventEnum Enumeration
See Also

Defined values for TV trigger Event

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTVTriggerEventEnum
C#
public enum IviDigitizerTVTriggerEventEnum
Visual C++
public enum class IviDigitizerTVTriggerEventEnum

Members

Member name | Value | Description
IviDigitizerTVTriggerEventField1 | 0x00000001 | Sets the digitizer to trigger on field 1 of the video signal.
IviDigitizerTVTriggerEventField2 | 0x00000002 | Sets the digitizer to trigger on field 2 of the video signal.
IviDigitizerTVTriggerEventAnyField | 0x00000003 | Sets the digitizer to trigger on any field.
IviDigitizerTVTriggerEventAnyLine | 0x00000004 | Sets the digitizer to trigger on any line.
IviDigitizerTVTriggerEventLineNumber | 0x00000005 | Sets the digitizer to trigger on a specific line number you specify with the TV Trigger Line Number attribute.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerTVTriggerPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerTVTriggerPolarityEnum Enumeration
See Also

Defined values for TV trigger Polarity

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerTVTriggerPolarityEnum
C#
public enum IviDigitizerTVTriggerPolarityEnum
Visual C++
public enum class IviDigitizerTVTriggerPolarityEnum

Members

Member name | Value | Description
IviDigitizerTVTriggerPolarityPositive | 0x00000001 | Configures the digitizer to trigger on a positive video sync pulse.
IviDigitizerTVTriggerPolarityNegative | 0x00000002 | Configures the digitizer to trigger on a negative video sync pulse.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerVerticalCouplingEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerVerticalCouplingEnum Enumeration
See Also

Defined values for channel Coupling.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerVerticalCouplingEnum
C#
public enum IviDigitizerVerticalCouplingEnum
Visual C++
public enum class IviDigitizerVerticalCouplingEnum

Members

Member name | Value | Description
IviDigitizerVerticalCouplingAC | 0x00000000 | The digitizer AC couples the input signal.
IviDigitizerVerticalCouplingDC | 0x00000001 | The digitizer DC couples the input signal.
IviDigitizerVerticalCouplingGnd | 0x00000002 | The digitizer couples the channel to the ground.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerWidthConditionEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerWidthConditionEnum Enumeration
See Also

Defined values for width trigger Condition

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerWidthConditionEnum
C#
public enum IviDigitizerWidthConditionEnum
Visual C++
public enum class IviDigitizerWidthConditionEnum

Members

Member name | Value | Description
IviDigitizerWidthConditionWithin | 0x00000001 | Configures the digitizer to trigger on signals when they enter the given triggering window. The end-user specifies the high and low thresholds with the Window Trigger High Threshold and Window Trigger Low Threshold properties.
IviDigitizerWidthConditionOutside | 0x00000002 | Configures the digitizer to trigger on signals when they leave the given triggering window. The end-user specifies the high and low thresholds with the Window Trigger High Threshold and Window Trigger Low Threshold properties.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerWidthPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerWidthPolarityEnum Enumeration
See Also

Defined values for width trigger Polarity

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerWidthPolarityEnum
C#
public enum IviDigitizerWidthPolarityEnum
Visual C++
public enum class IviDigitizerWidthPolarityEnum

Members

Member name | Value | Description
IviDigitizerWidthPolarityPositive | 0x00000001 | Configures the digitizer to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition attribute.
IviDigitizerWidthPolarityNegative | 0x00000002 | Configures the digitizer to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition attribute.
IviDigitizerWidthPolarityEither | 0x00000003 | Configures the digitizer to trigger on either positive or negative pulses that have a width that meets the condition the user specifies with the Width Condition attribute.

See Also

Reference

Ivi.Digitizer.Interop Namespace


IviDigitizerWindowConditionEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviDigitizerWindowConditionEnum Enumeration
See Also

Defined values for window trigger Condition.

Namespace: Ivi.Digitizer.Interop
Assembly: Ivi.Digitizer.Interop (in Ivi.Digitizer.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviDigitizerWindowConditionEnum
C#
public enum IviDigitizerWindowConditionEnum
Visual C++
public enum class IviDigitizerWindowConditionEnum

Members

Member name | Value | Description
IviDigitizerWindowConditionEntering | 0x00000001 | Configures the digitizer to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.
IviDigitizerWindowConditionLeaving | 0x00000002 | Configures the digitizer to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.

See Also

Reference

Ivi.Digitizer.Interop Namespace


Ivi.Scope.Interop Namespace

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Ivi.Scope.Interop Namespace

Interfaces

 | Interface | Description
Public interface | IIviScope | IVI Scope class-compliant root interface
Public interface | IIviScopeAcquisition | IVI Scope class-compliant acquisition interface
Public interface | IIviScopeChannel | IVI Scope class-compliant channel interface
Public interface | IIviScopeChannels | IVI Scope class-compliant channel collection interface
Public interface | IIviScopeMeasurement | IVI Scope class-compliant measurement interface
Public interface | IIviScopeMeasurements | IVI Scope class-compliant measurement collection interface
Public interface | IIviScopeReferenceLevel | IVI Scope class-compliant reference level interface
Public interface | IIviScopeTrigger | IVI Scope class-compliant trigger interface
Public interface | IIviScopeTriggerAcLine | IVI Scope class-compliant AC line trigger interface
Public interface | IIviScopeTriggerEdge | IVI Scope class-compliant edge trigger interface
Public interface | IIviScopeTriggerGlitch | IVI Scope class-compliant glitch trigger interface
Public interface | IIviScopeTriggerRunt | IVI Scope class-compliant runt trigger interface
Public interface | IIviScopeTriggerTv | IVI Scope class-compliant TV trigger interface
Public interface | IIviScopeTriggerWidth | IVI Scope class-compliant width trigger interface

Enumerations

 | Enumeration | Description
Public enumeration | IviScopeACLineSlopeEnum | IVI Scope class-compliant values for AC line trigger Slope
Public enumeration | IviScopeAcquisitionStatusEnum | IVI Scope class-compliant values for the status parameter of the acquisition Status method
Public enumeration | IviScopeAcquisitionTypeEnum | IVI Scope class-compliant values for Acquisition Type
Public enumeration | IviScopeErrorCodesEnum | IVI Scope class defined HRESULTS
Public enumeration | IviScopeGlitchConditionEnum | IVI Scope class-compliant values for glitch trigger Condition
Public enumeration | IviScopeGlitchPolarityEnum | IVI Scope class-compliant values for glitch trigger Polarity
Public enumeration | IviScopeInterpolationEnum | IVI Scope class-compliant values for acquisition Interpolation
Public enumeration | IviScopeMeasurementEnum | IVI Scope class-compliant values for the MeasFunction parameter of the measurement Read and Fetch methods
Public enumeration | IviScopeRuntPolarityEnum | IVI Scope class-compliant values for runt trigger Polarity
Public enumeration | IviScopeSampleModeEnum | IVI Scope class-compliant values for acquisition SampleMode
Public enumeration | IviScopeTimeOutEnum | IVI Scope class-compliant values for maxTime parameter of the measurement Read and Fetch methods.
Public enumeration | IviScopeTriggerCouplingEnum | IVI Scope class-compliant values for trigger Coupling
Public enumeration | IviScopeTriggerModifierEnum | IVI Scope class-compliant values for trigger Modifier
Public enumeration | IviScopeTriggerSlopeEnum | IVI Scope class-compliant values for edge trigger Slope
Public enumeration | IviScopeTriggerTypeEnum | IVI Scope class-compliant values for trigger Type
Public enumeration | IviScopeTVSignalFormatEnum | IVI Scope class-compliant values for TV trigger SignalFormat
Public enumeration | IviScopeTVTriggerEventEnum | IVI Scope class-compliant values for TV trigger Event
Public enumeration | IviScopeTVTriggerPolarityEnum | IVI Scope class-compliant values for TV trigger Polarity
Public enumeration | IviScopeVerticalCouplingEnum | IVI Scope class-compliant values for channel Coupling
Public enumeration | IviScopeWidthConditionEnum | IVI Scope class-compliant values for width trigger Condition
Public enumeration | IviScopeWidthPolarityEnum | IVI Scope class-compliant values for width trigger Polarity


IIviScopeAcquisition Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeAcquisition Interface
See Also

IVI Scope class-compliant acquisition interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeAcquisition
C#
public interface IIviScopeAcquisition
Visual C++
__interface IIviScopeAcquisition

Properties

 | Name | Description
Public property | Interpolation | -- NOT SUPPORTED -- The interpolation method the oscilloscope uses when it cannot sample a voltage for every point in the waveform record.
Public property | NumberOfAverages | The number of waveforms the oscilloscope acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.
Public property | NumberOfEnvelopes | -- NOT SUPPORTED -- The number of waveforms the oscilloscope acquires and analyzes to create the minimum and maximum waveforms, before returning to the idle state. Applies only when acquisition Type is Envelope
Public property | NumberOfPointsMin | The minimum number of points which can be in a waveform record for each channel. It configures the record length that the oscilloscope uses for waveform acquisition. The Record Length property returns the actual record length.
Public property | RecordLength | The actual number of points the oscilloscope acquires for each channel. It is equal to or greater than the minimum number of points specified with the Horizontal Minimun Number of Points property.
Public property | SampleMode | The sample mode the oscilloscope is currently using.
Public property | SampleRate | The effective digitizing rate using the current configuration. The units are samples per second.
Public property | StartTime | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Public property | TimePerRecord | The time in seconds that corresponds to the record length.
Public property | Type | How the oscilloscope acquires data and fills the waveform record. When set to Envelope or Peak Detect, the oscilloscope acquires minimum and maximum waveforms. When set to TypeAverage, averaged waveforms must be read uisng the Measurement ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods.
Top

Methods

 | Name | Description
Public method | ConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeChannel Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannel Interface
See Also

IVI Scope class-compliant channel interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeChannel
C#
public interface IIviScopeChannel
Visual C++
__interface IIviScopeChannel

Properties

 | Name | Description
Public property | Coupling | How the oscilloscope couples the input signal.
Public property | Enabled | If True, the oscilloscope acquires a waveform for this channel when the Initiate Acquisition, Read Waveform, Read Min Max Waveform, or Read Waveform Measurement methods are called.
Public property | InputFrequencyMax | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz.
Public property | InputImpedance | The input impedance of this channel. The units are ohms.
Public property | Offset | The location of the center of the range that you specify with the Range property. The units are volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Public property | ProbeAttenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Public property | ProbeSense | The probe attenuation value the oscilloscope automatically senses. If the automatic probe sense is disabled, its value is the manual probe attenuation setting.
Public property | Range | The absolute value of the input range the oscilloscope can acquire for the channel. The units are volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top

Methods

 | Name | Description
Public method | Configure | Configures the most commonly used properties of the oscilloscope channel sub-system. They are the range, offset, coupling, probe attenuation, and whether the channel is enabled.
Public method | ConfigureCharacteristics | Configures the properties that control the electrical characteristics of the channel. They are the input impedance and the maximum frequency of the input signal.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeChannels Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeChannels Interface
See Also

IVI Scope class-compliant channel collection interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeChannels
C#
public interface IIviScopeChannels
Visual C++
__interface IIviScopeChannels

Properties

 | Name | Description
Public property | Count | The number of channels.
Public property | Item | An interface reference pointer to one of the IviScopeChannel interfaces which is selected by the channel name.
Public property | Name | The channel name for a given index.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeMeasurement Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurement Interface
See Also

IVI Scope class-compliant measurement interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeMeasurement
C#
public interface IIviScopeMeasurement
Visual C++
__interface IIviScopeMeasurement

Methods

 | Name | Description
Public method | FetchWaveform | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | FetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Public method | FetchWaveformMinMax | -- NOT SUPPORTED -- Returns the previously acquired minimum and maximum waveforms for this specified channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.
Public method | ReadWaveform | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.
Public method | ReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Public method | ReadWaveformMinMax | -- NOT SUPPORTED -- Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the min/max waveforms for this channel. Call FetchMinMaxWaveform to obtain the min/max waveforms for other channels.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeMeasurements Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeMeasurements Interface
See Also

IVI Scope class-compliant measurement collection interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeMeasurements
C#
public interface IIviScopeMeasurements
Visual C++
__interface IIviScopeMeasurements

Properties

 | Name | Description
Public property | Count | The number of measurements.
Public property | Item | An interface reference pointer to one of the IviScopeMeasurement interfaces which is selected by the channel name.
Public property | Name | The measurement name for given index.
Top

Methods

 | Name | Description
Public method | Abort | Aborts an acquisition and returns the oscilloscope to the Idle state.
Public method | AutoSetup | -- NOT SUPPORTED -- Automatically configures all the oscilloscopes settings based on the input signals.
Public method | Initiate | Initiates a waveform acquisition. The oscilloscope leaves the Idle state and waits for a trigger. The oscilloscope acquires a waveform for each enabled channel.
Public method | IsWaveformElementInvalid | -- NOT SUPPORTED -- Returns False if an element in a waveform array returned by the driver contains a valid voltage. Returns True if an element in a waveform array returned by the driver contains a value indicating that the oscilloscope could not sample a voltage.
Public method | Status | Returns whether an acquisition is in progress, complete, or if the status is unknown.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeReferenceLevel Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeReferenceLevel Interface
See Also

IVI Scope class-compliant reference level interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeReferenceLevel
C#
public interface IIviScopeReferenceLevel
Visual C++
__interface IIviScopeReferenceLevel

Properties

 | Name | Description
Public property | High | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Low | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Public property | Mid | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Top

Methods

 | Name | Description
Public method | Configure | Configures the reference levels for waveform measurements, low, mid, and high.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTrigger Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTrigger Interface
See Also

IVI Scope class-compliant trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTrigger
C#
public interface IIviScopeTrigger
Visual C++
__interface IIviScopeTrigger

Properties

 | Name | Description
Public property | AcLine | Pointer to the class-compliant IIviScopeTriggerAcLine interface
Public property | Continuous | If True, the oscilloscope waits trigger holdoff seconds after a waveform acquisition is complete and then immediatley enters the wait for trigger state without passing through the idle state.
Public property | Coupling | How the oscilloscope couples the trigger source.
Public property | Edge | Pointer to the class-compliant IIviScopeTriggerEdge interface
Public property | Glitch | Pointer to the class-compliant IIviScopeTriggerGlitch interface
Public property | Holdoff | -- NOT SUPPORTED -- The length of time the oscilloscope waits after it fills the acquisition buffer until the oscilloscope enables the trigger subsystem to detect another trigger. The units are seconds.
Public property | Level | The voltage threshold for the trigger subsystem. The units are volts.
Public property | Modifier | The trigger modifier determines the oscilloscope's behavior in the absence of a trigger.
Public property | Runt | Pointer to the class-compliant IIviScopeTriggerRunt interface
Public property | Source | The signal the oscilloscope monitors for a trigger. It can be channel or one of many other values.
Public property | TV | Pointer to the class-compliant IIviScopeTriggerTv interface
Public property | Type | The kind of event that triggers the osciolloscope.
Public property | Width | Pointer to the class-compliant IIviScopeTriggerWidth interface
Top

Methods

 | Name | Description
Public method | Configure | -- Not Supported -- Configures trigger Type and Holdoff. Holdoff units are seconds.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTriggerAcLine Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerAcLine Interface
See Also

IVI Scope class-compliant AC line trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerAcLine
C#
public interface IIviScopeTriggerAcLine
Visual C++
__interface IIviScopeTriggerAcLine

Properties

 | Name | Description
Public property | Slope | -- NOT SUPPORTED -- The slope of the zero crossing upon which the scope triggers.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTriggerEdge Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerEdge Interface
See Also

IVI Scope class-compliant edge trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerEdge
C#
public interface IIviScopeTriggerEdge
Visual C++
__interface IIviScopeTriggerEdge

Properties

 | Name | Description
Public property | Slope | The slope, a rising or a falling edge, that triggers the oscilloscope.
Top

Methods

 | Name | Description
Public method | Configure | Configures the conidtions for edge trigger. An edge trigger occurs when the trigger source signal passes through the trigger level with the specified slope.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTriggerGlitch Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerGlitch Interface
See Also

IVI Scope class-compliant glitch trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerGlitch
C#
public interface IIviScopeTriggerGlitch
Visual C++
__interface IIviScopeTriggerGlitch

Properties

 | Name | Description
Public property | condition | -- NOT SUPPORTED -- The glitch condition detemermines whether the oscilloscope triggers on a a pulse with a width less than or greater than the glitch width value.
Public property | polarity | -- NOT SUPPORTED -- The polarity of the glitch that triggers the oscilloscope.
Public property | Width | -- NOT SUPPORTED -- The glitch width. The units are seconds.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configure the glitch trigger Source, Level, Width, Polarity, and Condition. A glitch trigger occurs when the edge of a pulse that matches the Width and Polarity crosses the specified Level (in Volts).
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTriggerRunt Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerRunt Interface
See Also

IVI Scope class-compliant runt trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerRunt
C#
public interface IIviScopeTriggerRunt
Visual C++
__interface IIviScopeTriggerRunt

Properties

 | Name | Description
Public property | polarity | -- NOT SUPPORTED -- The polarity of the runt that triggers the oscilloscope.
Public property | ThresholdHigh | -- NOT SUPPORTED -- The high threshold the oscilloscope uses for runt triggering. The units are volts.
Public property | ThresholdLow | -- NOT SUPPORTED -- The low threshold the oscilloscope uses for runt triggering. The units are volts.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the runt trigger Source, ThresholdLow, ThresholdHigh, and Polarity. A runt trigger occurs when the trigger signal crosses one of the runt thresholds twice without crossing the other runt threshold.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTriggerTv Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerTv Interface
See Also

IVI Scope class-compliant TV trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerTv
C#
public interface IIviScopeTriggerTv
Visual C++
__interface IIviScopeTriggerTv

Properties

 | Name | Description
Public property | Event | The event on which the oscilloscope triggers.
Public property | LineNumber | The line on which the oscilloscope triggers. The line number is absolute and not relative to the field of the TV signal.
Public property | polarity | The polarity of the TV signal.
Public property | SignalFormat | The format of the TV signal on which the oscilloscope triggers.
Top

Methods

 | Name | Description
Public method | Configure | Configures the TV trigger source, signal format, event and polarity.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IIviScopeTriggerWidth Interface

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IIviScopeTriggerWidth Interface
See Also

IVI Scope class-compliant width trigger interface

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Interface IIviScopeTriggerWidth
C#
public interface IIviScopeTriggerWidth
Visual C++
__interface IIviScopeTriggerWidth

Properties

 | Name | Description
Public property | condition | -- NOT SUPPORTED -- The condition of a pulse that triggers the oscilloscope. The condition is either inside or outside of the high and low thresholds.
Public property | polarity | -- NOT SUPPORTED -- The polarity of the pulse that triggers the oscilloscope.
Public property | ThresholdHigh | -- NOT SUPPORTED -- The high width threshold time. The units are seconds.
Public property | ThresholdLow | -- NOT SUPPORTED -- The low width threshold time. The units are seconds.
Top

Methods

 | Name | Description
Public method | Configure | -- NOT SUPPORTED -- Configures the width trigger Source, Level, ThresholdLow, ThresholdHigh, Polarity, and Condition. A width trigger occurs when a pulse, that passes through Level, with a width between or outside, the width thresholds is detected.
Top

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeACLineSlopeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeACLineSlopeEnum Enumeration
See Also

IVI Scope class-compliant values for AC line trigger Slope

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeACLineSlopeEnum
C#
public enum IviScopeACLineSlopeEnum
Visual C++
public enum class IviScopeACLineSlopeEnum

Members

Member name | Value | Description
IviScopeACLinePositive | 0x00000001 | Configures the oscilloscope to trigger on positive slope zero crossings of the network supply voltage.
IviScopeACLineNegative | 0x00000002 | Configures the oscilloscope to trigger on negative slope zero crossings of the network supply voltage.
IviScopeACLineEither | 0x00000003 | Configures the oscilloscope to trigger on either positive or negative slope zero crossings of the network supply voltage.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeAcquisitionStatusEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeAcquisitionStatusEnum Enumeration
See Also

IVI Scope class-compliant values for the status parameter of the acquisition Status method

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeAcquisitionStatusEnum
C#
public enum IviScopeAcquisitionStatusEnum
Visual C++
public enum class IviScopeAcquisitionStatusEnum

Members

Member name | Value | Description
IviScopeAcqComplete | 0x00000001 | The oscilloscope has completed the acquisition.
IviScopeAcqInProgress | 0x00000000 | The oscilloscope is still acquiring data.
IviScopeAcqStatusUnknown | 0xFFFFFFFF | The oscilloscope cannot determine the status of the acquisition.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeAcquisitionTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeAcquisitionTypeEnum Enumeration
See Also

IVI Scope class-compliant values for Acquisition Type

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeAcquisitionTypeEnum
C#
public enum IviScopeAcquisitionTypeEnum
Visual C++
public enum class IviScopeAcquisitionTypeEnum

Members

Member name | Value | Description
IviScopeAcquisitionTypeNormal | 0x00000000 | Configures the oscilloscope to acquire one sample for each point in the waveform record. The oscilloscope uses real-time or equivalent time sampling.
IviScopeAcquisitionTypePeakDetect | 0x00000001 | Sets the oscilloscope to the peak-detect acquisition mode. The oscilloscope oversamples the input signal and keeps the minimum and maximum values that correspond to each position in the waveform record. The oscilloscope uses only real-time sampling.
IviScopeAcquisitionTypeHiRes | 0x00000002 | Configures the oscilloscope to oversample the input signal. The oscilloscope calculates the average value that corresponds to each position in the waveform record. The oscilloscope uses only real-time sampling.
IviScopeAcquisitionTypeEnvelope | 0x00000003 | Sets the oscilloscope to the envelope acquisition mode. The oscilloscope acquires multiple waveforms and keeps the minimum and maximum voltages it acquires for each point in the waveform record. The end-user specifies the number of waveforms the oscilloscope acquires with the Number of Envelopes property. The oscilloscope can use real-time or equivalent-time sampling.
IviScopeAcquisitionTypeAverage | 0x00000004 | Configures the oscilloscope to acquire multiple waveforms and calculate the average value for each point in the waveform record. The end-user specifies the number of waveforms to acquire with the Number of Averages property. The oscilloscope uses real-time or equivalent time sampling.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeErrorCodesEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeErrorCodesEnum Enumeration
See Also

IVI Scope class defined HRESULTS

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeErrorCodesEnum
C#
public enum IviScopeErrorCodesEnum
Visual C++
public enum class IviScopeErrorCodesEnum

Members

Member name | Value | Description
E_IVISCOPE_CHANNEL_NOT_ENABLED | 0x80042001 |
E_IVISCOPE_UNABLE_TO_PERFORM_MEASUREMENT | 0x80042002 |
E_IVISCOPE_MAX_TIME_EXCEEDED | 0x80042003 |
E_IVISCOPE_INVALID_ACQ_TYPE | 0x80042004 |
S_IVISCOPE_INVALID_WFM_ELEMENT | 0x00042001 |

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeGlitchConditionEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeGlitchConditionEnum Enumeration
See Also

IVI Scope class-compliant values for glitch trigger Condition

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeGlitchConditionEnum
C#
public enum IviScopeGlitchConditionEnum
Visual C++
public enum class IviScopeGlitchConditionEnum

Members

Member name | Value | Description
IviScopeGlitchConditionLessThan | 0x00000001 | The oscilloscope triggers when the pulse width is less than the value you specify with the Glitch Width property.
IviScopeGlitchConditionGreaterThan | 0x00000002 | The oscilloscope triggers when the pulse width is greater than the value you specify with the Glitch Width property.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeGlitchPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeGlitchPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for glitch trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeGlitchPolarityEnum
C#
public enum IviScopeGlitchPolarityEnum
Visual C++
public enum class IviScopeGlitchPolarityEnum

Members

Member name | Value | Description
IviScopeGlitchPolarityPositive | 0x00000001 | The oscilloscope triggers on a positive glitch.
IviScopeGlitchPolarityNegative | 0x00000002 | The oscilloscope triggers on a negative glitch.
IviScopeGlitchPolarityEither | 0x00000003 | The oscilloscope triggers on either a positive or negative glitch.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeInterpolationEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeInterpolationEnum Enumeration
See Also

IVI Scope class-compliant values for acquisition Interpolation

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeInterpolationEnum
C#
public enum IviScopeInterpolationEnum
Visual C++
public enum class IviScopeInterpolationEnum

Members

Member name | Value | Description
IviScopeInterpolationNone | 0x00000001 | The oscilloscope does not interpolate points in the waveform. Instead, the driver sets every element in the waveform record for which the oscilloscope cannot receive a value to an IEEE-defined NaN (Not-a-Number) value. Use the Is Waveform Element Invalid method to determine if the waveform record element is invalid.
IviScopeInterpolationSineX | 0x00000002 | The oscilloscope uses a sin(x)/x calculation to interpolate a value when it cannot resolve a voltage in the waveform record.
IviScopeInterpolationLinear | 0x00000003 | The oscilloscope uses a linear approximation to interpolate a value when it cannot resolve a voltage in the waveform record.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeMeasurementEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeMeasurementEnum Enumeration
See Also

IVI Scope class-compliant values for the MeasFunction parameter of the measurement Read and Fetch methods

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeMeasurementEnum
C#
public enum IviScopeMeasurementEnum
Visual C++
public enum class IviScopeMeasurementEnum

Members

Member name | Value | Description
IviScopeMeasurementRiseTime | 0x00000000 | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
IviScopeMeasurementFallTime | 0x00000001 | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
IviScopeMeasurementFrequency | 0x00000002 | The frequency of one complete cycle in the waveform. The units are Hertz.
IviScopeMeasurementPeriod | 0x00000003 | The length of time of one complete cycle in the waveform. The units are seconds.
IviScopeMeasurementVoltageRMS | 0x00000004 | The true Root Mean Square voltage of the entire waveform. The units are Volts.
IviScopeMeasurementVoltagePeakToPeak | 0x00000005 | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
IviScopeMeasurementVoltageMax | 0x00000006 | The maximum amplitude found in the entire waveform. The units are Volts.
IviScopeMeasurementVoltageMin | 0x00000007 | The minimum amplitude found in the entire waveform. The units are Volts.
IviScopeMeasurementVoltageHigh | 0x00000008 | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.
IviScopeMeasurementVoltageLow | 0x00000009 | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.
IviScopeMeasurementVoltageAverage | 0x0000000A | The arithmetic average in volts measured over the entire waveform. The units are Volts.
IviScopeMeasurementWidthNeg | 0x0000000B | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
IviScopeMeasurementWidthPos | 0x0000000C | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
IviScopeMeasurementDutyCycleNeg | 0x0000000D | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
IviScopeMeasurementDutyCyclePos | 0x0000000E | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
IviScopeMeasurementAmplitude | 0x0000000F | The Voltage High less the Voltage Low in Volts over the entire waveform.
IviScopeMeasurementVoltageCycleRMS | 0x00000010 | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
IviScopeMeasurementVoltageCycleAverage | 0x00000011 | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
IviScopeMeasurementOverShoot | 0x00000012 | The relative waveform distortion that follows an edge transition.
IviScopeMeasurementPreshoot | 0x00000013 | The relative waveform distortion that precedes an edge transition.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeRuntPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeRuntPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for runt trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeRuntPolarityEnum
C#
public enum IviScopeRuntPolarityEnum
Visual C++
public enum class IviScopeRuntPolarityEnum

Members

Member name | Value | Description
IviScopeRuntPolarityPositive | 0x00000001 | The oscilloscope triggers on a positive runt. A positive runt occurs when a rising edge crosses the low runt threshold and does not cross the high runt threshold before re-crossing the low runt threshold.
IviScopeRuntPolarityNegative | 0x00000002 | The oscilloscope triggers on a negative runt. A negative runt occurs when a falling edge crosses the high runt threshold and does not cross the low runt threshold before re-crossing the high runt threshold.
IviScopeRuntPolarityEither | 0x00000003 | The oscilloscope triggers on either a positive or negative runt.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeSampleModeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeSampleModeEnum Enumeration
See Also

IVI Scope class-compliant values for acquisition SampleMode

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeSampleModeEnum
C#
public enum IviScopeSampleModeEnum
Visual C++
public enum class IviScopeSampleModeEnum

Members

Member name | Value | Description
IviScopeSampleModeRealTime | 0x00000000 | Indicates that the oscilloscope is using real-time sampling.
IviScopeSampleModeEquivalentTime | 0x00000001 | Indicates that the oscilloscope is using equivalent time sampling.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTimeOutEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTimeOutEnum Enumeration
See Also

IVI Scope class-compliant values for maxTime parameter of the measurement Read and Fetch methods.

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTimeOutEnum
C#
public enum IviScopeTimeOutEnum
Visual C++
public enum class IviScopeTimeOutEnum

Members

Member name | Value | Description
IviScopeTimeOutInfinite | 0xFFFFFFFF | The method waits indefinitely for the measurement to complete.
IviScopeTimeOutImmediate | 0x00000000 | The method returns immediately. If no valid measurement value exists, the method returns an error.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerCouplingEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTriggerCouplingEnum Enumeration
See Also

IVI Scope class-compliant values for trigger Coupling

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerCouplingEnum
C#
public enum IviScopeTriggerCouplingEnum
Visual C++
public enum class IviScopeTriggerCouplingEnum

Members

Member name | Value | Description
IviScopeTriggerCouplingAC | 0x00000000 | The oscilloscope AC couples the trigger signal.
IviScopeTriggerCouplingDC | 0x00000001 | The oscilloscope DC couples the trigger signal.
IviScopeTriggerCouplingHFReject | 0x00000003 | The oscilloscope filters out the high frequencies from the trigger signal.
IviScopeTriggerCouplingLFReject | 0x00000004 | -- NOT SUPPORTED -- The oscilloscope filters out the low frequencies from the trigger signal.
IviScopeTriggerCouplingNoiseReject | 0x00000005 | -- NOT SUPPORTED -- The oscilloscope filters out the noise from the trigger signal.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerModifierEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTriggerModifierEnum Enumeration
See Also

IVI Scope class-compliant values for trigger Modifier

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerModifierEnum
C#
public enum IviScopeTriggerModifierEnum
Visual C++
public enum class IviScopeTriggerModifierEnum

Members

Member name | Value | Description
IviScopeTriggerModifierNone | 0x00000001 | The oscilloscope waits until the trigger the end-user specifies occurs.
IviScopeTriggerModifierAuto | 0x00000002 | The oscilloscope automatically triggers if the configured trigger does not occur within the oscilloscope's timeout period.
IviScopeTriggerModifierAutoLevel | 0x00000003 | The oscilloscope adjusts the trigger level if the trigger the end-user specifies does not occur.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerSlopeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTriggerSlopeEnum Enumeration
See Also

IVI Scope class-compliant values for edge trigger Slope

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerSlopeEnum
C#
public enum IviScopeTriggerSlopeEnum
Visual C++
public enum class IviScopeTriggerSlopeEnum

Members

Member name | Value | Description
IviScopeTriggerSlopePositive | 0x00000001 | A positive (rising) edge passing through the trigger level triggers the oscilloscope.
IviScopeTriggerSlopeNegative | 0x00000000 | A negative (falling) edge passing through the trigger level triggers the oscilloscope.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTriggerTypeEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTriggerTypeEnum Enumeration
See Also

IVI Scope class-compliant values for trigger Type

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTriggerTypeEnum
C#
public enum IviScopeTriggerTypeEnum
Visual C++
public enum class IviScopeTriggerTypeEnum

Members

Member name | Value | Description
IviScopeTriggerEdge | 0x00000001 | Configures the oscilloscope for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source property passes the voltage threshold specified with the Trigger Level property and has the slope specified with the Trigger Slope property.
IviScopeTriggerWidth | 0x00000002 | -- NOT SUPPORTED -- Configures the oscilloscope for width triggering. Use the IviScopeWidthTrigger extension properties and methods to configure the trigger.
IviScopeTriggerRunt | 0x00000003 | -- NOT SUPPORTED -- Configures the oscilloscope for runt triggering. Use the IviScopeRuntTrigger extension properties and methods to configure the trigger.
IviScopeTriggerGlitch | 0x00000004 | -- NOT SUPPORTED -- Configures the oscilloscope for glitch triggering. Use the IviScopeGlitchTrigger extension properties and methods to configure the trigger.
IviScopeTriggerTV | 0x00000005 | Configures the oscilloscope for triggering on TV signals. Use the IviScopeTVTrigger extension properties and methods to configure the trigger.
IviScopeTriggerImmediate | 0x00000006 | Configures the oscilloscope for immediate triggering. The oscilloscope does not wait for trigger of any kind upon initialization.
IviScopeTriggerACLine | 0x00000007 | -- NOT SUPPORTED -- Configures the oscilloscope for AC Line triggering. Use the IviScopeACLineTrigger extension properties and methods to configure the trigger.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTVSignalFormatEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTVSignalFormatEnum Enumeration
See Also

IVI Scope class-compliant values for TV trigger SignalFormat

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTVSignalFormatEnum
C#
public enum IviScopeTVSignalFormatEnum
Visual C++
public enum class IviScopeTVSignalFormatEnum

Members

Member name | Value | Description
IviScopeTVSignalFormatNTSC | 0x00000001 | Configures the oscilloscope to trigger on the NTSC signal format.
IviScopeTVSignalFormatPAL | 0x00000002 | Configures the oscilloscope to trigger on the PAL signal format
IviScopeTVSignalFormatSECAM | 0x00000003 | Configures the oscilloscope to trigger on the SECAM signal format

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTVTriggerEventEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTVTriggerEventEnum Enumeration
See Also

IVI Scope class-compliant values for TV trigger Event

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTVTriggerEventEnum
C#
public enum IviScopeTVTriggerEventEnum
Visual C++
public enum class IviScopeTVTriggerEventEnum

Members

Member name | Value | Description
IviScopeTVTriggerEventField1 | 0x00000001 | Sets the oscilloscope to trigger on field 1 of the video signal.
IviScopeTVTriggerEventField2 | 0x00000002 | Sets the oscilloscope to trigger on field 2 of the video signal.
IviScopeTVTriggerEventAnyField | 0x00000003 | Sets the oscilloscope to trigger on any field.
IviScopeTVTriggerEventAnyLine | 0x00000004 | Sets the oscilloscope to trigger on any line.
IviScopeTVTriggerEventLineNumber | 0x00000005 | Sets the oscilloscope to trigger on a specific line number you specify with the TV Trigger Line Number property.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeTVTriggerPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeTVTriggerPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for TV trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeTVTriggerPolarityEnum
C#
public enum IviScopeTVTriggerPolarityEnum
Visual C++
public enum class IviScopeTVTriggerPolarityEnum

Members

Member name | Value | Description
IviScopeTVTriggerPolarityPositive | 0x00000001 | Configures the oscilloscope to trigger on a positive video sync pulse.
IviScopeTVTriggerPolarityNegative | 0x00000002 | Configures the oscilloscope to trigger on a negative video sync pulse.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeVerticalCouplingEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeVerticalCouplingEnum Enumeration
See Also

IVI Scope class-compliant values for channel Coupling

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeVerticalCouplingEnum
C#
public enum IviScopeVerticalCouplingEnum
Visual C++
public enum class IviScopeVerticalCouplingEnum

Members

Member name | Value | Description
IviScopeVerticalCouplingAC | 0x00000000 | The oscilloscope AC couples the input signal.
IviScopeVerticalCouplingDC | 0x00000001 | The oscilloscope DC couples the input signal.
IviScopeVerticalCouplingGnd | 0x00000002 | The oscilloscope couples the channel to the ground.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeWidthConditionEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeWidthConditionEnum Enumeration
See Also

IVI Scope class-compliant values for width trigger Condition

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeWidthConditionEnum
C#
public enum IviScopeWidthConditionEnum
Visual C++
public enum class IviScopeWidthConditionEnum

Members

Member name | Value | Description
IviScopeWidthConditionWithin | 0x00000001 | Configures the oscilloscope to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.
IviScopeWidthConditionOutside | 0x00000002 | Configures the oscilloscope to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.

See Also

Reference

Ivi.Scope.Interop Namespace


IviScopeWidthPolarityEnum Enumeration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IviScopeWidthPolarityEnum Enumeration
See Also

IVI Scope class-compliant values for width trigger Polarity

Namespace: Ivi.Scope.Interop
Assembly: Ivi.Scope.Interop (in Ivi.Scope.Interop.dll)

Syntax

Visual Basic
Public Enumeration IviScopeWidthPolarityEnum
C#
public enum IviScopeWidthPolarityEnum
Visual C++
public enum class IviScopeWidthPolarityEnum

Members

Member name | Value | Description
IviScopeWidthPolarityPositive | 0x00000001 | Configures the oscilloscope to trigger on positive pulses that have a width that meets the condition the user specifies with the Width Condition property.
IviScopeWidthPolarityNegative | 0x00000002 | Configures the oscilloscope to trigger on negative pulses that have a width that meets the condition the user specifies with the Width Condition property.
IviScopeWidthPolarityEither | 0x00000003 | Configures the oscilloscope to trigger on either positive or negative pulses that have a width that meets the condition the user specifies with the Width Condition property.

See Also

Reference

Ivi.Scope.Interop Namespace


Instrument Command Reference

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Instrument Command Reference

This is the reference for all the instrument commands issued by the driver.

Instrument Commands

Instrument Command Reference
Top


Errors and Warnings

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Errors and Warnings

Errors

Name | Value (Hex) | Value (Decimal) | Description
E_IVI_CANNOT_RECOVER | 0x80047000 | -2147192832 | Failure cannot recover.
E_IVI_INSTRUMENT_STATUS | 0x80047001 | -2147192831 | Instrument error detected. Use ErrorQuery() to determine error(s).
E_IVI_CANNOT_OPEN_FILE | 0x80047002 | -2147192830 | Cannot open file.
E_IVI_READING_FILE | 0x80047003 | -2147192829 | Error reading file.
E_IVI_WRITING_FILE | 0x80047004 | -2147192828 | Error writing file.
E_IVI_INVALID_PATHNAME | 0x8004700B | -2147192821 | The path name is invalid.
E_IVI_INVALID_VALUE | 0x80047010 | -2147192816 | Invalid value (%1) for method %2, parameter %3.
E_IVI_METHOD_NOT_SUPPORTED | 0x80047011 | -2147192815 | Does not support this class-compliant feature: method %1.
E_IVI_PROPERTY_NOT_SUPPORTED | 0x80047012 | -2147192814 | Does not support this class-compliant feature: property %1.
E_IVI_VALUE_NOT_SUPPORTED | 0x80047013 | -2147192813 | Does not support this class-compliant feature: (enumeration) value %1 passed as the value for parameter %2 in method %3.
E_IVI_NOT_INITIALIZED | 0x8004701D | -2147192803 | A connection to the instrument has not been established.
E_IVI_UNKNOWN_CHANNEL_NAME | 0x80047020 | -2147192800 | Unknown channel name.
E_IVI_TOO_MANY_OPEN_FILES | 0x80047023 | -2147192797 | Too many files are opened.
E_IVI_CHANNEL_NAME_REQUIRED | 0x80047044 | -2147192764 | A channel name is required.
E_IVI_MISSING_OPTION_NAME | 0x80047049 | -2147192759 | The option string is missing an option name.
E_IVI_MISSING_OPTION_VALUE | 0x8004704A | -2147192758 | The option string is missing an option value.
E_IVI_BAD_OPTION_NAME | 0x8004704B | -2147192757 | The %1 name in the option string is unknown.
E_IVI_BAD_OPTION_VALUE | 0x8004704C | -2147192756 | The %1 value in the option string is unknown.
E_IVI_OUT_OF_MEMORY | 0x80047056 | -2147192746 | Could not allocate necessary memory.
E_IVI_OPERATION_PENDING | 0x80047057 | -2147192745 | Operation in progress.
E_IVI_NULL_POINTER | 0x80047058 | -2147192744 | Null pointer passed for method %1, parameter %2.
E_IVI_UNEXPECTED_RESPONSE | 0x80047059 | -2147192743 | Unexpected response from the instrument.
E_IVI_FILE_NOT_FOUND | 0x8004705B | -2147192741 | File not found.
E_IVI_INVALID_FILE_FORMAT | 0x8004705C | -2147192740 | Invalid file format.
E_IVI_STATUS_NOT_AVAILABLE | 0x8004705D | -2147192739 | The instrument status is not available.
E_IVI_ID_QUERY_FAILED | 0x8004705E | -2147192738 | Instrument ID query failed.
E_IVI_RESET_FAILED | 0x8004705F | -2147192737 | Instrument reset failed.
E_IVI_RESOURCE_UNKNOWN | 0x80047060 | -2147192736 | Unknown resource.
E_IVI_ALREADY_INITIALIZED | 0x80047061 | -2147192735 | The driver is already initialized.
E_IVI_CANNOT_CHANGE_SIMULATION_STATE | 0x80047062 | -2147192734 | The simulation state cannot be changed.
E_IVI_INVALID_NUMBER_OF_LEVELS_IN_SELECTOR | 0x80047063 | -2147192733 | The number of levels in the selector is not valid for the %1 repeated capability.
E_IVI_INVALID_RANGE_IN_SELECTOR | 0x80047064 | -2147192732 | The range %1 is not valid for the repeated capability %2.
E_IVI_UNKNOWN_NAME_IN_SELECTOR | 0x80047065 | -2147192731 | Unknown name in selector.
E_IVI_BADLY_FORMED_SELECTOR | 0x80047066 | -2147192730 | The repeated capability selector is badly-formed.
E_IVI_UNKNOWN_PHYSICAL_IDENTIFIER | 0x80047067 | -2147192729 | Unknown physical repeated capability selector.
E_IVIDIGITIZER_TRIGGER_NOT_SOFTWARE | 0x80041001 | -2147217407 | Trigger source is not set to software trigger.
E_IVIDIGITIZER_CHANNEL_NOT_ENABLED | 0x80042001 | -2147213311 | Channel %1 is not enabled.
E_IVIDIGITIZER_MAX_TIME_EXCEEDED | 0x80042002 | -2147213310 | Maximum time exceeded before the operation completed.
E_IVIDIGITIZER_ARM_NOT_SOFTWARE | 0x80042003 | -2147213309 | Trigger source is not set to software trigger.
E_IVIDIGITIZER_INCOMPATIBLE_FETCH | 0x80042004 | -2147213308 | Records to acquire is greater than 1. Multi-record acquisition fetch must be used.
E_IVISCOPE_CHANNEL_NOT_ENABLED | 0x80042001 | -2147213311 | Specified channel is not enabled.
E_IVISCOPE_UNABLE_TO_PERFORM_MEASUREMENT | 0x80042002 | -2147213310 | Unable to perform desired measurement operation.
E_IVISCOPE_MAX_TIME_EXCEEDED | 0x80042003 | -2147213309 | Maximum time exceeded before the operation completed.
E_IVISCOPE_INVALID_ACQ_TYPE | 0x80042004 | -2147213308 | Invalid acquisition type.
E_AGMD1_PERSONALITY_NOT_ACTIVE | 0x80044211 | -2147204591 | Personality is not active.
E_AGMD1_PERSONALITY_NOT_INSTALLED | 0x80044212 | -2147204590 | Personality is not installed.
E_AGMD1_PERSONALITY_NOT_LICENSED | 0x80044213 | -2147204589 | Personality is not licensed.
E_AGMD1_IO_GENERAL | 0x80044214 | -2147204588 | I/O error: %1.
E_AGMD1_IO_TIMEOUT | 0x80044215 | -2147204587 | I/O timeout error: %1.
E_AGMD1_MODEL_NOT_SUPPORTED | 0x80044216 | -2147204586 | Instrument model does not support this feature: %1.
E_AGMD1_MODULE_API | 0x80044217 | -2147204585 | Module API error. %1: %2
Top

Warnings

Name | Value (Hex) | Value (Decimal) | Description
S_IVI_SUCCESS | 0x0 | 0 | Success.
S_IVI_NSUP_ID_QUERY | 0x47065 | 290917 | ID Query is not supported by this instrument.
S_IVI_NSUP_RESET | 0x47066 | 290918 | Reset is not supported by this instrument.
S_IVI_NSUP_SELF_TEST | 0x47067 | 290919 | Self test is not supported by this instrument.
S_IVI_NSUP_ERROR_QUERY | 0x47068 | 290920 | Error query is not supported by this instrument.
S_IVI_NSUP_REV_QUERY | 0x47069 | 290921 | Firmware revision query is not supported by this instrument.
S_IVISCOPE_INVALID_WFM_ELEMENT | 0x42001 | 270337 | One of the elements in the waveform array is invalid.
S_AGMD1_CALIBRATED_WITH_INTERNAL_CLOCK | 0x44001 | 278529 | Calibration performed with internal clock while instrument is configured with external clock
Top


AgMD1 IVI-C Driver

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1 IVI-C Driver

The AgMD1 driver includes a fully compliant IVI-C driver. The topics in this section detail how to perform specific programming tasks using the IVI-C functionality available with the AgMD1 driver.

In This Section

Initializing the IVI-C Driver

Presents the steps required to properly initialize the IVI-C driver.

Accessing Instrument-Specific Functionality

Explains how to access the specialized functionality of the AgMD1 driver.

Using Simulation

Provides information on using the simulation capabilities of the driver.

Programming with the IVI-C Driver in Various Development Environment

Demonstrates how the AgMD1 driver can be used in a various application development environments (ADEs).

Reference

Presents reference documentation for each IVI-C function and attribute.


Initializing the IVI-C Driver

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Initializing the IVI-C Driver

There are two basic ways to initialize the IVI-C driver -- invoking the Initialize function directly on the specific driver and using an IVI-C class driver. If the client application is to be interchangeable, then the appropriate class driver must be used. Class drivers require that the first parameter passed to the Initialize function be a logical name for the driver. Instantiating the driver by name keeps the client program from having any dependencies on a specific driver and enables the application to be interchangeable.

If interchangeability is not necessary for a particular client application, it is often simpler to initialize the IVI-C driver directly. This avoids the need for obtaining an IVI-C class driver from a 3rd-party vendor (since the IVI Foundation does not develop or distribute IVI-C class drivers). When using the specific driver directly, the client application will necessarily have references to the specific driver (through the use of the "AgMD1" in function call names and by directly references AgMD1.h and AgMD1.lib); For many applications, this is perfectly acceptable.

The examples below in the section describing the Initialize function will present both techniques for initializing an IVI-C driver.

Calling the Initialize Function

The IVI-defined Initialize function offers a variety of options and parameters that control fundamental aspects of the driver's behavior. It is critical to understand what options are available and how they impact driver operation.

ResourceName

The resource name parameter can be a logical name present in the IVI Configuration Store or a physical resource descriptor. If the ResourceName is a logical name, then additional options stored in the IVI Configuration Store will be loaded and processed. This allows client code to reuse driver option settings and to keep the driver code as concise as possible, by removing settings that can be stored in the IVI Configuration Store. It is important to note that any parameters or options passed directly to the Initialize function via the OptionString parameter (discussed below) override any settings found in the IVI Configuration Store.

Interface Physical Resource Descriptor Syntax
GPIB GPIB[board]::primary address[::secondary address][::INSTR]
Example: GPIB0::18::INSTR
ASRL ASRL[board][::INSTR]
Example: ASRL1::INSTR
TCPIP TCPIP[board]::host address[::LAN device name]::INSTR
Example: TCPIP0::127.0.0.1::INSTR
TCPIP TCPIP[board]::host address::port::SOCKET
Example: TCPIP0::127.0.0.1::5025::SOCKET
USB USB[board]::manufacturer ID::model code::serial number[::USB interface number][::INSTR]
Example: USB0::2391::291::SN_001001::INSTR
PXI PXI[bus]::device[::function][::INSTR]
Example: PXI1::5::INSTR
PXI PXI0::CHASSISchassis::SLOTslot[::FUNCfunction][::INSTR]
PXI0::bus-device[.function][::INSTR]

IdQuery

If this is enabled, the driver will query the instrument model and compare it with a list of instrument models that is supported by the driver. If the model is not supported, Initialize will fail with the IVI_ERROR_ID_QUERY_FAILED error code.

Reset

If this is enabled, the driver will perform a reset of the instrument. If the reset fails, Initialize will fail with the IVI_ERROR_RESET_FAILED error code.

OptionString

The OptionString allows the user to pass optional settings to the driver. These settings override any settings that are specified in the IVI Configuration Store. If the IVI Configuration Store is not used (a resource descriptor is passed as the ResourceName instead of a logical name) then any setting that is not specified has a default value as specified by IVI.

Option Name | Description | Default
QueryInstrStatus | Specifies whether the IVI specific driver queries the instrument status at the end of each user operation. Querying the instrument status is very useful for debugging. After validating the program, the user can set this attribute to False to disable status checking and maximize performance. The user specifies this value for the entire IVI driver session. | false
Simulate | Specifies whether or not the IVI specific driver simulates instrument driver I/O operations. If simulation is enabled, the specific driver functions do not perform instrument I/O. For output parameters that represent instrument data, the specific driver functions return simulated values. | false
Cache | Specifies whether or not to cache the value of attributes. When caching is enabled, the IVI specific driver keeps track of the current instrument settings so that it can avoid sending redundant commands to the instrument. | true
InterchangeCheck | Specifies whether the IVI specific driver performs interchangeability checking. If the Interchange Check attribute is enabled, the specific driver maintains a record of each interchangeability warning that it encounters. The user calls the Get Next Interchange Warning function to extract and delete the oldest interchangeability warning from the list. | false
RangeCheck | Specifies whether the IVI specific driver validates attribute values and function parameters. If enabled, the specific driver validates the parameter values that users pass to driver functions. Validating attribute values and function parameters is useful for debugging. After validating the program, the user can set this attribute to False to disable range checking and maximize performance. | true
RecordCoercions | Specifies whether the IVI specific driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the Record Value Coercions attribute is enabled, the specific driver maintains a record of each coercion. The user calls the Get Next Coercion Record function to extract and delete the oldest coercion record from the list. | false
DriverSetup | Specifies additional settings supported by the driver, but not defined by IVI. | ""

DriverSetup

This is used to specify settings that are supported by the driver but not defined by IVI. If the Options String parameter contains an assignment for the Driver Setup attribute, the Initialize function assumes that everything following 'DriverSetup=' is part of the assignment. The following settings are supported by the AgMD1 driver.

Option Name | Description | Default
Model | Instrument model to use during simulation. Must be one of the supported model strings as returned by the SUPPORTED_INSTRUMENT_MODELS attribute. | (default_model)
Trace | If true, output trace log of all driver calls to an XML file in the same directory as the application executable accessing the driver or as specified by the TraceName option. The log file may be viewed in your web browser. Beginning with Agilent IO Libraries Suite 16.0, driver trace messages may also be viewed with the IO Monitor utility. See IO Monitor help for details. | false
TraceName | If specified, sets the path and file name for the XML log file output when option Trace=true. It is not necessary to include the .xml extension with the name. Example: 'DriverSetup = Trace=true, TraceName=C:\Temp\TraceOut' If not specified, tracing generates a unique XML trace file name based on the date and time. A new file is created each time the driver is initialized with tracing enabled. | ""
TraceArray | If true, array parameter data is output to the trace log. | false
TraceArraySizeMax | Specifies the maximum number of elements to trace for array parameters. Requires option 'TraceArray=true'. | 10
TraceSizeMax | Specifies the maximum size of the trace log file in bytes. Once the file reaches this size, tracing will be turned off automatically by the driver. | 1000000
TraceSaveInterval | Specifies how often the driver should save trace data to the trace log file. The value is specified in minutes. | 1

Example 1 (no range checking, no state caching) -- Initializing with an IVI-C Class Driver

The following code initializes the driver with default options, except for range checking and state caching which are turned off.

C++ Copy image Copy Code
#include "IviDigitizer.h" // Class Driver header file

void main()
{
  ViStatus status;
  ViSession session;
  ViReal64 reading;

  // Initialize the driver using the IviDigitizer session factory.
  // This code is interchangeable since no reference to the specific driver exists.
  status = IviDigitizer_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);

  // ... call driver functions

  status = IviDigitizer_close(session);
}

Example 2 (simulation) -- Direct Driver Access

The following code initializes the driver in simulation mode and specifies the model to simulate.

C++ Copy image Copy Code
#include "AgMD1.h" // Specific driver header file

void main()
{
  ViStatus status;
  ViSession session;
  ViReal64 reading;

  // Initialize the driver with no range checking and no state caching
  // This will also check the instrument ID to make sure it is supported
  // and reset the instrument
  status = AgMD1_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "Simulate=true, DriverSetup= Model=M9210A", &session);

  // ... call driver functions

  status = AgMD1_close(session);
}


Writing Interchangeable Code Using the IviDigitizer Class Driver

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Writing Interchangeable Code Using the IviDigitizerClass Driver

A class driver is an implementation of the IVI-defined C API for a particular instrument class. The class driver delegates to the appropriate specific driver based upon the logical name passed to the init or InitWithOptions functions. All functions in the class driver begin with the class name ("IviDigitizer" in this case). Since an instrument-independent logical name is used to identify the specific driver and since the function calls have no instrument-specific references, code written using the IVI-C class driver is interchangeable.

IVI-C Class Driver Availability

An important consideration when programming with IVI-C drivers is that the IVI Foundation does not implement distribute class drivers. Member companies of the IVI Foundation provide class drivers as products. In order to program interchangeably with IVI-C drivers, you must obtain the appropriate class driver from a 3rd party vendor.

IVI-C Class Driver Usage

Because a class driver delegates to a specific driver, it is necessary to initialize the class driver using a logical name. This tells the class driver which specific driver is to be used. The class driver loads the appropriate specific driver and delegates all function calls to it.

IviDigitizer Class Driver Programming Example

This example uses the a IviDigitizer class driver to communicate with an instrument in an interchangeable manner. Note that the specific driver is not referenced at all in the client program.

C++ Copy image Copy Code
#include "IviDigitizer.h" // IviDigitizer class driver header file

void main()
{
  ViStatus status;
  ViSession session;
  ViReal64 reading;

  // Initialize the driver using a logical name
  status = IviDigitizer_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);

  // Call class-compliant functions
  status = IviDigitizer_ConfigureAcquisition(session, 5, 100, 1000);
  status = IviDigitizer_ConfigureTriggerSource(session, "LAN1", 1.5, IVIDIGITIZER_VAL_SLOPE_NEGATIVE);

  // Close the session
  status = IviDigitizer_close(session);
}


Accessing Repeated Capabilities

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Accessing Repeated Capabilities

This page provides information on the supported repeated capabilities and repeated capability names for the AgMD1 driver.

Repeated Capabilities

The AgMD1 driver supports the following repeated capabilities:

  • Channel
  • TriggerSource
  • ArmSource
  • DelayControl
  • LogicDevice

The following table provides detailed information on each repeated capability supported by the AgMD1 driver.

For a detailed explanation of repeated capabilities, including repeated capability styles, physical names, and dynamic repeated capabilities, see the topic Repeated Capabilities.

Repeated Capability | IVI-C Style | Dynamic | Physical Names
Channel | Parameter | Yes | Channel1
TriggerSource | Parameter | Yes |
ArmSource | Parameter | No |
DelayControl | Parameter | Yes |
LogicDevice | Parameter | Yes |


Accessing Instrument-Specific Functionality

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Accessing Instrument-Specific Functionality

As the name implies, the instrument-specific capabilities are those methods and properties that are unique to the instrument. In practice, the instrument-specific portion of the driver exposes the full functionality of the instrument -- including functionality that may also be available in the class-compliant capabilities. Users that do not care about interchangeability or that need to access functionality that is not defined by IVI will use the instrument-specific interfaces in application programs.

When to use the instrument specific interfaces

  • When the required functionality is not exposed in the class-compliant interfaces.
  • When interchangeability is not a requirement.
  • When performance is critical. Sometimes a driver may perform better using the instrument specific interfaces because they match the instrument functionality more closely than the class-compliant interfaces.

Example

The following example demonstrates accessing instrument-specific function on the driver. Note that instrument-specific function calls are always prefixed with the instrument-specific prefix ("AgMD1"). In contrast, calls to IVI-defined class-compliant functions are prefixed with the IVI class name.

C++ Copy image Copy Code
#include "AgMD1.h"

void main()
{
  ViStatus status;
  ViSession session;
  ViReal64 reading;

  status = AgMD1_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);

  status = AgMD1_ReadEx(session, 2000, 3, &reading);

  status = AgMD1_close(session);
}

Using both the class driver and specific driver

When programming against the class driver, it is possible to get access to the specific driver session that is used internally by the class driver. This allows the client program to talk directly to the specific driver.

Example

The following client code uses the class driver and the specific driver.

C++ Copy image Copy Code
#include "AgMD1.h"
#include "IviDmm.h"

void main()
{
  ViStatus status;
  ViSession classSession;
  ViSession specificSession;
  ViReal64 reading;

  status = IviDmm_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &classSession);

  status = IviDmm_Read(classSession, 2000, &reading);

  // Get access to the specific driver session
  status = IviDmm_GetSpecificDriverCHandle(classSession, &specificSession);

  // Call the specific driver
  // ReadEx takes an additional parameter
  // This is available only from the specific driver
  status = AgMD1_ReadEx(specificSession, 2000, 3, &reading);

  status = IviDmm_close(classSession);
}


Using Simulation

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Simulation

An IVI driver can operate without the presence of an actual instrument by using simulation mode. When simulation is turned on, the driver performs no instrument communication, but attempts to generate results which allow client applications to reasonably execute. You can turn on simulation using either of the following two techniques:

  • Passing the "simulate=VI_TRUE" option string parameter to the InitWithOptions function.
  • Setting the SIMULATE attribute to VI_TRUE.

The IVI-C driver contains a SIMULATE attribute. Note that you can turn simulation on, if you initialize a driver with it off. However, if you initialize an IVI-COM driver with simulation turned on, you will get an error (The simulation state cannot be changed) if you attempt to later turn it off. This is because you cannot initiate a live I/O session with an instrument after you have called the InitWithOptions function.

Using The Option String

The fourth and last parameter to the InitWithOptions function is the option string. See the help on InitWithOptions for more details. To turn simulation on with the option string, include the following in the option string:

simulate=VI_TRUE

For example, the InitWithOptions call might look like this:

AgMD1_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "Simulate=VI_TRUE", &session);

When the simulate option is set VI_TRUE, the value of the resource descriptor parameter (the first parameter above) is ignored. This is because no I/O connection will be made with the instrument, as is required by IVI-3.1: Driver Architecture Specification.

The Driver Session Simulate Attribute

A DriverSession in the IVI Configuration Store contains properties for the same items which can be set with the option string parameter. The name of a DriverSession, or the name of a LogicalName which points to a DriverSession, can be used as the first parameter to InitWithOptions. If the SIMULATE attribute in the DriverSession is true, the driver is initialized in simulation mode.

Changing the Instrument Model

Many drivers support more than one instrument model. Drivers will typically select one of these as the default model by creating a special type of entry in the IVI Configuration Store known as a Configurable Initial Settings. You can modify the Model value in the Configurable Initial Settings for the DriverSession of interest, or you can simply specify the model to simulate at runtime during the call to Initialize.

To have the driver simulate a specific model of your choosing, simply add the desired model to the DriverSetup string using the following special syntax:

Simulate=VI_TRUE, DriverSetup=Model=M9210A

The complete InitWithOptions call becomes:

AgMD1_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "Simulate=VI_TRUE, DriverSetup= Model=M9210A", &session);

If you set the model to a value not supported by the driver, the driver reports an error.

Limitations of Simulation

Simulation is designed to allow the driver to be used without an instrument or any I/O software or hardware. However, simulation is not intended to fully emulate the instrument. There are some important differences you should be aware of:

  • Many instruments have status systems, and these are not live. For instance, you can set Enable and Transition registers but queries of Condition and Event registers will always return a fixed value, which is usually zero.
  • There often is no parameter range checking or coercion unless done in the driver. Most drivers depend on the instrument to perform range checking and coercion of parameter values. In simulation mode, this will not occur. For example setting a frequency parameter to 1E99 will be accepted without error in simulation where an instrument would return a "parameter out of range" error.
  • AgMD1_error_query typically returns no error.
  • Measurement data is not live. Most data queries will return a fixed value or a small array of values.


Programming with the IVI-C Driver in Various Development Environments

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Programming with the IVI-C Driver in Various Development Environments

IVI-C drivers are implemented using standard Windows DLL technology. Consequently, IVI-C drivers can be used in a wide variety of development environments.

The topics in this section provide detailed instructions on how to access and use IVI-C drivers in a variety of popular development environments. Each topic includes a complete example of IVI-C driver usage.

In This Section

Using LabWindows™/CVI

Explains how to use the IVI-C driver in National Instruments® LabWindows/CVI.

Using LabVIEW®

Provides instructions on how to use the IVI-C driver in National Instruments LabVIEW.

Using Visual C++

Describes the process for including an IVI-C driver in a Visual C++ project.

Using .NET

Explains how to use the driver in .NET languages, such as VB.NET and C#.

Using MATLAB®

Presents information on using the driver with MATLAB.

Using Simulation

Presents information on using the simulation capabilities of the driver.


Using LabWindows/CVI

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using LabWindows™/CVI

This section describes how to use an IVI-C driver from LabWindows™/CVI.

Adding the Instrument Driver to the Project

In order to access any of the driver functions, the proper header file (.h) must be included in the project and the proper import library (.lib) must be referenced. LabWindows can automatically reference these files given the location of the function panel file (.fp). The sections below explain the steps required to add the instrument driver to a LabWindows project based on the .fp file.

Note that this section demonstrates usage of the driver using instrument-specific references. In order to write an interchangeable application, the IviDigitizer class driver must be used.

To modify the example code in this topic for use with the IviDigitizer class driver, make the following substitutions:

  • Include IviDigitizer.h instead of AgMD1.h.
  • Link to IviDigitizer.lib instead of AgMD1.lib.
  • Prefix function calls with "IviDigitizer" instead of "AgMD1".

To use the AgMD1 specific driver, perform the following steps in LabWindows.

  1. From the Edit menu, choose Add Files to Project... and select Instrument (.fp).
  2. Browse to the location of the AgMD1.fp file. The .fp file is installed in the "Drivers\AgMD1" folder of your IVI installation folder. Typically this will be something like the following:
    "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD1"
  3. LabWindows adds the driver to your project and loads it automatically.

Initializing the Driver

Calling InitWithOptions will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling close is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if close is not called.

For more details on initializing the driver, see Initializing the Driver topic.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party configuration utility.

LabWindows/CVI Copy image Copy Code
ViSession session;
ViStatus status;
status = AgMD1_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);
status = AgMD1_close(session);

Initializing Using a Resource Descriptor

When interchangeability is not required, the driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C++ Copy image Copy Code
ViSession session;
ViStatus status;
status = AgMD1_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "", &session);
status = AgMD1_close(session);

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on initializing the driver, see Initializing the Driver topic.

C++ Copy image Copy Code
// If true, this will query the instrument model and fail initialization
// if the model is not supported by the driver
ViBoolean idQuery = VI_FALSE;

// If true, the instrument is reset at initialization
ViBoolean reset = VI_FALSE;

// Setup IVI-defined initialization options
ViConstString standardInitOptions =
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false";

status = AgMD1_InitWithOptions("MyLogicalName", idQuery, reset, standardInitOptions, &session);
status = AgMD1_close(vi);

Accessing Attributes

Accessing attributes in an IVI-C driver is accomplished via a set of IVI-defined accessor functions. There are two accessor functions for each attribute type -- one accessor for reading attribute values and another accessor for writing attribute values.

The standard attribute accessors for reading attribute values are:

  • GetAttributeViInt32
  • GetAttributeViInt64
  • GetAttributeViReal64
  • GetAttributeViBoolean
  • GetAttributeViString

Correspondingly, the standard attribute accessors for writing attribute values are:

  • SetAttributeViInt32
  • SetAttributeViInt64
  • SetAttributeViReal64
  • SetAttributeViBoolean
  • SetAttributeViString

Each attribute accessor takes an attribute ID that uniquely identifies the attribute to access. These attribute IDs are #define'd constants listed in the AgMD1.h header file and documented in the "Attributes by Name" section of the help file.. The following example demonstrates basic usage of attribute accessors to read and write IVI-C driver attribute values.

C++ Copy image Copy Code
ViStatus status;

// Set the value of an attribute
status = AgMD1_SetAttributeViReal64(vi, VI_NULL, AGMD1_ATTR_SAMPLE_RATE, 2000);

// Get the value of a property
ViReal64 rate;
status = AgMD1_GetAttributeViReal64(vi, VI_NULL, AGMD1_ATTR_SAMPLE_RATE, &rate);

// Set the value of a property (enum)
// Note use of the #define'd constant for the attribute value
status = AgMD1_SetAttributeViInt32(vi, "Channel1", AGMD1_ATTR_TRIGGER_TYPE, AGMD1_VAL_EDGE_TRIGGER);

Complete Example

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Agilent IVI Drivers, AgMD1, Examples

C++ Copy image Copy Code
#include "AgMD1.h"

static ViSession session = VI_NULL;

int main (int argc, char *argv[])
{
  ViStatus status;

  // Initialize the driver using a logical name
  status = AgMD1_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);

  status = IviDigitizer_ConfigureAcquisition(session, 5, 100, 1000);
  status = IviDigitizer_ConfigureTriggerSource(session, "LAN1", 1.5, IVIDIGITIZER_VAL_SLOPE_NEGATIVE);

  // Close the session
  status = AgMD1_close(session);
}


Using LabVIEW

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using LabVIEW

LabVIEW® provides rich support for accessing both IVI-COM and IVI-C drivers. The best mechanism to use depends upon a few factors, such as whether interchangeability is required and/or if access to instrument-specific functionality is desired. This topic explains the options available.

Using the LabVIEW Class Driver VIs

LabVIEW provides IVI Class Driver VIs that can be used to write interchangeable IVI applications. If interchangeability is the overriding requirement or if only the IVI-defined functions are needed in an application, then using the LabVIEW IVI Class Driver VIs is the preferred way to access the AgMD1 driver in LabVIEW. These VIs are located on the Functions palette under Instrument I/O -> IVI Class Drivers. You can use these VIs to load and access the underlying AgMD1 IVI-C driver.

Please see the National Instruments® documentation for more details on using the IVI Class Driver VIs.

Using the LabVIEW Instrument Driver Import Wizard

National Instruments provides the LabVIEW Instrument Driver Import Wizard as a means to convert an IVI-C driver into a series of classic LabVIEW VIs arranged in standard LabVIEW menu palettes. This utility is not installed with the LabVIEW product, but it is freely available as a separate download from the National Instruments website. Unlike the IVI Class Driver VIs which only provide access to IVI-defined functions, the VIs produced by this utility provide access to the driver's instrument-specific functions. If interchangeability is not a requirement, then the LabVIEW Instrument Driver Import Wizard is a viable option.

Using the LabVIEW Class Browser

Although the import wizard produces convenient wrapper VIs for accessing the AgMD1 driver, it has some important shortcomings that should be considered when designing a LabVIEW application with IVI drivers. First, the import wizard only generates wrapper VIs for accessing IVI driver functions -- no VIs are generated for any driver attributes. Since IVI drivers typically contain more attributes than functions, this means that most of the IVI driver functionality will not be accessible via the VIs produced by the import wizard. To access the attributes of the AgMD1 driver, the LabVIEW Property Node must be used.

Another disadvantage of using the import wizard is that it generates VIs that unnecessarily call into the AgMD1 driver through the IVI-C interface instead of the native IVI-COM interface. LabVIEW provides a very convenient tool called the Class Browser for accessing the IVI-COM driver directly. This avoids the overhead of going through the IVI-C wrapper layer, and, unlike the import wizard VIs, it can be used to access functions and attributes. Also unlike the import wizard which is a separate download utility, the Class Browser is a standard feature of LabVIEW.

For these reasons, it is generally preferable to use the Class Browser feature in lieu of the import wizard when accessing instrument-specific functionality. For details on using the Class Browser to access the AgMD1 driver, please see the IVI-COM topic Using LabVIEW.


Using Visual C++

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using Visual C++

This section describes how to use an IVI-C driver from Visual C++.

Referencing the Driver

In order to access any of the driver functions, the proper header file (.h) must be included in the project and the proper import library (.lib) must be referenced. This section demonstrates usage of the driver using instrument-specific references. In order to write an interchangeable application, the IviDigitizer class driver must be used.

To modify the example code in this topic for use with the IviDigitizer class driver, make the following substitutions:

  • Include IviDigitizer.h instead of AgMD1.h.
  • Link to IviDigitizer.lib instead of AgMD1.lib.
  • Prefix function calls with "IviDigitizer" instead of "AgMD1".

To use the AgMD1 specific driver, perform the following steps in Visual Studio.

  1. In solution explorer, right-click on the project and choose Properties.
  2. In the property pages dialog, expand the Linker node and select Input.
  3. In the Additional Dependencies field, enter "AgMD1.lib".
  4. Click OK.
  5. In the main application source file (.cpp), add the following line to the top of the file:

    #include "AgMD1.h"

Visual Studio must know the path to your driver's library (.lib) and header (.h) files. You can enter the following paths using the Tools, Options, Projects and Solutions, VC++ Directories dialog.

For Include Files (Win32 & x64) add: C:\Program Files (x86)\IVI Foundation\IVI\Include
For Library Files (Win32) add: C:\Program Files (x86)\IVI Foundation\IVI\Lib_\msc
For Library Files (x64) add: C:\Program Files (x86)\IVI Foundation\IVI\Lib_x64\msc
Note: For 32 bit operating systems paths start with: C:\Program Files\

Alternately, these paths may be entered in the Project Properties dialog, Configuration Properties, C++ and Linker panes.

Initializing the Driver

Calling InitWithOptions will establish an I/O connection to an instrument (often referred to as an "I/O session") or setup the driver to work in simulation mode. Calling close is required by the IVI specifications, else unpredictable driver behavior could result. Any resources held by the driver will not be properly released if close is not called.

For more details on initializing the driver, see Initializing the Driver topic.

Initializing Using a Logical Name

The following code demonstrates how to initialize a driver using a Logical Name. A Logical Name must be used if the program is to be interchangeable. The "MyLogicalName" string shown in the example must be explicitly mapped by the end user to a Driver Session in the IVI Configuration Store. This is typically done using a 3rd-party configuration utility.

C++ Copy image Copy Code
ViSession session;
ViStatus status;
status = AgMD1_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);
status = AgMD1_close(session);

Initializing Using a Resource Descriptor

When interchangeability is not required, the driver is typically initialized using a resource descriptor, often a VISA resource descriptor, as shown below.

C++ Copy image Copy Code
ViSession session;
ViStatus status;
status = AgMD1_InitWithOptions("GPIB0::13::INSTR", VI_TRUE, VI_TRUE, "", &session);
status = AgMD1_close(session);

Initializing Using Options

This example shows how IVI-defined initialization options and driver-specific options can be passed to the Initialize function.

For more details on initializing the driver, see Initializing the Driver topic.

C++ Copy image Copy Code
// If true, this will query the instrument model and fail initialization
// if the model is not supported by the driver
ViBoolean idQuery = VI_FALSE;

// If true, the instrument is reset at initialization
ViBoolean reset = VI_FALSE;

// Setup IVI-defined initialization options
ViConstString standardInitOptions =
  "Cache=true, InterchangeCheck=false, QueryInstrStatus=true, RangeCheck=true, RecordCoercions=false, Simulate=false";

status = AgMD1_InitWithOptions("MyLogicalName", idQuery, reset, standardInitOptions, &session);
status = AgMD1_close(vi);

Accessing Attributes

Accessing attributes in an IVI-C driver is accomplished via a set of IVI-defined accessor functions. There are two accessor functions for each attribute type -- one accessor for reading attribute values and another accessor for writing attribute values.

The standard attribute accessors for reading attribute values are:

  • GetAttributeViInt32
  • GetAttributeViInt64
  • GetAttributeViReal64
  • GetAttributeViBoolean
  • GetAttributeViString

Correspondingly, the standard attribute accessors for writing attribute values are:

  • SetAttributeViInt32
  • SetAttributeViInt64
  • SetAttributeViReal64
  • SetAttributeViBoolean
  • SetAttributeViString

Each attribute accessor takes an attribute ID that uniquely identifies the attribute to access. These attribute IDs are #define'd constants listed in the AgMD1.h header file and documented in the "Attributes by Name" section of the help file.. The following example demonstrates basic usage of attribute accessors to read and write IVI-C driver attribute values.

C++ Copy image Copy Code
ViStatus status;

// Set the value of an attribute
status = AgMD1_SetAttributeViReal64(vi, VI_NULL, AGMD1_ATTR_SAMPLE_RATE, 2000);

// Get the value of a property
ViReal64 rate;
status = AgMD1_GetAttributeViReal64(vi, VI_NULL, AGMD1_ATTR_SAMPLE_RATE, &rate);

// Set the value of a property (enum)
// Note use of the #define'd constant for the attribute value
status = AgMD1_SetAttributeViInt32(vi, "Channel1", AGMD1_ATTR_TRIGGER_TYPE, AGMD1_VAL_EDGE_TRIGGER);

Complete Example

Complete, working example programs may be found by clicking the Windows Start Menu shortcut under:
All Programs, Agilent IVI Drivers, AgMD1, Examples

C++ Copy image Copy Code
#include "AgMD1.h"

void main()
{
  ViStatus status;
  ViSession session;

  // Initialize the driver using a logical name
  status = AgMD1_InitWithOptions("MyLogicalName", VI_TRUE, VI_TRUE, "", &session);

  status = IviDigitizer_ConfigureAcquisition(session, 5, 100, 1000);
  status = IviDigitizer_ConfigureTriggerSource(session, "LAN1", 1.5, IVIDIGITIZER_VAL_SLOPE_NEGATIVE);

  // Close the session
  status = AgMD1_close(session);
}


Using .NET

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using .NET

There is no standard mechanism for accessing an IVI-C driver in .NET languages. Though the Microsoft .NET framework provides the [DllImport] attribute as a means to access any DLL function, its use is not standardized within IVI and it is very tedious and error prone in practice.

However, since the AgMD1 driver is built upon an IVI-COM core driver, the best way to access the driver from .NET languages is via the .NET interop assembly provided with the driver. The interop assemblies directly accesses the IVI-COM driver (bypassing the IVI-C wrapper layer) and provide a way to author interchangeable .NET applications as well as instrument-specific applications that utility specialized driver features.

For details on using the AgMD1 driver in .NET applications, see the IVI-COM topic Using C#.


Using MATLAB

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Using MATLAB®

Although MATLAB® provides support for accessing conventional Windows DLLs, such as IVI-C drivers, the AgMD1 driver includes a MATLAB wrapper that provides the most convenient way to access the AgMD1 driver. This wrapper directly accesses the underlying IVI-COM core driver, so the overhead of going through the AgMD1 driver's IVI-C wrapper layer is avoided.

For details on using the AgMD1 driver in MATLAB, please see the IVI-COM topic Using MATLAB.


Reference

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Reference

The topics in this section document each function and attribute exposed from the IVI-C driver. Functions and attributes are presented in a hierarchical function tree as well as in a flat list by name.

In This Section

Hierarchy

Presents a hierarchical view of all driver functions and attributes.

Functions and Attributes

Displays the IVI-C functions and attributes together in a flat list.

Functions By Name

Lists all IVI-C functions sorted alphabetically by name.

Attributes By Name

Lists all IVI-C attributes sorted alphabetically by name.

Errors and Warnings

Presents all driver errors and warnings ordered by error code.


AgMD1

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1
See Also

Tree Node: \AgMD1

Branches

Name
Arm
Attribute Accessors
Calibration
Channel
Configuration
Inherent IVI Attributes
Instrument Specific
Reference Oscillator
Sample Clock
Trigger
Utility
Waveform Acquisition
Top

Functions

 | Name | Description
Function | Close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Function | Initialize | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | Initialize With Options | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Top

See Also

Reference

AgMD1


Attribute Accessors

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Attribute Accessors
See Also

Tree Node: \AgMD1\Attribute Accessors

Functions

 | Name | Description
Function | GetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | GetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | SetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Top

See Also

Reference

AgMD1


AgMD1_GetAttributeViBoolean Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetAttributeViBoolean Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\GetAttributeViBoolean
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_GetAttributeViInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetAttributeViInt32 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\GetAttributeViInt32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_GetAttributeViInt64 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetAttributeViInt64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\GetAttributeViInt64
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_GetAttributeViReal64 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetAttributeViReal64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\GetAttributeViReal64
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_GetAttributeViSession Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetAttributeViSession Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\GetAttributeViSession
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetAttributeViSession(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViSession* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_GetAttributeViString Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetAttributeViString Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\GetAttributeViString
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_SetAttributeViBoolean Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SetAttributeViBoolean Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\SetAttributeViBoolean
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_SetAttributeViInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SetAttributeViInt32 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\SetAttributeViInt32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_SetAttributeViInt64 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SetAttributeViInt64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\SetAttributeViInt64
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_SetAttributeViReal64 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SetAttributeViReal64 Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\SetAttributeViReal64
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_SetAttributeViSession Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SetAttributeViSession Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\SetAttributeViSession
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SetAttributeViSession(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViSession AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


AgMD1_SetAttributeViString Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SetAttributeViString Function
Attribute Accessors See Also

This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.

Function Tree Node: \AgMD1\Attribute Accessors\SetAttributeViString
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

If the attribute applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL or an empty string. For attributes requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

AttributeID

The ID of the attribute. The valid values for this parameter can be found in the driver header file.

AttributeValue

The value to which to set the attribute.

Return Value

Success or failure code.

See Also

Reference

Attribute Accessors
AgMD1


Calibration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Calibration
See Also

Tree Node: \AgMD1\Calibration

Functions

 | Name | Description
Function | Self Calibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Top

See Also

Reference

AgMD1


AgMD1_SelfCalibrate Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SelfCalibrate Function
Calibration See Also

Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.

Function Tree Node: \AgMD1\Calibration\Self Calibrate
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SelfCalibrate(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgMD1


Channel

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Channel
See Also

Tree Node: \AgMD1\Channel

Branches

Name
Downconversion
Filter
Top

Attributes

 | Name | Description
Attribute | Channel Count | The number of channels.
Attribute | Channel Enabled | Specifies whether the digitizer acquires a waveform for the channel.
Attribute | Input Connector Selection | Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1, 2
Attribute | Input Impedance | The input impedance of this channel. The units are Ohms.
Attribute | Time Interleaved Channel List | This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.
Attribute | Vertical Coupling | Specifies how the digitizer couples the input signal for the channel.
Attribute | Vertical Offset | The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Attribute | Vertical Range | The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_CHANNEL_COUNT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_COUNT Attribute
Channel See Also

The number of channels.

Attribute Tree Node: \AgMD1\Channel\Channel Count
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_COUNT 1050203

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_CHANNEL_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_ENABLED Attribute
Channel See Also

Specifies whether the digitizer acquires a waveform for the channel.

Attribute Tree Node: \AgMD1\Channel\Channel Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_ENABLED 1250002

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


Downconversion

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Downconversion
See Also

Tree Node: \AgMD1\Channel\Downconversion

Attributes

 | Name | Description
Attribute | Downconversion Center Frequency | Specifies the center frequency, in Hz, from which the digitizer should downconvert.
Attribute | Downconversion Enabled | Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.
Attribute | Downconversion IQ Interleaved | Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_DOWNCONVERSION_CENTER_FREQUENCY Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DOWNCONVERSION_CENTER_FREQUENCY Attribute
Downconversion See Also

Specifies the center frequency, in Hz, from which the digitizer should downconvert.

Attribute Tree Node: \AgMD1\Channel\Downconversion\Downconversion Center Frequency
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DOWNCONVERSION_CENTER_FREQUENCY 1250900

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DOWNCONVERSION_CENTER_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

Downconversion
AgMD1


AGMD1_ATTR_DOWNCONVERSION_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DOWNCONVERSION_ENABLED Attribute
Downconversion See Also

Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.

Attribute Tree Node: \AgMD1\Channel\Downconversion\Downconversion Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DOWNCONVERSION_ENABLED 1250901

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DOWNCONVERSION_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

Downconversion
AgMD1


AGMD1_ATTR_DOWNCONVERSION_IQ_INTERLEAVED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DOWNCONVERSION_IQ_INTERLEAVED Attribute
Downconversion See Also

Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.

Attribute Tree Node: \AgMD1\Channel\Downconversion\Downconversion IQ Interleaved
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DOWNCONVERSION_IQ_INTERLEAVED 1250902

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DOWNCONVERSION_IQ_INTERLEAVED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Note that the M9703A only supports interleaved I-Q data points, and each I-Q pair is treated as one complex sample.

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

M9703A

See Also

Reference

Downconversion
AgMD1


Filter

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Filter
See Also

Tree Node: \AgMD1\Channel\Filter

Attributes

 | Name | Description
Attribute | Input Filter Bypass | Specifies whether or not to bypass the input filter.
Attribute | Input Filter Max Frequency | Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_INPUT_FILTER_BYPASS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INPUT_FILTER_BYPASS Attribute
Filter See Also

Specifies whether or not to bypass the input filter.

Attribute Tree Node: \AgMD1\Channel\Filter\Input Filter Bypass
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INPUT_FILTER_BYPASS 1250200

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_INPUT_FILTER_BYPASS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Filter
AgMD1


AGMD1_ATTR_INPUT_FILTER_MAX_FREQUENCY Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INPUT_FILTER_MAX_FREQUENCY Attribute
Filter See Also

Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.

Attribute Tree Node: \AgMD1\Channel\Filter\Input Filter Max Frequency
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INPUT_FILTER_MAX_FREQUENCY 1250201

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_INPUT_FILTER_MAX_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Filter
AgMD1


AGMD1_ATTR_INPUT_CONNECTOR_SELECTION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INPUT_CONNECTOR_SELECTION Attribute
Channel See Also

Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1, 2

Attribute Tree Node: \AgMD1\Channel\Input Connector Selection
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INPUT_CONNECTOR_SELECTION 1250003

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_INPUT_CONNECTOR_SELECTION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_INPUT_IMPEDANCE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INPUT_IMPEDANCE Attribute
Channel See Also

The input impedance of this channel. The units are Ohms.

Attribute Tree Node: \AgMD1\Channel\Input Impedance
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INPUT_IMPEDANCE 1250004

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_INPUT_IMPEDANCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_TIME_INTERLEAVED_CHANNEL_LIST Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TIME_INTERLEAVED_CHANNEL_LIST Attribute
Channel See Also

This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.

Attribute Tree Node: \AgMD1\Channel\Time Interleaved Channel List
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TIME_INTERLEAVED_CHANNEL_LIST 1250400

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_TIME_INTERLEAVED_CHANNEL_LIST.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

For valid channel name values, see the Channel repeated capability.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_VERTICAL_COUPLING Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_VERTICAL_COUPLING Attribute
Channel See Also

Specifies how the digitizer couples the input signal for the channel.

Attribute Tree Node: \AgMD1\Channel\Vertical Coupling
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_VERTICAL_COUPLING 1250024

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_VERTICAL_COUPLING.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_VERTICAL_COUPLING_AC | The digitizer AC couples the input signal.
AGMD1_VAL_VERTICAL_COUPLING_DC | The digitizer DC couples the input signal.
AGMD1_VAL_VERTICAL_COUPLING_GND | The digitizer couples the channel to the ground.
Top

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_VERTICAL_OFFSET Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_VERTICAL_OFFSET Attribute
Channel See Also

The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.

Attribute Tree Node: \AgMD1\Channel\Vertical Offset
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_VERTICAL_OFFSET 1250025

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_VERTICAL_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_VERTICAL_RANGE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_VERTICAL_RANGE Attribute
Channel See Also

The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Attribute Tree Node: \AgMD1\Channel\Vertical Range
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_VERTICAL_RANGE 1250026

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_VERTICAL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AgMD1_close Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_close Function
AgMD1 See Also

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

Function Tree Node: \AgMD1\Close
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_close(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

AgMD1
AgMD1


Configuration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Configuration
See Also

Tree Node: \AgMD1\Configuration

Branches

Name
Acquisition
Arm
Channel
Reference Oscillator
Sample Clock
Trigger
Top

See Also

Reference

AgMD1


Acquisition

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Acquisition
See Also

Tree Node: \AgMD1\Configuration\Acquisition

Branches

Name
Downconversion
Top

Functions

 | Name | Description
Function | Configure Acquisition Record | This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.
Function | Configure Sample Mode | Configures the digitizer sample mode.
Top

See Also

Reference

AgMD1


AgMD1_ConfigureAcquisition Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureAcquisition Function
Acquisition See Also

This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.

Function Tree Node: \AgMD1\Configuration\Acquisition\Configure Acquisition Record
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureAcquisition(
    ViSession Vi,
    ViInt64 NumRecordsToAcquire,
    ViInt64 RecordSize,
    ViReal64 SampleRate
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

NumRecordsToAcquire

Specifies the number of records in the acquisition. This value sets the Num Records to Acquire attribute.

RecordSize

Specifies the number of samples in each record. This value sets the Record Size attribute.

SampleRate

Specifies the sample rate in samples per second. This value sets the Sample Rate attribute.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgMD1


AgMD1_ConfigureSampleMode Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureSampleMode Function
Acquisition See Also

Configures the digitizer sample mode.

Function Tree Node: \AgMD1\Configuration\Acquisition\Configure Sample Mode
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureSampleMode(
    ViSession Vi,
    ViInt32 SampleMode
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

SampleMode

Specifies the sample mode used by the digitizer. This value sets the Sample Mode attribute. See the attribute description for more details.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter SampleMode

Name | Description
AGMD1_VAL_SAMPLE_MODE_REAL_TIME | Real-time sampling is used.
AGMD1_VAL_SAMPLE_MODE_EQUIVALENT_TIME | Equivalent-time sampling is used.
Top

See Also

Reference

Acquisition
AgMD1


Downconversion

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Downconversion
See Also

Tree Node: \AgMD1\Configuration\Acquisition\Downconversion

Functions

 | Name | Description
Function | Configure Downconversion | Configures how the digitizer performs downconversion.
Top

See Also

Reference

AgMD1


AgMD1_ConfigureDownconversion Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureDownconversion Function
Downconversion See Also

Configures how the digitizer performs downconversion.

Function Tree Node: \AgMD1\Configuration\Acquisition\Downconversion\Configure Downconversion
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureDownconversion(
    ViSession Vi,
    ViConstString ChannelName,
    ViBoolean Enabled,
    ViReal64 CenterFrequency
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

Enabled

Enables or disables downversion. The driver uses this value to set the Downconversion Enabled attribute. See the attribute description for more details.

CenterFrequency

Specifies the center frequency, in Hz, from which the digitizer should downconvert. The driver uses this value to set the Downconversion Center Frequency attribute. See the attribute description for more details.

Return Value

Success or failure code.

Remarks

For the M9703A, when downconversion is enabled, the following applies:

The Read/Fetch/FetchMulti functions in Real64 are supported for all sample rates. The Read/Fetch/FetchMulti functions in Int16 are supported for the highest sample rate only. The Read/Fetch/FetchMulti functions in Int32 are supported for all except the highest sample rates. (The Int variants correspond to the respective data format as stored in module memory).

For these functions, the parameter ActualPoints is given in number of I-Q data point pairs, or complex samples. For the FetchMulti functions, the units of the OffsetWithinRecord and NumPointsPerRecord parameters are also complex samples. The FirstValidPoint parameter, which is primarily intended for dealing with memory alignment, is always given in array elements, like the WaveformArraySize parameter.

Requirements

Supported Models

M9703A

See Also

Reference

Downconversion
AgMD1


Channel

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Channel
See Also

Tree Node: \AgMD1\Configuration\Channel

Branches

Name
Interleaved Data
Top

Functions

 | Name | Description
Function | Configure Channel | This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.
Function | Get Channel Name | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the Name parameter and returns an error.
Top

See Also

Reference

AgMD1


AgMD1_ConfigureChannel Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureChannel Function
Channel See Also

This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.

Function Tree Node: \AgMD1\Configuration\Channel\Configure Channel
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureChannel(
    ViSession Vi,
    ViConstString ChannelName,
    ViReal64 Range,
    ViReal64 Offset,
    ViInt32 Coupling,
    ViBoolean Enabled
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

Range

Specifies the vertical range. This value sets the Vertical Range attribute.

Offset

Specifies the vertical offset. This value sets the Vertical Offset attribute.

Coupling

Specifies how to couple the input signal. This value sets the Vertical

Enabled

Specifies if the channel is enabled for acquisition. This value sets the Channel Enabled attribute.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Coupling

Name | Description
AGMD1_VAL_VERTICAL_COUPLING_AC | The digitizer AC couples the input signal.
AGMD1_VAL_VERTICAL_COUPLING_DC | The digitizer DC couples the input signal.
AGMD1_VAL_VERTICAL_COUPLING_GND | The digitizer couples the channel to the ground.
Top

See Also

Reference

Channel
AgMD1


AgMD1_GetChannelName Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetChannelName Function
Channel See Also

This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the Name parameter and returns an error.

Function Tree Node: \AgMD1\Configuration\Channel\Get Channel Name
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetChannelName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

The number of bytes in the ViChar array that the user specifies for the Name parameter.

Name

A user-allocated (for IVI-C) or driver-allocated (for IVI-COM) buffer into which the driver stores the channel name. The caller may pass VI_NULL for this parameter if the NameBufferSize parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


Reference Oscillator

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Reference Oscillator
See Also

Tree Node: \AgMD1\Configuration\Reference Oscillator

Functions

 | Name | Description
Function | Configure Reference Oscillator Output Enabled | Configures whether or not the reference frequency signal appears at an output of the digitizer.
Top

See Also

Reference

AgMD1


AgMD1_ConfigureReferenceOscillatorOutputEnabled Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureReferenceOscillatorOutputEnabled Function
Reference Oscillator See Also

Configures whether or not the reference frequency signal appears at an output of the digitizer.

Function Tree Node: \AgMD1\Configuration\Reference Oscillator\Configure Reference Oscillator Output Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureReferenceOscillatorOutputEnabled(
    ViSession Vi,
    ViBoolean Enabled
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Enabled

Specifies whether or not the reference frequency signal appears at a reference output of the digitizer. This value sets the Reference Oscillator Output Enabled attribute. See the attribute description for more details.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Reference Oscillator
AgMD1


Trigger

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Trigger
See Also

Tree Node: \AgMD1\Configuration\Trigger

Functions

 | Name | Description
Function | Configure Edge Trigger Source | This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Function | Configure Multi Trigger | Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.
Function | Configure Trigger Modifier | This function configures the digitizer's trigger modifier.
Function | Configure TV Trigger Source | This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.
Function | Get Trigger Source Name | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Trigger Source Count, the function returns an empty string in the Name parameter and returns an error.
Top

See Also

Reference

AgMD1


AgMD1_ConfigureEdgeTriggerSource Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureEdgeTriggerSource Function
Trigger See Also

This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Function Tree Node: \AgMD1\Configuration\Trigger\Configure Edge Trigger Source
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureEdgeTriggerSource(
    ViSession Vi,
    ViConstString Source,
    ViReal64 Level,
    ViInt32 Slope
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Source

Specifies the trigger source. This value sets the Trigger Source attribute.For valid values, see the TriggerSource repeated capability.

Level

Specifies the trigger level. This value sets the Trigger Level attribute.

Slope

Specifies the trigger slope. This value sets the Trigger Slope attribute.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Slope

Name | Description
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
Top

See Also

Reference

Trigger
AgMD1


AgMD1_ConfigureMultiTrigger Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureMultiTrigger Function
Trigger See Also

Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.

Function Tree Node: \AgMD1\Configuration\Trigger\Configure Multi Trigger
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureMultiTrigger(
    ViSession Vi,
    ViConstString SourceList,
    ViInt32 Operator
);

Parameters

Vi

SourceList

A comma separated list of source names to be used in a multi trigger scenario. The driver uses this value to set the Trigger Source List attribute.

Operator

Specifies the boolean operation to apply to the trigger sources specified by the SourceList parameter. The driver uses this value to set the Trigger Source Operator attribute.

Return Value

Success or failure code.

Requirements

Supported Models

DC122, DC122HF, DC122HZ, DC152, DC152HZ, DC222, DC222HF, DC222HZ, DC252, DC252HF, DC252HZ, DC282, DC282HZ, DP1400, M9210A, M9211A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

Defined Values For Parameter Operator

Name | Description
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_AND | Trigger sources are AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_OR | Trigger sources are OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_NONE | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Trigger Source attribute, and its associated trigger conditions are satisfied.
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_NAND |
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_NOR |
Top

See Also

Reference

Trigger
AgMD1


AgMD1_ConfigureTriggerModifier Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureTriggerModifier Function
Trigger See Also

This function configures the digitizer's trigger modifier.

Function Tree Node: \AgMD1\Configuration\Trigger\Configure Trigger Modifier
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureTriggerModifier(
    ViSession Vi,
    ViInt32 TriggerModifier
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

TriggerModifier

Specifies the method the digitizer uses in the absence of trigger conditions. The driver sets the Trigger Modifier attribute to this value. See the attribute description for more information and defined values.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter TriggerModifier

Name | Description
AGMD1_VAL_TRIGGER_MODIFIER_NONE | The digitizer waits until the trigger the end-user specifies occurs.
AGMD1_VAL_TRIGGER_MODIFIER_AUTO | The digitizer automatically triggers if the configured trigger does not occur within the digitizer timeout period.
Top

See Also

Reference

Trigger
AgMD1


AgMD1_ConfigureTVTriggerSource Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureTVTriggerSource Function
Trigger See Also

This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.

Function Tree Node: \AgMD1\Configuration\Trigger\Configure TV Trigger Source
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureTVTriggerSource(
    ViSession Vi,
    ViConstString Source,
    ViInt32 SignalFormat,
    ViInt32 Event,
    ViInt32 Polarity
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Source

Specifies the trigger source. This value sets the Trigger Source attribute.For valid values, see the TriggerSource repeated capability.

SignalFormat

Specifies the TV trigger signal format. This value sets the TV Trigger Signal Format attribute.

Event

Specifies the TV trigger event. This value sets the TV Trigger Event attribute.

Polarity

Specifies the polarity of the TV trigger. This value sets the TV Trigger Polarity attribute.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter SignalFormat

Name | Description
AGMD1_VAL_NTSC | Configures the digitizer to trigger on the NTSC signal format.
AGMD1_VAL_PAL | Configures the digitizer to trigger on the PAL signal format
AGMD1_VAL_SECAM | Configures the digitizer to trigger on the SECAM signal format
Top

Defined Values For Parameter Event

Name | Description
AGMD1_VAL_TV_EVENT_FIELD1 | Sets the digitizer to trigger on field 1 of the video signal.
AGMD1_VAL_TV_EVENT_FIELD2 | Sets the digitizer to trigger on field 2 of the video signal.
AGMD1_VAL_TV_EVENT_LINE_NUMBER | Sets the digitizer to trigger on a specific line number you specify with the TV Trigger Line Number attribute.
Top

Defined Values For Parameter Polarity

Name | Description
AGMD1_VAL_TV_POSITIVE | Configures the digitizer to trigger on a positive video sync pulse.
AGMD1_VAL_TV_NEGATIVE | Configures the digitizer to trigger on a negative video sync pulse.
Top

See Also

Reference

Trigger
AgMD1


AgMD1_GetTriggerSourceName Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetTriggerSourceName Function
Trigger See Also

This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Trigger Source Count, the function returns an empty string in the Name parameter and returns an error.

Function Tree Node: \AgMD1\Configuration\Trigger\Get Trigger Source Name
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetTriggerSourceName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

The number of bytes in the ViChar array that the user specifies for the Name parameter.

Name

A user-allocated (for IVI-C) or driver-allocated (for IVI-COM) buffer into which the driver stores the channel name. The caller may pass VI_NULL for this parameter if the NameBufferSize parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


Inherent IVI Attributes

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Inherent IVI Attributes
See Also

Tree Node: \AgMD1\Inherent IVI Attributes

Branches

Name
Advanced Session Information
Driver Capabilities
Driver Identification
Instrument Identification
User Options
Top

See Also

Reference

AgMD1


Advanced Session Information

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Advanced Session Information
See Also

Tree Node: \AgMD1\Inherent IVI Attributes\Advanced Session Information

Attributes

 | Name | Description
Attribute | Driver Setup | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Attribute | I/O Resource Descriptor | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Attribute | Logical Name | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_DRIVER_SETUP Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DRIVER_SETUP Attribute
Advanced Session Information See Also

The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Advanced Session Information\Driver Setup
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DRIVER_SETUP 1050007

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_DRIVER_SETUP.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Advanced Session Information
AgMD1


AGMD1_ATTR_IO_RESOURCE_DESCRIPTOR Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_IO_RESOURCE_DESCRIPTOR Attribute
Advanced Session Information See Also

The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Advanced Session Information\I/O Resource Descriptor
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_IO_RESOURCE_DESCRIPTOR 1050304

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_IO_RESOURCE_DESCRIPTOR.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Advanced Session Information
AgMD1


AGMD1_ATTR_LOGICAL_NAME Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_LOGICAL_NAME Attribute
Advanced Session Information See Also

Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Advanced Session Information\Logical Name
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_LOGICAL_NAME 1050305

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_LOGICAL_NAME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Advanced Session Information
AgMD1


Driver Capabilities

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Driver Capabilities
See Also

Tree Node: \AgMD1\Inherent IVI Attributes\Driver Capabilities

Attributes

 | Name | Description
Attribute | Class Group Capabilities | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Attribute | Supported Instrument Models | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_GROUP_CAPABILITIES Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_GROUP_CAPABILITIES Attribute
Driver Capabilities See Also

A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Capabilities\Class Group Capabilities
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_GROUP_CAPABILITIES 1050401

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_GROUP_CAPABILITIES.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Driver Capabilities
AgMD1


AGMD1_ATTR_SUPPORTED_INSTRUMENT_MODELS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SUPPORTED_INSTRUMENT_MODELS Attribute
Driver Capabilities See Also

A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Capabilities\Supported Instrument Models
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SUPPORTED_INSTRUMENT_MODELS 1050327

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SUPPORTED_INSTRUMENT_MODELS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Driver Capabilities
AgMD1


Driver Identification

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Driver Identification
See Also

Tree Node: \AgMD1\Inherent IVI Attributes\Driver Identification

Attributes

 | Name | Description
Attribute | Specific Driver Class Spec Major Version | Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | Specific Driver Class Spec Minor Version | Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | Specific Driver Description | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | Specific Driver Prefix | Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.
Attribute | Specific Driver Revision | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | Specific Driver Vendor | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION Attribute
Driver Identification See Also

Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Identification\Specific Driver Class Spec Major Version
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION 1050515

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

See Also

Reference

Driver Identification
AgMD1


AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION Attribute
Driver Identification See Also

Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Identification\Specific Driver Class Spec Minor Version
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION 1050516

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

See Also

Reference

Driver Identification
AgMD1


AGMD1_ATTR_SPECIFIC_DRIVER_DESCRIPTION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SPECIFIC_DRIVER_DESCRIPTION Attribute
Driver Identification See Also

Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Identification\Specific Driver Description
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SPECIFIC_DRIVER_DESCRIPTION 1050514

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SPECIFIC_DRIVER_DESCRIPTION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgMD1


AGMD1_ATTR_SPECIFIC_DRIVER_PREFIX Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SPECIFIC_DRIVER_PREFIX Attribute
Driver Identification See Also

Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Identification\Specific Driver Prefix
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SPECIFIC_DRIVER_PREFIX 1050302

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SPECIFIC_DRIVER_PREFIX.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgMD1


AGMD1_ATTR_SPECIFIC_DRIVER_REVISION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SPECIFIC_DRIVER_REVISION Attribute
Driver Identification See Also

Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Identification\Specific Driver Revision
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SPECIFIC_DRIVER_REVISION 1050551

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SPECIFIC_DRIVER_REVISION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgMD1


AGMD1_ATTR_SPECIFIC_DRIVER_VENDOR Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SPECIFIC_DRIVER_VENDOR Attribute
Driver Identification See Also

Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Driver Identification\Specific Driver Vendor
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SPECIFIC_DRIVER_VENDOR 1050513

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SPECIFIC_DRIVER_VENDOR.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

See Also

Reference

Driver Identification
AgMD1


Instrument Identification

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Instrument Identification
See Also

Tree Node: \AgMD1\Inherent IVI Attributes\Instrument Identification

Attributes

 | Name | Description
Attribute | Instrument Firmware Revision | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Attribute | Instrument Manufacturer | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
Attribute | Instrument Model | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Top

See Also

Reference

AgMD1


AGMD1_ATTR_INSTRUMENT_FIRMWARE_REVISION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_FIRMWARE_REVISION Attribute
Instrument Identification See Also

The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Instrument Identification\Instrument Firmware Revision
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_FIRMWARE_REVISION 1050510

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_FIRMWARE_REVISION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Instrument Identification
AgMD1


AGMD1_ATTR_INSTRUMENT_MANUFACTURER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_MANUFACTURER Attribute
Instrument Identification See Also

The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Instrument Identification\Instrument Manufacturer
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_MANUFACTURER 1050511

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_MANUFACTURER.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Instrument Identification
AgMD1


AGMD1_ATTR_INSTRUMENT_MODEL Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_MODEL Attribute
Instrument Identification See Also

The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\Instrument Identification\Instrument Model
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_MODEL 1050512

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_MODEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Instrument Identification
AgMD1


User Options

[image]

AgMD1 IVI Driver Reference Agilent Technologies
User Options
See Also

Tree Node: \AgMD1\Inherent IVI Attributes\User Options

Attributes

 | Name | Description
Attribute | Cache | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Attribute | Interchange Check | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Attribute | Query Instrument Status | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Attribute | Range Check | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Attribute | Record Value Coercions | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Attribute | Simulate | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_CACHE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CACHE Attribute
User Options See Also

Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\User Options\Cache
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CACHE 1050004

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_CACHE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgMD1


AGMD1_ATTR_INTERCHANGE_CHECK Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INTERCHANGE_CHECK Attribute
User Options See Also

If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\User Options\Interchange Check
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INTERCHANGE_CHECK 1050021

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INTERCHANGE_CHECK.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgMD1


AGMD1_ATTR_QUERY_INSTRUMENT_STATUS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_QUERY_INSTRUMENT_STATUS Attribute
User Options See Also

If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\User Options\Query Instrument Status
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_QUERY_INSTRUMENT_STATUS 1050003

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_QUERY_INSTRUMENT_STATUS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgMD1


AGMD1_ATTR_RANGE_CHECK Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_RANGE_CHECK Attribute
User Options See Also

Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\User Options\Range Check
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_RANGE_CHECK 1050002

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_RANGE_CHECK.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgMD1


AGMD1_ATTR_RECORD_COERCIONS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_RECORD_COERCIONS Attribute
User Options See Also

If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\User Options\Record Value Coercions
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_RECORD_COERCIONS 1050006

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_RECORD_COERCIONS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgMD1


AGMD1_ATTR_SIMULATE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SIMULATE Attribute
User Options See Also

If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

Attribute Tree Node: \AgMD1\Inherent IVI Attributes\User Options\Simulate
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SIMULATE 1050005

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SIMULATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

User Options
AgMD1


AgMD1_init Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_init Function
AgMD1 See Also

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Function Tree Node: \AgMD1\Initialize
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_init(
    ViRsrc ResourceName,
    ViBoolean IdQuery,
    ViBoolean Reset,
    ViSession* Vi
);

Parameters

ResourceName

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

IdQuery

Specifies whether to verify the ID of the instrument.

Reset

Specifies whether to reset the instrument.

Vi

Unique identifier for an IVI session.

Return Value

Success or failure code.

Remarks

For detailed parameter usage see: Initializing the IVI-C Driver

See Also

Reference

AgMD1
AgMD1


AgMD1_InitWithOptions Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_InitWithOptions Function
AgMD1 See Also

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Function Tree Node: \AgMD1\Initialize With Options
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_InitWithOptions(
    ViRsrc ResourceName,
    ViBoolean IdQuery,
    ViBoolean Reset,
    ViConstString OptionsString,
    ViSession* Vi
);

Parameters

ResourceName

An IVI logical name or an instrument specific string that identifies the address of the instrument, such as a VISA resource descriptor string.

IdQuery

Specifies whether to verify the ID of the instrument.

Reset

Specifies whether to reset the instrument.

OptionsString

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent attributes for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck,or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the DriverSetup attribute, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

Vi

Unique identifier for an IVI session.

Return Value

Success or failure code.

Remarks

Specific DriverSetup options
Option Name | Description | Default
Dma | If true, data transfers are performed in DMA mode. | true
Cal | If true, a calibration is performed during initialization. | true
For detailed parameter usage see: Initializing the IVI-C Driver

Requirements

Supported Models

All supported

See Also

Reference

AgMD1
AgMD1


Instrument Specific

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Instrument Specific
See Also

Tree Node: \AgMD1\Instrument Specific

Branches

Name
Acquisition
Calibration
Channel
ControlIO
InstrumentInfo
LogicDevice
ReferenceLevel
System
Temperature
Trigger
Top

See Also

Reference

AgMD1


Acquisition

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Acquisition
See Also

Tree Node: \AgMD1\Instrument Specific\Acquisition

Branches

Name
Status
Top

Functions

 | Name | Description
Function | Acquisition Configure Record | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Top

Attributes

 | Name | Description
Attribute | Acquisition Auto Arm Enabled | If true, auto arming is enabled. If false, after an acquisition has been initiated, SendSoftwareArm method must be called before any triggers will be accepted. Requires model: M9202A
Attribute | Acquisition Dither Enabled | If true, enables dithering. Requires model: M9202A
Attribute | Acquisition Dither Range | Sets amplitude of dithering signal. Range: 0 to 31. 0 = dithering amplitude is 0 (i. e. no dithering). 31 = dithering amplitude is Full Scale/2 = 500 mV. Requires model: M9202A
Attribute | Acquisition Downconversion Data Scaling Enabled | Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
Attribute | Acquisition Number Of Averages | The number of waveforms the digitizer acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.
Attribute | Acquisition Reference Channel | The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ...
Attribute | Acquisition Start Time | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Attribute | Acquisition Time Per Record | The time in seconds that corresponds to the record length.
Attribute | Mode | The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
Top

See Also

Reference

AgMD1


AGMD1_ATTR_ACQUISITION_AUTO_ARM_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_AUTO_ARM_ENABLED Attribute
Acquisition See Also

If true, auto arming is enabled. If false, after an acquisition has been initiated, SendSoftwareArm method must be called before any triggers will be accepted. Requires model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Auto Arm Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_AUTO_ARM_ENABLED 1150045

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_AUTO_ARM_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

M9202A

See Also

Reference

Acquisition
AgMD1


AgMD1_AcquisitionConfigureRecord Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_AcquisitionConfigureRecord Function
Acquisition See Also

Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.

Function Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Configure Record
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_AcquisitionConfigureRecord(
    ViSession Vi,
    ViReal64 TimePerRecord,
    ViInt32 MinNumPts,
    ViReal64 AcquisitionStartTime
);

Parameters

Vi

TimePerRecord

MinNumPts

AcquisitionStartTime

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_DITHER_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_DITHER_ENABLED Attribute
Acquisition See Also

If true, enables dithering. Requires model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Dither Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_DITHER_ENABLED 1150044

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_DITHER_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

M9202A, U1084A001, U1084A002, U1084A003

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_DITHER_RANGE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_DITHER_RANGE Attribute
Acquisition See Also

Sets amplitude of dithering signal. Range: 0 to 31. 0 = dithering amplitude is 0 (i. e. no dithering). 31 = dithering amplitude is Full Scale/2 = 500 mV. Requires model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Dither Range
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_DITHER_RANGE 1150046

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_DITHER_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

M9202A, U1084A001, U1084A002, U1084A003

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED Attribute
Acquisition See Also

Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Downconversion Data Scaling Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED 1150066

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

M9703A

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_NUMBER_OF_AVERAGES Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_NUMBER_OF_AVERAGES Attribute
Acquisition See Also

The number of waveforms the digitizer acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Number Of Averages
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_NUMBER_OF_AVERAGES 1150003

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_NUMBER_OF_AVERAGES.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_REFERENCE_CHANNEL Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_REFERENCE_CHANNEL Attribute
Acquisition See Also

The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ...

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Reference Channel
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_REFERENCE_CHANNEL 1150011

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_REFERENCE_CHANNEL.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_START_TIME Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_START_TIME Attribute
Acquisition See Also

The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Start Time
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_START_TIME 1150001

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_START_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_TIME_PER_RECORD Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_TIME_PER_RECORD Attribute
Acquisition See Also

The time in seconds that corresponds to the record length.

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Acquisition Time Per Record
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_TIME_PER_RECORD 1150002

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_TIME_PER_RECORD.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgMD1


AGMD1_ATTR_ACQUISITION_MODE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACQUISITION_MODE Attribute
Acquisition See Also

The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Acquisition\Mode
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACQUISITION_MODE 1150047

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACQUISITION_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_ACQUISITION_MODE_NORMAL | Normal digitizer mode
AGMD1_VAL_ACQUISITION_MODE_DOWNCONVERTER | Digital Downconverter (DDC) mode. Requires model: M9202A
AGMD1_VAL_ACQUISITION_MODE_COUNTER | Frequency counter mode
AGMD1_VAL_ACQUISITION_MODE_USER_FDK | User FDK mode. Requires model M9703A with FDK option.
Top

Requirements

Supported Models

All supported

See Also

Reference

Acquisition
AgMD1


Calibration

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Calibration
See Also

Tree Node: \AgMD1\Instrument Specific\Calibration

Branches

Name
DelayControl
Top

Functions

 | Name | Description
Function | Calibration Cal Required | Check if a self calibration is needed on the specified channel.
Function | Calibration Cancel | Abort any running self-calibration and return.
Function | Calibration Load Cal | Load calibration values and info from file.
Function | Calibration Save Cal | Save calibration values and info in a binary file.
Function | Calibration Self Calibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Top

See Also

Reference

AgMD1


AgMD1_CalibrationCalRequired Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_CalibrationCalRequired Function
Calibration See Also

Check if a self calibration is needed on the specified channel.

Function Tree Node: \AgMD1\Instrument Specific\Calibration\Calibration Cal Required
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_CalibrationCalRequired(
    ViSession Vi,
    ViInt32 Channel,
    ViBoolean* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Channel

Channel number [0,1...Nchan]. The value Channel = 0 can be used to do the query on all channels simultaneously.

Val

True if the specified channel need to be calibrated.

Return Value

Success or failure code.

Remarks

Query about the necessity of self calibration. A calibration is needed for channel 'Channel'>0, if one or more of the 3 following condition is true: 1. The channel 'Channel' of the instrument has never been calibrated for the desired acquisition conditions. 2. It has been calibrated more than 2 hours ago. 3. The instrument temperature since the last self calibration has changed by more than 5 degrees C.

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgMD1


AgMD1_CalibrationCancel Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_CalibrationCancel Function
Calibration See Also

Abort any running self-calibration and return.

Function Tree Node: \AgMD1\Instrument Specific\Calibration\Calibration Cancel
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_CalibrationCancel(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

If a self-calibration is run from another thread, this other thread will be interrupted immediately and the call will return with an operation cancelled error.

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgMD1


AgMD1_CalibrationLoadCal Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_CalibrationLoadCal Function
Calibration See Also

Load calibration values and info from file.

Function Tree Node: \AgMD1\Instrument Specific\Calibration\Calibration Load Cal
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_CalibrationLoadCal(
    ViSession Vi,
    ViConstString FilePathName
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

FilePathName

If NULL or empty string uses working directory and default file name of 'snXXXXX_calVal.bin'. If set to a path uses the specified directory with default file name. If a file name, with or without path, the specified name and path is used. File names must end in '.bin'

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgMD1


AgMD1_CalibrationSaveCal Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_CalibrationSaveCal Function
Calibration See Also

Save calibration values and info in a binary file.

Function Tree Node: \AgMD1\Instrument Specific\Calibration\Calibration Save Cal
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_CalibrationSaveCal(
    ViSession Vi,
    ViConstString FilePathName
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

FilePathName

If NULL or empty string uses working directory and default file name of 'snXXXXX_calVal.bin'. If set to a path uses the specified directory with default file name. If a file name, with or without path, the specified name and path is used. File names must end in '.bin'

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Calibration
AgMD1


AgMD1_CalibrationSelfCalibrate Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_CalibrationSelfCalibrate Function
Calibration See Also

Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.

Function Tree Node: \AgMD1\Instrument Specific\Calibration\Calibration Self Calibrate
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_CalibrationSelfCalibrate(
    ViSession Vi,
    ViInt32 Type,
    ViInt32 Channel
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Type

Type of self-calibration: see Programmers Reference manual.

Channel

If supported for the chosen calibrate type, specifies the channel: 0 = calibrate all channels, >0 = calibrate only the specified channel.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Type

Name | Description
AGMD1_VAL_CALIBRATE_TYPE_FULL | Calibrate the entire instrument.
AGMD1_VAL_CALIBRATE_TYPE_CHANNEL_CONFIGURATION | Calibrate only the current channel configuration.
AGMD1_VAL_CALIBRATE_TYPE_EXT_CLOCK_TIMING | Calibrate external clock timing. Requires operation in External Clock (Continuous).
AGMD1_VAL_CALIBRATE_TYPE_CURRENT_FREQUENCY | Calibrate only at the current frequency (only instruments with fine resolution timebases).
AGMD1_VAL_CALIBRATE_TYPE_FAST | FastCal: calibrate only at the current settings (if supported). Warning: in this mode, any change of range, max input frequency, channel combine, input impedance or coupling, will require a new calibration.
Top

See Also

Reference

Calibration
AgMD1


DelayControl

[image]

AgMD1 IVI Driver Reference Agilent Technologies
DelayControl
See Also

Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl

Functions

 | Name | Description
Function | Get Delay Control Name | Returns the delay control name that corresponds to the one-based index that the user specifies.
Top

Attributes

 | Name | Description
Attribute | Delay Control Count |
Attribute | Delay Control Enabled | Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
Attribute | Delay Control Max | Maximum value (DAC code) that can be set for the delay control.
Attribute | Delay Control Min | Minimum value (DAC code) that can be set for the delay control.
Attribute | Delay Control Value | The value (DAC code) set for the delay control.
Attribute | Range | Selects the range for the delay control. Useful only for delay controls with multiple ranges.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_DELAY_CONTROL_COUNT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DELAY_CONTROL_COUNT Attribute
DelayControl See Also

Attribute Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl\Delay Control Count
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DELAY_CONTROL_COUNT 1150059

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_DELAY_CONTROL_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

See Also

Reference

DelayControl
AgMD1


AGMD1_ATTR_DELAY_CONTROL_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DELAY_CONTROL_ENABLED Attribute
DelayControl See Also

Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.

Attribute Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl\Delay Control Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DELAY_CONTROL_ENABLED 1150064

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_DELAY_CONTROL_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

DelayControl
AgMD1


AGMD1_ATTR_DELAY_CONTROL_MAX Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DELAY_CONTROL_MAX Attribute
DelayControl See Also

Maximum value (DAC code) that can be set for the delay control.

Attribute Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl\Delay Control Max
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DELAY_CONTROL_MAX 1150060

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DelayControl repeated capability.

AttributeID

Must be AGMD1_ATTR_DELAY_CONTROL_MAX.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

M9703A

See Also

Reference

DelayControl
AgMD1


AGMD1_ATTR_DELAY_CONTROL_MIN Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DELAY_CONTROL_MIN Attribute
DelayControl See Also

Minimum value (DAC code) that can be set for the delay control.

Attribute Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl\Delay Control Min
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DELAY_CONTROL_MIN 1150061

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DelayControl repeated capability.

AttributeID

Must be AGMD1_ATTR_DELAY_CONTROL_MIN.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

M9703A

See Also

Reference

DelayControl
AgMD1


AGMD1_ATTR_DELAY_CONTROL_VALUE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DELAY_CONTROL_VALUE Attribute
DelayControl See Also

The value (DAC code) set for the delay control.

Attribute Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl\Delay Control Value
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DELAY_CONTROL_VALUE 1150062

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DelayControl repeated capability.

AttributeID

Must be AGMD1_ATTR_DELAY_CONTROL_VALUE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

WARNING: These controls are provided for very specific use cases. Their usage may have significant influences on the analog performance of the digitizer.

The delay controls are in DAC codes or delay steps, but not in time unit because the DACs are not calibrated. The conversion factors to time are provided for guidance but should not be taken as exact or calibrated values. If exact times are required, an external calibration is necessary.

Delay control repeated capability supported values
Repcap name | Description | Min | Max | Time Step or Delay [ps] | Time Range [ps]
DelayAXIe100 | Controls the delay on the AXIe 100MHz reference. | 0 | 4095 | ~0.130 | 0 to ~550 (Not linear)
DelayPLLReference | Controls the delay on the PLL reference. Positive values will control the delay of the AXIe and External references. Negative values will control the delay of the Internal reference, and in the opposite direction (i.e. negative delay values). | -7 | 7 | Not linear: 0: 0 1: 160 2: 320 3: 480 4: 830 5: 1130 6: 1450 7: 1750 | -1750 to 1750
DelaySampleClock<X> | Control the delay on the Sample Clock for channels on DPU <X>. <X> can be A, B, C or D (e.g. DelaySampleClockA). There is an Extended range which can be selected with the Range property. | 0 | 4095 | ~0.007 (Default range) ~0.013 (Extended range) | 0 to ~30 (Default range) 0 to ~60 (Extended range)
Note
Time Step and Time Range are specific to the hardware and can be different for each instrument modules. The values here are approximate.

Requirements

Supported Models

M9703A

See Also

Reference

DelayControl
AgMD1


AgMD1_GetDelayControlName Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetDelayControlName Function
DelayControl See Also

Returns the delay control name that corresponds to the one-based index that the user specifies.

Function Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl\Get Delay Control Name
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetDelayControlName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

DelayControl
AgMD1


AGMD1_ATTR_DELAY_CONTROL_RANGE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DELAY_CONTROL_RANGE Attribute
DelayControl See Also

Selects the range for the delay control. Useful only for delay controls with multiple ranges.

Attribute Tree Node: \AgMD1\Instrument Specific\Calibration\DelayControl\Range
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DELAY_CONTROL_RANGE 1150065

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the DelayControl repeated capability.

AttributeID

Must be AGMD1_ATTR_DELAY_CONTROL_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to DelayControls property for a list of supported delay controls and ranges.

Defined Values

Name | Description
AGMD1_VAL_DELAY_CONTROL_RANGE_DEFAULT |
AGMD1_VAL_DELAY_CONTROL_RANGE_EXTENDED |
Top

Requirements

Supported Models

M9703A

See Also

Reference

DelayControl
AgMD1


Channel

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Channel
See Also

Tree Node: \AgMD1\Instrument Specific\Channel

Branches

Name
Counter
DigitalDownconversion
Downconversion
Measurement
Top

Attributes

 | Name | Description
Attribute | Channel Active Inputs | String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc.
Attribute | Channel Connector Name | The connector name as it appears on the instrument's front panel.
Attribute | Channel Converters Per Channel | The number of converters currently assigned to each channel.
Attribute | Channel Input Frequency Max | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth).
Attribute | Channel Probe Attenuation | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_CHANNEL_ACTIVE_INPUTS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_ACTIVE_INPUTS Attribute
Channel See Also

String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc.

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Channel Active Inputs
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_ACTIVE_INPUTS 1150013

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_ACTIVE_INPUTS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_CHANNEL_CONNECTOR_NAME Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_CONNECTOR_NAME Attribute
Channel See Also

The connector name as it appears on the instrument's front panel.

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Channel Connector Name
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_CONNECTOR_NAME 1150012

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_CONNECTOR_NAME.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_CHANNEL_CONVERTERS_PER_CHANNEL Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_CONVERTERS_PER_CHANNEL Attribute
Channel See Also

The number of converters currently assigned to each channel.

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Channel Converters Per Channel
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_CONVERTERS_PER_CHANNEL 1150014

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_CONVERTERS_PER_CHANNEL.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_CHANNEL_INPUT_FREQUENCY_MAX Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_INPUT_FREQUENCY_MAX Attribute
Channel See Also

The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth).

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Channel Input Frequency Max
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_INPUT_FREQUENCY_MAX 1150004

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_INPUT_FREQUENCY_MAX.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


AGMD1_ATTR_CHANNEL_PROBE_ATTENUATION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_PROBE_ATTENUATION Attribute
Channel See Also

The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Channel Probe Attenuation
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_PROBE_ATTENUATION 1150005

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_PROBE_ATTENUATION.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Channel
AgMD1


Counter

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Counter
See Also

Tree Node: \AgMD1\Instrument Specific\Channel\Counter

Functions

 | Name | Description
Function | Counter Read | Counter measurement results for the current mode. Counter must be enabled by setting Acquisition.Mode = AgMD1AcquisitionModeCounter. The Read method will wait the current ApertureTime before returning measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.
Top

Attributes

 | Name | Description
Attribute | Aperture Time | The minimum measurement time for Frequency and Period modes. The duration to count input pulses for TotalizeGate mode. The Counter.Read method will wait this time before returning measurement data. Units are seconds.
Attribute | Mode | The mode for counter measurements, Frequency, Period, TotalizeTime, or TotalizeGate.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_COUNTER_APERTURE_TIME Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_COUNTER_APERTURE_TIME Attribute
Counter See Also

The minimum measurement time for Frequency and Period modes. The duration to count input pulses for TotalizeGate mode. The Counter.Read method will wait this time before returning measurement data. Units are seconds.

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Counter\Aperture Time
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_COUNTER_APERTURE_TIME 1150053

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_COUNTER_APERTURE_TIME.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

DC135, DC135HZ, DC140, DC140HZ

See Also

Reference

Counter
AgMD1


AgMD1_CounterRead Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_CounterRead Function
Counter See Also

Counter measurement results for the current mode. Counter must be enabled by setting Acquisition.Mode = AgMD1AcquisitionModeCounter. The Read method will wait the current ApertureTime before returning measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.

Function Tree Node: \AgMD1\Instrument Specific\Channel\Counter\Counter Read
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_CounterRead(
    ViSession Vi,
    ViConstString Channel,
    ViReal64* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single channel.For valid values, see the Channel repeated capability.

Val

Measurement data.Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.

Return Value

Success or failure code.

Requirements

Supported Models

DC135, DC135HZ, DC140, DC140HZ

See Also

Reference

Counter
AgMD1


AGMD1_ATTR_COUNTER_MODE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_COUNTER_MODE Attribute
Counter See Also

The mode for counter measurements, Frequency, Period, TotalizeTime, or TotalizeGate.

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Counter\Mode
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_COUNTER_MODE 1150054

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_COUNTER_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_COUNTER_MODE_FREQUENCY | Counter measures the frequency of the input signal.
AGMD1_VAL_COUNTER_MODE_PERIOD | Counter measures the period of the input signal.
AGMD1_VAL_COUNTER_MODE_TOTALIZE_TIME | Counts input pulses during interval defined by Counter.AperatureTime property.
AGMD1_VAL_COUNTER_MODE_TOTALIZE_GATE | Counts input pulses during interval defined by control I/O A or B input.
Top

Requirements

Supported Models

DC135, DC135HZ, DC140, DC140HZ

See Also

Reference

Counter
AgMD1


DigitalDownconversion

[image]

AgMD1 IVI Driver Reference Agilent Technologies
DigitalDownconversion
See Also

Tree Node: \AgMD1\Instrument Specific\Channel\DigitalDownconversion

Functions

 | Name | Description
Function | Digital Downconversion Configure | Configures the DigitalDownconverson DataBandwidth and TriggerBandwidth. Requires Model: M9202A
Top

Attributes

 | Name | Description
Attribute | Digital Downconversion Data Bandwidth | The output bandwidth in Hz for down-converted data. Range: 250e6, 200e6, 100e6, 50e6 etc following progression f(n+1) = f(n)/ 2, down to 2GHz/(2^21) = about 1 kHz. Requires Model: M9202A
Attribute | Digital Downconversion Double Data Rate Enabled | False = simple data rate (Samples / second = 1.25*bandwidth), True = double data rate (Samples / second = 2.5*bandwidth) Note: only applies for DataBandwidth values of 1.0e8 and below. Requires Model: M9202A
Attribute | Digital Downconversion Flip Band Enabled | True = First frequency shift is by -500MHz. False = First frequency shift is by +500MHz. Requires Model: M9202A
Attribute | Digital Downconversion Frequency Shift | Decoded to set up the frequency shift blocks of the down converter. The value of this attribute corresponds to the data frequency shift; trigger frequency shift is the nearest value available with the given TriggerBandwidth. I. e. the trigger frequency shift equals FrequencyShift if TriggerBandwidth <= DataBandwidth; otherwise it is rounded to the nearest multiple of TriggerBandwidth*2.5/4. Range: -125e6 to +125e6, step = DataBandwidth *2.5 / 4. Requires Model: M9202A
Attribute | Digital Downconversion Trigger Bandwidth | The output bandwidth in Hz for down-converted trigger. Requires Model: M9202A
Top

See Also

Reference

AgMD1


AgMD1_DigitalDownconversionConfigure Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_DigitalDownconversionConfigure Function
DigitalDownconversion See Also

Configures the DigitalDownconverson DataBandwidth and TriggerBandwidth. Requires Model: M9202A

Function Tree Node: \AgMD1\Instrument Specific\Channel\DigitalDownconversion\Digital Downconversion Configure
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_DigitalDownconversionConfigure(
    ViSession Vi,
    ViConstString Channel,
    ViReal64 DataBandwidth,
    ViReal64 TriggerBandwidth
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Channel

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single channel.For valid values, see the Channel repeated capability.

DataBandwidth

The output bandwidth in Hz for down-converted data.

TriggerBandwidth

The output bandwidth in Hz for down-converted trigger.

Return Value

Success or failure code.

Remarks

For the M9202A, when in digital downconversion acquisition mode, the following applies:

The Read/Fetch functions in Real64 are supported for all sample rates. The Read/Fetch functions in Int16 are supported for all sample rates. (The Int variants correspond to the data format as stored in module memory).

For these functions, the parameter ActualPoints is given in data samples, i.e. twice the number of I-Q data point pairs, or complex samples. The FirstValidPoint parameter, which is primarily intended for dealing with memory alignment, is always given in array elements, like the WaveformArraySize parameter.

Requirements

Supported Models

M9202A

See Also

Reference

DigitalDownconversion
AgMD1


AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH Attribute
DigitalDownconversion See Also

The output bandwidth in Hz for down-converted data. Range: 250e6, 200e6, 100e6, 50e6 etc following progression f(n+1) = f(n)/ 2, down to 2GHz/(2^21) = about 1 kHz. Requires Model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\DigitalDownconversion\Digital Downconversion Data Bandwidth
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH 1150039

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to the Remarks in the DigitalDownconversionConfigure function for detailed information on the usage of Read/Fetch functions and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

DigitalDownconversion
AgMD1


AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DOUBLE_DATA_RATE_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DOUBLE_DATA_RATE_ENABLED Attribute
DigitalDownconversion See Also

False = simple data rate (Samples / second = 1.25*bandwidth), True = double data rate (Samples / second = 2.5*bandwidth) Note: only applies for DataBandwidth values of 1.0e8 and below. Requires Model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\DigitalDownconversion\Digital Downconversion Double Data Rate Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DOUBLE_DATA_RATE_ENABLED 1150042

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DOUBLE_DATA_RATE_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to the Remarks in the DigitalDownconversionConfigure function for detailed information on the usage of Read/Fetch functions and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

DigitalDownconversion
AgMD1


AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED Attribute
DigitalDownconversion See Also

True = First frequency shift is by -500MHz. False = First frequency shift is by +500MHz. Requires Model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\DigitalDownconversion\Digital Downconversion Flip Band Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED 1150043

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to the Remarks in the DigitalDownconversionConfigure function for detailed information on the usage of Read/Fetch functions and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

DigitalDownconversion
AgMD1


AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT Attribute
DigitalDownconversion See Also

Decoded to set up the frequency shift blocks of the down converter. The value of this attribute corresponds to the data frequency shift; trigger frequency shift is the nearest value available with the given TriggerBandwidth. I. e. the trigger frequency shift equals FrequencyShift if TriggerBandwidth <= DataBandwidth; otherwise it is rounded to the nearest multiple of TriggerBandwidth*2.5/4. Range: -125e6 to +125e6, step = DataBandwidth *2.5 / 4. Requires Model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\DigitalDownconversion\Digital Downconversion Frequency Shift
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT 1150041

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to the Remarks in the DigitalDownconversionConfigure function for detailed information on the usage of Read/Fetch functions and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

DigitalDownconversion
AgMD1


AGMD1_ATTR_DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH Attribute
DigitalDownconversion See Also

The output bandwidth in Hz for down-converted trigger. Requires Model: M9202A

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\DigitalDownconversion\Digital Downconversion Trigger Bandwidth
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH 1150040

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

Please refer to the Remarks in the DigitalDownconversionConfigure function for detailed information on the usage of Read/Fetch functions and the data format when in digital downconversion acquisition mode.

Requirements

Supported Models

M9202A

See Also

Reference

DigitalDownconversion
AgMD1


Measurement

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Measurement
See Also

Tree Node: \AgMD1\Instrument Specific\Channel\Measurement

Functions

 | Name | Description
Function | Measurement Fetch Waveform Measurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | Measurement Read Waveform Measurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Top

Attributes

 | Name | Description
Attribute | Measurement Waveform Type | The waveform type used to calculate the various measurement functions by the FetchWaveformMeasurement and ReadWaveformMeasurement methods.
Top

See Also

Reference

AgMD1


AgMD1_MeasurementFetchWaveformMeasurement Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_MeasurementFetchWaveformMeasurement Function
Measurement See Also

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

Function Tree Node: \AgMD1\Instrument Specific\Channel\Measurement\Measurement Fetch Waveform Measurement
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_MeasurementFetchWaveformMeasurement(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 MeasFunction,
    ViReal64* Measurement
);

Parameters

Vi

Channel

The physical or virtual repeated capability identifier.For valid values, see the Channel repeated capability.

MeasFunction

Measurement

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

Defined Values For Parameter MeasFunction

Name | Description
AGMD1_VAL_MEASUREMENT_RISE_TIME | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AGMD1_VAL_MEASUREMENT_FALL_TIME | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AGMD1_VAL_MEASUREMENT_FREQUENCY | The frequency of one complete cycle in the waveform. The units are Hertz.
AGMD1_VAL_MEASUREMENT_PERIOD | The length of time of one complete cycle in the waveform. The units are seconds.
AGMD1_VAL_MEASUREMENT_VOLTAGERMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_PEAK_TO_PEAK | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_MAX | The maximum amplitude found in the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_MIN | The minimum amplitude found in the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_HIGH | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_LOW | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_AVERAGE | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_WIDTH_NEG | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AGMD1_VAL_MEASUREMENT_WIDTH_POS | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AGMD1_VAL_MEASUREMENT_DUTY_CYCLE_NEG | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGMD1_VAL_MEASUREMENT_DUTY_CYCLE_POS | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGMD1_VAL_MEASUREMENT_AMPLITUDE | The Voltage High less the Voltage Low in Volts over the entire waveform.
AGMD1_VAL_MEASUREMENT_VOLTAGE_CYCLERMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_CYCLE_AVERAGE | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_OVER_SHOOT | The relative waveform distortion that follows an edge transition.
AGMD1_VAL_MEASUREMENT_PRESHOOT | The relative waveform distortion that precedes an edge transition.
AGMD1_VAL_MEASUREMENT_DC_OFFSET | The DC offset voltage.
AGMD1_VAL_MEASUREMENT_PHASE_ANGLE | The phase angle between the current channel and the reference channel waveforms.
AGMD1_VAL_MEASUREMENT_PULSE_REPETITION_FREQUENCY | The pules repetition frequency.
Top

See Also

Reference

Measurement
AgMD1


AgMD1_MeasurementReadWaveformMeasurement Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_MeasurementReadWaveformMeasurement Function
Measurement See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

Function Tree Node: \AgMD1\Instrument Specific\Channel\Measurement\Measurement Read Waveform Measurement
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_MeasurementReadWaveformMeasurement(
    ViSession Vi,
    ViConstString Channel,
    ViInt32 MeasFunction,
    ViInt32 MaxTimeMilliseconds,
    ViReal64* Measurement
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Channel

The physical or virtual repeated capability identifier.For valid values, see the Channel repeated capability.

MeasFunction

Characteristic of the acquired waveform to be measured.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviScopeTimeOutEnum are also allowed.

Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Defined Values For Parameter MeasFunction

Name | Description
AGMD1_VAL_MEASUREMENT_RISE_TIME | The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.
AGMD1_VAL_MEASUREMENT_FALL_TIME | The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.
AGMD1_VAL_MEASUREMENT_FREQUENCY | The frequency of one complete cycle in the waveform. The units are Hertz.
AGMD1_VAL_MEASUREMENT_PERIOD | The length of time of one complete cycle in the waveform. The units are seconds.
AGMD1_VAL_MEASUREMENT_VOLTAGERMS | The true Root Mean Square voltage of the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_PEAK_TO_PEAK | The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_MAX | The maximum amplitude found in the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_MIN | The minimum amplitude found in the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_HIGH | The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_LOW | The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_AVERAGE | The arithmetic average in volts measured over the entire waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_WIDTH_NEG | The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.
AGMD1_VAL_MEASUREMENT_WIDTH_POS | The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.
AGMD1_VAL_MEASUREMENT_DUTY_CYCLE_NEG | The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGMD1_VAL_MEASUREMENT_DUTY_CYCLE_POS | The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.
AGMD1_VAL_MEASUREMENT_AMPLITUDE | The Voltage High less the Voltage Low in Volts over the entire waveform.
AGMD1_VAL_MEASUREMENT_VOLTAGE_CYCLERMS | The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_VOLTAGE_CYCLE_AVERAGE | The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.
AGMD1_VAL_MEASUREMENT_OVER_SHOOT | The relative waveform distortion that follows an edge transition.
AGMD1_VAL_MEASUREMENT_PRESHOOT | The relative waveform distortion that precedes an edge transition.
AGMD1_VAL_MEASUREMENT_DC_OFFSET | The DC offset voltage.
AGMD1_VAL_MEASUREMENT_PHASE_ANGLE | The phase angle between the current channel and the reference channel waveforms.
AGMD1_VAL_MEASUREMENT_PULSE_REPETITION_FREQUENCY | The pules repetition frequency.
Top

See Also

Reference

Measurement
AgMD1


AGMD1_ATTR_MEASUREMENT_WAVEFORM_TYPE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_MEASUREMENT_WAVEFORM_TYPE Attribute
Measurement See Also

The waveform type used to calculate the various measurement functions by the FetchWaveformMeasurement and ReadWaveformMeasurement methods.

Attribute Tree Node: \AgMD1\Instrument Specific\Channel\Measurement\Measurement Waveform Type
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_MEASUREMENT_WAVEFORM_TYPE 1150017

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_MEASUREMENT_WAVEFORM_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_MEASUREMENT_WAVEFORM_TYPE_UNKNOWN | This value indicates that the signal is of an unspecified waveform type.
AGMD1_VAL_MEASUREMENT_WAVEFORM_TYPE_SINE | The signal is a sine waveform.
AGMD1_VAL_MEASUREMENT_WAVEFORM_TYPE_SQUARE | The signal is a square waveform.
AGMD1_VAL_MEASUREMENT_WAVEFORM_TYPE_RAMP | The signal is a ramp or triangle waveform.
AGMD1_VAL_MEASUREMENT_WAVEFORM_TYPE_PULSEDDC | The signal is a pulsed DC waveform.
AGMD1_VAL_MEASUREMENT_WAVEFORM_TYPE_STEP | The signal is a pulsed DC waveform.
Top

Requirements

Supported Models

All supported

See Also

Reference

Measurement
AgMD1


ControlIO

[image]

AgMD1 IVI Driver Reference Agilent Technologies
ControlIO
See Also

Tree Node: \AgMD1\Instrument Specific\ControlIO

Attributes

 | Name | Description
Attribute | Control IO Signal A | Signal present on Control IO connector A. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Attribute | Control IO Signal B | Signal present on Control IO connector B. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Attribute | Control IO Signal C | Signal present on Control IO connector C if present. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed
Top

See Also

Reference

AgMD1


AGMD1_ATTR_CONTROL_IO_SIGNAL_A Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CONTROL_IO_SIGNAL_A Attribute
ControlIO See Also

Signal present on Control IO connector A. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.

Attribute Tree Node: \AgMD1\Instrument Specific\ControlIO\Control IO Signal A
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CONTROL_IO_SIGNAL_A 1150018

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_CONTROL_IO_SIGNAL_A.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

DC110, DC122, DC122HF, DC122HZ, DC135, DC135HZ, DC140, DC140HZ, DC152, DC152HZ, DC211, DC211A, DC222, DC222HF, DC222HZ, DC240, DC241, DC241A, DC252, DC252HF, DC252HZ, DC265, DC270, DC271, DC271A, DC271AR, DC282, DC282HZ, DC436, DC438, DC440, DP105, DP106, DP110, DP111, DP1400, DP210, DP211, DP212, DP214, DP235, DP240, DP306, DP308, DP310, M9210A, M9211A, M9703A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

ControlIO
AgMD1


AGMD1_ATTR_CONTROL_IO_SIGNAL_B Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CONTROL_IO_SIGNAL_B Attribute
ControlIO See Also

Signal present on Control IO connector B. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.

Attribute Tree Node: \AgMD1\Instrument Specific\ControlIO\Control IO Signal B
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CONTROL_IO_SIGNAL_B 1150019

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_CONTROL_IO_SIGNAL_B.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

DC110, DC122, DC122HF, DC122HZ, DC135, DC135HZ, DC140, DC140HZ, DC152, DC152HZ, DC211, DC211A, DC222, DC222HF, DC222HZ, DC240, DC241, DC241A, DC252, DC252HF, DC252HZ, DC265, DC270, DC271, DC271A, DC271AR, DC282, DC282HZ, DC436, DC438, DC440, DP105, DP106, DP110, DP111, DP1400, DP210, DP211, DP212, DP214, DP235, DP240, DP306, DP308, DP310, M9210A, M9211A, M9703A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

ControlIO
AgMD1


AGMD1_ATTR_CONTROL_IO_SIGNAL_C Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CONTROL_IO_SIGNAL_C Attribute
ControlIO See Also

Signal present on Control IO connector C if present. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed

Attribute Tree Node: \AgMD1\Instrument Specific\ControlIO\Control IO Signal C
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CONTROL_IO_SIGNAL_C 1150038

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_CONTROL_IO_SIGNAL_C.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

U1084A001, U1084A002, U1084A003

See Also

Reference

ControlIO
AgMD1


InstrumentInfo

[image]

AgMD1 IVI Driver Reference Agilent Technologies
InstrumentInfo
See Also

Tree Node: \AgMD1\Instrument Specific\InstrumentInfo

Attributes

 | Name | Description
Attribute | Fundamental Handle | Returns the Int32 equivalent ViSession handle to the fundamental API used to control the module hardware. Never call the fundamental Acqrs_close or Acqrs_closeAll functions with this handle or the driver will cease to operate. Use the IVI driver's Close method instead.
Attribute | Instrument Info Aq Drv Version | Version of the AqDrv Device Driver. Read only
Attribute | Instrument Info AqIO Version | Version of the Agilent Acqiris IO Driver. Read only
Attribute | Instrument Info Bus Number | PCI Bus number. Read only
Attribute | Instrument Info Cpld Firmware Rev | Revision of the CPLD Firmware. Read only
Attribute | Instrument Info Crate Number | Crate number. Starts at 121000 for autodetected CC121 crates. Read only
Attribute | Instrument Info Device ID | PCI Device ID. Read only
Attribute | Instrument Info Eeprom Common Section Rev | Revision of the EEPROM Common Section. Read only
Attribute | Instrument Info Eeprom Digitizer Section Rev | Revision of the EEPROM Digitizer Section. Read only
Attribute | Instrument Info Has High Res Sample Rate | True if the instrument features a high resolution sampling rate. Read only
Attribute | Instrument Info Nbr External Triggers | Number of external trigger sources. Read only
Attribute | Instrument Info Nbr Internal Triggers | Number of internal trigger sources. Read only
Attribute | Instrument Info Nbr Modules In Instrument | Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1. Read only
Attribute | Instrument Info NbrADC Bits | Number of bits of data per sample from this module's ADCs. Read only
Attribute | Instrument Info Options | List of comma separated options installed in this instrument. Read only
Attribute | Instrument Info Serial Number | Deprecated - Do not use. Use SerialNumberString. The serial number of the instrument. Read only
Attribute | Instrument Info Slot Number | The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates). Read only
Attribute | Serial Number String | The serial number string of the instrument. Read only
Top

See Also

Reference

AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_FUNDAMENTAL_HANDLE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_FUNDAMENTAL_HANDLE Attribute
InstrumentInfo See Also

Returns the Int32 equivalent ViSession handle to the fundamental API used to control the module hardware. Never call the fundamental Acqrs_close or Acqrs_closeAll functions with this handle or the driver will cease to operate. Use the IVI driver's Close method instead.

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Fundamental Handle
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_FUNDAMENTAL_HANDLE 1150052

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_FUNDAMENTAL_HANDLE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_AQ_DRV_VERSION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_AQ_DRV_VERSION Attribute
InstrumentInfo See Also

Version of the AqDrv Device Driver. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Aq Drv Version
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_AQ_DRV_VERSION 1150021

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_AQ_DRV_VERSION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_AQIO_VERSION Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_AQIO_VERSION Attribute
InstrumentInfo See Also

Version of the Agilent Acqiris IO Driver. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info AqIO Version
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_AQIO_VERSION 1150022

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_AQIO_VERSION.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_BUS_NUMBER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_BUS_NUMBER Attribute
InstrumentInfo See Also

PCI Bus number. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Bus Number
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_BUS_NUMBER 1150023

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_BUS_NUMBER.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_CPLD_FIRMWARE_REV Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_CPLD_FIRMWARE_REV Attribute
InstrumentInfo See Also

Revision of the CPLD Firmware. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Cpld Firmware Rev
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_CPLD_FIRMWARE_REV 1150024

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_CPLD_FIRMWARE_REV.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_CRATE_NUMBER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_CRATE_NUMBER Attribute
InstrumentInfo See Also

Crate number. Starts at 121000 for autodetected CC121 crates. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Crate Number
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_CRATE_NUMBER 1150025

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_CRATE_NUMBER.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_DEVICE_ID Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_DEVICE_ID Attribute
InstrumentInfo See Also

PCI Device ID. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Device ID
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_DEVICE_ID 1150026

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_DEVICE_ID.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV Attribute
InstrumentInfo See Also

Revision of the EEPROM Common Section. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Eeprom Common Section Rev
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV 1150027

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV Attribute
InstrumentInfo See Also

Revision of the EEPROM Digitizer Section. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Eeprom Digitizer Section Rev
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV 1150028

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE Attribute
InstrumentInfo See Also

True if the instrument features a high resolution sampling rate. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Has High Res Sample Rate
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE 1150029

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS Attribute
InstrumentInfo See Also

Number of external trigger sources. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Nbr External Triggers
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS 1150031

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS Attribute
InstrumentInfo See Also

Number of internal trigger sources. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Nbr Internal Triggers
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS 1150032

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT Attribute
InstrumentInfo See Also

Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Nbr Modules In Instrument
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT 1150033

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_NBRADC_BITS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_NBRADC_BITS Attribute
InstrumentInfo See Also

Number of bits of data per sample from this module's ADCs. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info NbrADC Bits
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_NBRADC_BITS 1150030

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_NBRADC_BITS.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_OPTIONS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_OPTIONS Attribute
InstrumentInfo See Also

List of comma separated options installed in this instrument. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Options
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_OPTIONS 1150034

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_OPTIONS.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER Attribute
InstrumentInfo See Also

Deprecated - Do not use. Use SerialNumberString. The serial number of the instrument. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Serial Number
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER 1150035

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_SLOT_NUMBER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_SLOT_NUMBER Attribute
InstrumentInfo See Also

The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates). Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Instrument Info Slot Number
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_SLOT_NUMBER 1150036

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_SLOT_NUMBER.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER_STRING Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER_STRING Attribute
InstrumentInfo See Also

The serial number string of the instrument. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\InstrumentInfo\Serial Number String
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER_STRING 1150051

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER_STRING.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

Requirements

Supported Models

All supported

See Also

Reference

InstrumentInfo
AgMD1


LogicDevice

[image]

AgMD1 IVI Driver Reference Agilent Technologies
LogicDevice
See Also

Tree Node: \AgMD1\Instrument Specific\LogicDevice

Functions

 | Name | Description
Function | Get Logic Device Name | Returns the logicdevice name that corresponds to the one-based index that the user specifies.
Function | Load Logic Device From File | Loads the bit file at the file system path Path into the FPGA(s) identified by the LogicDevice repeated capability.
Function | Read Indirect Int32 | Reads up to NumElements 32 bit integers of the Indirect Buffer with identifier Id from the FPGA identified by LogicDevice repeated capagility into the memory referenced by Data.
Function | Read Register Int32 | Reads a 32 bits integer value from the register at Offset in the FPGA identified by LogicDevice repeated capability.
Function | Write Indirect Int32 | Writes the contents of Data to the Indirect Buffer with identifier Id of the FPGA identified by LogicDevice repeated capability.
Function | Write Register Int32 | Writes the 32 bits integer value Value to the register at Offset in the FPGA identified by LogicDevice repeated capability.
Top

Attributes

 | Name | Description
Attribute | Logic Device Count | Returns the number of logic devices.
Top

See Also

Reference

AgMD1


AgMD1_GetLogicDeviceName Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetLogicDeviceName Function
LogicDevice See Also

Returns the logicdevice name that corresponds to the one-based index that the user specifies.

Function Tree Node: \AgMD1\Instrument Specific\LogicDevice\Get Logic Device Name
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetLogicDeviceName(
    ViSession Vi,
    ViInt32 Index,
    ViInt32 NameBufferSize,
    ViChar[] Name
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Index

A one-based index that defines which name to return.

NameBufferSize

Number of elements in Name.

Name

Specifies the buffer into which the function returns the name that corresponds to the index the user specifies. The caller may pass VI_NULL for this parameter if the buffer size parameter is 0.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

LogicDevice
AgMD1


AgMD1_LoadLogicDeviceFromFile Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_LoadLogicDeviceFromFile Function
LogicDevice See Also

Loads the bit file at the file system path Path into the FPGA(s) identified by the LogicDevice repeated capability.

Function Tree Node: \AgMD1\Instrument Specific\LogicDevice\Load Logic Device From File
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_LoadLogicDeviceFromFile(
    ViSession Vi,
    ViConstString LogicDevice,
    ViConstString Path
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single logicdevice.For valid values, see the LogicDevice repeated capability.

Path

The file system path where the file to load is.

Return Value

Success or failure code.

Requirements

Supported Models

M9703A

See Also

Reference

LogicDevice
AgMD1


AGMD1_ATTR_LOGIC_DEVICE_COUNT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_LOGIC_DEVICE_COUNT Attribute
LogicDevice See Also

Returns the number of logic devices.

Attribute Tree Node: \AgMD1\Instrument Specific\LogicDevice\Logic Device Count
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_LOGIC_DEVICE_COUNT 1150063

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_LOGIC_DEVICE_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

See Also

Reference

LogicDevice
AgMD1


AgMD1_ReadIndirectInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ReadIndirectInt32 Function
LogicDevice See Also

Reads up to NumElements 32 bit integers of the Indirect Buffer with identifier Id from the FPGA identified by LogicDevice repeated capagility into the memory referenced by Data.

Function Tree Node: \AgMD1\Instrument Specific\LogicDevice\Read Indirect Int32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ReadIndirectInt32(
    ViSession Vi,
    ViConstString LogicDevice,
    ViInt32 Id,
    ViInt32 StartAddress,
    ViInt32 NumElements,
    ViInt32 DataBufferSize,
    ViInt32[] Data,
    ViInt32* DataActualSize
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single logicdevice.For valid values, see the LogicDevice repeated capability.

Id

The firmware indirect buffer id.

StartAddress

The start address in the FPGA where the data will be read.

NumElements

Number of elements to read.

DataBufferSize

Data

Will contain the data read from the buffer.

DataActualSize

Actual number of elements in Data.

Return Value

Success or failure code.

Requirements

Supported Models

M9703A

See Also

Reference

LogicDevice
AgMD1


AgMD1_ReadRegisterInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ReadRegisterInt32 Function
LogicDevice See Also

Reads a 32 bits integer value from the register at Offset in the FPGA identified by LogicDevice repeated capability.

Function Tree Node: \AgMD1\Instrument Specific\LogicDevice\Read Register Int32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ReadRegisterInt32(
    ViSession Vi,
    ViConstString LogicDevice,
    ViInt32 Offset,
    ViInt32* Value
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single logicdevice.For valid values, see the LogicDevice repeated capability.

Offset

Address in the FPGA where the register will be read.

Value

Will contain the value read from the register.

Return Value

Success or failure code.

Requirements

Supported Models

M9703A

See Also

Reference

LogicDevice
AgMD1


AgMD1_WriteIndirectInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_WriteIndirectInt32 Function
LogicDevice See Also

Writes the contents of Data to the Indirect Buffer with identifier Id of the FPGA identified by LogicDevice repeated capability.

Function Tree Node: \AgMD1\Instrument Specific\LogicDevice\Write Indirect Int32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_WriteIndirectInt32(
    ViSession Vi,
    ViConstString LogicDevice,
    ViInt32 Id,
    ViInt32 StartAddress,
    ViInt32 NumElements,
    ViInt32 DataBufferSize,
    ViInt32[] Data
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single logicdevice.For valid values, see the LogicDevice repeated capability.

Id

The firmware indirect buffer id.

StartAddress

The start address in the FPGA where the data will be written.

NumElements

Number of elements to write.

DataBufferSize

Data

Buffer containing data to write into the firmware indirect buffer.

Return Value

Success or failure code.

Requirements

Supported Models

M9703A

See Also

Reference

LogicDevice
AgMD1


AgMD1_WriteRegisterInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_WriteRegisterInt32 Function
LogicDevice See Also

Writes the 32 bits integer value Value to the register at Offset in the FPGA identified by LogicDevice repeated capability.

Function Tree Node: \AgMD1\Instrument Specific\LogicDevice\Write Register Int32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_WriteRegisterInt32(
    ViSession Vi,
    ViConstString LogicDevice,
    ViInt32 Offset,
    ViInt32 Value
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

LogicDevice

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single logicdevice.For valid values, see the LogicDevice repeated capability.

Offset

Address in the FPGA where the register will be written.

Value

Value to write into the register.

Return Value

Success or failure code.

Requirements

Supported Models

M9703A

See Also

Reference

LogicDevice
AgMD1


ReferenceLevel

[image]

AgMD1 IVI Driver Reference Agilent Technologies
ReferenceLevel
See Also

Tree Node: \AgMD1\Instrument Specific\ReferenceLevel

Functions

 | Name | Description
Function | Reference Level Configure | Configures the reference levels for waveform measurements, low, mid, and high.
Top

Attributes

 | Name | Description
Attribute | Reference Level High | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | Reference Level Low | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | Reference Level Mid | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Top

See Also

Reference

AgMD1


AgMD1_ReferenceLevelConfigure Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ReferenceLevelConfigure Function
ReferenceLevel See Also

Configures the reference levels for waveform measurements, low, mid, and high.

Function Tree Node: \AgMD1\Instrument Specific\ReferenceLevel\Reference Level Configure
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ReferenceLevelConfigure(
    ViSession Vi,
    ViReal64 Low,
    ViReal64 Mid,
    ViReal64 High
);

Parameters

Vi

Low

Mid

High

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

ReferenceLevel
AgMD1


AGMD1_ATTR_REFERENCE_LEVEL_HIGH Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_REFERENCE_LEVEL_HIGH Attribute
ReferenceLevel See Also

The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Attribute Tree Node: \AgMD1\Instrument Specific\ReferenceLevel\Reference Level High
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_REFERENCE_LEVEL_HIGH 1150006

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_REFERENCE_LEVEL_HIGH.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

ReferenceLevel
AgMD1


AGMD1_ATTR_REFERENCE_LEVEL_LOW Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_REFERENCE_LEVEL_LOW Attribute
ReferenceLevel See Also

The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Attribute Tree Node: \AgMD1\Instrument Specific\ReferenceLevel\Reference Level Low
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_REFERENCE_LEVEL_LOW 1150007

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_REFERENCE_LEVEL_LOW.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

ReferenceLevel
AgMD1


AGMD1_ATTR_REFERENCE_LEVEL_MID Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_REFERENCE_LEVEL_MID Attribute
ReferenceLevel See Also

The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

Attribute Tree Node: \AgMD1\Instrument Specific\ReferenceLevel\Reference Level Mid
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_REFERENCE_LEVEL_MID 1150008

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_REFERENCE_LEVEL_MID.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

ReferenceLevel
AgMD1


System

[image]

AgMD1 IVI Driver Reference Agilent Technologies
System
See Also

Tree Node: \AgMD1\Instrument Specific\System

Functions

 | Name | Description
Function | System Power Off All | Forces all instruments to prepare and enter the system power down state. Suspend all other calling threads. If a thread is performing a long operation which cannot be completed within milliseconds (e.g. a self-calibration), it will be interrupted immediately and will return the status 'ACQIRIS_ERROR_OPERATION_INTERRUPTED'. Note that if an acquisition is still running when the PowerOffAll method is invoked, it might be incomplete or corrupted.
Function | System Power On All | Forces all instruments power up and return from the system power down state. Re-enable the instruments at the same state as they were before the PowerOffAll method was invoked. Threads which were suspended will be resumed. However, interrupted operations which returned an error 'ACQIRIS_ERROR_OPERATION_INTERRUPTED' will have to be redone.
Function | System Resume Control | Resume the control of an instrument that was suspended (see SuspendControl).
Function | System Suspend Control | Suspend control of an instrument to allow using it from another process. NOTE: This is only available for Windows operating systems.
Top

Attributes

 | Name | Description
Attribute | System Nbr Instruments | The number of instruments supporting the AgMD1 driver in the system. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Read only
Attribute | System Trace Enabled | If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_SYSTEM_NBR_INSTRUMENTS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SYSTEM_NBR_INSTRUMENTS Attribute
System See Also

The number of instruments supporting the AgMD1 driver in the system. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Read only

Attribute Tree Node: \AgMD1\Instrument Specific\System\System Nbr Instruments
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SYSTEM_NBR_INSTRUMENTS 1150037

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SYSTEM_NBR_INSTRUMENTS.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

System
AgMD1


AgMD1_SystemPowerOffAll Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SystemPowerOffAll Function
System See Also

Forces all instruments to prepare and enter the system power down state. Suspend all other calling threads. If a thread is performing a long operation which cannot be completed within milliseconds (e.g. a self-calibration), it will be interrupted immediately and will return the status 'ACQIRIS_ERROR_OPERATION_INTERRUPTED'. Note that if an acquisition is still running when the PowerOffAll method is invoked, it might be incomplete or corrupted.

Function Tree Node: \AgMD1\Instrument Specific\System\System Power Off All
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SystemPowerOffAll(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgMD1


AgMD1_SystemPowerOnAll Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SystemPowerOnAll Function
System See Also

Forces all instruments power up and return from the system power down state. Re-enable the instruments at the same state as they were before the PowerOffAll method was invoked. Threads which were suspended will be resumed. However, interrupted operations which returned an error 'ACQIRIS_ERROR_OPERATION_INTERRUPTED' will have to be redone.

Function Tree Node: \AgMD1\Instrument Specific\System\System Power On All
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SystemPowerOnAll(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

System
AgMD1


AgMD1_SystemResumeControl Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SystemResumeControl Function
System See Also

Resume the control of an instrument that was suspended (see SuspendControl).

Function Tree Node: \AgMD1\Instrument Specific\System\System Resume Control
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SystemResumeControl(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

This function reacquires the driver lock of the instrument and allows calls to it from the current process. The error code ACQIRIS_ERROR_DEVICE_ALREADY_OPEN is returned when calling an instrument already locked by another process. After successfully calling ResumeControl, the module will be set to a default hardware state. It will have no valid data and the timestamp will be set to 0. When the next acquisition is started, the module will be configured with all of the unmodified settings from before the SuspendControl was invoked.

Requirements

Supported Models

All supported

See Also

Reference

System
AgMD1


AgMD1_SystemSuspendControl Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SystemSuspendControl Function
System See Also

Suspend control of an instrument to allow using it from another process. NOTE: This is only available for Windows operating systems.

Function Tree Node: \AgMD1\Instrument Specific\System\System Suspend Control
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SystemSuspendControl(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Remarks

This function releases the driver lock of the instrument and prevents all further calls from the current process. The error code ACQIRIS_ERROR_INVALID_HANDLE is returned when calling functions on a suspended instrument. Use ResumeControl to reacquire the control of the instrument. Once suspended, this instrument can be used from another process. However, if this is the first time this other process is used, all desired acquisition settings must be defined and a calibration will be needed.

Requirements

Supported Models

All supported

See Also

Reference

System
AgMD1


AGMD1_ATTR_SYSTEM_TRACE_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SYSTEM_TRACE_ENABLED Attribute
System See Also

If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.

Attribute Tree Node: \AgMD1\Instrument Specific\System\System Trace Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SYSTEM_TRACE_ENABLED 1150010

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SYSTEM_TRACE_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

You may also enable tracing, specify a file name and path, and additional trace options when initializing the driver. For complete information on Initialize tracing options see the 'Driver Setup' section on the Initializing the IVI-C Driver page.

Requirements

Supported Models

All supported

See Also

Reference

System
AgMD1


Temperature

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Temperature
See Also

Tree Node: \AgMD1\Instrument Specific\Temperature

Functions

 | Name | Description
Function | Temperature Get Module Temperature | Temperature of the specified module. The units are governed by the Temperature.Units property.
Top

See Also

Reference

AgMD1


AgMD1_TemperatureGetModuleTemperature Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_TemperatureGetModuleTemperature Function
Temperature See Also

Temperature of the specified module. The units are governed by the Temperature.Units property.

Function Tree Node: \AgMD1\Instrument Specific\Temperature\Temperature Get Module Temperature
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_TemperatureGetModuleTemperature(
    ViSession Vi,
    ViInt32 ModuleNumber,
    ViInt32* Val
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ModuleNumber

The module number in a Multi-Instrument (ASBus), runs from 0 to (nbr of modules - 1).

Val

The module temperature.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Temperature
AgMD1


Trigger

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Trigger
See Also

Tree Node: \AgMD1\Instrument Specific\Trigger

Branches

Name
Output
TriggerSource
Top

Attributes

 | Name | Description
Attribute | Pxi Trig Out Enabled | If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input.
Attribute | Pxi Trig Slope | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR".
Top

See Also

Reference

AgMD1


Output

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Output
See Also

Tree Node: \AgMD1\Instrument Specific\Trigger\Output

Attributes

 | Name | Description
Attribute | Multi Module Sync Enabled | M9202A Multi Module Synchronization. Enable a M9202A to be the trigger master to synchronize multiple other M9202A modules (the trigger slaves modules). For all modules to synchronize, only one module can be the trigger master module while all others must be trigger slave modules.
Attribute | Source | Select the trigger source to drive the TRG OUT output connector on the front panel. Possible values are Channel1, ..., Channel<n> or External1, ..., External<n> trigger sources where <n> is the number of available channels or external trigger inputs. For M9703A, possible values are TriggerCompare, TriggerAccepted, AXIe_TRIG0, AXIe_TRIG1, ..., AXIe_TRIG11, AXIe_STRIG, HighLevel, LowLevel.
Attribute | Trigger Output Offset | Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).
Attribute | Trigger Output Resync Enabled | Controls whether the trigger out signal is resynchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false).
Top

See Also

Reference

AgMD1


AGMD1_ATTR_TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED Attribute
Output See Also

M9202A Multi Module Synchronization. Enable a M9202A to be the trigger master to synchronize multiple other M9202A modules (the trigger slaves modules). For all modules to synchronize, only one module can be the trigger master module while all others must be trigger slave modules.

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\Output\Multi Module Sync Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED 1150056

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Remarks

The trigger master module will drive the front panel TRG OUT output connector with a trigger signal that must be connected to the external trigger input:

  • TRG1 of the slave modules and TRG1 of the master module, when the trigger Type of the master modules is set to Magnitude trigger. In this case, all modules will show an identical trigger delay and will be tightly synchronized.
  • TRG1 of the slaves modules only, when the master module is configured in External trigger, i.e. ActiveSource = "External1" or "External2" (TRG1 or TRG2). In this case, the master module will show a trigger delay of -25 ns compared to the slave modules. The trigger delay difference can be compensated using the trigger delay controls.

Requirements

Supported Models

M9202A

See Also

Reference

Output
AgMD1


AGMD1_ATTR_TRIGGER_OUTPUT_SOURCE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_OUTPUT_SOURCE Attribute
Output See Also

Select the trigger source to drive the TRG OUT output connector on the front panel. Possible values are Channel1, ..., Channel<n> or External1, ..., External<n> trigger sources where <n> is the number of available channels or external trigger inputs. For M9703A, possible values are TriggerCompare, TriggerAccepted, AXIe_TRIG0, AXIe_TRIG1, ..., AXIe_TRIG11, AXIe_STRIG, HighLevel, LowLevel.

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\Output\Source
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_OUTPUT_SOURCE 1150057

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_OUTPUT_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Output
AgMD1


AGMD1_ATTR_TRIGGER_OUTPUT_OFFSET Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_OUTPUT_OFFSET Attribute
Output See Also

Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\Output\Trigger Output Offset
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_OUTPUT_OFFSET 1150015

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_OUTPUT_OFFSET.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Output
AgMD1


AGMD1_ATTR_TRIGGER_OUTPUT_RESYNC_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_OUTPUT_RESYNC_ENABLED Attribute
Output See Also

Controls whether the trigger out signal is resynchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false).

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\Output\Trigger Output Resync Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_OUTPUT_RESYNC_ENABLED 1150016

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_OUTPUT_RESYNC_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Output
AgMD1


AGMD1_ATTR_PXI_TRIG_OUT_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_PXI_TRIG_OUT_ENABLED Attribute
Trigger See Also

If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input.

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\Pxi Trig Out Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_PXI_TRIG_OUT_ENABLED 1150048

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_PXI_TRIG_OUT_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_PXI_TRIG_SLOPE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_PXI_TRIG_SLOPE Attribute
Trigger See Also

Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR".

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\Pxi Trig Slope
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_PXI_TRIG_SLOPE 1150050

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_PXI_TRIG_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


TriggerSource

[image]

AgMD1 IVI Driver Reference Agilent Technologies
TriggerSource
See Also

Tree Node: \AgMD1\Instrument Specific\Trigger\TriggerSource

Branches

Name
Magnitude
Top

Attributes

 | Name | Description
Attribute | Ext Trig Range | The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_EXT_TRIG_RANGE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_EXT_TRIG_RANGE Attribute
TriggerSource See Also

The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts.

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\TriggerSource\Ext Trig Range
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_EXT_TRIG_RANGE 1150049

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_EXT_TRIG_RANGE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

TriggerSource
AgMD1


Magnitude

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Magnitude
See Also

Tree Node: \AgMD1\Instrument Specific\Trigger\TriggerSource\Magnitude

Functions

 | Name | Description
Function | Trigger Magnitude Configure | This function sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Top

Attributes

 | Name | Description
Attribute | Dwell Time | Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
Attribute | Slope | Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES Attribute
Magnitude See Also

Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\TriggerSource\Magnitude\Dwell Time
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES 1150058

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

M9703A

See Also

Reference

Magnitude
AgMD1


AGMD1_ATTR_TRIGGER_MAGNITUDE_SLOPE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_MAGNITUDE_SLOPE Attribute
Magnitude See Also

Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.

Attribute Tree Node: \AgMD1\Instrument Specific\Trigger\TriggerSource\Magnitude\Slope
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_MAGNITUDE_SLOPE 1150055

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_MAGNITUDE_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
Top

Requirements

Supported Models

M9202A, M9703A

See Also

Reference

Magnitude
AgMD1


AgMD1_TriggerMagnitudeConfigure Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_TriggerMagnitudeConfigure Function
Magnitude See Also

This function sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.

Function Tree Node: \AgMD1\Instrument Specific\Trigger\TriggerSource\Magnitude\Trigger Magnitude Configure
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_TriggerMagnitudeConfigure(
    ViSession Vi,
    ViConstString TriggerSource,
    ViReal64 Level,
    ViReal64 Hysteresis,
    ViInt32 Slope
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

TriggerSource

The physical or virtual repeated capability identifier. Pass VI_NULL if the operation does not apply to a repeated capability. You can also pass VI_NULL if the device only has a single triggersource.For valid values, see the TriggerSource repeated capability.

Level

Specifies the trigger level in Volts.

Hysteresis

Specifies the trigger hysteresis in Volts.

Slope

Specifies whether a rising (Positive) or a falling (Negative) edge triggers the digitizer.

Return Value

Success or failure code.

Remarks

Re-triggering is prevented until the magnitude of the signal has met the following criteria:
If magnitude < Threshold - Hysteresis (when positive trigger slope is selected)
If magnitude > Threshold + Hysteresis (when negative trigger slope is selected)

Requirements

Supported Models

M9202A, M9703A

Defined Values For Parameter Slope

Name | Description
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
Top

See Also

Reference

Magnitude
AgMD1


Reference Oscillator

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Reference Oscillator
See Also

Tree Node: \AgMD1\Reference Oscillator

Attributes

 | Name | Description
Attribute | Reference Oscillator External Frequency | Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
Attribute | Reference Oscillator Output Enabled | Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.
Attribute | Reference Oscillator Source | Specifies the reference frequency source used.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY Attribute
Reference Oscillator See Also

Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.

Attribute Tree Node: \AgMD1\Reference Oscillator\Reference Oscillator External Frequency
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY 1250600

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Reference Oscillator
AgMD1


AGMD1_ATTR_REFERENCE_OSCILLATOR_OUTPUT_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_REFERENCE_OSCILLATOR_OUTPUT_ENABLED Attribute
Reference Oscillator See Also

Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.

Attribute Tree Node: \AgMD1\Reference Oscillator\Reference Oscillator Output Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_REFERENCE_OSCILLATOR_OUTPUT_ENABLED 1250601

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_REFERENCE_OSCILLATOR_OUTPUT_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Reference Oscillator
AgMD1


AGMD1_ATTR_REFERENCE_OSCILLATOR_SOURCE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_REFERENCE_OSCILLATOR_SOURCE Attribute
Reference Oscillator See Also

Specifies the reference frequency source used.

Attribute Tree Node: \AgMD1\Reference Oscillator\Reference Oscillator Source
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_REFERENCE_OSCILLATOR_SOURCE 1250602

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_REFERENCE_OSCILLATOR_SOURCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_REFERENCE_OSCILLATOR_SOURCE_INTERNAL | The internal reference oscillator is used.
AGMD1_VAL_REFERENCE_OSCILLATOR_SOURCE_EXTERNAL | An external reference oscillator is used.
AGMD1_VAL_REFERENCE_OSCILLATOR_SOURCE_AXIE_CLK100 | AXIeClk100 reference oscillator is used.
AGMD1_VAL_REFERENCE_OSCILLATOR_SOURCE_PXI_CLK10 | PXIClk10 reference oscillator is used. Not supported yet.
AGMD1_VAL_REFERENCE_OSCILLATOR_SOURCE_PXIE_CLK100 | PXIeClk100 reference oscillator is used. Not supported yet.
Top

Requirements

Supported Models

All supported

See Also

Reference

Reference Oscillator
AgMD1


Sample Clock

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Sample Clock
See Also

Tree Node: \AgMD1\Sample Clock

Attributes

 | Name | Description
Attribute | Sample Clock External Divider | Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
Attribute | Sample Clock External Frequency | Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
Attribute | Sample Clock Source | Specifies the clock used to pace acquisition sampling.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_DIVIDER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_DIVIDER Attribute
Sample Clock See Also

Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.

Attribute Tree Node: \AgMD1\Sample Clock\Sample Clock External Divider
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_DIVIDER 1250700

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_DIVIDER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Sample Clock
AgMD1


AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_FREQUENCY Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_FREQUENCY Attribute
Sample Clock See Also

Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.

Attribute Tree Node: \AgMD1\Sample Clock\Sample Clock External Frequency
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_FREQUENCY 1250701

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_FREQUENCY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Sample Clock
AgMD1


AGMD1_ATTR_SAMPLE_CLOCK_SOURCE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SAMPLE_CLOCK_SOURCE Attribute
Sample Clock See Also

Specifies the clock used to pace acquisition sampling.

Attribute Tree Node: \AgMD1\Sample Clock\Sample Clock Source
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SAMPLE_CLOCK_SOURCE 1250703

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SAMPLE_CLOCK_SOURCE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_SAMPLE_CLOCK_SOURCE_INTERNAL | The internal sample clock is used.
AGMD1_VAL_SAMPLE_CLOCK_SOURCE_EXTERNAL | An external sample clock is used.
Top

Requirements

Supported Models

All supported

See Also

Reference

Sample Clock
AgMD1


Trigger

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Trigger
See Also

Tree Node: \AgMD1\Trigger

Branches

Name
Edge Triggering
Glitch Triggering
Multi Trigger
Runt Triggering
TV Triggering
Width Triggering
Window Triggering
Top

Attributes

 | Name | Description
Attribute | Active Trigger Source | Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".
Attribute | Trigger Coupling | Specifies how the digitizer couples the trigger source.
Attribute | Trigger Delay | Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
Attribute | Trigger Hysteresis | Specifies the trigger hysteresis in Volts.
Attribute | Trigger Level | Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
Attribute | Trigger Modifier | Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.
Attribute | Trigger Output Enabled | Specifies whether or not an accepted trigger appears at an output of the digitizer.
Attribute | Trigger Source Count | The number of trigger sources.
Attribute | Trigger Type | The kind of event that triggers the digitizer. TV triggering requires External trigger source.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_ACTIVE_TRIGGER_SOURCE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_ACTIVE_TRIGGER_SOURCE Attribute
Trigger See Also

Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".

Attribute Tree Node: \AgMD1\Trigger\Active Trigger Source
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_ACTIVE_TRIGGER_SOURCE 1250001

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_ACTIVE_TRIGGER_SOURCE.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


Edge Triggering

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Edge Triggering
See Also

Tree Node: \AgMD1\Trigger\Edge Triggering

Attributes

 | Name | Description
Attribute | Trigger Slope | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_TRIGGER_SLOPE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_SLOPE Attribute
Edge Triggering See Also

Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.

Attribute Tree Node: \AgMD1\Trigger\Edge Triggering\Trigger Slope
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_SLOPE 1250021

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_SLOPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_NEGATIVE | A negative (falling) edge passing through the trigger level triggers the digitizer.
AGMD1_VAL_TRIGGER_SLOPE_POSITIVE | A positive (rising) edge passing through the trigger level triggers the digitizer.
Top

Requirements

Supported Models

All supported

See Also

Reference

Edge Triggering
AgMD1


Multi Trigger

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Multi Trigger
See Also

Tree Node: \AgMD1\Trigger\Multi Trigger

Attributes

 | Name | Description
Attribute | Trigger Source List | A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.
Attribute | Trigger Source Operator | Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute. See the definition of that attribute for details.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_TRIGGER_SOURCE_LIST Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_SOURCE_LIST Attribute
Multi Trigger See Also

A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.

Attribute Tree Node: \AgMD1\Trigger\Multi Trigger\Trigger Source List
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_SOURCE_LIST 1251800

ViStatus AgMD1_GetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValueBufferSize,
    ViChar[] AttributeValue
);

ViStatus AgMD1_SetAttributeViString(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViConstString AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_SOURCE_LIST.

AttributeValueBufferSize

The number of bytes in the ViChar array that the user specifies for the AttributeValue parameter.

AttributeValue (GetAttribute)

The buffer in which the function returns the current value of the attribute. Can be VI_NULL if AttributeValueBufferSize is 0.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Multi Trigger
AgMD1


AGMD1_ATTR_TRIGGER_SOURCE_OPERATOR Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_SOURCE_OPERATOR Attribute
Multi Trigger See Also

Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute. See the definition of that attribute for details.

Attribute Tree Node: \AgMD1\Trigger\Multi Trigger\Trigger Source Operator
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_SOURCE_OPERATOR 1251801

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_SOURCE_OPERATOR.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_AND | Trigger sources are AND'd together. The digitizer triggers when all configured trigger source conditions are satisfied.
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_OR | Trigger sources are OR'd together. The digitizer triggers when the first configured trigger source condition is satisfied.
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_NONE | No operator is applied to the configured list of trigger sources. The trigger source list is ignored, and the digitizer triggers when the currently configured trigger source, given by the Trigger Source attribute, and its associated trigger conditions are satisfied.
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_NAND |
AGMD1_VAL_TRIGGER_SOURCE_OPERATOR_NOR |
Top

Requirements

Supported Models

All supported

See Also

Reference

Multi Trigger
AgMD1


AGMD1_ATTR_TRIGGER_COUPLING Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_COUPLING Attribute
Trigger See Also

Specifies how the digitizer couples the trigger source.

Attribute Tree Node: \AgMD1\Trigger\Trigger Coupling
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_COUPLING 1250016

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_COUPLING.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_TRIGGER_COUPLING_AC | The digitizer AC couples the trigger signal.
AGMD1_VAL_TRIGGER_COUPLING_DC | The digitizer DC couples the trigger signal.
AGMD1_VAL_TRIGGER_COUPLING_HF_REJECT | The digitizer filters out the high frequencies from the arm signal.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_TRIGGER_DELAY Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_DELAY Attribute
Trigger See Also

Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.

Attribute Tree Node: \AgMD1\Trigger\Trigger Delay
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_DELAY 1250017

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_DELAY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_TRIGGER_HYSTERESIS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_HYSTERESIS Attribute
Trigger See Also

Specifies the trigger hysteresis in Volts.

Attribute Tree Node: \AgMD1\Trigger\Trigger Hysteresis
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_HYSTERESIS 1250018

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_HYSTERESIS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_TRIGGER_LEVEL Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_LEVEL Attribute
Trigger See Also

Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.

Attribute Tree Node: \AgMD1\Trigger\Trigger Level
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_LEVEL 1250019

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_LEVEL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_TRIGGER_MODIFIER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_MODIFIER Attribute
Trigger See Also

Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.

Attribute Tree Node: \AgMD1\Trigger\Trigger Modifier
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_MODIFIER 1251700

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_MODIFIER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_TRIGGER_MODIFIER_NONE | The digitizer waits until the trigger the end-user specifies occurs.
AGMD1_VAL_TRIGGER_MODIFIER_AUTO | The digitizer automatically triggers if the configured trigger does not occur within the digitizer timeout period.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_TRIGGER_OUTPUT_ENABLED Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_OUTPUT_ENABLED Attribute
Trigger See Also

Specifies whether or not an accepted trigger appears at an output of the digitizer.

Attribute Tree Node: \AgMD1\Trigger\Trigger Output Enabled
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_OUTPUT_ENABLED 1250020

ViStatus AgMD1_GetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean* AttributeValue
);

ViStatus AgMD1_SetAttributeViBoolean(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViBoolean AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_OUTPUT_ENABLED.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_TRIGGER_SOURCE_COUNT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_SOURCE_COUNT Attribute
Trigger See Also

The number of trigger sources.

Attribute Tree Node: \AgMD1\Trigger\Trigger Source Count
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_SOURCE_COUNT 1250022

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_SOURCE_COUNT.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


AGMD1_ATTR_TRIGGER_TYPE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TRIGGER_TYPE Attribute
Trigger See Also

The kind of event that triggers the digitizer. TV triggering requires External trigger source.

Attribute Tree Node: \AgMD1\Trigger\Trigger Type
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TRIGGER_TYPE 1250023

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TRIGGER_TYPE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_EDGE_TRIGGER | Configures the digitizer for edge triggering. An edge trigger occurs when the trigger signal specified with the Trigger Source attribute passes the voltage threshold specified with the Trigger Level attribute and has the slope specified with the Trigger Slope attribute.
AGMD1_VAL_TV_TRIGGER | Configures the digitizer for triggering on TV signals. Use the IviDigitizerTVTrigger extension properties and methods to configure the trigger.
AGMD1_VAL_IMMEDIATE_TRIGGER | Immediately triggers the measurement.
AGMD1_VAL_MAGNITUDE_TRIGGER | The trigger type must be set to this value before calling the AgMD1_TriggerMagnitudeConfigure function.
Top

Requirements

Supported Models

All supported

See Also

Reference

Trigger
AgMD1


TV Triggering

[image]

AgMD1 IVI Driver Reference Agilent Technologies
TV Triggering
See Also

Tree Node: \AgMD1\Trigger\TV Triggering

Attributes

 | Name | Description
Attribute | TV Trigger Event | Specifies the event on which the digitizer triggers.
Attribute | TV Trigger Line Number | Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).
Attribute | TV Trigger Polarity | Specifies the polarity of the TV signal.
Attribute | TV Trigger Signal Format | Specifies the format of TV signal on which the digitizer triggers.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_TV_TRIGGER_EVENT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TV_TRIGGER_EVENT Attribute
TV Triggering See Also

Specifies the event on which the digitizer triggers.

Attribute Tree Node: \AgMD1\Trigger\TV Triggering\TV Trigger Event
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TV_TRIGGER_EVENT 1252300

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TV_TRIGGER_EVENT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_TV_EVENT_FIELD1 | Sets the digitizer to trigger on field 1 of the video signal.
AGMD1_VAL_TV_EVENT_FIELD2 | Sets the digitizer to trigger on field 2 of the video signal.
AGMD1_VAL_TV_EVENT_LINE_NUMBER | Sets the digitizer to trigger on a specific line number you specify with the TV Trigger Line Number attribute.
Top

Requirements

Supported Models

All supported

See Also

Reference

TV Triggering
AgMD1


AGMD1_ATTR_TV_TRIGGER_LINE_NUMBER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TV_TRIGGER_LINE_NUMBER Attribute
TV Triggering See Also

Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).

Attribute Tree Node: \AgMD1\Trigger\TV Triggering\TV Trigger Line Number
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TV_TRIGGER_LINE_NUMBER 1252301

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TV_TRIGGER_LINE_NUMBER.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

TV Triggering
AgMD1


AGMD1_ATTR_TV_TRIGGER_POLARITY Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TV_TRIGGER_POLARITY Attribute
TV Triggering See Also

Specifies the polarity of the TV signal.

Attribute Tree Node: \AgMD1\Trigger\TV Triggering\TV Trigger Polarity
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TV_TRIGGER_POLARITY 1252302

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TV_TRIGGER_POLARITY.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_TV_POSITIVE | Configures the digitizer to trigger on a positive video sync pulse.
AGMD1_VAL_TV_NEGATIVE | Configures the digitizer to trigger on a negative video sync pulse.
Top

Requirements

Supported Models

All supported

See Also

Reference

TV Triggering
AgMD1


AGMD1_ATTR_TV_TRIGGER_SIGNAL_FORMAT Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TV_TRIGGER_SIGNAL_FORMAT Attribute
TV Triggering See Also

Specifies the format of TV signal on which the digitizer triggers.

Attribute Tree Node: \AgMD1\Trigger\TV Triggering\TV Trigger Signal Format
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TV_TRIGGER_SIGNAL_FORMAT 1252303

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the TriggerSource repeated capability.

AttributeID

Must be AGMD1_ATTR_TV_TRIGGER_SIGNAL_FORMAT.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_NTSC | Configures the digitizer to trigger on the NTSC signal format.
AGMD1_VAL_PAL | Configures the digitizer to trigger on the PAL signal format
AGMD1_VAL_SECAM | Configures the digitizer to trigger on the SECAM signal format
Top

Requirements

Supported Models

DC110, DC122, DC122HF, DC122HZ, DC135, DC135HZ, DC140, DC140HZ, DC152, DC152HZ, DC436, DC438, DC440, DP105, DP106, DP110, DP111, DP1400, DP210, DP211, DP212, DP214, DP235, DP240, DP306, DP308, DP310, M9202A, M9203A, M9210A, M9211A, M9703A, U1071A002, U1071A004, U1071AHZ1, U1071AHZ2, U1071AHZ4, U1084A001, U1084A002, U1084A003, U1091AD28

See Also

Reference

TV Triggering
AgMD1


Utility

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Utility
See Also

Tree Node: \AgMD1\Utility

Branches

Name
Temperature
Top

Functions

 | Name | Description
Function | Clear Error | This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.
Function | Clear Interchange Warnings | -- NOT SUPPORTED -- Clears the list of interchangeability warnings that the IVI specific driver maintains.
Function | Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Function | Error Message | Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
Function | Error Query | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Function | Get Error | This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.
Function | Get Next Coercion Record | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Function | Get Next Interchange Warning | -- NOT SUPPORTED -- Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
Function | Invalidate All Attributes | Invalidates all of the driver's cached values.
Function | Lock Session | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Function | Reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Function | Reset Interchange Check | -- NOT SUPPORTED -- Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
Function | Reset With Defaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Function | Revision Query | Retrieves revision information from the instrument.
Function | Self Test | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Function | Unlock Session | Releases a previously obtained mutlithread lock.
Top

See Also

Reference

AgMD1


AgMD1_ClearError Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ClearError Function
Utility See Also

This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.

Function Tree Node: \AgMD1\Utility\Clear Error
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ClearError(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

See Also

Reference

Utility
AgMD1


AgMD1_ClearInterchangeWarnings Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ClearInterchangeWarnings Function
Utility See Also

-- NOT SUPPORTED -- Clears the list of interchangeability warnings that the IVI specific driver maintains.

Function Tree Node: \AgMD1\Utility\Clear Interchange Warnings
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ClearInterchangeWarnings(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_Disable Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_Disable Function
Utility See Also

Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.

Function Tree Node: \AgMD1\Utility\Disable
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_Disable(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_error_message Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_error_message Function
Utility See Also

Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

Function Tree Node: \AgMD1\Utility\Error Message
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_error_message(
    ViSession Vi,
    ViStatus ErrorCode,
    ViChar[] ErrorMessage
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ErrorCode

Instrument driver status code.

ErrorMessage

Instrument driver error message.

Return Value

Success or failure code.

See Also

Reference

Utility
AgMD1


AgMD1_error_query Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_error_query Function
Utility See Also

Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.

Function Tree Node: \AgMD1\Utility\Error Query
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_error_query(
    ViSession Vi,
    ViInt32* ErrorCode,
    ViChar[] ErrorMessage
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ErrorCode

Instrument error code

ErrorMessage

Instrument error message

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_GetError Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetError Function
Utility See Also

This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.

Function Tree Node: \AgMD1\Utility\Get Error
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetError(
    ViSession Vi,
    ViStatus* ErrorCode,
    ViInt32 ErrorDescriptionBufferSize,
    ViChar[] ErrorDescription
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ErrorCode

Returns the error code. Zero indicates that no error occurred. A positive value indicates a warning. A negative value indicates an error. The user can pass VI_NULL if the user does not want to retrieve this value.

ErrorDescriptionBufferSize

The number of bytes in the ViChar array that the user specifies for the ErrorDescription parameter.

ErrorDescription

Buffer into which the function copies the full formatted error string. The string describes the error code and any extra information regarding the error or warning condition. The buffer shall contain at least as many bytes as the user specifies in the ErrorDescriptionBufferSize parameter. The user can pass VI_NULL if the ErrorDescriptionBufferSize parameter is zero.

Return Value

Success or failure code.

See Also

Reference

Utility
AgMD1


AgMD1_GetNextCoercionRecord Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetNextCoercionRecord Function
Utility See Also

Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.

Function Tree Node: \AgMD1\Utility\Get Next Coercion Record
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetNextCoercionRecord(
    ViSession Vi,
    ViInt32 CoercionRecordBufferSize,
    ViChar[] CoercionRecord
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

CoercionRecordBufferSize

CoercionRecord

The coercion record string shall contain the following information: (1) The name of the attribute that was coerced. This can be the generic name, the COM property name, or the C defined constant. (2) If the attribute is channel-based, the name of the channel. The channel name can be the specific driver channel string or the virtual channel name that the user specified.(3) If the attribute applies to a repeated capability, the name of the repeated capability. The name can be the specific driver repeated capability token or the virtual repeated capability name that the user specified.(4) The value that the user specified for the attribute.(5) The value to which the attribute was coerced.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_GetNextInterchangeWarning Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_GetNextInterchangeWarning Function
Utility See Also

-- NOT SUPPORTED -- Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.

Function Tree Node: \AgMD1\Utility\Get Next Interchange Warning
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_GetNextInterchangeWarning(
    ViSession Vi,
    ViInt32 InterchangeWarningBufferSize,
    ViChar[] InterchangeWarning
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

InterchangeWarningBufferSize

InterchangeWarning

A string describing the oldest interchangeability warning or empty string if no warrnings remain.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_InvalidateAllAttributes Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_InvalidateAllAttributes Function
Utility See Also

Invalidates all of the driver's cached values.

Function Tree Node: \AgMD1\Utility\Invalidate All Attributes
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_InvalidateAllAttributes(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_LockSession Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_LockSession Function
Utility See Also

Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.

Function Tree Node: \AgMD1\Utility\Lock Session
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_LockSession(
    ViSession Vi,
    ViBoolean* CallerHasLock
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

CallerHasLock

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_reset Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_reset Function
Utility See Also

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

Function Tree Node: \AgMD1\Utility\Reset
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_reset(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_ResetInterchangeCheck Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ResetInterchangeCheck Function
Utility See Also

-- NOT SUPPORTED -- Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.

Function Tree Node: \AgMD1\Utility\Reset Interchange Check
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ResetInterchangeCheck(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_ResetWithDefaults Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ResetWithDefaults Function
Utility See Also

Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.

Function Tree Node: \AgMD1\Utility\Reset With Defaults
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ResetWithDefaults(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


AgMD1_revision_query Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_revision_query Function
Utility See Also

Retrieves revision information from the instrument.

Function Tree Node: \AgMD1\Utility\Revision Query
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_revision_query(
    ViSession Vi,
    ViChar[] DriverRev,
    ViChar[] InstrRev
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DriverRev

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision attribute. Refer to the Specific Driver Revision attribute for more information.

InstrRev

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision attribute. Refer to the Instrument Firmware Revision attribute for more information.

Return Value

Success or failure code.

See Also

Reference

Utility
AgMD1


AgMD1_self_test Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_self_test Function
Utility See Also

Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.

Function Tree Node: \AgMD1\Utility\Self Test
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_self_test(
    ViSession Vi,
    ViInt16* TestResult,
    ViChar[] TestMessage
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

TestResult

The numeric result from the self test operation. 0 = no error (test passed)

TestMessage

The self test status message

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


Temperature

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Temperature
See Also

Tree Node: \AgMD1\Utility\Temperature

Functions

 | Name | Description
Function | Configure Temperature Units | This function is used to configure the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Function | Query Board Temperature | This function is used to query the temperature of the entire board. The units are governed by the Temperature Units attribute.
Function | Query Channel Temperature | This function is used to query the temperature of a specific channel. The units are governed by the Temperature Units attribute.
Top

Attributes

 | Name | Description
Attribute | Board Temperature | Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.
Attribute | Channel Temperature | Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.
Attribute | Temperature Units | Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_BOARD_TEMPERATURE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_BOARD_TEMPERATURE Attribute
Temperature See Also

Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.

Attribute Tree Node: \AgMD1\Utility\Temperature\Board Temperature
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_BOARD_TEMPERATURE 1250100

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_BOARD_TEMPERATURE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Temperature
AgMD1


AGMD1_ATTR_CHANNEL_TEMPERATURE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_CHANNEL_TEMPERATURE Attribute
Temperature See Also

Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.

Attribute Tree Node: \AgMD1\Utility\Temperature\Channel Temperature
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_CHANNEL_TEMPERATURE 1250300

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

A physical or virtual repeated capability identifier. For valid values, see the Channel repeated capability.

AttributeID

Must be AGMD1_ATTR_CHANNEL_TEMPERATURE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Temperature
AgMD1


AgMD1_ConfigureTemperatureUnits Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ConfigureTemperatureUnits Function
Temperature See Also

This function is used to configure the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Function Tree Node: \AgMD1\Utility\Temperature\Configure Temperature Units
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ConfigureTemperatureUnits(
    ViSession Vi,
    ViInt32 Units
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Units

Temperature units to be used by the Board Temperature and Channel Temperature attributes. This value sets the Temperature Units attribute. See the attribute description for more details.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Units

Name | Description
AGMD1_VAL_CELSIUS | Temperature values returned from the digitizer are in degrees Celsius.
AGMD1_VAL_FAHRENHEIT | Temperature values returned from the digitizer are in degrees Fahrenheit.
AGMD1_VAL_KELVIN | Temperature values returned from the digitizer are in degrees Kelvin.
Top

See Also

Reference

Temperature
AgMD1


AgMD1_QueryBoardTemperature Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_QueryBoardTemperature Function
Temperature See Also

This function is used to query the temperature of the entire board. The units are governed by the Temperature Units attribute.

Function Tree Node: \AgMD1\Utility\Temperature\Query Board Temperature
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_QueryBoardTemperature(
    ViSession Vi,
    ViReal64* Temperature
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Temperature

Returns whether the current temperature of the entire board. The units are governed by the Temperature Units attribute.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Temperature
AgMD1


AgMD1_QueryChannelTemperature Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_QueryChannelTemperature Function
Temperature See Also

This function is used to query the temperature of a specific channel. The units are governed by the Temperature Units attribute.

Function Tree Node: \AgMD1\Utility\Temperature\Query Channel Temperature
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_QueryChannelTemperature(
    ViSession Vi,
    ViConstString Channel,
    ViReal64* Temperature
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Channel

For valid values, see the Channel repeated capability.

Temperature

Returns whether the current temperature of the entire board. The units are governed by the Temperature Units attribute.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Temperature
AgMD1


AGMD1_ATTR_TEMPERATURE_UNITS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_TEMPERATURE_UNITS Attribute
Temperature See Also

Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.

Attribute Tree Node: \AgMD1\Utility\Temperature\Temperature Units
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_TEMPERATURE_UNITS 1250101

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_TEMPERATURE_UNITS.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_CELSIUS | Temperature values returned from the digitizer are in degrees Celsius.
AGMD1_VAL_FAHRENHEIT | Temperature values returned from the digitizer are in degrees Fahrenheit.
AGMD1_VAL_KELVIN | Temperature values returned from the digitizer are in degrees Kelvin.
Top

Requirements

Supported Models

All supported

See Also

Reference

Temperature
AgMD1


AgMD1_UnlockSession Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_UnlockSession Function
Utility See Also

Releases a previously obtained mutlithread lock.

Function Tree Node: \AgMD1\Utility\Unlock Session
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_UnlockSession(
    ViSession Vi,
    ViBoolean* CallerHasLock
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

CallerHasLock

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Utility
AgMD1


Waveform Acquisition

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Waveform Acquisition
See Also

Tree Node: \AgMD1\Waveform Acquisition

Branches

Name
Low-Level Acquisition
Top

Functions

 | Name | Description
Function | Read Waveform Int16 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Read Waveform Int32 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Read Waveform Int8 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Read Waveform Real64 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.
Top

Attributes

 | Name | Description
Attribute | Is Idle | Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | Is Measuring | Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | Is Waiting For Arm | Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | Is Waiting For Trigger | Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | Max First Valid Point Value | Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
Attribute | Max Samples Per Channel | Returns the maximum number of samples per channel that can be captured.
Attribute | Min Record Size | Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.
Attribute | Num Acquired Records | Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.
Attribute | Num Records To Acquire | Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
Attribute | Record Size | Specifies the number of samples to acquire in each waveform record.
Attribute | Sample Mode | -- NOT SUPPORTED, Always RealTime mode -- Specifies the sample mode used by the digitizer.
Attribute | Sample Rate | Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
Top

See Also

Reference

AgMD1


AGMD1_ATTR_IS_IDLE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_IS_IDLE Attribute
Waveform Acquisition See Also

Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Is Idle
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_IS_IDLE 1250005

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_IS_IDLE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Defined Values

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_IS_MEASURING Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_IS_MEASURING Attribute
Waveform Acquisition See Also

Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Is Measuring
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_IS_MEASURING 1250006

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_IS_MEASURING.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Defined Values

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_IS_WAITING_FOR_ARM Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_IS_WAITING_FOR_ARM Attribute
Waveform Acquisition See Also

Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Is Waiting For Arm
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_IS_WAITING_FOR_ARM 1250007

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_IS_WAITING_FOR_ARM.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Defined Values

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_IS_WAITING_FOR_TRIGGER Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_IS_WAITING_FOR_TRIGGER Attribute
Waveform Acquisition See Also

Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Is Waiting For Trigger
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_IS_WAITING_FOR_TRIGGER 1250008

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_IS_WAITING_FOR_TRIGGER.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Defined Values

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


Low-Level Acquisition

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Low-Level Acquisition
See Also

Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition

Branches

Name
Multi-Record Acquisition
Top

Functions

 | Name | Description
Function | Abort | Aborts an acquisition and returns the digitizer to the Idle state.
Function | Fetch Waveform Int16 | This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Fetch Waveform Int32 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Fetch Waveform Int8 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Fetch Waveform Real64 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.
Function | Initiate Acquisition | Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.
Function | Is Idle | This function is used to determine if the digitizer is currently in the Idle state.
Function | Is Measuring | This function is used to determine if the digitizer is currently in the Measuring state.
Function | Is Waiting For Arm | This function is used to determine if the digitizer is currently in the Waiting For Arm state.
Function | Is Waiting For Trigger | This function is used to determine if the digitizer is currently in the Waiting For Trigger state.
Function | Query Min Waveform Memory | This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.
Function | Send Software Arm | This function follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.
Function | Send Software Trigger | Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.
Function | Wait For Acquisition Complete | Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.
Top

See Also

Reference

AgMD1


AgMD1_Abort Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_Abort Function
Low-Level Acquisition See Also

Aborts an acquisition and returns the digitizer to the Idle state.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Abort
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_Abort(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_FetchWaveformInt16 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchWaveformInt16 Function
Low-Level Acquisition See Also

This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Fetch Waveform Int16
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchWaveformInt16(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 WaveformArraySize,
    ViInt16[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_FetchWaveformInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchWaveformInt32 Function
Low-Level Acquisition See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Fetch Waveform Int32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchWaveformInt32(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 WaveformArraySize,
    ViInt32[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_FetchWaveformInt8 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchWaveformInt8 Function
Low-Level Acquisition See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Fetch Waveform Int8
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchWaveformInt8(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 WaveformArraySize,
    ViChar[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_FetchWaveformReal64 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchWaveformReal64 Function
Low-Level Acquisition See Also

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Fetch Waveform Real64
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchWaveformReal64(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 WaveformArraySize,
    ViReal64[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_InitiateAcquisition Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_InitiateAcquisition Function
Low-Level Acquisition See Also

Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Initiate Acquisition
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_InitiateAcquisition(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_IsIdle Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_IsIdle Function
Low-Level Acquisition See Also

This function is used to determine if the digitizer is currently in the Idle state.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Is Idle
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_IsIdle(
    ViSession Vi,
    ViInt32* Status
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Idle state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Status

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_IsMeasuring Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_IsMeasuring Function
Low-Level Acquisition See Also

This function is used to determine if the digitizer is currently in the Measuring state.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Is Measuring
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_IsMeasuring(
    ViSession Vi,
    ViInt32* Status
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the Measuring state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Status

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_IsWaitingForArm Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_IsWaitingForArm Function
Low-Level Acquisition See Also

This function is used to determine if the digitizer is currently in the Waiting For Arm state.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Is Waiting For Arm
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_IsWaitingForArm(
    ViSession Vi,
    ViInt32* Status
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the WaitingForArm state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Status

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_IsWaitingForTrigger Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_IsWaitingForTrigger Function
Low-Level Acquisition See Also

This function is used to determine if the digitizer is currently in the Waiting For Trigger state.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Is Waiting For Trigger
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_IsWaitingForTrigger(
    ViSession Vi,
    ViInt32* Status
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Status

Returns whether the digitizer is currently in the WaitingForTrigger state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

Defined Values For Parameter Status

Name | Description
AGMD1_VAL_ACQUISITION_STATUS_RESULT_TRUE | The state of the status condition is true.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_FALSE | The state of the status condition is false.
AGMD1_VAL_ACQUISITION_STATUS_RESULT_UNKNOWN | The state of the status condition could not be determined.
Top

See Also

Reference

Low-Level Acquisition
AgMD1


Multi-Record Acquisition

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Multi-Record Acquisition
See Also

Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Multi-Record Acquisition

Functions

 | Name | Description
Function | Fetch Multi-Record Waveform Int16 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Fetch Multi-Record Waveform Int32 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Fetch Multi-Record Waveform Int8 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | Fetch Multi-Record Waveform Real64 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.
Top

See Also

Reference

AgMD1


AgMD1_FetchMultiRecordWaveformInt16 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchMultiRecordWaveformInt16 Function
Multi-Record Acquisition See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Multi-Record Acquisition\Fetch Multi-Record Waveform Int16
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchMultiRecordWaveformInt16(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 FirstRecord,
    ViInt64 NumRecords,
    ViInt64 OffsetWithinRecord,
    ViInt64 NumPointsPerRecord,
    ViInt64 WaveformArrayBufferSize,
    ViInt16[] WaveformArray,
    ViInt64* WaveformArrayActualSize,
    ViInt64* ActualRecords,
    ViInt64[] ActualPoints,
    ViInt64[] FirstValidPoint,
    ViReal64[] InitialXOffset,
    ViReal64[] InitialXTimeSeconds,
    ViReal64[] InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Multi-Record Acquisition
AgMD1


AgMD1_FetchMultiRecordWaveformInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchMultiRecordWaveformInt32 Function
Multi-Record Acquisition See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Multi-Record Acquisition\Fetch Multi-Record Waveform Int32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchMultiRecordWaveformInt32(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 FirstRecord,
    ViInt64 NumRecords,
    ViInt64 OffsetWithinRecord,
    ViInt64 NumPointsPerRecord,
    ViInt64 WaveformArrayBufferSize,
    ViInt32[] WaveformArray,
    ViInt64* WaveformArrayActualSize,
    ViInt64* ActualRecords,
    ViInt64[] ActualPoints,
    ViInt64[] FirstValidPoint,
    ViReal64[] InitialXOffset,
    ViReal64[] InitialXTimeSeconds,
    ViReal64[] InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Multi-Record Acquisition
AgMD1


AgMD1_FetchMultiRecordWaveformInt8 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchMultiRecordWaveformInt8 Function
Multi-Record Acquisition See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Multi-Record Acquisition\Fetch Multi-Record Waveform Int8
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchMultiRecordWaveformInt8(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 FirstRecord,
    ViInt64 NumRecords,
    ViInt64 OffsetWithinRecord,
    ViInt64 NumPointsPerRecord,
    ViInt64 WaveformArrayBufferSize,
    ViChar[] WaveformArray,
    ViInt64* WaveformArrayActualSize,
    ViInt64* ActualRecords,
    ViInt64[] ActualPoints,
    ViInt64[] FirstValidPoint,
    ViReal64[] InitialXOffset,
    ViReal64[] InitialXTimeSeconds,
    ViReal64[] InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Multi-Record Acquisition
AgMD1


AgMD1_FetchMultiRecordWaveformReal64 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_FetchMultiRecordWaveformReal64 Function
Multi-Record Acquisition See Also

This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Multi-Record Acquisition\Fetch Multi-Record Waveform Real64
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_FetchMultiRecordWaveformReal64(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt64 FirstRecord,
    ViInt64 NumRecords,
    ViInt64 OffsetWithinRecord,
    ViInt64 NumPointsPerRecord,
    ViInt64 WaveformArrayBufferSize,
    ViReal64[] WaveformArray,
    ViInt64* WaveformArrayActualSize,
    ViInt64* ActualRecords,
    ViInt64[] ActualPoints,
    ViInt64[] FirstValidPoint,
    ViReal64[] InitialXOffset,
    ViReal64[] InitialXTimeSeconds,
    ViReal64[] InitialXTimeFraction,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier. Pass VI_NULL or empty string if operation does not apply to a repeated capability.For valid values, see the Channel repeated capability.

FirstRecord

Specifies the number of the first record to read.

NumRecords

Specifies the number of consecutive records to read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved

NumPointsPerRecord

Specifies the number of data points per record to return. This number may be larger than the amount of data available.

WaveformArrayBufferSize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

WaveformArrayActualSize

Actual number of elements in WaveformArray.

ActualRecords

Indicates how many records in the acquisition completed successfully.

ActualPoints

Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.

FirstValidPoint

Indicates the index of the first valid data point in the output data array for each completed record.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Multi-Record Acquisition
AgMD1


AgMD1_QueryMinWaveformMemory Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_QueryMinWaveformMemory Function
Low-Level Acquisition See Also

This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Query Min Waveform Memory
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_QueryMinWaveformMemory(
    ViSession Vi,
    ViInt32 DataWidth,
    ViInt64 NumRecords,
    ViInt64 OffsetWithinRecord,
    ViInt64 NumPointsPerRecord,
    ViInt64* NumSamples
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

DataWidth

Specifies the size of the sampled data that will be retrieved. The value of this parameter must be 8, 16, 32 or 64, corresponding to the intended Read/Fetch function.

NumRecords

Specifies the number of records that will be read.

OffsetWithinRecord

Specifies the start index within the record from which the data should be retrieved.

NumPointsPerRecord

Specifies the number of data points to return.

NumSamples

The minimum buffer size in samples needed for a subsequent Read or Fetch call with the same readout parameters.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_SendSoftwareArm Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SendSoftwareArm Function
Low-Level Acquisition See Also

This function follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Send Software Arm
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SendSoftwareArm(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

M9202A

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_SendSoftwareTrigger Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_SendSoftwareTrigger Function
Low-Level Acquisition See Also

Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Send Software Trigger
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_SendSoftwareTrigger(
    ViSession Vi
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AgMD1_WaitForAcquisitionComplete Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_WaitForAcquisitionComplete Function
Low-Level Acquisition See Also

Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.

Function Tree Node: \AgMD1\Waveform Acquisition\Low-Level Acquisition\Wait For Acquisition Complete
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_WaitForAcquisitionComplete(
    ViSession Vi,
    ViInt32 MaxTimeMilliseconds
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this function to complete. The units are milliseconds. Defined values: (-1) - The function waits indefinitely for the acquisition to complete.

Return Value

Success or failure code.

Requirements

Supported Models

All supported

See Also

Reference

Low-Level Acquisition
AgMD1


AGMD1_ATTR_MAX_FIRST_VALID_POINT_VAL Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_MAX_FIRST_VALID_POINT_VAL Attribute
Waveform Acquisition See Also

Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Max First Valid Point Value
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_MAX_FIRST_VALID_POINT_VAL 1250009

ViStatus AgMD1_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_MAX_FIRST_VALID_POINT_VAL.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_MAX_SAMPLES_PER_CHANNEL Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_MAX_SAMPLES_PER_CHANNEL Attribute
Waveform Acquisition See Also

Returns the maximum number of samples per channel that can be captured.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Max Samples Per Channel
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_MAX_SAMPLES_PER_CHANNEL 1250010

ViStatus AgMD1_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_MAX_SAMPLES_PER_CHANNEL.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_MIN_RECORD_SIZE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_MIN_RECORD_SIZE Attribute
Waveform Acquisition See Also

Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Min Record Size
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_MIN_RECORD_SIZE 1250011

ViStatus AgMD1_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_MIN_RECORD_SIZE.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_NUM_ACQUIRED_RECORDS Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_NUM_ACQUIRED_RECORDS Attribute
Waveform Acquisition See Also

Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Num Acquired Records
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_NUM_ACQUIRED_RECORDS 1250012

ViStatus AgMD1_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_NUM_ACQUIRED_RECORDS.

AttributeValue

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_NUM_RECORDS_TO_ACQUIRE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_NUM_RECORDS_TO_ACQUIRE Attribute
Waveform Acquisition See Also

Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Num Records To Acquire
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_NUM_RECORDS_TO_ACQUIRE 1250013

ViStatus AgMD1_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_NUM_RECORDS_TO_ACQUIRE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AgMD1_ReadWaveformInt16 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ReadWaveformInt16 Function
Waveform Acquisition See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Read Waveform Int16
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ReadWaveformInt16(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt32 MaxTimeMilliseconds,
    ViInt64 WaveformArraySize,
    ViInt16[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier.For valid values, see the Channel repeated capability.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AgMD1_ReadWaveformInt32 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ReadWaveformInt32 Function
Waveform Acquisition See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Read Waveform Int32
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ReadWaveformInt32(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt32 MaxTimeMilliseconds,
    ViInt64 WaveformArraySize,
    ViInt32[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier.For valid values, see the Channel repeated capability.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AgMD1_ReadWaveformInt8 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ReadWaveformInt8 Function
Waveform Acquisition See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset

Function Tree Node: \AgMD1\Waveform Acquisition\Read Waveform Int8
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ReadWaveformInt8(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt32 MaxTimeMilliseconds,
    ViInt64 WaveformArraySize,
    ViChar[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement,
    ViReal64* ScaleFactor,
    ViReal64* ScaleOffset
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier.For valid values, see the Channel repeated capability.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

ScaleFactor

Scaling factor for the waveform data.

ScaleOffset

Scaling offset for the waveform data.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AgMD1_ReadWaveformReal64 Function

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AgMD1_ReadWaveformReal64 Function
Waveform Acquisition See Also

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.

Function Tree Node: \AgMD1\Waveform Acquisition\Read Waveform Real64
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
ViStatus AgMD1_ReadWaveformReal64(
    ViSession Vi,
    ViConstString ChannelName,
    ViInt32 MaxTimeMilliseconds,
    ViInt64 WaveformArraySize,
    ViReal64[] WaveformArray,
    ViInt64* ActualPoints,
    ViInt64* FirstValidPoint,
    ViReal64* InitialXOffset,
    ViReal64* InitialXTimeSeconds,
    ViReal64* InitialXTimeFraction,
    ViReal64* XIncrement
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

ChannelName

The physical or virtual repeated capability identifier.For valid values, see the Channel repeated capability.

MaxTimeMilliseconds

Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.

WaveformArraySize

Number of elements in WaveformArray.

WaveformArray

Buffer into which the acquired waveform is stored.

ActualPoints

Indicates how many data points were actually retrieved from the instrument.

FirstValidPoint

Indicates the index of the first valid data point in the output data array.

InitialXOffset

The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.

InitialXTimeSeconds

Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

InitialXTimeFraction

Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.

XIncrement

The time between points in the acquired waveform in seconds.

Return Value

Success or failure code.

Remarks

Please refer to the Remarks in the ConfigureDownconversion function for detailed information on the usage of Read/Fetch functions and the data format when downconversion is enabled.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_RECORD_SIZE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_RECORD_SIZE Attribute
Waveform Acquisition See Also

Specifies the number of samples to acquire in each waveform record.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Record Size
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_RECORD_SIZE 1250014

ViStatus AgMD1_GetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViInt32 AttributeID,
    ViInt64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_RECORD_SIZE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_SAMPLE_MODE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SAMPLE_MODE Attribute
Waveform Acquisition See Also

-- NOT SUPPORTED, Always RealTime mode -- Specifies the sample mode used by the digitizer.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Sample Mode
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SAMPLE_MODE 1250800

ViStatus AgMD1_GetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32* AttributeValue
);

ViStatus AgMD1_SetAttributeViInt32(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViInt32 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SAMPLE_MODE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Defined Values

Name | Description
AGMD1_VAL_SAMPLE_MODE_REAL_TIME | Real-time sampling is used.
AGMD1_VAL_SAMPLE_MODE_EQUIVALENT_TIME | Equivalent-time sampling is used.
Top

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


AGMD1_ATTR_SAMPLE_RATE Attribute

[image]

AgMD1 IVI Driver Reference Agilent Technologies
AGMD1_ATTR_SAMPLE_RATE Attribute
Waveform Acquisition See Also

Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.

Attribute Tree Node: \AgMD1\Waveform Acquisition\Sample Rate
Declaration: AgMD1.h
Implementation: AgMD1.dll

Syntax

Visual C++
#define AGMD1_ATTR_SAMPLE_RATE 1250015

ViStatus AgMD1_GetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64* AttributeValue
);

ViStatus AgMD1_SetAttributeViReal64(
    ViSession Vi,
    ViConstString RepCapIdentifier,
    ViAttr AttributeID,
    ViReal64 AttributeValue
);

Parameters

Vi

The ViSession handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.

RepCapIdentifier

Must be VI_NULL or an empty string. This attribute is not defined on a repeated capability.

AttributeID

Must be AGMD1_ATTR_SAMPLE_RATE.

AttributeValue (GetAttribute)

Returns the current value of the attribute. The user must specify the address of a variable that has the same data type as the attribute.

AttributeValue (SetAttribute)

The value to which to set the attribute.

Requirements

Supported Models

All supported

See Also

Reference

Waveform Acquisition
AgMD1


Functions and Attributes

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Functions and Attributes

Functions

 | Name | Description
Function | AgMD1_Abort | Aborts an acquisition and returns the digitizer to the Idle state.
Function | AgMD1_AcquisitionConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Function | AgMD1_CalibrationCalRequired | Check if a self calibration is needed on the specified channel.
Function | AgMD1_CalibrationCancel | Abort any running self-calibration and return.
Function | AgMD1_CalibrationLoadCal | Load calibration values and info from file.
Function | AgMD1_CalibrationSaveCal | Save calibration values and info in a binary file.
Function | AgMD1_CalibrationSelfCalibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Function | AgMD1_ClearError | This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.
Function | AgMD1_ClearInterchangeWarnings | -- NOT SUPPORTED -- Clears the list of interchangeability warnings that the IVI specific driver maintains.
Function | AgMD1_close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Function | AgMD1_ConfigureAcquisition | This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.
Function | AgMD1_ConfigureChannel | This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.
Function | AgMD1_ConfigureDownconversion | Configures how the digitizer performs downconversion.
Function | AgMD1_ConfigureEdgeTriggerSource | This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Function | AgMD1_ConfigureMultiTrigger | Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.
Function | AgMD1_ConfigureReferenceOscillatorOutputEnabled | Configures whether or not the reference frequency signal appears at an output of the digitizer.
Function | AgMD1_ConfigureSampleMode | Configures the digitizer sample mode.
Function | AgMD1_ConfigureTemperatureUnits | This function is used to configure the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Function | AgMD1_ConfigureTriggerModifier | This function configures the digitizer's trigger modifier.
Function | AgMD1_ConfigureTVTriggerSource | This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.
Function | AgMD1_CounterRead | Counter measurement results for the current mode. Counter must be enabled by setting Acquisition.Mode = AgMD1AcquisitionModeCounter. The Read method will wait the current ApertureTime before returning measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.
Function | AgMD1_DigitalDownconversionConfigure | Configures the DigitalDownconverson DataBandwidth and TriggerBandwidth. Requires Model: M9202A
Function | AgMD1_Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Function | AgMD1_error_message | Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
Function | AgMD1_error_query | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Function | AgMD1_FetchMultiRecordWaveformInt16 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchMultiRecordWaveformInt32 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchMultiRecordWaveformInt8 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchMultiRecordWaveformReal64 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.
Function | AgMD1_FetchWaveformInt16 | This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchWaveformInt32 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchWaveformInt8 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchWaveformReal64 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.
Function | AgMD1_GetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetChannelName | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the Name parameter and returns an error.
Function | AgMD1_GetDelayControlName | Returns the delay control name that corresponds to the one-based index that the user specifies.
Function | AgMD1_GetError | This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.
Function | AgMD1_GetLogicDeviceName | Returns the logicdevice name that corresponds to the one-based index that the user specifies.
Function | AgMD1_GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Function | AgMD1_GetNextInterchangeWarning | -- NOT SUPPORTED -- Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
Function | AgMD1_GetTriggerSourceName | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Trigger Source Count, the function returns an empty string in the Name parameter and returns an error.
Function | AgMD1_init | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgMD1_InitiateAcquisition | Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.
Function | AgMD1_InitWithOptions | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgMD1_InvalidateAllAttributes | Invalidates all of the driver's cached values.
Function | AgMD1_IsIdle | This function is used to determine if the digitizer is currently in the Idle state.
Function | AgMD1_IsMeasuring | This function is used to determine if the digitizer is currently in the Measuring state.
Function | AgMD1_IsWaitingForArm | This function is used to determine if the digitizer is currently in the Waiting For Arm state.
Function | AgMD1_IsWaitingForTrigger | This function is used to determine if the digitizer is currently in the Waiting For Trigger state.
Function | AgMD1_LoadLogicDeviceFromFile | Loads the bit file at the file system path Path into the FPGA(s) identified by the LogicDevice repeated capability.
Function | AgMD1_LockSession | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Function | AgMD1_MeasurementFetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | AgMD1_MeasurementReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Function | AgMD1_QueryBoardTemperature | This function is used to query the temperature of the entire board. The units are governed by the Temperature Units attribute.
Function | AgMD1_QueryChannelTemperature | This function is used to query the temperature of a specific channel. The units are governed by the Temperature Units attribute.
Function | AgMD1_QueryMinWaveformMemory | This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.
Function | AgMD1_ReadIndirectInt32 | Reads up to NumElements 32 bit integers of the Indirect Buffer with identifier Id from the FPGA identified by LogicDevice repeated capagility into the memory referenced by Data.
Function | AgMD1_ReadRegisterInt32 | Reads a 32 bits integer value from the register at Offset in the FPGA identified by LogicDevice repeated capability.
Function | AgMD1_ReadWaveformInt16 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_ReadWaveformInt32 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_ReadWaveformInt8 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_ReadWaveformReal64 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.
Function | AgMD1_ReferenceLevelConfigure | Configures the reference levels for waveform measurements, low, mid, and high.
Function | AgMD1_reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Function | AgMD1_ResetInterchangeCheck | -- NOT SUPPORTED -- Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
Function | AgMD1_ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Function | AgMD1_revision_query | Retrieves revision information from the instrument.
Function | AgMD1_self_test | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Function | AgMD1_SelfCalibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Function | AgMD1_SendSoftwareArm | This function follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.
Function | AgMD1_SendSoftwareTrigger | Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.
Function | AgMD1_SetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SystemPowerOffAll | Forces all instruments to prepare and enter the system power down state. Suspend all other calling threads. If a thread is performing a long operation which cannot be completed within milliseconds (e.g. a self-calibration), it will be interrupted immediately and will return the status 'ACQIRIS_ERROR_OPERATION_INTERRUPTED'. Note that if an acquisition is still running when the PowerOffAll method is invoked, it might be incomplete or corrupted.
Function | AgMD1_SystemPowerOnAll | Forces all instruments power up and return from the system power down state. Re-enable the instruments at the same state as they were before the PowerOffAll method was invoked. Threads which were suspended will be resumed. However, interrupted operations which returned an error 'ACQIRIS_ERROR_OPERATION_INTERRUPTED' will have to be redone.
Function | AgMD1_SystemResumeControl | Resume the control of an instrument that was suspended (see SuspendControl).
Function | AgMD1_SystemSuspendControl | Suspend control of an instrument to allow using it from another process. NOTE: This is only available for Windows operating systems.
Function | AgMD1_TemperatureGetModuleTemperature | Temperature of the specified module. The units are governed by the Temperature.Units property.
Function | AgMD1_TriggerMagnitudeConfigure | This function sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Function | AgMD1_UnlockSession | Releases a previously obtained mutlithread lock.
Function | AgMD1_WaitForAcquisitionComplete | Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.
Function | AgMD1_WriteIndirectInt32 | Writes the contents of Data to the Indirect Buffer with identifier Id of the FPGA identified by LogicDevice repeated capability.
Function | AgMD1_WriteRegisterInt32 | Writes the 32 bits integer value Value to the register at Offset in the FPGA identified by LogicDevice repeated capability.
Top

Attributes

 | Name | Description
Attribute | AGMD1_ATTR_ACQUISITION_AUTO_ARM_ENABLED | If true, auto arming is enabled. If false, after an acquisition has been initiated, SendSoftwareArm method must be called before any triggers will be accepted. Requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_DITHER_ENABLED | If true, enables dithering. Requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_DITHER_RANGE | Sets amplitude of dithering signal. Range: 0 to 31. 0 = dithering amplitude is 0 (i. e. no dithering). 31 = dithering amplitude is Full Scale/2 = 500 mV. Requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED | Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
Attribute | AGMD1_ATTR_ACQUISITION_MODE | The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_NUMBER_OF_AVERAGES | The number of waveforms the digitizer acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.
Attribute | AGMD1_ATTR_ACQUISITION_REFERENCE_CHANNEL | The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ...
Attribute | AGMD1_ATTR_ACQUISITION_START_TIME | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Attribute | AGMD1_ATTR_ACQUISITION_TIME_PER_RECORD | The time in seconds that corresponds to the record length.
Attribute | AGMD1_ATTR_ACTIVE_TRIGGER_SOURCE | Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".
Attribute | AGMD1_ATTR_BOARD_TEMPERATURE | Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.
Attribute | AGMD1_ATTR_CACHE | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Attribute | AGMD1_ATTR_CHANNEL_ACTIVE_INPUTS | String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc.
Attribute | AGMD1_ATTR_CHANNEL_CONNECTOR_NAME | The connector name as it appears on the instrument's front panel.
Attribute | AGMD1_ATTR_CHANNEL_CONVERTERS_PER_CHANNEL | The number of converters currently assigned to each channel.
Attribute | AGMD1_ATTR_CHANNEL_COUNT | The number of channels.
Attribute | AGMD1_ATTR_CHANNEL_ENABLED | Specifies whether the digitizer acquires a waveform for the channel.
Attribute | AGMD1_ATTR_CHANNEL_INPUT_FREQUENCY_MAX | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth).
Attribute | AGMD1_ATTR_CHANNEL_PROBE_ATTENUATION | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Attribute | AGMD1_ATTR_CHANNEL_TEMPERATURE | Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.
Attribute | AGMD1_ATTR_CONTROL_IO_SIGNAL_A | Signal present on Control IO connector A. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Attribute | AGMD1_ATTR_CONTROL_IO_SIGNAL_B | Signal present on Control IO connector B. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Attribute | AGMD1_ATTR_CONTROL_IO_SIGNAL_C | Signal present on Control IO connector C if present. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed
Attribute | AGMD1_ATTR_COUNTER_APERTURE_TIME | The minimum measurement time for Frequency and Period modes. The duration to count input pulses for TotalizeGate mode. The Counter.Read method will wait this time before returning measurement data. Units are seconds.
Attribute | AGMD1_ATTR_COUNTER_MODE | The mode for counter measurements, Frequency, Period, TotalizeTime, or TotalizeGate.
Attribute | AGMD1_ATTR_DELAY_CONTROL_COUNT |
Attribute | AGMD1_ATTR_DELAY_CONTROL_ENABLED | Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
Attribute | AGMD1_ATTR_DELAY_CONTROL_MAX | Maximum value (DAC code) that can be set for the delay control.
Attribute | AGMD1_ATTR_DELAY_CONTROL_MIN | Minimum value (DAC code) that can be set for the delay control.
Attribute | AGMD1_ATTR_DELAY_CONTROL_RANGE | Selects the range for the delay control. Useful only for delay controls with multiple ranges.
Attribute | AGMD1_ATTR_DELAY_CONTROL_VALUE | The value (DAC code) set for the delay control.
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH | The output bandwidth in Hz for down-converted data. Range: 250e6, 200e6, 100e6, 50e6 etc following progression f(n+1) = f(n)/ 2, down to 2GHz/(2^21) = about 1 kHz. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DOUBLE_DATA_RATE_ENABLED | False = simple data rate (Samples / second = 1.25*bandwidth), True = double data rate (Samples / second = 2.5*bandwidth) Note: only applies for DataBandwidth values of 1.0e8 and below. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED | True = First frequency shift is by -500MHz. False = First frequency shift is by +500MHz. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT | Decoded to set up the frequency shift blocks of the down converter. The value of this attribute corresponds to the data frequency shift; trigger frequency shift is the nearest value available with the given TriggerBandwidth. I. e. the trigger frequency shift equals FrequencyShift if TriggerBandwidth <= DataBandwidth; otherwise it is rounded to the nearest multiple of TriggerBandwidth*2.5/4. Range: -125e6 to +125e6, step = DataBandwidth *2.5 / 4. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH | The output bandwidth in Hz for down-converted trigger. Requires Model: M9202A
Attribute | AGMD1_ATTR_DOWNCONVERSION_CENTER_FREQUENCY | Specifies the center frequency, in Hz, from which the digitizer should downconvert.
Attribute | AGMD1_ATTR_DOWNCONVERSION_ENABLED | Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.
Attribute | AGMD1_ATTR_DOWNCONVERSION_IQ_INTERLEAVED | Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.
Attribute | AGMD1_ATTR_DRIVER_SETUP | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Attribute | AGMD1_ATTR_EXT_TRIG_RANGE | The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Attribute | AGMD1_ATTR_GROUP_CAPABILITIES | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Attribute | AGMD1_ATTR_INPUT_CONNECTOR_SELECTION | Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1, 2
Attribute | AGMD1_ATTR_INPUT_FILTER_BYPASS | Specifies whether or not to bypass the input filter.
Attribute | AGMD1_ATTR_INPUT_FILTER_MAX_FREQUENCY | Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
Attribute | AGMD1_ATTR_INPUT_IMPEDANCE | The input impedance of this channel. The units are Ohms.
Attribute | AGMD1_ATTR_INSTRUMENT_FIRMWARE_REVISION | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_AQ_DRV_VERSION | Version of the AqDrv Device Driver. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_AQIO_VERSION | Version of the Agilent Acqiris IO Driver. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_BUS_NUMBER | PCI Bus number. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_CPLD_FIRMWARE_REV | Revision of the CPLD Firmware. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_CRATE_NUMBER | Crate number. Starts at 121000 for autodetected CC121 crates. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_DEVICE_ID | PCI Device ID. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV | Revision of the EEPROM Common Section. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV | Revision of the EEPROM Digitizer Section. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_FUNDAMENTAL_HANDLE | Returns the Int32 equivalent ViSession handle to the fundamental API used to control the module hardware. Never call the fundamental Acqrs_close or Acqrs_closeAll functions with this handle or the driver will cease to operate. Use the IVI driver's Close method instead.
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE | True if the instrument features a high resolution sampling rate. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS | Number of external trigger sources. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS | Number of internal trigger sources. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT | Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBRADC_BITS | Number of bits of data per sample from this module's ADCs. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_OPTIONS | List of comma separated options installed in this instrument. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER | Deprecated - Do not use. Use SerialNumberString. The serial number of the instrument. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER_STRING | The serial number string of the instrument. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_SLOT_NUMBER | The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates). Read only
Attribute | AGMD1_ATTR_INSTRUMENT_MANUFACTURER | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
Attribute | AGMD1_ATTR_INSTRUMENT_MODEL | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Attribute | AGMD1_ATTR_INTERCHANGE_CHECK | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Attribute | AGMD1_ATTR_IO_RESOURCE_DESCRIPTOR | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Attribute | AGMD1_ATTR_IS_IDLE | Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_IS_MEASURING | Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_IS_WAITING_FOR_ARM | Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_IS_WAITING_FOR_TRIGGER | Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_LOGIC_DEVICE_COUNT | Returns the number of logic devices.
Attribute | AGMD1_ATTR_LOGICAL_NAME | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
Attribute | AGMD1_ATTR_MAX_FIRST_VALID_POINT_VAL | Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
Attribute | AGMD1_ATTR_MAX_SAMPLES_PER_CHANNEL | Returns the maximum number of samples per channel that can be captured.
Attribute | AGMD1_ATTR_MEASUREMENT_WAVEFORM_TYPE | The waveform type used to calculate the various measurement functions by the FetchWaveformMeasurement and ReadWaveformMeasurement methods.
Attribute | AGMD1_ATTR_MIN_RECORD_SIZE | Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.
Attribute | AGMD1_ATTR_NUM_ACQUIRED_RECORDS | Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.
Attribute | AGMD1_ATTR_NUM_RECORDS_TO_ACQUIRE | Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
Attribute | AGMD1_ATTR_PXI_TRIG_OUT_ENABLED | If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input.
Attribute | AGMD1_ATTR_PXI_TRIG_SLOPE | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR".
Attribute | AGMD1_ATTR_QUERY_INSTRUMENT_STATUS | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Attribute | AGMD1_ATTR_RANGE_CHECK | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Attribute | AGMD1_ATTR_RECORD_COERCIONS | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Attribute | AGMD1_ATTR_RECORD_SIZE | Specifies the number of samples to acquire in each waveform record.
Attribute | AGMD1_ATTR_REFERENCE_LEVEL_HIGH | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGMD1_ATTR_REFERENCE_LEVEL_LOW | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGMD1_ATTR_REFERENCE_LEVEL_MID | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGMD1_ATTR_REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY | Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
Attribute | AGMD1_ATTR_REFERENCE_OSCILLATOR_OUTPUT_ENABLED | Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.
Attribute | AGMD1_ATTR_REFERENCE_OSCILLATOR_SOURCE | Specifies the reference frequency source used.
Attribute | AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_DIVIDER | Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
Attribute | AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_FREQUENCY | Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
Attribute | AGMD1_ATTR_SAMPLE_CLOCK_SOURCE | Specifies the clock used to pace acquisition sampling.
Attribute | AGMD1_ATTR_SAMPLE_MODE | -- NOT SUPPORTED, Always RealTime mode -- Specifies the sample mode used by the digitizer.
Attribute | AGMD1_ATTR_SAMPLE_RATE | Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
Attribute | AGMD1_ATTR_SIMULATE | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION | Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION | Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_DESCRIPTION | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_PREFIX | Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_REVISION | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_VENDOR | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SUPPORTED_INSTRUMENT_MODELS | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Attribute | AGMD1_ATTR_SYSTEM_NBR_INSTRUMENTS | The number of instruments supporting the AgMD1 driver in the system. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Read only
Attribute | AGMD1_ATTR_SYSTEM_TRACE_ENABLED | If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.
Attribute | AGMD1_ATTR_TEMPERATURE_UNITS | Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Attribute | AGMD1_ATTR_TIME_INTERLEAVED_CHANNEL_LIST | This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.
Attribute | AGMD1_ATTR_TRIGGER_COUPLING | Specifies how the digitizer couples the trigger source.
Attribute | AGMD1_ATTR_TRIGGER_DELAY | Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
Attribute | AGMD1_ATTR_TRIGGER_HYSTERESIS | Specifies the trigger hysteresis in Volts.
Attribute | AGMD1_ATTR_TRIGGER_LEVEL | Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
Attribute | AGMD1_ATTR_TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES | Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
Attribute | AGMD1_ATTR_TRIGGER_MAGNITUDE_SLOPE | Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
Attribute | AGMD1_ATTR_TRIGGER_MODIFIER | Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_ENABLED | Specifies whether or not an accepted trigger appears at an output of the digitizer.
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED | M9202A Multi Module Synchronization. Enable a M9202A to be the trigger master to synchronize multiple other M9202A modules (the trigger slaves modules). For all modules to synchronize, only one module can be the trigger master module while all others must be trigger slave modules.
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_OFFSET | Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_RESYNC_ENABLED | Controls whether the trigger out signal is resynchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false).
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_SOURCE | Select the trigger source to drive the TRG OUT output connector on the front panel. Possible values are Channel1, ..., Channel<n> or External1, ..., External<n> trigger sources where <n> is the number of available channels or external trigger inputs. For M9703A, possible values are TriggerCompare, TriggerAccepted, AXIe_TRIG0, AXIe_TRIG1, ..., AXIe_TRIG11, AXIe_STRIG, HighLevel, LowLevel.
Attribute | AGMD1_ATTR_TRIGGER_SLOPE | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
Attribute | AGMD1_ATTR_TRIGGER_SOURCE_COUNT | The number of trigger sources.
Attribute | AGMD1_ATTR_TRIGGER_SOURCE_LIST | A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.
Attribute | AGMD1_ATTR_TRIGGER_SOURCE_OPERATOR | Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute. See the definition of that attribute for details.
Attribute | AGMD1_ATTR_TRIGGER_TYPE | The kind of event that triggers the digitizer. TV triggering requires External trigger source.
Attribute | AGMD1_ATTR_TV_TRIGGER_EVENT | Specifies the event on which the digitizer triggers.
Attribute | AGMD1_ATTR_TV_TRIGGER_LINE_NUMBER | Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).
Attribute | AGMD1_ATTR_TV_TRIGGER_POLARITY | Specifies the polarity of the TV signal.
Attribute | AGMD1_ATTR_TV_TRIGGER_SIGNAL_FORMAT | Specifies the format of TV signal on which the digitizer triggers.
Attribute | AGMD1_ATTR_VERTICAL_COUPLING | Specifies how the digitizer couples the input signal for the channel.
Attribute | AGMD1_ATTR_VERTICAL_OFFSET | The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Attribute | AGMD1_ATTR_VERTICAL_RANGE | The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top


Functions and Attributes

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Functions

Functions

 | Name | Description
Function | AgMD1_Abort | Aborts an acquisition and returns the digitizer to the Idle state.
Function | AgMD1_AcquisitionConfigureRecord | Configures the most commonly used properties of the oscilloscope's acquisition subsystem: time per record, minimum record length, and the acquisition start time.
Function | AgMD1_CalibrationCalRequired | Check if a self calibration is needed on the specified channel.
Function | AgMD1_CalibrationCancel | Abort any running self-calibration and return.
Function | AgMD1_CalibrationLoadCal | Load calibration values and info from file.
Function | AgMD1_CalibrationSaveCal | Save calibration values and info in a binary file.
Function | AgMD1_CalibrationSelfCalibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Function | AgMD1_ClearError | This function clears the error code and error description for the current execution thread and for the IVI session. If the user specifies a valid IVI session for the Vi parameter, this function clears the error information for the session. If the user passes VI_NULL for the Vi parameter, this function clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error.
Function | AgMD1_ClearInterchangeWarnings | -- NOT SUPPORTED -- Clears the list of interchangeability warnings that the IVI specific driver maintains.
Function | AgMD1_close | Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.
Function | AgMD1_ConfigureAcquisition | This function configures the most commonly configured attributes of the digitizer acquisition sub-system. These attributes are the samples per record, the number of records, and the sample rate.
Function | AgMD1_ConfigureChannel | This function configures the most commonly configured attributes of the digitizer channel sub-system. These attributes are the range, offset, coupling, and whether the channel is enabled.
Function | AgMD1_ConfigureDownconversion | Configures how the digitizer performs downconversion.
Function | AgMD1_ConfigureEdgeTriggerSource | This function sets the edge triggering attributes. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This function affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this function. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Function | AgMD1_ConfigureMultiTrigger | Configures the digitizer to trigger based on multiple trigger sources. The digitizer can be instructed to trigger when any one of multiple trigger source conditions are met or when all specified trigger source conditions are met.
Function | AgMD1_ConfigureReferenceOscillatorOutputEnabled | Configures whether or not the reference frequency signal appears at an output of the digitizer.
Function | AgMD1_ConfigureSampleMode | Configures the digitizer sample mode.
Function | AgMD1_ConfigureTemperatureUnits | This function is used to configure the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Function | AgMD1_ConfigureTriggerModifier | This function configures the digitizer's trigger modifier.
Function | AgMD1_ConfigureTVTriggerSource | This function configures the digitizer for TV triggering. It configures the TV signal format, the event and the signal polarity. This function affects instrument behavior only if the trigger type is TV Trigger. Set the Trigger Type and Trigger Coupling before calling this function.
Function | AgMD1_CounterRead | Counter measurement results for the current mode. Counter must be enabled by setting Acquisition.Mode = AgMD1AcquisitionModeCounter. The Read method will wait the current ApertureTime before returning measurement data. Units are Hz for Frequency, Seconds for Period, and Counts for Totalize measurements.
Function | AgMD1_DigitalDownconversionConfigure | Configures the DigitalDownconverson DataBandwidth and TriggerBandwidth. Requires Model: M9202A
Function | AgMD1_Disable | Quickly places the instrument in a state where it has no, or minimal, effect on the external system to which it is connected. This state is not necessarily a known state.
Function | AgMD1_error_message | Translates the error return value from an IVI driver function to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.
Function | AgMD1_error_query | Queries the instrument and returns instrument specific error information. This function can be used when QueryInstrumentStatus is True to retrieve error details when the driver detects an instrument error.
Function | AgMD1_FetchMultiRecordWaveformInt16 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchMultiRecordWaveformInt32 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchMultiRecordWaveformInt8 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchMultiRecordWaveformReal64 | This function returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are Volts.
Function | AgMD1_FetchWaveformInt16 | This function returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchWaveformInt32 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchWaveformInt8 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_FetchWaveformReal64 | Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel. Returned waveform data units are Volts.
Function | AgMD1_GetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_GetChannelName | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the function returns an empty string in the Name parameter and returns an error.
Function | AgMD1_GetDelayControlName | Returns the delay control name that corresponds to the one-based index that the user specifies.
Function | AgMD1_GetError | This function retrieves and then clears the IVI error information for the session or the current execution thread. If the user specifies a valid IVI session for the Vi parameter, Get Error retrieves and then clears the error information for the session. If the user passes VI_NULL for the Vi parameter, Get Error retrieves and then clears the error information for the current execution thread. If the Vi parameter is an invalid session, the function does nothing and returns an error. Normally, the error information describes the first error that occurred since the user last called the Get Error or Clear Error function.
Function | AgMD1_GetLogicDeviceName | Returns the logicdevice name that corresponds to the one-based index that the user specifies.
Function | AgMD1_GetNextCoercionRecord | Returns the oldest record from the coercion record list. Records are only added to the list if RecordCoercions is True.
Function | AgMD1_GetNextInterchangeWarning | -- NOT SUPPORTED -- Returns the oldest warning from the interchange warning list. Records are only added to the list if InterchangeCheck is True.
Function | AgMD1_GetTriggerSourceName | This function returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Trigger Source Count, the function returns an empty string in the Name parameter and returns an error.
Function | AgMD1_init | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgMD1_InitiateAcquisition | Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.
Function | AgMD1_InitWithOptions | Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.
Function | AgMD1_InvalidateAllAttributes | Invalidates all of the driver's cached values.
Function | AgMD1_IsIdle | This function is used to determine if the digitizer is currently in the Idle state.
Function | AgMD1_IsMeasuring | This function is used to determine if the digitizer is currently in the Measuring state.
Function | AgMD1_IsWaitingForArm | This function is used to determine if the digitizer is currently in the Waiting For Arm state.
Function | AgMD1_IsWaitingForTrigger | This function is used to determine if the digitizer is currently in the Waiting For Trigger state.
Function | AgMD1_LoadLogicDeviceFromFile | Loads the bit file at the file system path Path into the FPGA(s) identified by the LogicDevice repeated capability.
Function | AgMD1_LockSession | Obtains a multithread lock on the driver after waiting until all other execution threads have released their locks on the instrument session.
Function | AgMD1_MeasurementFetchWaveformMeasurement | Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.
Function | AgMD1_MeasurementReadWaveformMeasurement | Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.
Function | AgMD1_QueryBoardTemperature | This function is used to query the temperature of the entire board. The units are governed by the Temperature Units attribute.
Function | AgMD1_QueryChannelTemperature | This function is used to query the temperature of a specific channel. The units are governed by the Temperature Units attribute.
Function | AgMD1_QueryMinWaveformMemory | This function is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.
Function | AgMD1_ReadIndirectInt32 | Reads up to NumElements 32 bit integers of the Indirect Buffer with identifier Id from the FPGA identified by LogicDevice repeated capagility into the memory referenced by Data.
Function | AgMD1_ReadRegisterInt32 | Reads a 32 bits integer value from the register at Offset in the FPGA identified by LogicDevice repeated capability.
Function | AgMD1_ReadWaveformInt16 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_ReadWaveformInt32 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values which may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_ReadWaveformInt8 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are raw ADC values. Unsigned byte data is actually signed (+-128) and must be cast to a signed byte data type. Signed raw data may be converted to volts by the formula: V = ScaleFactor * data - ScaleOffset
Function | AgMD1_ReadWaveformReal64 | Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels. Returned waveform data units are Volts.
Function | AgMD1_ReferenceLevelConfigure | Configures the reference levels for waveform measurements, low, mid, and high.
Function | AgMD1_reset | Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.
Function | AgMD1_ResetInterchangeCheck | -- NOT SUPPORTED -- Resets the interchangeability checking algorithms of the driver so that methods and properties that executed prior to calling this function have no affect on whether future calls to the driver generate interchangeability warnings.
Function | AgMD1_ResetWithDefaults | Does the equivalent of Reset and then, (1) disables class extension capability groups, (2) sets attributes to initial values defined by class specs, and (3) configures the driver to option string settings used when Initialize was last executed.
Function | AgMD1_revision_query | Retrieves revision information from the instrument.
Function | AgMD1_self_test | Performs an instrument self test, waits for the instrument to complete the test, and queries the instrument for the results. If the instrument passes the test, TestResult is zero and TestMessage is 'Self test passed'.
Function | AgMD1_SelfCalibrate | Executes all internal calibrations. If the digitizer does not support calibration, this function silently succeeds.
Function | AgMD1_SendSoftwareArm | This function follows semantics similar to Send Software Trigger. Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of the Send Software Trigger function.
Function | AgMD1_SendSoftwareTrigger | Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this function.
Function | AgMD1_SetAttributeViBoolean | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViInt32 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViInt64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViReal64 | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViSession | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SetAttributeViString | This routine is used to access low-level settings of the instrument. See the attributeID parameter for a link to all attributes of the instrument.
Function | AgMD1_SystemPowerOffAll | Forces all instruments to prepare and enter the system power down state. Suspend all other calling threads. If a thread is performing a long operation which cannot be completed within milliseconds (e.g. a self-calibration), it will be interrupted immediately and will return the status 'ACQIRIS_ERROR_OPERATION_INTERRUPTED'. Note that if an acquisition is still running when the PowerOffAll method is invoked, it might be incomplete or corrupted.
Function | AgMD1_SystemPowerOnAll | Forces all instruments power up and return from the system power down state. Re-enable the instruments at the same state as they were before the PowerOffAll method was invoked. Threads which were suspended will be resumed. However, interrupted operations which returned an error 'ACQIRIS_ERROR_OPERATION_INTERRUPTED' will have to be redone.
Function | AgMD1_SystemResumeControl | Resume the control of an instrument that was suspended (see SuspendControl).
Function | AgMD1_SystemSuspendControl | Suspend control of an instrument to allow using it from another process. NOTE: This is only available for Windows operating systems.
Function | AgMD1_TemperatureGetModuleTemperature | Temperature of the specified module. The units are governed by the Temperature.Units property.
Function | AgMD1_TriggerMagnitudeConfigure | This function sets the magnitude triggering attributes when used with a down-converted Digital Downconverter (DDC) signal. The magnitude trigger function operates in a similar manner to an edge trigger in that it triggers when the Threshold value is passed in the selected Slope direction, but in this case the signal is the magnitude value of the complex down-converted DDC signal. Set Acquisition.Mode = Downconverter and trigger Type = Magnitude before calling this function. The trigger source must be one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this function.
Function | AgMD1_UnlockSession | Releases a previously obtained mutlithread lock.
Function | AgMD1_WaitForAcquisitionComplete | Waits until the configured acquisition is complete. If no acquisition is currently running, this function returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the function returns the Max Time Exceeded error.
Function | AgMD1_WriteIndirectInt32 | Writes the contents of Data to the Indirect Buffer with identifier Id of the FPGA identified by LogicDevice repeated capability.
Function | AgMD1_WriteRegisterInt32 | Writes the 32 bits integer value Value to the register at Offset in the FPGA identified by LogicDevice repeated capability.
Top


Attributes

Attributes

 | Name | Description
Attribute | AGMD1_ATTR_ACQUISITION_AUTO_ARM_ENABLED | If true, auto arming is enabled. If false, after an acquisition has been initiated, SendSoftwareArm method must be called before any triggers will be accepted. Requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_DITHER_ENABLED | If true, enables dithering. Requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_DITHER_RANGE | Sets amplitude of dithering signal. Range: 0 to 31. 0 = dithering amplitude is 0 (i. e. no dithering). 31 = dithering amplitude is Full Scale/2 = 500 mV. Requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_DOWNCONVERSION_DATA_SCALING_ENABLED | Enable or disable the factor 2 scaling of downconversion data. This scaling factor can be used to return the true input signal power of single side band signal resulting from the data downconversion with tuning. The scaling is disabled by default.
Attribute | AGMD1_ATTR_ACQUISITION_MODE | The acquisition mode, Normal digitizer or digital Downconverter. Downconverter mode requires model: M9202A
Attribute | AGMD1_ATTR_ACQUISITION_NUMBER_OF_AVERAGES | The number of waveforms the digitizer acquires and averages before returning to the idle state. Averaged waveforms must be read uisng the Measurement.ReadWaveform methods. Averaging is not supported (ignored) by all FetchWaveform methods. Averaging is enabled by setting the Acquisition.Type property to TypeAverage.
Attribute | AGMD1_ATTR_ACQUISITION_REFERENCE_CHANNEL | The channel to which the reference signal is connected to. Some measurements are relative to a reference signal and require this property to be set accordingly. Valid strings: Channel1, Channel2, ...
Attribute | AGMD1_ATTR_ACQUISITION_START_TIME | The length of time from the trigger event to the first point in the waveform record. The units are seconds. If positive, the first point in the waveform occurs after the trigger. If negative, the first point in the waveform occurs before the trigger.
Attribute | AGMD1_ATTR_ACQUISITION_TIME_PER_RECORD | The time in seconds that corresponds to the record length.
Attribute | AGMD1_ATTR_ACTIVE_TRIGGER_SOURCE | Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability (Channel<n>, External<n>) or "PXI_STAR".
Attribute | AGMD1_ATTR_BOARD_TEMPERATURE | Indicates the temperature of the entire board. The units are governed by the Temperature Units attribute.
Attribute | AGMD1_ATTR_CACHE | Drivers may choose to always cache some instrument settings, never cache others, and optionally cache others, to avoid unecessary I/O to the instrument. If True, the driver caches optionally cached instrument settings.
Attribute | AGMD1_ATTR_CHANNEL_ACTIVE_INPUTS | String indicating which channels are active. Concatenation of 'Ch<n>', e.g. 'Ch1', or 'Ch3Ch4', etc.
Attribute | AGMD1_ATTR_CHANNEL_CONNECTOR_NAME | The connector name as it appears on the instrument's front panel.
Attribute | AGMD1_ATTR_CHANNEL_CONVERTERS_PER_CHANNEL | The number of converters currently assigned to each channel.
Attribute | AGMD1_ATTR_CHANNEL_COUNT | The number of channels.
Attribute | AGMD1_ATTR_CHANNEL_ENABLED | Specifies whether the digitizer acquires a waveform for the channel.
Attribute | AGMD1_ATTR_CHANNEL_INPUT_FREQUENCY_MAX | The maximum input frequency of this channel. It the frequency at which the input circuitry attenuates the input signal by 3 dB. The units are hertz. Returns 0.0 when no filter is set (i.e. max bandwidth).
Attribute | AGMD1_ATTR_CHANNEL_PROBE_ATTENUATION | The scaling factor by which the probe attenuates the input signal. For example, with a 10:1 probe, the value is 10.0.
Attribute | AGMD1_ATTR_CHANNEL_TEMPERATURE | Indicates the temperature of the channel. The units are governed by the Temperature Units attribute.
Attribute | AGMD1_ATTR_CONTROL_IO_SIGNAL_A | Signal present on Control IO connector A. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Attribute | AGMD1_ATTR_CONTROL_IO_SIGNAL_B | Signal present on Control IO connector B. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed, Out-LowLevel, Out-HighLevel, Out-TriggerAcceptedResync.
Attribute | AGMD1_ATTR_CONTROL_IO_SIGNAL_C | Signal present on Control IO connector C if present. Valid strings are: Disabled, In-GateForTriggerAND, Out-10MHzReferenceClock, Out-AcquisitionActive, Out-SkippingToNextSeg, Out-TriggerArmed
Attribute | AGMD1_ATTR_COUNTER_APERTURE_TIME | The minimum measurement time for Frequency and Period modes. The duration to count input pulses for TotalizeGate mode. The Counter.Read method will wait this time before returning measurement data. Units are seconds.
Attribute | AGMD1_ATTR_COUNTER_MODE | The mode for counter measurements, Frequency, Period, TotalizeTime, or TotalizeGate.
Attribute | AGMD1_ATTR_DELAY_CONTROL_COUNT |
Attribute | AGMD1_ATTR_DELAY_CONTROL_ENABLED | Specifies whether the delay controls are set manually. If set to true, all delay controls must be set manually. When false, the delay controls are set by the self-calibration.
Attribute | AGMD1_ATTR_DELAY_CONTROL_MAX | Maximum value (DAC code) that can be set for the delay control.
Attribute | AGMD1_ATTR_DELAY_CONTROL_MIN | Minimum value (DAC code) that can be set for the delay control.
Attribute | AGMD1_ATTR_DELAY_CONTROL_RANGE | Selects the range for the delay control. Useful only for delay controls with multiple ranges.
Attribute | AGMD1_ATTR_DELAY_CONTROL_VALUE | The value (DAC code) set for the delay control.
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DATA_BANDWIDTH | The output bandwidth in Hz for down-converted data. Range: 250e6, 200e6, 100e6, 50e6 etc following progression f(n+1) = f(n)/ 2, down to 2GHz/(2^21) = about 1 kHz. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_DOUBLE_DATA_RATE_ENABLED | False = simple data rate (Samples / second = 1.25*bandwidth), True = double data rate (Samples / second = 2.5*bandwidth) Note: only applies for DataBandwidth values of 1.0e8 and below. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FLIP_BAND_ENABLED | True = First frequency shift is by -500MHz. False = First frequency shift is by +500MHz. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_FREQUENCY_SHIFT | Decoded to set up the frequency shift blocks of the down converter. The value of this attribute corresponds to the data frequency shift; trigger frequency shift is the nearest value available with the given TriggerBandwidth. I. e. the trigger frequency shift equals FrequencyShift if TriggerBandwidth <= DataBandwidth; otherwise it is rounded to the nearest multiple of TriggerBandwidth*2.5/4. Range: -125e6 to +125e6, step = DataBandwidth *2.5 / 4. Requires Model: M9202A
Attribute | AGMD1_ATTR_DIGITAL_DOWNCONVERSION_TRIGGER_BANDWIDTH | The output bandwidth in Hz for down-converted trigger. Requires Model: M9202A
Attribute | AGMD1_ATTR_DOWNCONVERSION_CENTER_FREQUENCY | Specifies the center frequency, in Hz, from which the digitizer should downconvert.
Attribute | AGMD1_ATTR_DOWNCONVERSION_ENABLED | Enables or disables downconversion. When enabled, the Read and Fetch functions return data according to the setting of the Fetch IQ Interleaved Data attribute.
Attribute | AGMD1_ATTR_DOWNCONVERSION_IQ_INTERLEAVED | Controls how the Read and Fetch functions return data when downconversion is enabled. When this attribute is True and downconversion is enabled, the data returned from the Read and Fetch functions is interleaved I-Q data points. When this attribute is False and downconversion is enabled, the Read and Fetch functions return data with all I data points in sequence followed by all Q data points. This attribute has no effect when the Downconversion Enabled attribute is False.
Attribute | AGMD1_ATTR_DRIVER_SETUP | The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.
Attribute | AGMD1_ATTR_EXT_TRIG_RANGE | The absolute value of the trigger signal range the digitizer can use for the external trigger input. The units are Volts. For example, to use a trigger signal spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Attribute | AGMD1_ATTR_GROUP_CAPABILITIES | A comma-separated list of the class capability groups implemented by the driver. Capability group names are documented in the IVI class specifications. If the driver is not class compliant, the driver returns an empty string.
Attribute | AGMD1_ATTR_INPUT_CONNECTOR_SELECTION | Some digitizers include multiple connectors for each digitizer input channel. These connectors are often simply a matter of convenience for system cabling ? multiple signals can be routed to the various connectors, the the desired signal can be sent into the digitizer by changing an internal switch. With other digitizers, the connectors may be of different types or even different impedances. This attribute is used to determine which connector is to be used. Valid values: 1, 2
Attribute | AGMD1_ATTR_INPUT_FILTER_BYPASS | Specifies whether or not to bypass the input filter.
Attribute | AGMD1_ATTR_INPUT_FILTER_MAX_FREQUENCY | Specifies the maximum input filter frequency. Specifying a value of zero means that the device should be set to the full bandwidth that the filter can deliver without being bypassed. The units are Hertz.
Attribute | AGMD1_ATTR_INPUT_IMPEDANCE | The input impedance of this channel. The units are Ohms.
Attribute | AGMD1_ATTR_INSTRUMENT_FIRMWARE_REVISION | The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_AQ_DRV_VERSION | Version of the AqDrv Device Driver. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_AQIO_VERSION | Version of the Agilent Acqiris IO Driver. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_BUS_NUMBER | PCI Bus number. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_CPLD_FIRMWARE_REV | Revision of the CPLD Firmware. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_CRATE_NUMBER | Crate number. Starts at 121000 for autodetected CC121 crates. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_DEVICE_ID | PCI Device ID. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_COMMON_SECTION_REV | Revision of the EEPROM Common Section. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_EEPROM_DIGITIZER_SECTION_REV | Revision of the EEPROM Digitizer Section. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_FUNDAMENTAL_HANDLE | Returns the Int32 equivalent ViSession handle to the fundamental API used to control the module hardware. Never call the fundamental Acqrs_close or Acqrs_closeAll functions with this handle or the driver will cease to operate. Use the IVI driver's Close method instead.
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_HAS_HIGH_RES_SAMPLE_RATE | True if the instrument features a high resolution sampling rate. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBR_EXTERNAL_TRIGGERS | Number of external trigger sources. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBR_INTERNAL_TRIGGERS | Number of internal trigger sources. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBR_MODULES_IN_INSTRUMENT | Number of modules in this instrument. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Individual modules (not connected by ASBus) return 1. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_NBRADC_BITS | Number of bits of data per sample from this module's ADCs. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_OPTIONS | List of comma separated options installed in this instrument. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER | Deprecated - Do not use. Use SerialNumberString. The serial number of the instrument. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_SERIAL_NUMBER_STRING | The serial number string of the instrument. Read only
Attribute | AGMD1_ATTR_INSTRUMENT_INFO_SLOT_NUMBER | The slot number as indicated on the crate's front panel (for Agilent Acqiris CCxxx crates). Read only
Attribute | AGMD1_ATTR_INSTRUMENT_MANUFACTURER | The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes
Attribute | AGMD1_ATTR_INSTRUMENT_MODEL | The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes
Attribute | AGMD1_ATTR_INTERCHANGE_CHECK | If True, the driver maintains a record of interchangeability warnings. If the driver does not support interchangeability checking, attempts to set InterchangeCheck to True return an error.
Attribute | AGMD1_ATTR_IO_RESOURCE_DESCRIPTOR | The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.
Attribute | AGMD1_ATTR_IS_IDLE | Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_IS_MEASURING | Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_IS_WAITING_FOR_ARM | Returns whether the device is currently in the Waiting For Arm state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_IS_WAITING_FOR_TRIGGER | Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.
Attribute | AGMD1_ATTR_LOGIC_DEVICE_COUNT | Returns the number of logic devices.
Attribute | AGMD1_ATTR_LOGICAL_NAME | Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.
Attribute | AGMD1_ATTR_MAX_FIRST_VALID_POINT_VAL | Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.
Attribute | AGMD1_ATTR_MAX_SAMPLES_PER_CHANNEL | Returns the maximum number of samples per channel that can be captured.
Attribute | AGMD1_ATTR_MEASUREMENT_WAVEFORM_TYPE | The waveform type used to calculate the various measurement functions by the FetchWaveformMeasurement and ReadWaveformMeasurement methods.
Attribute | AGMD1_ATTR_MIN_RECORD_SIZE | Indicates the minimum waveform record size. If the digitizer can support any arbitrary size record, then this attribute returns 1.
Attribute | AGMD1_ATTR_NUM_ACQUIRED_RECORDS | Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.
Attribute | AGMD1_ATTR_NUM_RECORDS_TO_ACQUIRE | Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.
Attribute | AGMD1_ATTR_PXI_TRIG_OUT_ENABLED | If true, enables PXI trigger out signal. Not allowed when ActiveSource is "PXI_STAR" as this uses the PXI signal as the trigger input.
Attribute | AGMD1_ATTR_PXI_TRIG_SLOPE | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the ActiveSource attribute is set to "PXI_STAR".
Attribute | AGMD1_ATTR_QUERY_INSTRUMENT_STATUS | If True, the driver queries the instrument status at the end of each method or property that performs I/O to the instrument. If an error is reported, use ErrorQuery to retrieve error messages one at a time from the instrument.
Attribute | AGMD1_ATTR_RANGE_CHECK | Drivers may choose to always validate some property/parameter values, never validate others, and optionally validate others, to avoid sending invalid commands to the instrument. If True, the driver performs optional validations.
Attribute | AGMD1_ATTR_RECORD_COERCIONS | If True, the driver keeps a list of the value coercions it makes for ViInt32 and ViReal64 attributes. If the driver does not support coercion recording, attempts to set RecordCoercions to True will return an error.
Attribute | AGMD1_ATTR_RECORD_SIZE | Specifies the number of samples to acquire in each waveform record.
Attribute | AGMD1_ATTR_REFERENCE_LEVEL_HIGH | The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGMD1_ATTR_REFERENCE_LEVEL_LOW | The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGMD1_ATTR_REFERENCE_LEVEL_MID | The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.
Attribute | AGMD1_ATTR_REFERENCE_OSCILLATOR_EXTERNAL_FREQUENCY | Specifies the frequency of the external signal which is as a frequency reference. This value is used only if the Reference Oscillator Source attribute is set to External. The units are Hertz.
Attribute | AGMD1_ATTR_REFERENCE_OSCILLATOR_OUTPUT_ENABLED | Specifies whether or not the reference frequency signal appears at the Control I/O "A" connector of the digitizer.
Attribute | AGMD1_ATTR_REFERENCE_OSCILLATOR_SOURCE | Specifies the reference frequency source used.
Attribute | AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_DIVIDER | Specifies the value by which the external sample clock should be divided. This value is used only if the Sample Clock Source attribute is set to External.
Attribute | AGMD1_ATTR_SAMPLE_CLOCK_EXTERNAL_FREQUENCY | Specifies the frequency of the external signal which is used as a sample clock. This value is used only if the Sample Clock Source attribute is set to External. The units are Hertz.
Attribute | AGMD1_ATTR_SAMPLE_CLOCK_SOURCE | Specifies the clock used to pace acquisition sampling.
Attribute | AGMD1_ATTR_SAMPLE_MODE | -- NOT SUPPORTED, Always RealTime mode -- Specifies the sample mode used by the digitizer.
Attribute | AGMD1_ATTR_SAMPLE_RATE | Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.
Attribute | AGMD1_ATTR_SIMULATE | If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MAJOR_VERSION | Returns the major version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_CLASS_SPEC_MINOR_VERSION | Returns the minor version number of the class specification in accordance with which the IVI specific driver was developed. Zero is returned if the driver is not compliant with a class specification.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_DESCRIPTION | Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_PREFIX | Returns the case-sensitive prefix of the user-callable functions that the IVI-C specific driver exports. The string that this attribute returns contains a maximum of 32 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_REVISION | Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SPECIFIC_DRIVER_VENDOR | Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.
Attribute | AGMD1_ATTR_SUPPORTED_INSTRUMENT_MODELS | A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.
Attribute | AGMD1_ATTR_SYSTEM_NBR_INSTRUMENTS | The number of instruments supporting the AgMD1 driver in the system. An "instrument" may be a single digitizer module or multiple modules joined using the ASBus connectors. Read only
Attribute | AGMD1_ATTR_SYSTEM_TRACE_ENABLED | If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.
Attribute | AGMD1_ATTR_TEMPERATURE_UNITS | Specifies the temperature units returned by the Board Temperature and the Channel Temperature attributes.
Attribute | AGMD1_ATTR_TIME_INTERLEAVED_CHANNEL_LIST | This attribute is used to combine this channel with one or more other channels to achieve higher effective sampling rates and/or greater memory depth. The string provided here specifies which channels should operate in combined mode with the current channel. This attribute is a comma-separated list of one, two, or more channel names.
Attribute | AGMD1_ATTR_TRIGGER_COUPLING | Specifies how the digitizer couples the trigger source.
Attribute | AGMD1_ATTR_TRIGGER_DELAY | Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.
Attribute | AGMD1_ATTR_TRIGGER_HYSTERESIS | Specifies the trigger hysteresis in Volts.
Attribute | AGMD1_ATTR_TRIGGER_LEVEL | Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.
Attribute | AGMD1_ATTR_TRIGGER_MAGNITUDE_DWELL_TIME_SAMPLES | Positive values of dwell time indicate the number of samples that must be in the initial trigger state (e.g. below the low threshold for a rising edge trigger) before a trigger will be recognized. Negative values of dwell time indicate the number of samples that must be in the second trigger state before a trigger is recognized.
Attribute | AGMD1_ATTR_TRIGGER_MAGNITUDE_SLOPE | Specifies whether a rising (Positive) or a falling (Negative) magnitude triggers the digitizer.
Attribute | AGMD1_ATTR_TRIGGER_MODIFIER | Specifies the trigger modifier. The trigger modifier determines the digitizer's behavior in the absence of the configured trigger.
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_ENABLED | Specifies whether or not an accepted trigger appears at an output of the digitizer.
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_MULTI_MODULE_SYNC_ENABLED | M9202A Multi Module Synchronization. Enable a M9202A to be the trigger master to synchronize multiple other M9202A modules (the trigger slaves modules). For all modules to synchronize, only one module can be the trigger master module while all others must be trigger slave modules.
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_OFFSET | Control of the Trigger Out signal offset. This offset and the actual load connected will determine the signal shape (range).
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_RESYNC_ENABLED | Controls whether the trigger out signal is resynchronized to the sampling clock (true) or maintains a precise timing relation to the trigger input (false).
Attribute | AGMD1_ATTR_TRIGGER_OUTPUT_SOURCE | Select the trigger source to drive the TRG OUT output connector on the front panel. Possible values are Channel1, ..., Channel<n> or External1, ..., External<n> trigger sources where <n> is the number of available channels or external trigger inputs. For M9703A, possible values are TriggerCompare, TriggerAccepted, AXIe_TRIG0, AXIe_TRIG1, ..., AXIe_TRIG11, AXIe_STRIG, HighLevel, LowLevel.
Attribute | AGMD1_ATTR_TRIGGER_SLOPE | Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.
Attribute | AGMD1_ATTR_TRIGGER_SOURCE_COUNT | The number of trigger sources.
Attribute | AGMD1_ATTR_TRIGGER_SOURCE_LIST | A comma separated list of source names to be used in a multi trigger scenario. This attribute only affects instrument behavior when the Trigger Source Operator attribute is set to AND or OR. When Trigger Source Operator is set to AND, the trigger conditions associated with each source in this list must be simultaneously satsified in order to trigger the digitizer. When Trigger Source Operator is set to OR, the first trigger source in the list that satisfies its trigger conditions will trigger the digitizer. Any valid name used for the Trigger Source attribute may be used in this list. A trigger source may appear only once in the list. If a name in the list is not recognized, the driver returns the Unknown Channel Name error. See IVI-3.2 for the definition of this error.
Attribute | AGMD1_ATTR_TRIGGER_SOURCE_OPERATOR | Specifies the boolean operation to apply to the arm sources specified by the Trigger Source List attribute. See the definition of that attribute for details.
Attribute | AGMD1_ATTR_TRIGGER_TYPE | The kind of event that triggers the digitizer. TV triggering requires External trigger source.
Attribute | AGMD1_ATTR_TV_TRIGGER_EVENT | Specifies the event on which the digitizer triggers.
Attribute | AGMD1_ATTR_TV_TRIGGER_LINE_NUMBER | Specifies the line on which the digitizer triggers. The driver uses this attribute when the TV Trigger Event is set to TV Event Line Number. The line number setting is independent of the field. This means that to trigger on the first line of the second field, the user must configure the line number to the value of 263 (if we presume that field one had 262 lines).
Attribute | AGMD1_ATTR_TV_TRIGGER_POLARITY | Specifies the polarity of the TV signal.
Attribute | AGMD1_ATTR_TV_TRIGGER_SIGNAL_FORMAT | Specifies the format of TV signal on which the digitizer triggers.
Attribute | AGMD1_ATTR_VERTICAL_COUPLING | Specifies how the digitizer couples the input signal for the channel.
Attribute | AGMD1_ATTR_VERTICAL_OFFSET | The location of the center of the range that you specify with the Range attribute. The units are Volts, with respect to ground. For example, to acquire a sine wave spanning 0.0 to 10.0 volts, set Offset to 5.0 volts.
Attribute | AGMD1_ATTR_VERTICAL_RANGE | The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 10.0 volts.
Top


Errors and Warnings

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Errors and Warnings

Errors

Name | Value (Hex) | Value (Decimal) | Description
AGMD1_ERROR_CANNOT_RECOVER | 0xBFFA0000 | -1074135040 | Failure cannot recover.
AGMD1_ERROR_INSTRUMENT_STATUS | 0xBFFA0001 | -1074135039 | Instrument error detected. Use ErrorQuery() to determine the error(s).
AGMD1_ERROR_CANNOT_OPEN_FILE | 0xBFFA0002 | -1074135038 | Cannot open file.
AGMD1_ERROR_READING_FILE | 0xBFFA0003 | -1074135037 | Error reading file.
AGMD1_ERROR_WRITING_FILE | 0xBFFA0004 | -1074135036 | Error writing file.
AGMD1_ERROR_INVALID_PATHNAME | 0xBFFA000B | -1074135029 | The pathname is invalid.
AGMD1_ERROR_INVALID_VALUE | 0xBFFA0010 | -1074135024 | Invalid value (%1) for method %2, parameter %3.
AGMD1_ERROR_FUNCTION_NOT_SUPPORTED | 0xBFFA0011 | -1074135023 | Does not support this class-compliant feature: method %1
AGMD1_ERROR_ATTRIBUTE_NOT_SUPPORTED | 0xBFFA0012 | -1074135022 | Does not support this class-compliant feature: property %1.
AGMD1_ERROR_VALUE_NOT_SUPPORTED | 0xBFFA0013 | -1074135021 | Does not support this class-compliant feature: (enumeration) value %1 passed as the value for parameter %2 in method %3.
AGMD1_ERROR_NOT_INITIALIZED | 0xBFFA001D | -1074135011 | A connection to the instrument has not been established.
AGMD1_ERROR_UNKNOWN_CHANNEL_NAME | 0xBFFA0020 | -1074135008 | Unknown channel name.
AGMD1_ERROR_TOO_MANY_OPEN_FILES | 0xBFFA0023 | -1074135005 | Too many files are open.
AGMD1_ERROR_CHANNEL_NAME_REQUIRED | 0xBFFA0044 | -1074134972 | A channel name is required.
AGMD1_ERROR_MISSING_OPTION_NAME | 0xBFFA0049 | -1074134967 | The option string is missing an option name.
AGMD1_ERROR_MISSING_OPTION_VALUE | 0xBFFA004A | -1074134966 | The option string is missing an option value.
AGMD1_ERROR_BAD_OPTION_NAME | 0xBFFA004B | -1074134965 | The %1 name in the option string is unknown.
AGMD1_ERROR_BAD_OPTION_VALUE | 0xBFFA004C | -1074134964 | The %1 value in the option string is unknown.
AGMD1_ERROR_OUT_OF_MEMORY | 0xBFFA0056 | -1074134954 | Could not allocate necessary memory.
AGMD1_ERROR_OPERATION_PENDING | 0xBFFA0057 | -1074134953 | Operation in progress.
AGMD1_ERROR_NULL_POINTER | 0xBFFA0058 | -1074134952 | Null pointer passed for method %1, parameter %2.
AGMD1_ERROR_UNEXPECTED_RESPONSE | 0xBFFA0059 | -1074134951 | Unexpected response from instrument.
AGMD1_ERROR_FILE_NOT_FOUND | 0xBFFA005B | -1074134949 | File not found.
AGMD1_ERROR_INVALID_FILE_FORMAT | 0xBFFA005C | -1074134948 | Invalid file format.
AGMD1_ERROR_STATUS_NOT_AVAILABLE | 0xBFFA005D | -1074134947 | The instrument status is not available.
AGMD1_ERROR_ID_QUERY_FAILED | 0xBFFA005E | -1074134946 | Instrument ID query failed.
AGMD1_ERROR_RESET_FAILED | 0xBFFA005F | -1074134945 | Instrument reset failed.
AGMD1_ERROR_RESOURCE_UNKNOWN | 0xBFFA0060 | -1074134944 | Unknown resource.
AGMD1_ERROR_ALREADY_INITIALIZED | 0xBFFA0061 | -1074134943 | The driver is already initialized.
AGMD1_ERROR_CANNOT_CHANGE_SIMULATION_STATE | 0xBFFA0062 | -1074134942 | The simulation state cannot be changed.
AGMD1_ERROR_INVALID_NUMBER_OF_LEVELS_IN_SELECTOR | 0xBFFA0063 | -1074134941 | The number of levels in the selector is not valid for the %1 repeated capability.
AGMD1_ERROR_INVALID_RANGE_IN_SELECTOR | 0xBFFA0064 | -1074134940 | The range %1 is not valid for the repeated capability %2.
AGMD1_ERROR_UNKOWN_NAME_IN_SELECTOR | 0xBFFA0065 | -1074134939 | Unknown name in selector.
AGMD1_ERROR_BADLY_FORMED_SELECTOR | 0xBFFA0066 | -1074134938 | The repeated capability selector is badly-formed.
AGMD1_ERROR_UNKNOWN_PHYSICAL_IDENTIFIER | 0xBFFA0067 | -1074134937 | Unknown physical repeated capability selector.
AGMD1_ERROR_TRIGGER_NOT_SOFTWARE | 0xBFFA1001 | -1074130943 |
AGMD1_ERROR_CHANNEL_NOT_ENABLED | 0xBFFA2001 | -1074126847 |
AGMD1_ERROR_MAX_TIME_EXCEEDED | 0xBFFA2002 | -1074126846 |
AGMD1_ERROR_ARM_NOT_SOFTWARE | 0xBFFA2003 | -1074126845 |
AGMD1_ERROR_INCOMPATIBLE_FETCH | 0xBFFA2004 | -1074126844 |
AGMD1_ERROR_PERSONALITY_NOT_ACTIVE | 0xBFFA4211 | -1074118127 | Personality is not active.
AGMD1_ERROR_PERSONALITY_NOT_INSTALLED | 0xBFFA4212 | -1074118126 | Personality is not installed.
AGMD1_ERROR_PERSONALITY_NOT_LICENSED | 0xBFFA4213 | -1074118125 | Personality is not licensed.
AGMD1_ERROR_IO_GENERAL | 0xBFFA4214 | -1074118124 | I/O error.
AGMD1_ERROR_IO_TIMEOUT | 0xBFFA4215 | -1074118123 | I/O timeout error.
AGMD1_ERROR_MODEL_NOT_SUPPORTED | 0xBFFA4216 | -1074118122 | Instrument model does not support this feature.
AGMD1_ERROR_MODULE_API | 0xBFFA4217 | -1074118121 | An error was returned from the module fundamental API.
Top

Warnings

Name | Value (Hex) | Value (Decimal) | Description
AGMD1_SUCCESS | 0x0 | 0 | Success.
AGMD1_WARN_NSUP_ID_QUERY | 0x3FFA0065 | 1073348709 | ID Query is not supported by this instrument.
AGMD1_WARN_NSUP_RESET | 0x3FFA0066 | 1073348710 | Reset is not supported by this instrument.
AGMD1_WARN_NSUP_SELF_TEST | 0x3FFA0067 | 1073348711 | Self test is not supported by this instrument.
AGMD1_WARN_NSUP_ERROR_QUERY | 0x3FFA0068 | 1073348712 | Error query is not supported by this instrument.
AGMD1_WARN_NSUP_REV_QUERY | 0x3FFA0069 | 1073348713 | Firmware revision query is not supported by this instrument.
AGMD1_WARN_CALIBRATED_WITH_INTERNAL_CLOCK | 0x3FFA4001 | 1073364993 |
Top


IVI Backgrounder

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IVI Backgrounder

The IVI Foundation is an open consortium founded in 1998 to promote standards for programming test instruments. Composed primarily of instrument manufacturers, end-users, software vendors, and system integrators, the Foundation strives to create specifications that govern the development of instrument drivers.

IVI-compliant drivers offer a number of benefits, such as a consistent programming interface, better performance, seamless integration into a wide variety of development environments, and interchangeability. Interchangeability refers to the ability of an end user to replace one IVI driver in an application program with another IVI driver from a different vendor, without modifying or even recompiling the application program. To achieve interchangeability, IVI driver developers must carefully follow all of the requirements laid out in the IVI Foundation specifications.

The following sections present an overview of some of the most important IVI topics for driver developers. This document does not attempt to reproduce all of the details contained in the IVI specifications. For complete information on IVI and for the most up-to-date versions of all IVI specifications and components, visit the IVI Foundation web site.

In This Section

What All IVI Drivers Do -- Inherent Capabilities

Explains how to basic functionality that all IVI drivers support.

Two Flavors of IVI -- IVI-COM and IVI-C

Compares IVI-COM and IVI-C drivers.

How IVI Drivers Provide Interchangeability

Explains the basics of how interchangeability works with IVI-COM and IVI-C.

Instrument-Specific Capabilities

Provides a brief explanation of non-interchangeable device-specific functionality in IVI drivers.

IVI Shared Components

Provides an introduction to the shared software components required for an IVI-based system.

IVI Configuration Store

Information on using the IVI Configuration Store with the driver.

Repeated Capabilities

Explains IVI repeated capabilities along with the notions of physical and virtual names.

LXI Fundamentals

Presents an introduction to the LXI standards and how they relate to IVI drivers.

Installation

Where IVI drivers are installed and what components are required.


What All IVI Drivers Do -- Inherent Capabilities

[image]

AgMD1 IVI Driver Reference Agilent Technologies
What All IVI Drivers Do -- Inherent Capabilities

The IVI Foundation has established a set of functions and attributes that all IVI drivers must support -- irrespective of which IVI instrument class the driver supports. These common functions and attributes are called IVI inherent capabilities and they are documented in IVI-3.2 -- Inherent Capabilities Specification. Importantly, drivers that do not support any IVI instrument class must still support the IVI inherent capabilities.

Having a common set of basic functionality that all IVI drivers must support ensures that end users have a standard, recognizable way to perform basic operations with the IVI driver. If an end user has programmed with an IVI driver of any type before, they will immediately know how to perform at least basic tasks with any new IVI driver they encounter. Some of the tasks that fall under the inherent capabilities specification are:

  • Initializing the driver.
  • Querying errors from the driver.
  • Enabling standard driver features, such as simulation, state caching, and range checking.
  • Identifying the capabilities of the driver, such as the supported instrument classes, capability groups.
  • Reading driver and instrument identification information.
  • Performing instrument self-test and reset operations.

A detailed description of the IVI inherent capabilities can be found in the Reference section under the topic IviDriver.

Standard Driver Features

IVI drivers may offer several different features whose behavior has been standardized by the IVI Foundation. Although these are referred to as standard driver features, they are not all required to be supported by an IVI driver, as shown in the table below:

Feature | Required
State caching | No
Range checking | No
Coercion and coercion recording | No
Interchangeability checking | No
Simulation | Yes

The remainder of this topic discusses each driver feature in detail.

State Caching -- Optional

As a means to offer better performance in customer test applications, IVI drivers often support a feature known as state caching. The principle of state caching is quite simple, although in practice it can be extraordinarily difficult to implement properly.

When a end user enables state caching for an IVI driver, the driver attempts to determine if new settings passed into the driver are different from the actual instrument state. In this way, I/O traffic between the driver and the instrument is reduced, as fewer I/O calls are performed.

In the simplest example of when state caching improves performance, consider what happens when a user passes identical values several times in a row for the frequency property on a function generator driver. Without state caching, each call into the driver would result in an I/O function call to the instrument, whereas a driver performing state caching would detect that subsequent calls to the frequency property were redundant and should not result in any communication with the instrument. Correspondingly, the driver can "remember" the last known value for instrument properties so that queries can be performed by retrieving data from computer memory, rather than by performing instrument I/O.

As with caching schemes in other types of software systems, IVI driver state caching is frought with potential pitfalls. The chief challenge in properly implementing state caching is maintaining cache coherency. Complex instruments often have complex couplings between instrument settings, making it difficult for the driver to track whether or not settings stored in the driver cache are valid. Consequently, many instrument vendors choose not to implement state caching in the driver.

For more information on state caching, see IVI-3.1: Driver Architecture Specification.

Range Checking -- Optional

Range checking in IVI drivers simply refers to the ability for the driver to test whether or not input values passed to the driver are within an acceptable range. End users typically use range checking during debugging and, after validation is complete, disable it to maximize performance.

For more information on range checking, see IVI-3.1: Driver Architecture Specification.

Coercion and Coercion Recording -- Optional

Instruments often accept only a discrete set of values for certain properties. For example, a DMM might only accept values such as 10 V, 100 V, 300 V for the voltage range setting. These discrete value sets will necessarily be different for different vendor's instruments. An Agilent® DMM may accept 10 V, 100 V, 300 V while a Fluke DMM accepts 20 V, 200 V, and 400 V. As a result, IVI class specifications are forced to define such real-valued properties as accepting a continuous range of values, even though the underlying instrument only accepts a discrete set of values.

Following along with the DMM voltage range example, if a user sends a value of 150 V for the voltage range, the instrument will internally coerce the value to one of the accepted values, such as 300 V. To maximize interchangeability, the IVI class specifications provide guidance on how IVI drivers should coerce user requested values for specific properties.

To aid end users in building interchangeable applications, IVI drivers may implement a feature called coercion recording. If a user enables coercion recording, the IVI driver retains a log of each user value that it coerces. Standard functions in the IVI inherent capabilities provide the user with access to the driver's coercion log.

For more information on coercion, see IVI-3.1: Driver Architecture Specification.

Interchangeability checking -- Optional

A program written using an IVI driver will not be interchangeable if the program relies upon default settings within the instrument. This is because different instruments will have different default values for many important settings. Repeatable results can only be obtained if all of the instrument settings on which an operation depends are in a user-specified state.

IVI drivers may implement a feature called interchangeability checking to ensure that driver attributes relevant to a particular operation are in a user-specified state whenever that operation is performed. The IVI instrument class specifications all include class-specific sections detailing which driver attributes need to be in a known state for particular operations. The driver can then track these attributes and report a warning if one or more are not set explicitly by the client program before an important operation is performed.

Standard functions in the IVI inherent capabilities provide the user with the ability to enable interchangeability checking in the driver and to retrieve any warnings that occur. Typically, this feature is only used during development and debug of an application and disabled during normal operation, so as not to adversely impact performance.

For more information on interchangeability checking, see IVI-3.1: Driver Architecture Specification.

Simulation -- Required

IVI drivers are often constructed for complex instruments that are difficult to procure or that are in high demand at the end user facility. Consequently, it may be the case that end users need to be able to test their application programs without being physically connected to an instrument. IVI driver simulation is a feature that allows end users to use IVI drivers without a physical connection to the instrument.

When an end user enables simulation in an IVI driver, the driver performs no I/O communication whatsoever. IVI drivers are free in their choice of mechanisms for returning meaningful output values to the end user, but the intent is that the user program should be able to proceed normally when calling functions on the driver. This allows the end user to exercise their test application before the actual hardware is available.

For more information on simulation, see IVI-3.1: Driver Architecture Specification.


Two Flavors of IVI -- IVI-COM and IVI-C

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Two Flavors of IVI -- IVI-COM and IVI-C

IVI drivers currently come in two basic types -- IVI-COM and IVI-C. Although the functionality offered by both types of driver is often very similar, the fundamental differences in interface technology results in a very different end-user experience. This topic discusses some of the important differences between IVI-COM and IVI-C drivers.

IVI-COM and IVI-C at a Glance

The table below presents a summary of some of the important differences between IVI-COM and IVI-C drivers. A brief explanation of each point is given later in this topic.

IVI-COM IVI-C
Files Supplied
  • COM DLL (<Driver>.dll).
  • .NET DLL (<Company>.<Driver>.Interop.dll).
  • Windows DLL (<prefix>.dll).
  • Header file (<prefix>.h).
  • Import library (<prefix>.lib).
  • Function panel file (<prefix>.fp).
  • Attribute information file (<prefix>.sub).
ADEs of Choice
  • Visual C#.
  • Visual C++.
  • Visual Basic.NET.
  • LabWindows™/CVI.
.NET Support
  • Use interop assembly as per IVI specs.
  • No manual coding in client program.
  • Interchangeability supported.
  • No standard mechanism.
  • Manual coding in client program.
  • Interchangeability not possible.
Interchangeability
  • Use COM session factory.
  • No 3rd party components.
  • Multiple instrument classes per driver possible.
  • Requires 3rd-party class drivers.
  • Only one instrument class per driver.
Data Types
  • COM data types.
  • Strings and arrays are self-describing.
  • Memory can be allocated by the driver or by the client.
  • VISA data types.
  • Strings and arrays require extra parameters to indicate size.
  • Memory must be allocated by the client program.
Attribute Programming
  • Same as methods (built-in).
  • Attributes can have parameters.
  • Use attribute accessors and C macros.
  • GetAttributeViReal64, etc..
  • Attributes cannot have parameters.

IVI-COM Basics

IVI-COM drivers use Microsoft's standard COM technology to expose the driver's methods and properties. COM is a proven standard for building reusable, cross-language components on Windows. IVI-COM methods and properties are organized into interfaces that together form a hierarchy of driver functionality. IVI-COM drivers use standardized COM data types that can be understood in a wide variety of ADEs (application development environments).

IVI-COM Type Libraries

IVI-COM drivers are packaged as DLLs, like conventional Windows components. However, unlike conventional Windows components, IVI-COM DLLs contain description information about the functionality of the driver. This information is called the type library and offers such details as the name and signature of all driver functions, version information, parameter input/output direction, and even help information. Since the type library information is baked into the DLL, IVI-COM drivers are fully self-describing. This makes them easier to use in building programs because the developer only has to reference a single DLL to import the driver into their development environment. This also allows IVI-COM drivers to be used seamlessly in .NET programming languages, as is discussed later in this topic.

IVI-C Basics

IVI-C drivers are provided as conventional Windows DLLs with entry points exposed for each function supported by the driver. In addition to the DLL, IVI-C drivers include a header file (.h) and an import library (.lib). You use an IVI-C driver by including the header file in your program source code and then linking to the .lib file. IVI-C drivers use VISA data types, such as ViInt32, ViReal64, and ViChar.

IVI-C Function Panel and Attribute Files

Since IVI-C drivers rely upon basic Windows DLL technology, there is no way to represent a hierarchy of driver functionality in the DLL itself. Instead, IVI-C drivers use two additional files to present the logical organization of driver functions and attributes. The function panel file (.fp) is a variable-record binary file that presents the function hierarchy only. The attribute hierarchy is managed in a separate file called the attribute information file (.sub). The .sub file is a text file. The function and attribute hierarchies are managed separately because IVI-C development was heavily influenced by VXI Plug-n-Play driver standards, which had already established this bifurcation.

ADE Support for IVI-COM and IVI-C Drivers

Arguably the most important consideration in comparing IVI-COM and IVI-C drivers is the end user experience in various ADEs. Since IVI-COM drivers are based on Microsoft COM technology, it's not surprising that IVI-COM drivers offer the richest user experience in Microsoft ADEs. Users working in Visual C++, Visual C#, Visual Basic.NET and Visual Basic 6 will enjoy a host of features, such as object browsers, IntelliSense, and context-sensitive help.

IVI-COM drivers are also well-supported in environments targeting the test and measurement industry. Agilent® VEE® and MATLAB® provide built-in support for IVI-COM drivers, as does National Instruments® LabVIEW®. As of LabVIEW 8.0, a new feature called the Class Browser appeared, greatly simplifying the use of IVI-COM drivers in LabVIEW.

For more details on using an IVI-COM driver in various ADEs, see the topic Programming with the IVI-COM Driver in Various Development Environments.

The ADE story for IVI-C centers primarily around National Instruments LabWindows/CVI. IVI-C drivers work seamlessly in LabWindows/CVI, with built-in support for rendering the hierarchies and function panels stored in the .fp and .sub files. In all other environments, however, IVI-COM drivers provide a better user experience. LabWindows/CVI is a special case where IVI-COM drivers do not fare well. Users working in LabWindows/CVI will have a fundamental expectation that an IVI-C driver be provided for any instrument they need to use in that environment.

.NET Support and Interop Assemblies

Microsoft provides excellent .NET support for all COM components through .NET wrappers called interop assemblies. These interop assemblies are generated automatically with standard Microsoft tools (such as Visual Studio) and present a familiar .NET interface to a COM component. Since IVI-COM drivers are standard COM components, these interop assemblies can be produced for IVI-COM drivers in precisely the same way as for any other COM component. Programmers working in any .NET environment (C#, VB.NET, C++) can work with the IVI-COM driver as if it were a native .NET component.

The IVI Foundation provides a specification prescribing how this should be done, so that end users have a consistent experience with IVI-COM drivers in .NET. Please see IVI-3.14: Primary Interop Assembly Specification for details on building IVI-COM interop assemblies. More importantly, the IVI Foundation provides the interop assemblies required for achieving .NET interchangeability with IVI-COM drivers. These are installed as part of the IVI Shared Components.

In the "\IVI\Bin\Primary Interop Assemblies" subfolder of your IVI installation directory, you will find the interop assemblies for the IVI instrument classes as well as those for specific instrument drivers. The interop assemblies shipped by the IVI Foundation have names such as Ivi.Dmm.Interop.dll and Ivi.SpecAn.Interop.dll. Correspondingly, all instrument-specific interop assemblies must follow an IVI-specified convention:
<Company>.<Driver>.Interop.dll

Since IVI-C drivers are conventional Windows DLLs, there is no standard mechanism for creating .NET wrappers for IVI-C drivers. Instead, client programmers must add special declarations to their program for any IVI-C driver function they wish to use in their application. These declarations must be adorned with special .NET attributes that instruct the .NET environment on what kind of function is inside the driver. (For details on what's required to call DLL functions in .NET, see the MSDN documentation regarding the "DllImport" attribute and a featured called "P/Invoke".) The critical thing to note is that because there is no standard mechanism for creating .NET wrappers on conventional Windows DLLs, the IVI Foundation cannot supply a standard mechanism for programming against IVI-C drivers in .NET. Thus, interchangeability with IVI-C drivers in .NET is not possible.

Interchangeability

IVI-COM drivers and IVI-C drivers differ fundamentally is how they allow you to write interchangeable programs. With IVI-COM drivers, the developer references a standard, IVI Foundation-supplied DLL that defines the functions and attributes for a particular instrument class. These Foundation-supplied DLLs are referred to as the IVI-COM type libraries, and they are automatically installed as part of the IVI Shared Components. Another shared component called the COM Session Factory is used to instantiate an IVI-COM driver without having a hard-coded reference to the specific driver in use.

The topic Writing Interchangeable Code Using the IviDigitizer Class-Compliant Interfaces provides examples on interchangeable programming with the IVI-COM driver while the topic Writing Interchangeable Code Using the IviDigitizer Class Driver illustrates how to write interchangeable programs using the IVI-C driver.

One important distinction between IVI-COM and IVI-C drivers when considering interchangeability is the number of instrument classes a single driver can support. Some instruments actually have functionality that spans more than one instrument class. For instance, some popular switch measure units offer both IviDmm and IviSwtch functionality, so supporting both sets of IVI-defined interfaces is very useful. With IVI-COM, a single driver such an instrument can be accommodated, as IVI-COM drivers can support any number of instrument classes at once. IVI-C drivers, however, have a fundamental limitation imposed by the attribute model they use. Each attribute in IVI-C is assigned a numeric identifier, but these identifiers are only unique within an instrument class -- not between instrument classes. Because of this, an IVI-C driver would not be able to support attributes from more than one instrument class, and so only a single class can be supported by any IVI-C driver.

Data Types

IVI-COM and IVI-C drivers use two different sets of data types. IVI-COM drivers use a special subset of the COM data type system, called automation data types. Simply put, this type system is designed to allow common access from a wide range of programming languages -- from Visual Basic 6 to C++ to C#. IVI-C drivers, on the other hand, use the VISA data type system, which is based on classic C data types.

The primitive data types, such as integers, floating point numbers, and booleans are represented similarly in both IVI-COM and IVI-C drivers. The key differences are in how arrays and strings are handled. IVI-COM drivers use the SAFEARRAY data type to represent arrays and the BSTR data type to represent strings. These data types are self describing in that the SAFEARRAY contains the number of elements in the array and the BSTR contains the length of the string. This means that when passing array parameters into or out of an IVI-COM driver, no extra parameters are required to describe the array. IVI-C drivers, on the other hand, need to pass extra "size" parameters to any IVI-C function that uses an array or string. (It is also a useful note that BSTR strings are allowed to contain embedded NULL characters, whereas IVI-C ViString parameters must always be NULL-terminated.)

In the IVI-COM example below, a client program is calling an IVI-COM driver function to fetch an array of measurements from the instrument. Note how only the array parameter need be returned from the function, as the size of the array is embedded in the SAFEARRAY data type.

C++ Copy image Copy Code
double[] data;
scope.Measurement.FetchWaveform(ref data);

In the IVI-C example below, a client program is calling an IVI-C driver function to read from the instrument. In constrast to the previous IVI-COM example, the IVI-C programmer must pass in two extra parameters to describe the array -- one for the client to tell the driver the size of the input array, and one for the driver to tell the client how many array elements were returned.

C++ Copy image Copy Code
ViSession vi;
/* session initialization omitted for clarity */

ViReal64 waveform[1000];
ViInt32 waveformSize = 1000;
ViInt32 actualSize;
ViStatus status = IviScope_FetchWaveform(vi, VI_NULL, waveformSize, waveform, &actualSize);

Memory Allocation

IVI-COM and IVI-C drivers use opposite rules for memory allocation. This is important when dealing with string and array parameters. In IVI-COM, the driver typically allocates the memory associated with an output parameter, such as an array of measurement data. This is convenient for the end user because they do not need to know how much memory to allocate ahead of time. The driver simply allocates the memory required to return the output data. In some situations, such as when dealing with very large data sets, it may be desirable for the client program to pre-allocate memory and pass it to the driver. This allows memory to be reused across multiple calls to the driver. To support this use case, IVI-COM drivers allow pre-allocated memory to be passed in as well.

When using IVI-C drivers, the calling program must always allocate the memory for an output parameter. This requires the caller to know how much memory to allocate ahead of time and to pass in an extra parameter to the driver indicating the amount of memory that was allocated. This prevents the driver from writing too much data into the output parameter. The driver must then return an additional output parameter that indicates how much data was actually copied into the output buffer. It's up to the client program to determine whether or not all of the data has been retrieved.

Programming with Attributes

In both IVI-COM and IVI-C, drivers use functions and attributes to control the instrument. In both models, functions typically represent operations, such as taking a measurement, while attributes typically represent instrument settings, such as range or resolution. However, IVI-COM and IVI-C drivers have a very different model for programming attributes.

The IVI-COM model for programming attributes is straightforward. The functions and attributes are part of the same hierarchy. The user accesses an attribute using a simple assignment statement, as in the following:

C++ Copy image Copy Code
// Set the sample rate to 1000
scope.Acquisition.SampleRate = 1000;

Conventional Windows DLLs have no built-in notion of attributes, so IVI-C drivers rely upon a special idiom where dedicated "getter" and "setter" functions are used along with C macro identifiers. Every IVI-C driver supports the following standard set of attribute accessors, organized based on the data type of the attribute:

  • GetAttributeViInt32, SetAttributeViInt32
  • GetAttributeViInt64, SetAttributeViInt64
  • GetAttributeViReal64, SetAttributeViReal64
  • GetAttributeViString, SetAttributeViString
  • GetAttributeViBoolean, SetAttributeViBoolean
  • GetAttributeViSession, SetAttributeViSession

Each IVI-C attribute has an associated #define'd constant in the driver header file, and this constant is passed to the appropriate getter or setter function to read or write the attribute, as in the following example:

C++ Copy image Copy Code
ViSession vi;
/* session initialization omitted for clarity */

/* Set the sample rate to 1000 */
ViStatus status = IviScope_SetAttributeViReal64(vi, VI_NULL, IVISCOPE_ATTR_HORZ_SAMPLE_RATE, 1000);

A couple of things are noteworthy about the IVI-C attribute model. First, the programmer must take care to use the correct type of attribute setter or getter for the attribute in question. In the above example, the IVISCOPE_ATTR_HORZ_SAMPLE_RATE attribute is a double-precision floating-point value, and the end user must know this when programming with the driver. There is no way for the compiler to catch any error, such as using SetAttributeViInt32 with a boolean type attribute.

The other thing to note about the IVI-C attribute model is that since the setter and getter function signatures are fixed for all attributes, there is no way to have parameterized attributes. In contrast, IVI-COM drivers support attributes with parameters.


How IVI Drivers Provide Interchangeability

[image]

AgMD1 IVI Driver Reference Agilent Technologies
How IVI Drivers Provide Interchangeability

What is an IVI Instrument Class?

The IVI Foundation uses the term instrument class to refer to a distinct set of functionality for a canonical instrument type. Although there are many different types of instruments used in test and measurement and their functionality varies considerably, many of these instruments naturally fall into distinct categories, or types. Often these instruments are categorized based upon the type of measurements they can perform or the type of output they can produce.

For each instrument class, the IVI Foundation publishes a specification, known as the class specification. Each class specification lays out the requirements for compliance with that class specification. An IVI driver that complies with a class specification is said to be a class-compliant IVI driver. The primary purpose of an IVI class specification is to detail the set of functions and attributes that an IVI driver must support in order to be class-compliant. The class specification carefully prescribes the exact name of each function, along with the parameter list and the API hierarchy, as well as other behavior details.

Currently, the IVI Foundation has defined and approved specifications for twelve instrument classes. These specifications are available from the IVI Foundation.

  • IVI-4.1: IviScope Class Specification
  • IVI-4.2: IviDmm Class Specification
  • IVI-4.3: IviFgen Class Specification
  • IVI-4.4: IviDCPwr Class Specification
  • IVI-4.5: IviACPwr Class Specification
  • IVI-4.6: IviSwtch Class Specification
  • IVI-4.7: IviPwrMeter Class Specification
  • IVI-4.8: IviSpecAn Class Specification
  • IVI-4.10: IviRFSigGen Class Specification
  • IVI-4.12: IviCounter Class Specification
  • IVI-4.13: IviDownconverter Class Specification
  • IVI-4.14: IviUpconverter Class Specification
  • IVI-4.15: IviDigitizer Class Specification

Interchangeability and IVI

The term interchangeability in IVI refers to the ability to exchange an instrument of one class in a system with a different instrument from that same class. IVI interchangeability does not generally refer to the case of exchanging instruments from different instrument classes.

Client applications achieve interchangeability by writing their code such that it meets at least the following two conditions:

  1. It uses only functions and attributes from the IVI class specification.
  2. It has no references to a specific IVI instrument driver.

Since IVI drivers can contain functionality beyond the class specification (known as instrument-specific functionality), the client programmer must take care to only use functionality from the IVI specification if their program is to be interchangeable. Only the IVI-defined functionality is guaranteed to be supported by a class-compliant driver.

The second condition (excluding references to a specific driver) is a bit trickier to meet, and requires the use of extra software components. The mechanism by which this is achieved is different for IVI-COM drivers and IVI-C drivers.

IVI-COM Interchangeability

Interchangeability with IVI-COM relies upon special components shipped as part of the IVI Shared Components. The first component required for IVI-COM interchangeability is the COM Session Factory. This component allows users to instantiate a specific IVI-COM driver by name, rather than by a hard-coded program reference.

The name used to instantiate the driver is termed the logical name. The IVI Configuration Store holds all of the user-assigned logical names, and maps them to specific IVI drivers. When a different instrument is introduced into the system, the user need only change the specific driver referenced by their logical name in the IVI Configuration Store. No user code is modified, so the application will run without re-compiling or re-linking. The COM Session Factory will lookup the logical name in the IVI Configuration Store and instantiate the new driver.

The second component required for IVI-COM interchangeability is the type library associated with the IVI instrument class in use. The IVI-COM type libraries are also part of the IVI Shared Components. These DLLs contain the interface definitions (function signatures, property and parameter types, etc.) for a particular instrument class. Class-compliant IVI-COM drivers reference these type libraries to implement the functionality they define. Client applications reference these type libraries to access driver functionality in a driver-independent fashion.

The COM Session Factory and the IVI-COM type libraries are the basic machinery that enables interchangeability with IVI-COM drivers.

IVI-C Interchangeability

IVI-C interchangeability differs fundamentally from IVI-COM interchangeability in that IVI-C drivers require the use of a special 3rd-party component called a class driver.

Note:

It is crucial to understand that IVI-C class drivers are not shipped as part of the IVI Shared Components. Rather, class drivers must be obtained from a 3rd party vendor. Furthermore, IVI-C interchangeability does not extend to interchanging class drivers. Specifically, a client application built using class drivers from Vendor A must be modified, re-compiled, and re-linked if it is to use class drivers from Vendor B.

The class driver exposes the functions defined in a particular IVI instrument class. All of the class driver functions have generic names, so that client applications have no driver-specific references. For example, rather than naming a function "ag34401_Configure", which is obviously device-specific, the class driver will expose the function with the name "IviDmm_Configure".

IVI-C client applications link to the class driver and call into the class driver's Initialize function providing a logical name. This logical name is the same as that described for IVI-COM drivers above. Specifically, the logical name identifies a specific IVI-C driver that the class driver should load. Once the specific driver is loaded, subsequent function calls on the class driver are delegated to the corresponding function in the specific driver. In this way, IVI-C client applications can be written generically against a class driver and incorporate new specific drivers without modification.

Base Capabilities and Extension Groups

Each IVI class specification partitions IVI-defined functionality into two groups -- base capabilities and extension groups.

Base Capabilities Group

The Base Capabilities group contains functionality that all IVI drivers must implement if they wish to claim conformance with the instrument class in question. Typically, the Base Capabilities group represents the "least common denominator" of functionality for an instrument class, so most commercial instruments can be expected to support this level of capability.

As an example, the IviDmm Base Capabilities group contains functions for range, resolution, and triggering. Most commercial DMMs possess at least these capabilities, so any IVI driver that wishes to claim IviDmm-compliance must support this group of functionality.

Extension Groups

IVI uses Extension Groups to define functionality that is found in many instruments of a particular class but may not be as common as the functionality expressed in the Base Capabilities. One may think of Extension Groups as being standard definitions for "optional" functionality in an IVI driver.

Extension Groups provide a means for more advanced instruments to expose functionality in an interchangeable fashion, while still allowing simpler instruments to be class-compliant. For instance, not all DMMs have the ability to perform temperature measurements. Thus, the IviDmm class specification uses the IviDmmTemperature Extension Group to define temperature measurement capabilities.

Simply put, an Extension Group is making the statement to the driver developer, "You do not have to provide these capabilities in your IVI driver, but if you do, you must do it according to the IVI definition." An IVI driver can be class-compliant without supporting any of the extension groups in its instrument class. All IVI drivers expose a GroupCapabilities attribute that returns a comma-separated list of the extension groups supported by the driver. Using this attribute, client applications and tools can programmatically determine what optional functionality is present in an IVI driver.


Instrument-Specific Capabilities

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Instrument-Specific Capabilities

Modern instruments typically possess much more functionality than is represented in the IVI instrument class specifications. End users must have a way to access the full capability of the instrument they have purchased. Thus, the driver must expose interfaces that are specific to that instrument alone. These are known as instrument-specific capabilities.

Instrument-specific capabilities are obviously not interchangeable. End users programming against a driver's instrument-specific interfaces typically do so to access functionality that is not available in the class-compliant interfaces . Nevertheless, for complex instruments such as spectrum analyzers, there will often be far more functionality in the IVI driver's instrument-specific hierarchy than in the class-compliant hierarchy.

Although, by definition, IVI does not dictate the syntax and semantics of instrument-specific interfaces, there are still guidelines that must be followed in the design of the interfaces if the driver is to be IVI compliant. Most of these rules are laid out in IVI-3.4: API Style Guide.


IVI Shared Components

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IVI Shared Components

In order to facilitate IVI driver development and to ensure a consistent experience for end users building IVI-based test systems, the IVI Foundation develops and maintains a series of freely available software components. These components are collectively referred to as the IVI Shared Components, and they must be installed on any computer that will use IVI drivers. In fact, IVI driver installation programs are required to check for the presence of the IVI Shared Components before installing.

The following sections provide a brief overview of some of the most important IVI Shared Components.

IVI Shared Component Installer

The IVI Foundation provides an installer for the IVI Shared Components. Moreover, the Foundation's Shared Component installer is the only IVI-compliant way to install the IVI Shared Components. Third parties are not allowed to develop custom installation programs for the IVI Shared Components.

The IVI Shared Component installer creates a directory structure to house the IVI Shared Components as well as IVI drivers themselves. The root of this directory structure is referred to as the IVI install directory (<IviInstallDir>) and is typically <ProgramFilesDir>\IVI Foundation\IVI.

The IVI Shared Component installer is available for download from the IVI Foundation web site.

IVI Configuration Store

When the IVI Shared Components are installed, a special XML file named IviConfigurationStore.xml is placed in the <IviInstallDir>\Data directory. This file is known as the IVI Configuration Store and serves as a central repository for IVI driver configuration information.

IVI driver installers are required to populate the Configuration Store with information such as the instrument classes supported, the instrument models for which the driver is designed, and the physical channel names understood by the driver. End users add information to the Configuration Store to describe how they intend to use IVI drivers in their system. End users can specify logical names for IVI drivers and virtual names for channels.

For more information on the structure of the IVI Configuration Store, see IVI-3.5: Configuration Server Specification available on the IVI Foundation web site.

IVI Configuration Server

The IVI Foundation discourages users and driver developers from directly manipulating the Configuration Store XML file (IviConfigurationStore.xml). The Configuration Store is highly self-referential and easily corrupted if modified directly. Thus, the Foundation provides a COM component known as the IVI Configuration Server for programmatically reading and writing information to the Configuration Store.

The IVI Configuration Server is installed automatically by the IVI Shared Component installer. For more information on how to use the IVI Configuration Server, see IVI-3.5: Configuration Server Specification available on the IVI Foundation web site.

COM Session Factory

IVI-COM drivers, like all COM components, must be created using a specific, hard-coded reference to the main COM class. In Visual Basic, this reference takes the form of a class data type, while in Visual C++, a CLSID must be specified. Irrespective of the IDE in use, this identifier must somehow be provided to instantiate the driver and begin calling methods and properties. Yet, having a direct reference to such an instrument-specific item in an application program renders that application non-interchangeable. Specifically, if the user wishes to use a different instrument (and, hence, a different driver), then this CLSID (or class name in Visual Basic) must be manually changed and the program re-complied and re-linked.

The COM Session Factory (or, simply, the session factory)is a very simple COM component supplied with the IVI Shared Components. In spite of its simplicity, the session factory is a key to writing interchangeable applications that use IVI-COM drivers.

Rather than directly creating an IVI-COM driver using a CLSID (or the equivalent), the application program creates an instance of the session factory and then asks it to instantiate a specific IVI-COM driver. For this to work, the user must create a Logical Name in the IVI Configuration Store and associate that Logical Name with the specific IVI-COM driver they wish to instantiate. The COM Session Factory simply looks up the Logical Name in the IVI Configuration Store, locates the associated IVI-COM driver and instantiates it accordingly.

Note that, as the name implies, the COM Session Factory is only relevant for IVI-COM drivers. IVI-C drivers use a completely different mechanism (namely, IVI Class Drivers), to facilitate interchangeability.

The COM Session Factory is installed automatically by the IVI Shared Component installer. For more information on how to use the IVI Session Factory, see IVI-3.6: COM Session Factory Specification available on the IVI Foundation web site.

IVI-COM Type Libraries

Part of the IVI Shared Components include a series of COM type libraries that contain the interface definitions for the IVI inherent capabilities as well as for all IVI instrument classes. These type libraries are installed in <IviInstallDir>\Bin and are generally named <IviClass>TypeLib.dll. For instance, the type library containing the interface definitions for the IviDmm instrument class is IviDmmTypeLib.dll.

Client applications must directly reference the IVI-COM type libraries from their projects in order to call methods and properties in IVI-defined interfaces. All client applications must include a reference to IviDriverTypeLib.dll, since this type library houses the interface definitions for the IVI inherent capabilities. Application programs must also reference the type library containing the interface definitions for any class-compliant interfaces they wish to support.


IVI Configuration Store

[image]

AgMD1 IVI Driver Reference Agilent Technologies
IVI Configuration Store

The IVI Configuration Store is part of the IVI Shared Components distributed by the IVI Foundation. The IVI Configuration Store serves as a central repository for driver registration information. Physically, the IVI Configuration Store is an XML file installed by the IVI Shared Component Installer in the following directory:
<IviInstallDir>\Data\IviConfigurationStore.xml.
where, <IviInstallDir> is typically C:\Program Files\IVI Foundation\IVI.

The AgMD1 installer populates the IVI Configuration Store (Config Store) with the required entries for using the driver. Specifically, the driver installer adds a Software Module entry to the Config Store to represent the driver DLL itself. No other entries in the Config Store are created by the driver. If you only wish to access the instrument specific functionality of the driver, then no other entries in the Config Store are required.

To use the driver in application programs that will be interchangeable, you must edit the Config Store and add a few specific entries. Instrument vendors and other third parties provide graphical tools for conveniently editing the Config Store.

Note:

Although the IVI Configuration Store is a human readable XML file, the IVI Foundation strongly discourages you from directly editing this file. The Config Store file is highly self-referential and easily corrupted if directly modified. Instead, use one of the available third-party editors. Alternatively, the IVI Shared Components include a programmatic interface to the Config Store, known as the IVI Configuration Server.

Editing the IVI Configuration Store

The driver installer creates only one entry in the Config Store -- the Software Module. This entry is removed by the driver uninstaller. End users should never modify the Software Module entry.

To author test programs that allow for interchangeability, you must create three additional entries in the Config Store:

  • Hardware Asset
  • Driver Session
  • Logical Name

The following sections provide descriptions of each of the Config Store entries mentioned here. Consult the documentation for your Config Store editor for detailed instructions on modifying these items.

Software Module

The Software Module identifies the instrument driver DLL, as well as various pieces of important driver information, such as the physical repeated capability names used for the repeated capabilities, IVI compliance information, as well as a variety of other items.

Hardware Asset

The Hardware Asset identifies a specific piece of instrument hardware. The main purpose of the Hardware Asset is to house the I/O resource descriptor used to communicate with the device.

Driver Session

The Driver Session associates the Software Module with the Hardware Asset. The Driver Session also specifies such things as driver initialization values and mappings between physical repeated capability names and virtual repeated capability names. Virtual names are used by client programs to access repeated capabilities in an interchangeable fashion.

For a discussion of repeated capabilities, physical names, and virtual names, see the Repeated Capabilities topic.

Users create a separate Driver Session for each unique combination of driver software, instrument hardware, and initialization settings. You may have multiple Driver Sessions for the same Software Module, if, for instance, the driver is being used to control several instances of the same instrument at different GPIB addresses.

Logical Name

The Logical Name allows users to associate an arbitrary name with a Driver Session. Since the Driver Session is tied to a particular driver and instrument, a level of indirection is needed to abstract these details in interchangeable client applications. The Logical Name serves as this extra level of abstraction -- a simple string identifier for a Driver Session.

The Logical Name is what client programs must use to build interchangeable systems. Applications create instances of IVI-COM drivers by using the COM Session Factory and specifying the Logical Name. Applications load IVI-C specific drivers by passing a Logical Name to the Initialize function on an IVI-C class driver. In either case, no instrument-specific details exist in the client program. Swapping instruments in such a system involves merely associating the Logical Name in the Config Store with a different Driver Session (i.e. a different driver-instrument combination).


Repeated Capabilities

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Repeated Capabilities

Instruments often contain multiple instances of the same kind of functionality or capability. For instance, modern oscilloscopes may have multiple channels, each with independent settings for such things as vertical scale and input attenuation. IVI refers to functionality that is duplicated in an instrument as a repeated capability.

Physical Repeated Capability Names

Instances of repeated capabilities are identified by name. These names are passed as parameters to standard repeated capability accessor functions in order to change settings and execute methods on a driver's repeated capabilities. There are two types of repeated capability names -- physical names and virtual names. Physical repeated capability names are those that the driver writer specifies during driver development. These are the names that the driver natively understands and, as such, they cannot be modified by an end user. They can only be read by an end user. Virtual repeated capability names are explained below.

The physical repeated capability names (or simply physical names) understood by a particular driver can be discovered interactively or programmatically. Each IVI driver is required to register the set of physical names it understands with the IVI Configuration Store. This means an end user can use whatever IVI Configuration Store browser they have to look up the physical names supported by the driver.

Physical names can also be discovered programmatically using standard repeated capability functions. Example code for doing this is given below in the section on Parameter-Style Repeated Capabilities.

Virtual Repeated Capability Names

Virtual names allow end users to specify their own names for repeated capability instances and map those names to the physical names that the driver natively understands. The user establishes the virtual-to-physical name mappings in the IVI Configuration Store. At runtime, the user can supply a virtual channel name to the appropriate function the driver will use the mappings in the IVI Configuration Store to translate the virtual name into a physical name that the driver understands.

The purpose of virtual names is to facilitate driver interchangeability. If a user writes application code using virtual names, then no modifications to the application code are necessary when an existing driver is replaced with one that natively understands different physical names. The user need only modify the appropriate settings in the IVI Configuration Store to map their virtual names to the new driver's physical names.

Types of Repeated Capabilities

The IVI specifications define three different types of repeated capabilities -- parameter-style repeated capabilities, selector-style repeated capabilities, and collection-style repeated capabilities. Each type of repeated capability is often more appropriate depending upon such factors as how common the repeated capability is in a particular instrument class and whether one repeated capability instance is controlled at a time or multiple instances are commonly controlled at a time. Since IVI instrument classes use all three types of repeated capabilities in various instrument classes, it is important to understand the basics of each type of repeated capability.

Parameter-Style Repeated Capabilities

The simplest type of repeated capability is the parameter style. Parameter-style repeated capabilities are used most commonly in IVI-C drivers, though they can also appear in IVI-COM drivers. As the name implies, parameter-style repeated capabilities are supported by simply adding an extra string parameter to any function that applies to a repeated capability (as opposed to a function that applies to the driver as a whole). The client application passes in either a valid physical or virtual repeated capability name for this parameter to identify the particular repeated capability instance to access.

The code below shows an IVI-C driver client using the ConfigureOperationMode function from the IviFGen class specification:

C++ Copy image Copy Code
ViSession vi;
// ...
IviFgen_ConfigureOperationMode(vi, "Output1", IVIFGEN_VAL_OPERATE_BURST);

In the code above, the second parameter is the repeated capability name. The repeated capability name almost always appears as the second parameter to a function that applies to a repeated capability. The example is setting the operation mode to burst for only the output channel identified by "Output1". The name "Output1" could be a physical name or a virtual name.

Drivers that expose a parameter-style repeated capability always expose a couple of additional functions and attributes that allow you to programmatically determine the number of repeated capabilities instances (e.g. "channels") and the physical names supported (e.g. channel names). The names of these support functions are also standardized, so that they can easily be identified when the name of the capability is know. IVI-COM drivers and IVI-C drivers differ slightly in the repeated capability support functions they expose for parameter-style repeated capabilities.

For IVI-COM drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • <Capability>Name attribute (Ex: "ChannelName")

For IVI-C drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • Get<Capability>Name attribute (Ex: "GetChannelName")

With either IVI-COM or IVI-C, the use model for these attributes is virtually identical. Specifically, the client code simply reads the value of the Count attribute and then uses this value to iterate through the repeated capability instances. The Name attribute (for IVI-COM) and the GetName function (for IVI-C) both accept a one-based index parameter to identify which repeated capability instance name is desired. The code below shows how to iterate through all of the physical names supported by an IVI-C FGen driver that exposes a "Channel" repeated capability.

C++ Copy image Copy Code
ViSession vi;
ViInt32 i;
ViChar name[1024];
// ...
ViInt32 count;
IviFgen_GetAttributeViInt32(vi, VI_NULL, IVIFGEN_VAL_CHANNEL_COUNT);
for (i = 1; i <= count; i++)
{
  // Note: One-based indexing
  IviFgen_GetChannelName(vi, i, 1024, name);
  printf(name);
}

Selector-Style Repeated Capabilities

Selector-style repeated capabilities use a special selector function to set the "active" repeated capability. Subsequent function calls that apply to a repeated capability are understood to apply to the active instance. The active instance remains active until the client code sets the active instance to another repeated capability name.

Selector-style repeated capabilities can be used in both IVI-COM and IVI-C drivers, and, though less common than the parameter style and collection style (discussed shortly), selector-style repeated capabilities have the advantage of not requiring a repeated capability name to be passed to every function that applies to the repeated capability.

As with parameter-style repeated capabilities, drivers that expose a selector-style repeated capability always expose additional functions for managing the repeated capability instances. Indeed, the selector-style repeated capability uses the same functions and attributes as the parameter style, with the addition of one attribute and one function for setting and getting the active instance.

For IVI-COM drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • <Capability>Name attribute (Ex: "ChannelName")
  • Active<Capability> attribute (Ex: "ActiveChannel")
  • SetActive<Capability> function (Ex: "SetActiveChannel")

For IVI-C drivers, the following are required to be present:

  • <Capability>Count attribute (Ex: "ChannelCount")
  • Get<Capability>Name attribute (Ex: "GetChannelName")
  • Active<Capability> attribute (Ex: "ActiveChannel")
  • SetActive<Capability> function (Ex: "SetActiveChannel")

Since the selector-style repeated capability uses the same Count attribute and GetName function as the parameter style, the code required to iterate through the instance names for a selector-style repeated capability is identical to that shown above for the parameter style.

Collection-Style Repeated Capabilities (IVI-COM only)

By far, the most common type of repeated capability for IVI-COM drivers is the collection-style repeated capability. Collection-style repeated capabilities are not supported for IVI-C drivers.

As with the parameter and collection style, collection-style repeated capabilities always expose a Count and Name attribute for iterating through the list of available repeated capability names. Unique to collection-style repeated capabilities is the Item property, which provides access to individual repeated capability instances. The Item property accepts a repeated capability name (physical name or virtual name) and returns an interface pointer to the desired repeated capability instance. All method and property calls on the returned interface pointer implicitly apply to the repeated capability instance chosen with the Item property.

The C# code below demonstrates how to use the Item property to access a channel called "CH1" and enable it.

C# Copy image Copy Code
IIviScope scope = new AcmeScopeClass();
// ... Initialize called
IIviScopeChannel channel = scope.Channels.get_Item("CH1");
channel.Enabled = true;

Note that in C#, the Item property is invoked using the get_Item accessor method. This is required for C# because that language does not support parameterized properties. Thus, any property that accepts one or more parameters must be accessed as if it were a method. The standard way in which such properties appear in C# is with a "get_" prefix (for reads) and a "set_" prefix (for writes).

Note also that declaring the intermediate variable for the IIviScopeChannel interface returned by get_Item is not necessary. Depending upon the client application, it may be more convenient to write the code as follows:

C# Copy image Copy Code
IIviScope scope = new AcmeScopeClass();
// ... Initialize called
scope.Channels.get_Item("CH1").Enabled = true;

Static and Dynamic Repeated Capabilities

Many instruments have a fixed number of repeated capabilities. For instance, a function generator typically has a fixed number of output channels. However, some instruments can have a variable number of repeated capabilities, depending upon end-user configuration. For instance, a switching mainframe might have any of a number of combinations of multiplexer cards installed on a particular end-user system. Thus, the number of channels is not fixed and can only be determined at runtime. Such instruments possess what are termed dynamic repeated capabilities. Conversely, instruments that always have a fixed number of repeated capabilities use the term static repeated capabilities.

A driver that exposes dynamic repeated capabilities cannot register the supported repeated capability names during driver installation. Instead, during the driver Initialize call, the driver typically queries the instrument to determine its exact configuration. The mechanism by which a driver determines the name and number of the supported repeated capabilities is always instrument specific, but the net result is that the end user must use the Count and Name attributes to programmatically determine what repeated capability instances are available. An IVI Configuration Store browser is useless in determining what dynamic repeated capabilities a driver supports. It relies only upon static information in the IVI Configuration Store, so it can only report details on static repeated capabilities.

Finally, it is worth noting that a driver can contain both static and dynamic repeated capabilities.


LXI Fundamentals

[image]

AgMD1 IVI Driver Reference Agilent Technologies
LXI Fundamentals

What is LXI?

The LXI Consortium was formed in 2005 with the goal of using LAN-based communication to control instrumentation. LXI stands for (LAN eXtensions for Instrumentation) and the hope is that high-performance, low cost systems can be built based on standard Ethernet technology, as an alternative to the popular, but more industry-specific GPIB communication interface.

Note:

A full discussion of the LXI specifications and their requirements is far beyond the scope of this document. Only a basic introduction to LXI is given here. Please see the LXI Consortium web site for full details.

The LXI standards mostly prescribe hardware and firmware requirements for building LXI-compliant instruments. These requirements are grouped into three classes of LXI compliance -- Class A, Class B, and Class C. (Note that the use of the term "class" here has no relation to the notion of "class" in IVI instrument classes.) The features of each class are summarized in the following table:

Feature | Class C | Class B | Class A
IVI driver | X | X | X
Programmatic control via LAN | X | X | X
LAN-based discovery | X | X | X
Web-based configuration page | X | X | X
1588 Precision Time Protocol |  | X | X
Event logging |  | X | X
LAN-based triggering |  | X | X
Hardware trigger bus |  |  | X

Features of LXI Devices

As the table in the previous section shows, LXI devices possess a variety of useful features, base on their LXI functional class (A, B, or C). The most fundamental features of LXI are required for all functional classes. First and foremost, an IVI driver (either IVI-COM or IVI-C) must be provided with any instrument claiming LXI compliance. Next, the instrument must provide a configuration web page so that users can simply open a browser, navigate to the LAN address of the instrument, and interact with the device. In addition, all LXI devices must support a standard discovery mechanism so that tools and client applications can determine what devices are connected to the network.

With LXI Class B comes important new requirements. First, Class B devices must support the IEEE 1588 Precision Time Protocol standard. This standard provides a way for multiple devices to synchronize their clocks over standard Ethernet networks. Since LAN-based communication is inherently non-deterministic, some mechanism for reliably synchronizing devices in a system is required. The IEEE 1588 standard (simply referred to as "1588") provides this for LXI devices.

Class B devices also support LAN-based triggering and events. The LXI specification defines how devices format, send and receive special LAN packets used to communicate between devices. All Class B devices support a standard set of eight LAN packets. This forms a sort of virtual LAN-based trigger bus, with each of the standard eight LAN packets (known as "LAN0...LAN7") serving as individual trigger lines. LXI devices can be programmed to trigger a measurement or sweep based on receipt of a LAN packet or they can be told to send a specific LAN packet (an event) when a particular operation has completed or the device enters some other interesting operational state.

Class A devices are the most complex LXI devices. They support all of the functionality defined for Class B but add a hardware trigger bus. This trigger bus can be useful in applications that demand extremely precise timing and ultra-low latency triggering between components.

The IviLxiSync Specification

In 2006, the IVI Foundation and the LXI Consortium joined forces to define a standard API for controlling the triggering and eventing capabilities of LXI devices. The result of this cooperation was the IviLxiSync specification, formally known as IVI-3.15: IviLxiSync Specification. The IviLxiSync specification is not an instrument class specification, because it does not define functionality for a particular type of instrument. Rather, it defines operations common to any LXI-compliant device, whether that device is a DMM, oscilloscope, or spectrum analyzer.

Since the IviLxiSync specification spans devices of all instrument classes, it is common that an IVI driver will support IviLxiSync as well as one or more IVI instrument classes. Some of the operations that a client application can perform through the IviLxiSync interfaces include:

  • Configuring a device to trigger on a specific LAN packet.
  • Configuring a device to send an event upon receipt of a particular event from another LXI device.
  • Using filtering to control from which devices an instrument "sees" incoming LAN triggers.
  • Retrieving event log entries from the device.

Just as with IVI instrument classes, the standard functions and attributes defined in the IviLxiSync specification are compiled into an IVI-COM type library. This type library is shipped as part of the IVI Shared Components. Also, as with IVI instrument classes, users can program interchangeably with LXI devices by referencing the IviLxiSync type library and using only IviLxiSync-defined interfaces in their application.

IviLxiSync Subsystems

The IviLxiSync API is divided into five subsystems. Each subsystem controls different aspects of LXI device operation in a system. Depending upon a device's functional class, it may support only some of these subsystems. Class C devices, for example, need not support any of the functionality defined in the IviLxiSync specification. Also, only Class A devices will typically support arming, triggering, and events using the hardware trigger bus. The following table gives the different IviLxiSync subsystems along with their functionality:

Subsystem | Description
IviLxiSyncArm | Controls when triggers are accepted by the LXI device.
IviLxiSyncTrigger | Controls when the LXI device starts a measurement or other operation.
IviLxiSyncEvent | Controls when the LXI device signals specific conditions to other LXI devices.
IviLxiSyncEventLog | Provides access to the event logging features of an LXI device.
IviLxiSyncTime | Exposes functionality for access to the 1588 timebase of the LXI bus.

IviLxiSync Programming Example

This section presents an example LXI test system with common programming tasks using the IviLxiSync interfaces. The example code is based upon the stimulus/response test system shown in the figure below:

In the system above, an arbitrary waveform generator (arb) is used to stimulate a device under test with waveforms at various frequencies, in order to measure the distortion characteristics of the device across its operating range. The stimulus waveform is up-converted to microwave frequencies using an upconverter module and the receiver uses a downconverter to translate the DUT output signal into a range suitable for processing by the digitizer.

The up and down converters are capable of frequency stepped sweep operations (start Frequency, stop Frequency, step Frequency) and can initiate each step based on a trigger signal. The LXI-defined LAN events will be used for this triggering. At each frequency in the sweep, the digitizer acquires the DUT's output waveform using an internal signal level to trigger the acquisition. At each step in the frequency step sweep, the digitizer will wait for a LAN signal from the upconverter and downconverter modules indicating that their signals have settled.

The first task is to configure the digitizer to output a synchronization signal to trigger the arb. The LXI-defined LAN packet named "LAN1" will be used for this purpose. We want the digitizer to send the LAN1 event to the arb when the digitizer is in the waiting-for-trigger state (also known as "armed"). IviLxiSync defines the "WaitingForTrigger" event name as a standard string to identify precisely this device state. This is referred to as the "source" of the outgoing event, because when it occurs (e.g. when the digitizer enters the waiting-for-trigger state), the digitizer will send an outbound LAN packet ("LAN1" in our example).

C# Copy image Copy Code
// Instantiate drivers for all four devices and retrieve the IIviLxiSync interface from all
IIviLxiSync digitizer = (IIviLxiSync) new AcmeDigitizerClass();
IIviLxiSync arb = (IIviLxiSync) new AcmeArbClass();
IIviLxiSync upconverter = (IIviLxiSync) new AcmeUpconverterClass();
IIviLxiSync downconverter = (IIviLxiSync) new AcmeDownconverterClass();

// Call the Initialize function on all drivers (omitted for clarity)
// ...

// Tell the digitizer to send LAN1 when it arms -- used to trigger the arb
digitizer.Events.get_Item("LAN1").Source = "WaitingForTrigger";
digitizer.Events.get_Item("LAN1").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;

// Configuring the "slope" here refers to the slope of the "WaitingForTrigger" event
// that causes the digitizer to send a LAN1 packet
digitizer.Events.get_Item("LAN1").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeRise;

We next configure the arb to accept a trigger on the rising edge of the LAN1 packet that the digitizer will be sending.

C# Copy image Copy Code
// Tell the arb to trigger on the rising edge of LAN1
arb.Trigger.get_Item("LAN1").Detection = IviLxiSyncTriggerSourceDetectionEnum.IviLxiSyncTriggerSourceDetectionRise;
arb.Trigger.TriggerSource = "LAN1";

Next, we configure the digitizer to send an event on LAN2 on the falling edge of the IviLxiSync-defined "WaitingForArm". As with "WaitingForTrigger", the "WaitingForArm" event name provides a standard way to refer to common events that occur within an LXI device. We use the falling edge of the LAN2 packet to trigger the upconverter and downconverter, which must be configured to accept LAN2 as their trigger source.

C# Copy image Copy Code
// Tell the digitizer to send LAN2 on the falling edge of WaitingForArm
digitizer.Events.get_Item("LAN2").Source = "WaitingForArm";
digitizer.Events.get_Item("LAN2").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;
digitizer.Events.get_Item("LAN2").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeFall;

// Tell the up and downconverters to trigger on the rising edge of LAN2
upconverter.Trigger.get_Item("LAN2").Detection = IviLxiSyncTriggerSourceDetectionEnum.IviLxiSyncTriggerSourceDetectionRise;
upconverter.Trigger.TriggerSource = "LAN2";

downconverter.Trigger.get_Item("LAN2").Detection = IviLxiSyncTriggerSourceDetectionEnum.IviLxiSyncTriggerSourceDetectionRise;
downconverter.Trigger.TriggerSource = "LAN2";

The digitizer needs to begin processing when the output signals from both the upconverter and downconverter have settled to a point suitable for processing. This can be accomplished by configuring the upconverter to send a LAN3 packet when the "Settling" event occurs. Similarly, the downconverter will send a LAN4 packet when its "Settling" event occurs.

C# Copy image Copy Code
// Tell the upconverter to output LAN3 when the "Settling" event occurs
upconverter.Events.get_Item("LAN3").Source = "Settling";
upconverter.Events.get_Item("LAN3").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;
upconverter.Events.get_Item("LAN3").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeNegative;

// Tell the downconverter to output LAN4 when the "Settling" event occurs
downconverter.Events.get_Item("LAN4").Source = "Settling";
downconverter.Events.get_Item("LAN4").Mode = IviLxiSyncDriveModeEnum.IviLxiSyncDriveModeDriven;
downconverter.Events.get_Item("LAN4").Slope = IviLxiSyncSourceSlopeEnum.IviLxiSyncSourceSlopeNegative;

// Tell the digitizer to arm when *both* LAN3 and LAN4 are "High"
digitizer.Arm.Sources.get_Item("LAN3").Enabled = true;
digitizer.Arm.Sources.get_Item("LAN3").Detection = IviLxiSyncArmSourceDetectionEnum.IviLxiSyncArmSourceDetectionHigh;

digitizer.Arm.Sources.get_Item("LAN4").Enabled = true;
digitizer.Arm.Sources.get_Item("LAN4").Detection = IviLxiSyncArmSourceDetectionEnum.IviLxiSyncArmSourceDetectionHigh;

digitizer.Arm.Sources.OrEnabled = false;	// "false" means use AND-summing of all enabled arm sources

With the LAN signals "wired" appropriately, the remaining tasks involve configuring and initiating the actual measurements. This might involve configuring other aspects of the digitizer (acquisition length, etc.) and loading a signal file into the arb. The frequency sweep parameters of the upconverter and downconverter also need to be configured.

C# Copy image Copy Code
// Load signal file into arb and get it ready to go
// ...

// Setup rest of digitizer parameters (acquisition length, SignalLevel trigger, etc.)
// ...

// Start digitizer
digitizer.Arm.ArmCount = 100;  // acquire 100 signal packets
digitizer.Initiate();          // digitizer will now wait until it sees Settled from the up and down converters

// Setup frequencies for up and down converters
// NOTE: Functions used here are *not* part of the IviLxiSync specification.  They are just included
// as examples of sweep configuration functions in drivers.
upconverter.Frequency.Sweep.Start = 2e9;
upconverter.Frequency.Sweep.Stop = 3e9;
upconverter.Frequency.Sweep.Step = 10e6;

downconverter.Frequency.Sweep.Start = 2e9;
downconverter.Frequency.Sweep.Stop = 3e9;
downconverter.Frequency.Sweep.Step = 10e6;

// As soon as both converters settle, the digitizer will trigger the arb and take the first measurement

// Call Fetch function on digitizer to retrieve data
// ...


Installation

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Installation

Updating to a New Driver Version

It is important to note that only a single version of an IVI driver can be installed on a system at once. This rule is dictated by the IVI specifications. To ensure that only a single version of the AgMD1 driver exists on the machine, the AgMD1 installer will automatically uninstall a previous version of the driver. Although you can always explicitly uninstall the driver, this is typically not necessary.

Location of Files

The AgMD1 installer deploys and registers a variety of files on the target computer. The notation <IviInstallDir> is used to denote the directory in which the IVI Shared Components have been installed. By default, this is C:\Program Files\IVI Foundation\IVI. Substitute your install directory if the IVI Shared Components were installed in an alternate location.

File | Description
<IviInstallDir>\Bin\AgMD1.dll | Driver DLL.
<IviInstallDir>\Bin\Primary Interop Assemblies\Agilent.AgMD1.Interop.dll | Interop assembly for using the driver in .NET environments.
<IviInstallDir>\Bin\Primary Interop Assemblies\Agilent.AgMD1.Interop.xml | XML documentation file for providing IntelliSense support in .NET environments.
<IviInstallDir>\Include\AgMD1.h | Driver header file.
<IviInstallDir>\Lib\msc\AgMD1.lib | Microsoft-format import library.
<IviInstallDir>\Drivers\AgMD1\AgMD1.fp | Function panel file.
<IviInstallDir>\Drivers\AgMD1\AgMD1.sub | Attribute information file.
<IviInstallDir>\Drivers\AgMD1\AgMD1.chm | HTML 1.0 format help file.
<IviInstallDir>\Drivers\AgMD1\AgMD1.HxS | HTML 2.0 format help file.

Installation on a System with the .NET Framework

The AgMD1 installer detects if the .NET Framework is installed and, if so, registers the driver's Primary Interop Assembly (PIA) and deploys it in the .NET Global Assembly Cache (GAC).

Note:

If the .NET Framework is installed on the target computer after the AgMD1 installer runs, then the PIA must be registered manually. This must be done from a Visual Studio command prompt (not a regular command prompt). The Visual Studio command prompt can be found from Start -> Programs -> Microsoft Visual Studio 2005 -> Visual Studio Tools -> Visual Studio 2005 Command Prompt.

From the Visual Studio command prompt, perform the following two steps:

  1. Navigate to the PIA (<IviInstallDir>\Bin\Primary Interop Assemblies\AgMD1.dll) and execute the following command: "gacutil -i AgMD1.dll". You can also drag-n-drop the PIA from Windows explorer into the GAC folder (C:\Windows\Assembly).
  2. Execute the following command: "regasm /codebase AgMD1.dll".

IVI Shared Components

Before any IVI driver may be installed on a system, the IVI Shared Components must be properly installed. For an introduction to the IVI Shared Components, see the topic IVI Shared Components.

For additional information on the IVI Shared Components, visit the IVI Foundation web site.

To determine which version of the IVI Shared Components are installed on your system

  1. Navigate to <IviInstallDir>\Bin. Typically this is C:\Program Files\IVI Foundation\IVI\Bin.
  2. Locate the file IviSharedComponentVersion.dll.
  3. Right-click on that file and choose Properties.
  4. In the Properties Window, click the Version tab.
  5. The File version field indicates which version of the IVI Shared Components are installed.

Uninstallation

The only proper way to explicitly remove the driver from the system is to use the uninstallation program. Simply removing the installed files will not properly uninstall the driver.

To uninstall the driver

  1. From the Windows Start menu, choose All Programs and select Control Panel.
  2. Double-click Add or Remove Programs.
  3. Select the driver and click Remove.
Note:

In order to prevent loss of important user configuration information between uninstall/reinstall operations, the uninstallation program does not remove any of the following items from the IVI Configuration Store:

  • Logical Name
  • Driver Session
  • Hardware Asset
The only IVI Configuration Store item that is deleted during an uninstall is the Software Module.
For a discussion of IVI Configuration Store entries, such as the Software Module, see Configuring the Driver.


Copyright

[image]

AgMD1 IVI Driver Reference Agilent Technologies
Copyright

Agilent Technologies may have patents, patent applications, trademarks, copyrights, or other intellectual property rights covering subject matter in this document. Except as expressly provided in any written license agreement from Agilent Technologies, the furnishing of this document does not give you any license to these patents, trademarks, copyrights, or other intellectual property.

Copyright 2010-2012 Agilent Technologies. All rights reserved.

The names of actual companies and products mentioned herein may be the trademarks of their respective owners.